15:14 <knome> #startmeeting Xubuntu community meeting
15:14 <meetingology> Meeting started Thu Oct 31 15:14:46 2013 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:14 <meetingology> 
15:14 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:14 <knome> #topic Open action items from previous meeting
15:14 <jjfrv8> o/
15:15 <elfy> o/
15:15 <knome> #action knome to prepare the website for the desktop of the week
15:15 * meetingology knome to prepare the website for the desktop of the week
15:15 <knome> still TBD
15:15 <knome> skellat, have you prepared a blog article about upgrading? :)
15:15 <PhilDick> i came to lurk the meeting, hoping to get involved in 14.04 rollout/qa
15:15 <knome> PhilDick, welcome!
15:15 <knome> PhilDick, you should talk with elfy after the meeting is over
15:15 <PhilDick> ok
15:16 <skellat> knome: In light of a particular bug issue, it is best we put that action item on deep freeze
15:16 <skellat> Bug 1208204
15:16 <ubottu> bug 1208204 in indicator-sound (Ubuntu) "indicator-sound no longer functions with xfce4-indicator-plugin" [High,Triaged] https://launchpad.net/bugs/1208204
15:16 <knome> ok, i'll just let it slip from the agenda
15:16 <knome> #topic Strategy Document reviewing
15:16 <knome> yeah, i've been too busy to get the new version out
15:16 <knome> #action knome will send the updated SD to lists later this week
15:16 * meetingology knome will send the updated SD to lists later this week
15:16 <knome> #topic Team updates
15:17 <knome> does anybody have updates since last week?
15:17 <skellat> Tomorrow is the deadline for booking UDS sessions
15:18 <elfy> nothing to update from me
15:19 <knome> let's bump the UDS discussion first after announcements.
15:19 <knome> any other updates?
15:19 <ochosi> nothing much from my side
15:19 <jjfrv8> #info nothing from docs
15:19 <knome> yeah, as expected, still quiet in the development front
15:20 <ochosi> well, there's some news in xfdesktop
15:20 <knome> aha, go ahead
15:20 <lderan> belated here for the meeting
15:20 <ochosi> not sure that really belongs here, but in many of our reviews ppl complained about us not shipping a set of nice wallpapers by default
15:20 <ochosi> a few things have become easier with the new xfdesktop (4.11)
15:20 <knome> ochosi, oh great :)
15:21 <ochosi> there are builtin options to change wallpapers based on time
15:21 <knome> we do have the community wallpapers idea still WIP, and i think the LTS release is the perfect place to introduce that
15:21 <ochosi> so we could have a morning, noon, afternoon and evening variant of our wallpaper
15:21 <ochosi> yup, i agree
15:22 <ochosi> and the thing is that the new xfdesktop allows users to simply select a folder which contains wallpapers, which is much better than the current system of being able to only add single wallpapers to the list (which would disappear after logout)
15:22 <ochosi> so i hope we can get a 4.11 release into 14.04
15:22 <ochosi> (as i don't expect xfce4.12 to land in time for 14.04)
15:23 <skellat> ochosi: What's the timeline looking like for 4.12 upstream?
15:23 <ochosi> many fixes also went into the desktop, eric was quite active on it
15:23 <ochosi> skellat: it's unknown
15:23 <skellat> ochosi: Okay
15:23 <ochosi> basically xfce has become a one-man show (especially wrt core-releases)
15:23 <knome> ochosi, i agree with trying to get the 4.11 release in. can you add that to the roadmap and specify the package we need and the reason? :)
15:23 <ochosi> so as long as NSchermer isn't around/active, nothing much is going to happen
15:23 <slickymaster> hi guys, sorry for being late :(
15:24 <lderan> hey slickymaster
15:24 <ochosi> knome: yeah, will try to quickly add that (the package is already in the 4.12ppa)
15:24 <knome> ochosi, cheers
15:24 <ochosi> so we can even ask ppl to test things *now*
15:24 <elfy> excellent
15:24 <ochosi> and report issues if they exist (so far i've not experienced any extra bugs with the 4.11 version, and i've been using it for a while)
15:25 <micahg-work> ochosi, I won't land 4.11 unless 4.12 is guaranteed to come behind it
15:25 <knome> #info xfdesktop 4.11 has some nice features; builtin support for wallpapers based on the time, support for selecting a specific directory where xfdesktop looks for wallpapers instead of the fixed system directory
15:25 <knome> micahg-work, i think we need to discuss that
15:25 <micahg-work> I don't like the idea of dropping in pre-release versions unless necessary
15:26 <micahg-work> we selected the pieces that look stable enough
15:26 <knome> micahg-work, landing stuff is fine from my point of view, as long as we test it thoroughly
15:26 <ochosi> yeah, so why not continue to do so?
15:26 <micahg-work> knome, sorry, didn't mean to be snarky :)
15:26 <ochosi> (i mean, continue to land pieces that seem stable enough)
15:27 <knome> micahg-work, the list we dropped in for 13.10 was short because of the lack of time, not because components weren't stable enough
15:27 <micahg-work> ochosi, because upgrade paths might become messy, as this is an LTS, I'd prefer to keep it as stable as sanely possible
15:27 <micahg-work> if this were LTS+1 I'd have no problem dropping in the prereleases if they looked stable
15:28 <micahg-work> I'd just rather not do it for the LTS unless we have no choice
15:28 <knome> as i said, i think we need to discuss what the policy re: including stuff is
15:28 <ochosi> micahg-work: i agree, in this case there's a migrate-patch: http://git.xfce.org/xfce/xfdesktop/commit/?id=af240b063cd0678dc1739ffa28e93f1ff530bead
15:28 <ochosi> just saying, xfdesktop should take care of the transition by itself
15:28 <knome> ultimately, us dropping in some pieces of 4.11 can help xfce release 4.12 sooner.
15:29 <ochosi> +1
15:29 <knome> and we should definitely be in touch with them about releasing 4.12 too
15:29 <micahg-work> I wouldn't mind getting it packaged in a PPA, I'm just averse to throwing it in the archiv
15:29 <ochosi> well, it's already in a PPA ;)
15:29 <knome> my point is that if nobody is pushing stuff forward, we're going to stay quite frozen
15:30 <micahg-work> if we knew 4.12 was being released in Jan or Feb, this wouldn't be an issue, but that was supposed to happen at the beginning of the year
15:30 <ochosi> yeah, as i said, the situation weighs more or less on NSchermer's shoulders
15:30 <ochosi> and there aren't many other contributors to -core
15:31 <ochosi> i could get in touch with him about a 4.12 release-date, but i'm very pessimistic about that
15:31 <knome> we should all sit down, with nick, and discuss about this openly
15:32 <ochosi> there are still things left to do for 4.12, and i fear many of these things would have to be done by him
15:32 <skellat> We need to get that done before UDS anyhow as we need to have our features settled by then
15:32 <ochosi> simply because there aren't many other ppl around
15:32 <knome> with our and their concerns, the ways we can help them release sooner
15:32 <knome> skellat, yes and no... that's quite subjective :)
15:33 <skellat> knome: Feature Definition Freeze supposedly falls the same week as UDS in the Trusty Tahr schedule
15:34 <knome> skellat, yes, i'm aware of that, but it's still so-so if we "really" need to have everything planned; we've slipped that times and times...
15:34 <skellat> Okay
15:34 <knome> skellat, ...and nobody comes asking us what we're preparing, or need our list
15:34 <skellat> Okay
15:34 <ochosi> yeah, i think these are things we can decide for ourselves
15:34 <ochosi> but ofc it's helpful if we have some kind of feature definition freeze (in theory)
15:35 <knome> of course!
15:35 <knome> there's still a week to go, and tbh, i think that's enough time for us to sit down and think what we want *even if 4.12 didn't land*
15:35 <knome> i mean it's not a huge list, and it's not something that's going to break the world.
15:36 <ochosi> knome: one more thing we could discuss is the current panel layout
15:36 <knome> ochosi, okay.
15:36 <ochosi> i'm mostly happy with the top-panel, but i'm wondering about the bottom panel
15:36 <knome> ochosi, bluesabre, micahg-work: can we set some date in the next 7 days to sit down and discuss?
15:37 <micahg-work> Sunday is probably better for me
15:37 <ochosi> i mean i personally haven't used that one for ages and i'm really wondering how useful it is
15:37 <micahg-work> otherwise, it'll be too late for all of you
15:37 <lderan> i remove the bottom
15:37 <knome> sunday works for me, if it's late enough
15:37 <ochosi> hmm, sunday i'm travelling all day, but depends on the time
15:37 <knome> 22UTC?
15:37 <knome> ochosi, micahg-work: late enough?
15:37 <micahg-work> sounds good to me
15:37 <ochosi> late enough or too late :)
15:37 <elfy> ochosi: +1 to bottom panel and lderan I do as well
15:38 <knome> ochosi, propose.
15:38 <ochosi> i'll try to make it
15:38 <micahg-work> well, that's late afternoon for me :)
15:38 <knome> ochosi, i can make it later... and earlier.
15:38 <ochosi> knome: ok, let me quickly check my train schedule
15:38 <knome> sure
15:38 <ochosi> elfy: +1 means drop the bottom panel or keep it in this context?
15:38 <PhilDick> i remove bottom panel
15:39 <knome> i'm fine with dropping the panel
15:39 <micahg-work> I'm fine with 22:00 UTC
15:39 <knome> micahg-work, let's wait for ochosi's train schedule confirmation :)
15:39 <elfy> ochosi: I mean I never use it and in fact remove it
15:39 <ochosi> i think if we add e.g. whiskermenu by default (which i hope we will), it's easay enough to launch apps
15:39 <ochosi> easy
15:39 <knome> *coughs* :)
15:39 <ochosi> ok, thanks for the quick feedback
15:39 * ochosi adds it to the roadmap
15:39 <knome> ochosi, sun schedule?
15:40 <ochosi> knome: sure sure, just one sec...
15:41 <micahg-work> I think the panel adds a nice touch, but if we can easily launch apps, it should be fine to remove
15:41 <knome> i don't know who actually use the panel
15:41 <micahg-work> let's make sure we have docs on how to add it back for people
15:41 <micahg-work> I use it to launch email/browser
15:41 <knome> it's somewhat hidden, and otoh, when it opens, it's a distraction
15:41 <knome> that's why i remove it
15:41 <ochosi> yeah, either add a real dock or drop that
15:41 <ochosi> (imo)
15:42 <jjfrv8> it's one of the first things I do on a new install - remove it, that is
15:42 <ochosi> knome: so i think it might work for me, let's make it 22utc
15:42 <knome> not sure if a real dock is any less distractive.
15:42 <knome> okay, 22 utc it is
15:42 <ochosi> dunno, i've been using plank for a while now and i enjoy it so far
15:42 <knome> #info Discussion about cherry-picking on Sunday, 3 November at 22UTC on #xubuntu-devel
15:42 <knome> #undo
15:42 <meetingology> Removing item from minutes: <MeetBot.items.Info object at 0x18d3690>
15:42 <PhilDick> keep in mind xfce/xubuntu users may be avoiding bells and whistles intentionally. otoh those here may not be representative of all xub users
15:43 <ochosi> it also fits xubuntu nicely, because it's lightweight etc
15:43 <knome> #info Discussion about cherry-picking Xfce 4.11 components (and related issues) on Sunday, 3 November at 22UTC on #xubuntu-devel
15:43 <knome> ochosi, i think we can discuss about the panel configuration at a later time, in a general meeting
15:43 <ochosi> knome: we could try to invite some xfce devs too..
15:43 <knome> yep, we should.
15:43 <knome> #info ochosi and knome will try to invite some Xfce devs to the meeting
15:43 <knome> err
15:43 <knome> #undo
15:43 <meetingology> Removing item from minutes: <MeetBot.items.Info object at 0x15afe10>
15:43 <ochosi> i'll send a quick note to the xfdesktop-dev
15:43 * elfy will try to be there for that meeting so he can keep up with what he might need to think about
15:43 <knome> #action ochosi and knome will try to invite some Xfce devs to the meeting
15:43 * meetingology ochosi and knome will try to invite some Xfce devs to the meeting
15:44 <knome> elfy, cheers :) we will naturally also make notes...
15:44 <knome> #topic Announcements
15:44 <elfy> yep - not the same as following a discussion though at the time :)
15:44 <knome> #info Today is set as the last day of brainstorming for the Roadmap; the team shall approve blueprints next week
15:45 <knome> #info After approving, people have two weeks to finalize their specifications (where applicable)
15:45 <knome> any other announcements?
15:45 <ochosi> bbiab
15:46 <knome> ochosi, thanks for the announcement
15:46 * elfy has a pet peeve that could be an announcement
15:46 <knome> elfy, go ahead
15:46 <elfy> does it need an # ?
15:47 <knome> elfy, #info please
15:47 <elfy> #info - When I ask people on the -dev list for what's likely to come up that needs testing during the cycle - can they please answer. Because I will be doing so.
15:47 <knome> yep, we will :)
15:48 <knome> and we will also try to be in contact the other way; when we know something else/new needs testing, we will let you know
15:48 <skellat> #info A meeting may be scheduled if circumstances warrant outside the regular team meeting schedule on creating the core seed
15:48 <elfy> I'd rather know now that something is coming up in a few months - than then when otjher things are planned
15:49 <knome> elfy, sure. the meetings on sunday and next thurday when we approve things should give you a good idea what we are preparing to land to 14.04 images
15:49 <lderan> will be going through the list of the gtk apps for autopilot testing and seeing which ones now launch without error that didn't before and update the wiki
15:49 <knome> lderan, #action lderan ... :)
15:49 <elfy> #info During the next week I will be mailing -dev list re planning testing (cadence)
15:49 <knome> elfy, feel free to add that to the meeting schedule as well, if you want that discussed next thu
15:49 <lderan> #action lderan to go through the gtk list to see which apps now work with autopilot
15:49 * meetingology lderan to go through the gtk list to see which apps now work with autopilot
15:50 * knome bows
15:50 <elfy> lderan: can you keep in touch with me re that
15:50 <lderan> will do
15:50 <knome> #topic New and emerging items
15:50 <lderan> catfish works with it now which is prompting it
15:50 <knome> #subtopic Xubuntu Core: Do we offer it only as a metapackage or shall we make downloadable media avaiable as well?
15:50 <elfy> knome: I suspect I will be working next thursday and missing - will leave copious notes
15:50 <knome> elfy, sure :)
15:50 <skellat> I can speak to the subtopic briefly
15:51 <knome> this has been discussed quite a bit, and i think the current stance is "only a metapackage"
15:51 <knome> skellat, go ahead
15:51 <micahg-work> would be nice as a netinstall or metapackage, I don't know that we need media unless we have the testers
15:51 <knome> i would like to avoid the extra image
15:51 <knome> another option is to make it selectable from the installer, as edubuntu does
15:51 <knome> i'm not against that, but if you make me choose, just a metapackage works.
15:52 <skellat> Within the limits of the current approved generation options for installation, we can either generate an image or have a user go through mini.iso
15:52 <PhilDick> as a potential new qa tester, easier is better.... i'm willing to learn whats required but easier may equal more testers.
15:52 <elfy> I'd be +1 for whatever is easiest for us as a team to work with
15:52 <skellat> If core is kept as a strict subset of regular xubuntu-desktop, though
15:52 <knome> skellat, ...and we can offer it as an option in the installer :)
15:53 <ochosi> yeah, that'd be really nice
15:53 <skellat> knome: That would require some hacking on ubiquity to make it available as an option
15:53 <knome> skellat, sure, but that's completely in our reach, if we want to do that
15:53 <elfy> and a whole lot of extra testing - do we really think that we'd get that?
15:53 <skellat> With the way live cd images are generated
15:53 <skellat> ...
15:54 <elfy> I don't want to be having to do more tests on milestone days because we've not had sufficient turnout
15:54 <skellat> core would have to be a strict subset and ubiquity would need additional rules on what to leave behind
15:54 <knome> elfy, a few more testcases.
15:54 <knome> skellat, yep.
15:54 <xnox> skellat: ubiquity supports plugins, so one of xubuntu specific packages can just drop in one .py file as a plugin to fully customize ubiquity. thus actually you can do all of that without touching lp:ubiquity at all =)
15:54 <elfy> knome: which is ok if you have more than ~20 testers
15:54 <GridCube> oh meeting
15:54 <elfy> yep :)
15:54 <skellat> Thank you xnox.  We'll still need somebody to make the plugin, though.
15:54 <knome> elfy, i'm not disagreeing or pushing for the ubiquity stuff. just saying *it is possible if we want it*
15:55 <knome> even from the QA point of view.
15:55 <elfy> yep - I understand what you're saying - just putting my pov across now :)
15:55 <knome> of course it's additional burden... but it's about the same as if we reintroduced the alternate images
15:55 <xnox> skellat: knome: in terms of implementation - ubiquity is stupid and copies everything first, and then does removal. So xubuntu-desktop will be install first, and then you need to intelligently do an $ apt-get remove * step in essence.
15:55 <skellat> The case behind core remains we give the bare basic subset of desktop, which should require fewer test cases, that installers can then customize as they see fit in lieu of what xubuntu-desktop provides.
15:56 <elfy> skellat: it's not about what is IN a testcase - but that we rarely have enough people testing what we already have :)
15:56 <skellat> elfy: True
15:56 <knome> skellat, we still need/want to test what's in the -desktop metapackage as well
15:56 <skellat> Ideally the tests would overlap
15:57 <knome> sure :)
15:57 <skellat> The same things would be covered
15:57 <skellat> -core would just have fewer of them than -desktop
15:57 <knome> skellat, what's your take on the subject? what would you do?
15:57 <skellat> From what xnox said about ubiquity, I'd generate a separate image
15:58 <skellat> That way we don't have to deal with ubiquity having to remove things
15:58 <knome> that would mean quite many new testcases though
15:58 <skellat> True
15:58 <knome> which i think isn't sustainable
15:58 <skellat> My second choice would be fabulous documentation on the art of using mini.iso
15:58 <knome> okay
15:58 <knome> so you would try to avoid modifying ubiquity? :)
15:59 <GridCube> but mini ist a real option to poeple who want -core because they dont have a fast connection
15:59 <skellat> The plugin could be done as xnox mentions above but then we'd have to worry about dependencies being broken during a remove and possibly creating dead installs
15:59 <xnox> knome: skellat: alternative is to make the default liveimage xubuntu-core, and ship the rest of xubuntu-desktop in the /pool/ which is installed in-target "the slow way" (same as it was done by alternate image)
15:59 <knome> GridCube, that's not the only reason why people want -core
16:00 <GridCube> no, i didnt said it where
16:00 <xnox> knome: skellat: but then "try xubuntu" would actually be "try xubuntu-core"
16:00 <knome> xnox, yeah, that's not what we want... whatever we end up doing, -desktop should be the default
16:01 <knome> so anyway, Unit193 has been setting up a list of packages we want for -core
16:01 <xnox> knome: it can still be default, but there is an option to sacrafice the "livecd session" to be -core.
16:01 <micahg-work> Personally, I'd rather generate and test one image well, than 2 images poorly
16:01 <knome> rather than argue about how we'll do it, let's see what it would consist instead, first
16:01 <knome> micahg-work, +1
16:01 <elfy> micahg-work: +1
16:01 <GridCube> +1
16:01 <GridCube> also thats why we droped alternate in the first time
16:01 <skellat> As to GridCube's notion of needing a fast connection to download, we would get enough to bootstrap & apt-offline would be useful to grab the rest.  That's why we seed it.
16:01 <knome> #action Unit193 to send a proposed list of packages for -core to ML
16:01 * meetingology Unit193 to send a proposed list of packages for -core to ML
16:02 <PhilDick> i'd say that raising visibility of the need for testers and the howto on tester setup might be most impactful option. i'd describe what i found starting from xubuntu.org as subdued and scattered.
16:02 <micahg-work> I'm fine with the metapackage and tasksel installation option, but let's leave it off the media, I think we have enough to test for the LTS, let's not add to that
16:02 <elfy> PhilDick: yea - that's on the roadmap for QA actually
16:02 <knome> PhilDick, that's a different question, and i can't agree more; and it's on the roadmap/plans for 14.04; talk with elfy if you want to help :)
16:02 <knome> micahg-work, s/for the LTS/for any version/ :)
16:02 <micahg-work> we can think about adding that for LTS+1 and if it's successful, we can produce a point release for those new images
16:03 <knome> i don't think it's important enough to warrant a new image
16:03 <knome> ultimately, it should be only installed by people who know what they are doing
16:03 <micahg-work> knome, I'd say especially the LTS as we have to support this for 3 years, so we want to get it right, plus, this is what we point non-advanced users to as a rock solid platform
16:03 <knome> and that kind of people should be comfortable with the mini ISO
16:04 <knome> micahg-work, sure, but it's true enough for any release, we don't have dozens of testers anyway
16:04 <knome> anyway, we're agreeing; let's move on
16:04 <knome> #chair ochosi
16:04 <meetingology> Current chairs: knome ochosi
16:04 <knome> ochosi, the floor is yours
16:05 <ochosi> ok, first of all, thanks slickymaster and jjfrv8 on helping out with parole-docs
16:05 <knome> ochosi, #subtopic too, if you want to have #info #action
16:05 <ochosi> it's really a great help for bluesabre and me, so we can focus on fixing bugs
16:05 <ochosi> knome: sure
16:06 <ochosi> i think one way we can help both xfce and xubuntu is by improving the xfce docs
16:06 <ochosi> they're in dokuwiki format, which is easier to handle for newbies than docbook etc
16:07 <ochosi> #info ochosi thinks one way we can help both xfce and xubuntu is by improving the xfce docs
16:07 * knome facepalms
16:07 <knome> #undo
16:07 <meetingology> Removing item from minutes: <MeetBot.items.Info object at 0x17c9f10>
16:08 <knome> #subtopic Documentation
16:08 <knome> #info ochosi thinks one way we can help both xfce and xubuntu is by improving the xfce docs
16:08 <ochosi> ok ok :)
16:09 <ochosi> #info e.g. for parole-docs we set up a staging site for the docs, we can do the same for other xfce components
16:09 <ochosi> #info xfdesktop could use some updates, looking ahead at the changes of the 4.12 release
16:11 <ochosi> #info so feel free to get in touch with ochosi if you wanna help out with xfce docs
16:11 <knome> that includes jono_ at the redhat nat!
16:11 * knome hides
16:11 <jono_> ;-)
16:11 <ochosi> ok, that's it from my side
16:12 <knome> anybody else has any issues?
16:12 <GridCube> o/
16:12 <GridCube> i added a few topics to the roadmap
16:12 <knome> ok
16:12 <knome> thanks
16:12 <GridCube> well, two
16:13 <knome> we will be going through them this week, and deciding about them next thu
16:13 <GridCube> ok, if we find new ideas can we still add them to the roadmap?
16:14 <knome> feel free to; i'll add a subheader to separate things added after today though
16:14 <GridCube> alright
16:14 <knome> but no reason to not add new items; ultimately, we can use them for planning the U roadmap
16:14 <GridCube> what about the desktop of the week?
16:15 <knome> i will need to get to that some day
16:15 <knome> i've still been really busy; sorry about that :)
16:15 <GridCube> :/ that doesnt sound very promising
16:15 <knome> and :(
16:15 <GridCube> but alright :) i know its really low in the lists
16:15 <knome> tell that to my clients and real life :P
16:15 <knome> anything else?
16:15 <GridCube> do not worry
16:16 <knome> don't worry, i won't worry... and don't get that wrong, it's on the list and i will eventually get to it ;)
16:16 <knome> #subtopic Schedule next meeting
16:17 <knome> #info There is a non-regular meeting on Sunday, 3 November at 22UTC on #xubuntu-devel about picking Xfce 4.11 components (and related issues)
16:18 <knome> #info The next regular Xubuntu community meeting is on Thursday, 7 November at 15UTC on #xubuntu-devel
16:18 <knome> #endmeeting