15:03 <knome> #startmeeting Xubuntu community meeting
15:03 <meetingology> Meeting started Thu Oct 24 15:03:32 2013 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:03 <knome> #topic Items carried on
15:03 <slickymaster> it's the early bird whocatches the worm
15:03 <knome> #subtopic Open action items from previous meetings
15:03 <GridCube> �/
15:04 <knome> #action knome to prepare the website for the desktop of the week
15:04 * meetingology knome to prepare the website for the desktop of the week
15:04 <GridCube> :) thanks
15:04 <knome> #info knome tries to have time for that latest next week
15:04 <knome> #action skellat to prepare blog article discussing updating & upgrading for users and why it is okay to do so
15:04 * meetingology skellat to prepare blog article discussing updating & upgrading for users and why it is okay to do so
15:04 <knome> #nick skellat
15:04 <GridCube> #info GridCube will be ready whenever knome needs his asistance
15:04 <knome> that's it for the open action items
15:05 <GridCube> yes, i mean the desktop of the weeks thing
15:05 <GridCube> :)
15:05 <knome> let's postpone the strategy document review for a bit, we have more news about it
15:05 <GridCube> i tiped slow
15:05 <knome> #subtopic Ideas for using the project money
15:05 <knome> #info Discussion will continue on the mailing lists
15:05 <knome> #topic Team updates
15:05 <GridCube> i though we had agree to that already
15:05 <knome> partly, not wholly
15:05 <GridCube> ok
15:05 <knome> ok, everybody, is there any news?
15:06 <knome> (remember to use #action and #info)
15:06 <knome> i'm afk for 2mins
15:06 <GridCube> i've been tracking the reviews for xubuntu around
15:06 <GridCube> and watching the responses on the main channel
15:06 <elfy> #info  Planning for testing of LTS is moving on http://pad.ubuntu.com/SdHxBbkLTO
15:07 <GridCube> most reviews says that our desktop is "simple" and "minimalist"
15:07 <elfy> # Some input from -team on various aspects of that is required
15:07 <elfy> #info  Some input from -team on various aspects of that is required
15:07 <elfy> even
15:08 <pleia2> #info Published latest in "Xubuntu at" series: http://xubuntu.org/news/xubuntu-at-techs-for-a-cause-in-kansas-city/
15:08 <pleia2> #info If anyone else knows of people using Xubuntu in the wild, please send them my way :)
15:08 <knome> elfy, looks good
15:08 * elfy saw the draft of that - nice :)
15:08 <knome> GridCube, for me, that sounds like what we are after - cool! we should add those reviews to the press page
15:08 <knome> GridCube, if you have a list of them, can you send it to the -devel ML?
15:09 <GridCube> ok
15:09 <knome> #info knome has still one "Xubuntu at..." -series mail QIP
15:09 <knome> WIP too
15:09 <knome> #action GridCube to send a list of Xubuntu reviews to the -devel mailing list
15:09 * meetingology GridCube to send a list of Xubuntu reviews to the -devel mailing list
15:09 <GridCube> knome, there is a few people that complains about that though
15:09 <knome> GridCube, let's discuss that in the "wrap-up saucy" bit. remind me...
15:10 <knome> any other updates?
15:10 <elfy> #info Elfy is half way through doing an QA Saucy roundup
15:10 <knome> elfy, you've kept yourself busy :)
15:10 <pleia2> indeed!
15:10 <elfy> :)
15:10 <elfy> on holiday apparently ...
15:11 <pleia2> knome: mention edits to strat guide?
15:11 <knome> pleia2, i'll speak about that later :)
15:11 <elfy> knome pleia2 - I want to make more use of the xubuntu.org page for getting QA information out there - so a roundup seems like a good place to start
15:11 <knome> but yeah, i could
15:11 <pleia2> l
15:11 <pleia2> k
15:12 <knome> #info knome and pleia2 reviewed the strategy document a bit further...
15:12 <pleia2> elfy: great, we all should make more use of it
15:12 <knome> elfy, definitely1
15:12 <knome> ! too
15:12 <knome> #topic Annoucements
15:12 <knome> so,
15:12 <knome> as some of you acknowledge, this is my second and last term as the XPL within the extended term
15:13 <GridCube> :)
15:13 <knome> so that it doesn't come as a surprise, and the project can plan accordingly, i'm announcing it will stay at my last for now; to put it differently, i'm not seeking for another extension
15:13 <pleia2> :'(
15:13 <elfy> sad but unexpected
15:14 <elfy> expected ...
15:14 <knome> i will keep around though, for consulting and more, but i wish to focus on different things in the community for a change
15:15 <knome> and finally, i hope to get the community and the infrastructure in a good shape before i quit
15:16 <knome> my main goals for this cycle is to get at least one more contirbutor upload rights and to finalize the strategy document review so it can actually be helpful in the daily work
15:17 <pleia2> ++
15:17 <knome> other goals include, but are not limited to finalizing long-term projects, like getting some new apps uploaded and making logging/locking/shutting down consistent
15:17 <GridCube> :)
15:17 <GridCube> sounds good
15:17 <knome> anyway, there seems to be another announcement in the wiki:
15:17 <knome> #info skellat article about upgrading is in progress and can be found at lp:~skellat/+junk/UpgradingXubuntu
15:17 <knome> since skellat isn't around, let's move on
15:18 <knome> #topic New and emerging items
15:18 <knome> #subtopic Strategy Document reviewing
15:18 <knome> so, as mentioned in the updates, me and pleia2 worked more with the SD
15:18 <pleia2> it was boring, knome caught me off guard as I was wrapping up work
15:18 <knome> ha!
15:18 <pleia2> :)
15:18 <knome> anyway, we were able to strip off all process-related stuff from the strategy document
15:19 <knome> what this means?
15:19 <knome> well, the processes are now listed in https://wiki.ubuntu.com/Xubuntu/Processes
15:20 <knome> the goal is to make that separate from the strategy document and allow more flexibility and updating the process descriptions while we go
15:20 <pleia2> \o/
15:20 <pleia2> and hopefully with the shortening of the strategy document it'll be easier for folks to actually read
15:20 <knome> i also hope these could be more helpful for new contributors, specifically the release cycle process description
15:21 <knome> and that we could keep that updated, so when we start a new cycle, everybody knows what's going to happen
15:21 <knome> and yeah, to keep the strategy document shorter, and to the point
15:22 <knome> changing things in the strategy document shouldn't be easy, but after this last set of changes it *shouldn't* be easy.
15:22 <knome> err, first shouldn't -> isn't
15:22 <knome> basically, the SD should only describe what our long-term goals and core ideals are
15:23 * pleia2 nods
15:23 <knome> describing how we plan a release isn't such a thing
15:23 <knome> #action knome to make sure latest draft for the new SD is available for everybody before next week
15:23 * meetingology knome to make sure latest draft for the new SD is available for everybody before next week
15:23 <GridCube> i would like it very much if we could get people who develops xfce to join us to review the SD
15:23 <GridCube> if our goals and theirs dont collide its well
15:23 <GridCube> its not good
15:24 <knome> can you shed some light why do you think it would be beneficial?
15:24 <knome> after all, our SD says that something being xfce-related doesn't mean it should be automatically included in xubuntu, or by that nomination, be preferred over something else
15:25 <GridCube> well if they decide to go a road that we can not easily follow,or we decide to go a road that they dont wish to go (like just for example the mir issue) then we are going against the thing that makes us different
15:25 <GridCube> no ofcourse not
15:26 <knome> if they decide to do something we don't agree with, then we need to either rethink our mission or drop the component that is against our mission
15:26 <GridCube> as said, I, myself, think it would be nice to have someone upstream to review it and give their impressions
15:27 <GridCube> just that
15:27 <knome> while xubuntu is ubuntu with xfce, i personally do not think xubuntu is "the xfce OS", or that we should without constructive criticism and thought follow the way they are leading
15:28 <ochosi> i'm wondering whether the SD isn
15:28 <knome> i am not sure i see how it would be beneficial still
15:28 <ochosi> 't too xubuntu-specific and probably not too interesting for xfce devs
15:28 <GridCube> (i'd like to think xubuntu is not just one more of the xfce distros outhere but a very important one, i might be wrong ofcourse)
15:29 <knome> i'm pretty sure some of the xfce people disagree with some of our goals, or the means to reach them, or whether we have reached them or not
15:29 <GridCube> anyway, it was just a wish, lets move on
15:29 <knome> i think i'm also with ochosi on being not-too-interesting for them :)
15:30 <GridCube> i wouldnt hurt to ask
15:30 <knome> i suppose we could forward the SD to their development list once the rewrite is done
15:30 <GridCube> mmhm :)
15:30 <knome> (this last rewrite didn't really change anything re: xfce, just internal procedures and stuff)
15:31 <GridCube> i was thinking more about the whole gtk3 indicators issue
15:31 <knome> that's been discussed with them
15:31 <knome> and tbh, that's a non-SD related issue
15:31 <ochosi> yeah, and that's more a roadmap item
15:31 <GridCube> but again, lets move on
15:31 <knome> (or it should be)
15:32 <knome> #subtopic Developer communication and coordination in IRC
15:32 <knome> ok, i just wanted to let you guys know that we *really* should use #xubuntu-devel for development discussion, not -offtopic
15:32 <knome> it keeps the development transparent and logged
15:33 <GridCube> alright, sounds fair
15:33 <knome> #info Use #xubuntu-devel for development discussions, not #xubuntu-offtopic (where you are of course encouraged to socialize with other developers)
15:33 <GridCube> can i note that we should not use -offtopic for devel things aswell
15:33 <knome> well that's what i said ;)
15:33 <GridCube> oh ahahaha i missreaded
15:34 <GridCube> i swapped the channels
15:34 <knome> heh.
15:34 <knome> #subtopic Translating the website, LP 797600
15:34 <ubottu> Launchpad bug 797600 in Xubuntu Website "Enable translations for the Xubuntu website" [Medium,Confirmed] https://launchpad.net/bugs/797600
15:35 <knome> can't remember who set this agenda item up, but
15:35 <GridCube> olbi probably
15:35 <knome> anyway, the relevant comment: https://bugs.launchpad.net/xubuntu-website/+bug/797600/comments/6
15:35 <knome> pleia2, what do you think of that?
15:35 * pleia2 reads
15:36 <knome> we would be able to do this without any translation plugins, and the text itself could be something that was useful for flyers and stuff as well.
15:36 <pleia2> seems messy
15:36 <pleia2> but possible
15:36 <knome> not really, as long as the languages are a subpage of a page
15:36 <knome> that's of course just one of the options
15:37 <knome> i was thinking that would also help the burden for translators short- AND long-term
15:37 <ochosi> can't we handle the translations via launchpad?
15:37 <knome> ochosi, website translations?
15:37 <knome> humm,
15:37 <ochosi> something like putting the source of xubuntu.org on lp
15:37 <knome> heh.
15:37 <knome> the problem is how to *handle* those translations
15:37 <knome> but that's another idea.
15:37 <ochosi> on the wordpress-side, you mean?
15:38 <knome> yep
15:38 <ochosi> right
15:38 <knome> i mean, even for this translate-one-page
15:38 <ochosi> well you're the wp-expert, i've never handled translateable installations ;)
15:38 <knome> we could create a simple plugin that loads a page and serves alternative languages from .po files
15:39 <knome> but that's somewhat fishy as well
15:39 <knome> let's see how i have time during the next cycle
15:39 <knome> maybe i might be able to finish off my translation plugin as well
15:40 <knome> #subtopic Wrap up the Saucy cycle; things we did well, areas to improve, postponing blueprints to T, ...
15:40 <knome> so...
15:40 <knome> GridCube, people not liking xubuntu?
15:41 <knome> or thinking it's too simplistic...
15:41 <GridCube> yes
15:42 <GridCube> the reviews i've seen are a bit dissapointed with us
15:42 <GridCube> i understand that they have to show new shinny things and we dont provide that
15:42 <GridCube> and over that we even give away a desktop that has an obvious broken indicator issue
15:42 <knome> so what they are saying is that we didn't provide enough new features for them?
15:43 <ochosi> from what i read the broken sound-indicator is quite a bummer for most upgraders
15:43 <ochosi> (unsurprisingly)
15:43 <GridCube> knome, basically they say that there is no reason to install 13.10 whatsoever
15:43 <knome> the broken indicators situation sucks.
15:43 <GridCube> just wait for next LTS waht most of them say
15:43 <ochosi> and there are some logind/suspend issues
15:43 <knome> from my POV, we progressed more "behind the curtains" than in front of
15:44 <GridCube> knome, yes, i do understand that, im not saying not, as said they need to show new thingies to their readers
15:44 <GridCube> they could copy paste the review from 13.04 and it would still work
15:44 <brainwash> we have a new wallpaper, this is a major change!
15:44 <GridCube> yeah...
15:45 <knome> heh, i read a review that said you can barely notice it unless you compare the two next to each other
15:45 <GridCube> not even a few wallapers to choose
15:45 <knome> that's highly subjective though
15:45 <brainwash> the average xubuntu/xfce user does not like fancy changes anyway, things should simply work
15:45 <GridCube> yeah well, also some said that basic xubuntu needs about 500mb of ram with nothing open
15:45 <pleia2> speaking of reviews, can you pleia2: me when you find one? http://xubuntu.org/press/ doesn't have many at the moment
15:46 <knome> brainwash, that's a dangerous generalisation to make
15:46 <knome> brainwash, probably more true with xfce users, but i don't know about xubuntu users
15:46 <GridCube> pleia2, i've been pasting some on -offtopic
15:46 <GridCube> but sure
15:46 <knome> so;
15:46 <pleia2> GridCube: I can't read full backlogs of that channel, so highlight here is appreciated
15:47 <GridCube> :D
15:47 <GridCube> most of them did say that our system almost never crash and its fast
15:47 <knome> pleia2, i understand, it's icky enough that most of us can't
15:47 <ochosi> sorry folks, gotta go, have a goo drest of a meeting
15:47 <knome> 1) we need to get the fixed indicator stack in the backports soon
15:48 <knome> 2) people want new features, but we didn't provide them those; we will with 14.04
15:48 <GridCube> :)
15:48 <knome> i think the indicator stack issue is one of the things where we could've done better
15:49 <knome> releasing with them was a decision taken, not an accident though
15:49 * GridCube wasnt really involved to notice how broken that was
15:49 <elfy> knome: not sure how - it was down to time for the few that could do anything
15:49 <knome> it was known for a long time, but fixing it in a way or other wasn't trivial
15:49 <elfy> indeed
15:50 <knome> elfy, i suppose we should've asked for more external support and/or generally just going for the gtk3 stack because we "need" that for 14.04 anyway
15:51 <elfy> possibly - I don't know enough about the ramifications of that to comment :)
15:51 <knome> and a lot of that discussion could have happened earlier in the cycle, even/especially amongst those who couldn't do the final heavy lifting
15:51 <knome> and that might've given the people who were able to do the heavy lifting more time to do it
15:51 <knome> anyway, i think it was a good cycle community-wise
15:52 <elfy> as far as I know it was being discussed in here almost as soon as it showed up
15:52 <knome> and as i said, more things seemed to happen behind the curtains than in front of
15:52 <elfy> yea definitely
15:53 <knome> elfy, the gtk3 indicator stack was a possible direction at the beginning of the cycle, though at that point it wasn't as clear how broken the gtk2 indicators would've been (but maybe we would've found out...)
15:53 <knome> and - congrats to everybody who contributed
15:53 <GridCube> the overall status of xubuntu is impressive, if i can say, i mean besides the gtk3 indicators i dont think there is a single complain that is not subjetive
15:53 <knome> 13.10 is a good stepping stone for 14.04, which will be, i'm sure, the best xubuntu LTS out there
15:53 <elfy> :)
15:54 <GridCube> ;D
15:54 <elfy> it's be tested - that's for sure :p
15:54 <knome> that too!
15:54 <knome> the agenda has a mention of postponing blueprints/work items for T, but we'll do that later
15:54 <knome> Unit193, you around?
15:55 <knome> #subtopic Xubuntu Core (or xubuntu-core)
15:55 <knome> i'm thinking we should carry on this item for the next meeting
15:55 <elfy> I agree with that
15:55 <GridCube> third
15:55 <knome> #subtopic Schedule next meeting
15:55 <GridCube> o/
15:55 <knome> GridCube, oi?
15:56 <GridCube> i want to ask something for 14.04
15:56 <GridCube> i've read on a review this;
15:56 <GridCube> xfce4-power-manager-plugins is not installed by default, and in 13.10 is now hidden under technical items in the software center.
15:56 <GridCube> This means that the users who can't get their brightness buttons working have to know all of that as well as how to add the brightness manager to the panel to see it at all. That is unacceptable for a newbie to linux.
15:56 <knome> i don't know enough of that to say this or that
15:56 <GridCube> i've heard a lot of people comming to the channel to ask about brightness and this is the first time i've learned that xfce has a tool for it
15:56 <knome> we need to look at it
15:57 <GridCube> i would like this to be investigated
15:57 <GridCube> :) yes
15:57 <knome> can you add that to the roadmap page in the discussion?
15:57 <knome> https://wiki.ubuntu.com/Xubuntu/Roadmap
15:57 <GridCube> in lp�
15:57 <GridCube> ok yes
15:57 <knome> thanks
15:57 <knome> so, next week is the end of brainstorming
15:58 <knome> we should discuss the roadmap then, so let's schedule a meeting for next week
15:58 <knome> #info Next Xubuntu community meeting: Thu, Oct 31st, 15UTC at #xubuntu-devel
15:58 <knome> #endmeeting