15:00 <knome> #startmeeting Xubuntu community meeting
15:00 <meetingology> Meeting started Thu Jul 11 15:00:20 2013 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00 <meetingology> 
15:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:00 <knome> #chair elfy pleia2
15:00 <meetingology> Current chairs: elfy knome pleia2
15:00 <elfy> micahg-work: ping
15:00 <jono> hey everyone :-)
15:00 <lderan> hello :)
15:00 <skellat> Good morning jono
15:00 <pleia2> o/
15:00 <knome> since we have jono as a guest here today, and he has a tight schedule i'm sure, let's go ahead with the mir discussion right away
15:01 <knome> #topic Mir, XMir, X, and stuff (with Jono Bacon)
15:01 <bluesabre_work> sounds good to me
15:01 <jono> thanks knome :-)
15:01 <jono> so I have been reaching out to each of the flavors to discuss Mir
15:01 <jono> and to discuss their plans for 13.10 and 14.04
15:02 <jono> much of the discussions so far has been the flavors asking technical questions about Mir and what is involved in integrating it
15:03 <jono> so I just wanted to reach out to you folks to see what Xubuntu's perspective is, and if there is any support and guidance I can help with, or the Mir team can help with
15:03 <elfy> jono: these discussions documented anywhere ?
15:03 <jono> elfy, no, they have been on phone calls
15:03 <knome> i suppose the first question has to be: what options do we have and which of those are more or less "canonical-supported"
15:04 <jono> knome, good question
15:04 <jono> so these are the options I think:
15:04 <jono> for 13.10:
15:04 <jono> * XMir + Mir - this will been you can run XFCE without any changes - it will run just like normal on the XMir compatibility layer
15:05 <jono> XMir is currently seeing a wealth of performance improvements and will match the speed of X in 13.10
15:05 <jono> XMir + Mir will be fully supported by Canonical and will be our primary display server stack
15:06 <jono> also, XMir is a very thin layer so it should not introduce any bugs into Xubuntu, and if you do see a bug, it will be so obvious it is XMir
15:06 <jono> * Use the regular X stack - Canonical will not be maintaining a regular X stack, the X we will maintain will be XMir + Mir
15:06 <jono> for 14.04:
15:06 <jono> * XMir + Mir - again, you can ship XFCE just like normal using our X compatibility layer
15:07 <micahg-work> jono, I thought for 13.10 Canonical would maintain the X stack as a fallback for those drivers that aren't supported by XMir
15:07 <jono> * Use the regular X stack - again, Canonical will not be supporting X in 14.04, and I suspect this will degrade as the five year support period progresses
15:08 <jono> * XFCE using Mir - another option, and one which we would like to encourage upstreams with, is to build a Mir backend for the desktop
15:09 <pleia2> our upstream is a smaller team than we are, I think getting Xfce to write for Mir is highly unlikely
15:09 <jono> micahg-work, yes, so if a driver cannot work with Mir (at the moment, proprietary drivers) it will fallback to X
15:09 <knome> +1 for micahg-work's and pleia2's comments
15:09 <GridCube> highly
15:09 <micahg-work> jono, as we're not even sure if we're shipping Xfce 4.12  as it's not released, having Mir as a backend for Xfce in the 14.04 timeframe is very unlikely
15:09 <pleia2> (they don't even have Waylan plans right now)
15:09 <jono> micahg-work, so we will maintain the fallback
15:09 <pleia2> Wayland
15:09 <jono> pleia2, I can understand that concern
15:09 <pleia2> I also have concern that we're halfway through the cycle and not only is xmir not in the repos, but when Unit193, skellat and I tested it, only skellat was actually able to get it to run
15:10 <bluesabre_work> I also tested it with no luck
15:10 <skellat> When I had that up the experience was clearly sub-optimal
15:10 <jono> pleia2, XMir should land in the next two weeks, and you can test XFCE with Xmir today using the PPA in the interim
15:10 <skellat> We have users, not test subjects
15:10 <knome> jono, so should we interpret that as you will or will not maintain X in 13.03?
15:10 <pleia2> jono: we tried to use the PPA, it fails
15:11 <Unit193> In theory you can test it, the one from the PPA just crashed at startup, on all 3 computers I tried.
15:11 <jono> knome, to be clearer, our maintained X stack will be XMir + Mir, not desktops using X directly
15:11 <pleia2> yeah, all mine fail back to xorg
15:11 <jono> pleia2, when did you try it?
15:11 <pleia2> jono: last night
15:11 <jono> pleia2, ahhh, I thought that was fixed
15:11 <jono> there was an issue in the last few days
15:11 <skellat> I got it to boot last night on a System76 Starling netbook but the UI experience was suboptimal with two cursors barely tracking each other correctly
15:11 <micahg-work> jono, why for 13.10 is the X stack support being dropped since it's still the fallback?
15:11 <jono> pleia2, I will ensure the Mir team look into that
15:12 <jono> skellat, the two cursor thing is temporary - the second cursor just shows you are in Mir
15:12 <jono> skellat, that will be removed soon and a watermark used
15:12 <skellat> jono: They shouldn't be **both** moving like a bad VirtualBox session though
15:12 <jono> skellat, it is *temporary* :-)
15:12 <jono> skellat, it is a poor man's watermark :-)
15:12 <bluesabre_work> haha
15:13 <jono> micahg-work, X is not dropped, it will be just maintained to support XMir
15:13 <knome> jono, is there a mailing list or other output where the mir-related news are updated (and mir-devel isn't what i'm looking for, that's too high traffic)
15:13 <jono> micahg-work, I think a Mir engineer can provide a better response on this question on the details, I will note that down
15:13 <jono> knome, you raise a great question
15:14 <micahg-work> jono, right, I get the X stack through XMir is supported, I'm just not sure why straight X support would be dropped for 13.10 being that it's the fallback (I understand for 14.04)
15:14 <jono> knome, so in terms of a list, we don't have anything for just updates, but I have been thinking about providing weekly flavor updates of Mir progress, would that be useful?
15:14 <jono> micahg-work, I will check with the Mir team with what the difference is
15:14 <knome> jono, that sounds fair. if it's doable, just subscribe our developer mailing list for that mailing.
15:14 <jono> knome, will do, thanks for the note
15:14 <jono> we do have the weekly video update, but I understand that that is not the same
15:15 <GridCube> nope
15:15 <jono> so it sounds like upstream are currently focusing on X, is that right?
15:15 <Unit193> From what I've seen, Mir/XMir isn't even planning on getting virtual support until August, that's pretty close to release date (And FF?)...
15:15 <pleia2> unfortunately we're all pretty busy, it's impossible for most of us to take an hour out of our week to watch a video
15:16 <jono> Unit193, virtual support?
15:16 <GridCube> xfce upstream yes
15:16 <knome> jono, they have pretty much only one active contributor, so they aren't really "focusing" on any display server...
15:16 <Unit193> jono: vmware, virtualbox.
15:16 <pleia2> scanning IRC logs and similar is much faster and easier
15:16 <jono> knome, gotcha
15:16 <knome> pleia2, or a good old email
15:16 <pleia2> or at least having a summary emailed somewhere so we know if portions of the video are worth our time
15:16 <skellat> A late drop toward Feature Freeze has us worried that there would be a need to scramble in case we find that we feel XMir is not in a condition we feel comfortable shipping to users.
15:16 <pleia2> skellat: +1
15:16 <jono> knome, so in terms of Xubuntu, upstream can continue to ship an X display server in 14.04
15:16 <skellat> We want our users to have a finished product instead of a work in progress.
15:16 <jono> with XMir
15:17 <jono> Unit193, I haven't tested it in a VM, I have heard mixed reports of whether it works
15:17 <jono> Unit193, but I think you face that issue with Wayland too
15:17 <Unit193> It doesn't in vbox.
15:17 <Unit193> I don't with X.
15:17 <knome> i've heard it simply "does not work" with virtualbox.
15:17 <pleia2> jono: understand, wayland is not even on the horizon for us
15:17 <skellat> I had a race condition with VirtualBox last night testing our test disc that locked up my machine totally
15:17 <pleia2> it's not on Xfce's roadmap at all
15:17 <jono> pleia2, I think an email summary might be easiest - we take notes for the video, I could send those
15:17 <jono> pleia2, right
15:18 <pleia2> so we're talking about sticking with xorg or using xmir, no mir or wayland in the discussion :)
15:18 <jono> ok, so it sounds like the primary focus here for you folks is being able to ship the current codebase, and test it with XMir
15:18 <pleia2> yeah, since most of our tests fail this is a very concerning situation
15:18 <mrpouit> how far is xmir wrt xrandr support?
15:18 <mrpouit> and xi?
15:18 <jono> whoever tested the PPA and it failed, could you email a summary of the problem?
15:19 <knome> Unit193, can you coordinate a... coordinated reply? :)
15:19 <jono> I recommend we kick off an email discussion thread about getting you folks up and running
15:19 <pleia2> my errors were the same as Unit193's
15:19 <jono> so it was pleia2 and Unit193 who tested it?
15:19 <pleia2> and bluesabre_work
15:19 <knome> and skellat and bluesabre_work
15:19 <skellat> jono: And me
15:19 <bluesabre_work> mine as well
15:19 <elfy> I can look at trying it as well on one of the lappies
15:19 <pleia2> it worked for skellat though :)
15:19 <Unit193> pleia2: I had a couple different ones.
15:19 <lderan> aye same
15:19 <elfy> so it won't be virtual
15:19 <knome> i can probably chime in with some hardware at some point
15:19 <knome> (if badly needed)
15:20 <jono> ok, pleia2, would you mind starting an email thread with everyone involved and copying me in, and summarize the issues, I will then copy a Mir engineer in
15:20 <skellat> pleia2: It bootstrapped but wasn't very functional.  Not sure if that counts as worked.
15:20 <jono> this is also pretty temporary, it should land in the archive in the next few weeks, but at least in the interim you can do some testing
15:20 <knome> pleia2, please delegate to Unit193 and make sure he CC's xubuntu-devel ;)
15:20 <jono> skellat, define functional?
15:20 <holstein> pleia2: if you can easily, add me. i will test with a machine i am wiping this week
15:21 <pleia2> #action Unit193 to collect details about Mir failures and email to -devel, jono and testers
15:21 * meetingology Unit193 to collect details about Mir failures and email to -devel, jono and testers
15:21 <skellat> jono: Being able to boot without the kernel apparently going into a fault condition and nm-applet failing
15:21 <skellat> I couldn't report flaws as it wouldn't connect to a network
15:21 <jono> skellat, that is outside of XMir
15:21 <slickymaster> pleia2, you can also include me if you want. I can test it, also
15:21 <jono> skellat, that sounds like another issue
15:21 <pleia2> slickymaster: great! (and welcome :))
15:21 <micahg-work> well, the sooner it lands, the sooner we can evaluate, I think we'd like to take a decision about a week before feature freeze whether or not to go with XMir for 13.10
15:21 <jono> today XFCE should work as expected with XMir, apart from the annoying extra cursor
15:21 <skellat> jono: We'll park that then for later review
15:22 <pleia2> micahg-work: +1
15:22 <jono> multi-monitor is also being worked on and will not expose any regressions in Mir
15:22 <knome> i definitely +1 micahg-work
15:22 * elfy does as well
15:22 <micahg-work> jono, can you speak to mr_pouit's questions?  they revolve around some base functionality
15:22 <skellat> +1 micahg-work
15:22 <jono> micahg-work, agreed, rest assured the Mir team are peddling as fast as they can :-)
15:22 <knome> jono, d'oh, don't promise us that since it will have bugs (not to say i don't believe you don't fix them ;))
15:22 <jono> micahg-work, which questions?
15:22 <elfy> <mrpouit> how far is xmir wrt xrandr support?
15:22 <elfy> <mrpouit> and xi?
15:22 <pleia2> 08:18:28 < mrpouit> how far is xmir wrt xrandr support?
15:22 <micahg-work> <mrpouit> how far is xmir wrt xrandr support?
15:22 <micahg-work> <mrpouit> and xi?
15:22 <pleia2> 08:18:45 < mrpouit> and xi?
15:22 <pleia2> haha
15:23 <elfy> lol
15:23 <knome> flood alert!
15:23 <jono> knome, I am sure there will be some bugs, but we will get 'em fixed :-)
15:23 <knome> there are three trolls in the channel..
15:23 <jono> mrpouit, are you referring specifically to multi-monitor?
15:23 <mrpouit> jono, yes
15:23 <jono> mrpouit, so the goal for 13.10 is zero regressions
15:23 <mrpouit> ffrom what I could find (basically, nothing, xmir isn't documented at all), there's no plan
15:23 <jono> some reading that will help:
15:23 <jono> * blueprint: https://blueprints.launchpad.net/ubuntu/+spec/client-1310-mir-multimonitor
15:24 <jono> * thread: https://lists.ubuntu.com/archives/mir-devel/2013-June/000235.html
15:24 <jono> mrpouit, if you have any further questions, mir-devel will be the best place to ask them, the engineers live there
15:24 <knome> so what's the situation with (X)Mir documentation in general?
15:25 <jono> knome, what kind of docs do you mean?
15:25 <jono> integrating it?
15:25 <knome> any documentation.
15:26 <mrpouit> I think he means: "written documentation", without needing to listen to 1-hour long videos
15:26 <knome> ^ that
15:26 <jono> knome, docs currently live at http://unity.ubuntu.com/mir/
15:26 <jono> the docs are improving each week too
15:26 <knome> mrpouit, do you have insight if that's even near what we'd need?
15:26 <jono> if you have any further questions about integration Mir, the Mir team can help answer them
15:27 <jono> I have asked dholbach to merge new docs into the core Mir docs
15:27 <knome> jono, i would say one of the things that really should start working is xmir with virtualbox
15:27 <jono> knome, I will note down to see where that sits right now
15:27 <mrpouit> knome, yeah, planning for example. Also, what about ewmh, xrandr, xi? Will the support be identical to Xorg?
15:27 <jono> I am not sure how far along that is
15:27 <jono> mrpouit, yes
15:27 <jono> everything should be the same
15:28 <jono> mrpouit, but again, if you have specific questions, mir-devel is the best place to ask
15:28 <Unit193> "Should be", and "are" aren't always the same. ;)
15:28 <knome> since we have an already small testing team and many of the tests are run with virtualbox... you can see where you leave us if xmir isn't working with it
15:28 <mrpouit> jono, is it the same kind of promise as "gtk2 indicators will be maintained during all the 12.04 lifetime", and they got dropped for 12.10? :)
15:28 <jono> Unit193, which is why I am recommending mrpouit posts to the list ;-)
15:28 <jono> knome, can you elaborate on the tests? automated tests?
15:29 <knome> jono, manual tests
15:29 <jono> mrpouit, I don't know about indicator support
15:29 <jono> knome, ahhh gotcha, well I will see if it runs in a VM, I have heard mixed reports tbh
15:29 <bluesabre_work> jono, what are the additional memory requirements of using XMir as opposed to just X?
15:29 <knome> jono, i suppose he's asking that you keep what you promise - that wasn't the case with the gtk2 indicators
15:29 <pleia2> none of us have gotten it to work in virtualbox either
15:30 <knome> jono, as i said, i've heard that it simply doesn't work with virtualbox.
15:30 <mrpouit> jono: basically, you're asking us to trust you on that, because right now to be able to take an informed decision we have to wait for the bits to land, and they land very very late, when it's too late to decide...
15:30 <jono> knome, XMir will definitely be supported as we need it to ship Unity :-)
15:30 <jono> mrpouit, I appreciate that, but the Mir team can only work so fast
15:30 <skellat> mrpouit: What date would you call as the "point of no return" where we need to make decisions?
15:30 <jono> which is why I am recommending you test with the PPA - the issues with the PPA recently were a blip
15:31 <pleia2> we've all been testing with the ppa
15:31 <Unit193> And it's crashed over and over.
15:31 <jono> pleia2, if there are issues with the PPA I would encourage you to report them to mir-devel so the devs can get them fixed
15:31 <jono> they are very responsive
15:31 <knome> jono, it doesn't work with hardware or virtualbox. if you can't promise it won't work for 13.10, don't
15:32 <jono> knome, can't promise what will work?
15:32 <knome> jono, (x)mir for xubuntu
15:32 <mrpouit> skellat, I'm not sure, this is probably a question for the testers too, but end of july would have been the limit (after that people go to vacation/will be less available). Maybe we can wait until feature freeze, but meh :P
15:32 <jono> knome, I can promise XMir will work in the archive
15:32 <jono> we have committed to that
15:32 <jono> again, we need it to ship Ubuntu itself
15:33 <elfy> committed to it working with Ubuntu or everything?
15:33 <knome> elfy, +1
15:33 <lderan> committed to it being in a usable state for everything as well?
15:33 <jono> elfy, we are committed to XMir being the X stack that all flavors can use for their desktops too
15:34 <mrpouit> jono, "we're rushing it into 13.10 so 14.04 can be rock-solid" (basically what Olli Ries wrote) isn't very reassuring
15:34 <jono> if we make XMir work for Ubuntu, it will work for flavors
15:34 <elfy> mrpouit: +1
15:34 <micahg-work> I'm not worried about XMir being usable for Ubuntu by release, I'm worried about it being usable enough that we can make an informed decision in time
15:34 <jono> mrpouit, it is what it is - it is shipping in 13.10
15:34 <jono> this isnt rushing it, this is shipping it
15:34 <knome> jono, that's not assuring for us
15:34 <jono> knome, what isn't reassuring?
15:34 <mrpouit> jono, "it is what it is" << are you really here to listen to our concerns?
15:35 <knome> jono, "it will work for flavors", since flavors *aren't* the focus of (x)mir or canonical-paid developers
15:35 <jono> mrpouit, I believe I am being responsive to your concerns, but my point is: XMir is landing in 13.10, nothing we discuss here is going to change that - my goal here is to provide as much support as possible to our flavors
15:35 <knome> jono, and i understand that, but if you are going to make it work barely in time for ubuntu, why should we trust it's usable for us in 13.10?
15:35 <jono> knome, I think that is a fair point
15:35 <skellat> jono: XMir isn't going to turn out like 100 scopes did then?
15:36 <jono> if you folks don't feel you have the time to use XMir between when XMir lands and when you ship, that is a reasonable concern
15:36 <knome> jono, that just doesn't make sense, even if mark put half of his money and dirty socks in the gamble.
15:36 <jono> but there isn't much we can do about it as we can't land Mir any earlier as they are currently working on integrating it
15:36 <jono> skellat, ?
15:36 <jono> skellat, what do you mean?
15:37 <jono> knome, I agree you folks need to make your own call about whether the timelines work for you
15:37 <jono> I agree that it is right
15:37 <knome> jono, that is exactly our concern; stuff landing too late so we don't really have time to make a decision and not even talking about testing and making it integrated for *us*
15:37 <jono> but the Mir team are working long day and nights to get it in ASAP
15:37 <elfy> we understand that jono
15:37 <elfy> but we're concerned about us at the moment
15:37 <skellat> jono: 100 scopes was a major commitment for R that had to be delayed to S because it missed deadlines and wasn't in a ship-worthy state in time
15:38 <Unit193> #action Unit193 to rebuild the XMir ISO once sufficient changes land in the PPA.
15:38 * meetingology Unit193 to rebuild the XMir ISO once sufficient changes land in the PPA.
15:38 <lderan> im sure their work will come to fruition well with ubuntu
15:38 <jono> skellat, yes, it was delayed because the quality wasnt there - we had received criticism about not shipping low quality code, so we were receptive to that
15:38 <pleia2> just to be clear, Xubuntu has always tracked Ubuntu's base and I think we want to here too, we just aren't keen on using our users as guinea pigs on a major portion of the desktop for 13.10 "so it's solid for 14.04"
15:38 <knome> jono, so will the it be the same story with mir?
15:39 <pleia2> we want to give xmir a chance :) it's just quite scary at the moment
15:39 <jono> if the release and QA team don't approve Mir, it won't go in
15:39 <jono> pleia2, I can understand that
15:39 <jono> so I think the conclusion here is the following:
15:39 <jono> * XMir is landing in the next few weeks
15:39 <knome> to be fair, how much control does the release and QA teams really have in that if mark wants it in?
15:40 <jono> * the PPA is available for testing, if there are bugs, please report them to mir-devel so we can fix them
15:40 <mrpouit> knome: (zero control, even the release team can not object)
15:40 <jono> * the timescales are short, so the Xubuntu team should make an assessment if XMir is going to work
15:40 <Unit193> So, what was the outcome of contacting Kubuntu and Lubuntu anyway?
15:40 <jono> * the Mir team are here to provide help and guidance for Mir-related questions and issues
15:40 <knome> mrpouit, exactly my point, but i want to hear that from mr. bacon
15:41 <jono> knome, Mark doesn't override the release tean
15:41 <jono> teamn
15:41 <mrpouit> jono, he does
15:41 <knome> yes he does.
15:41 <mrpouit> I guess you're not subscribed to the -release bug reports
15:41 <jono> that is a seperate discussion, I disagree, but lets not derail this
15:41 <knome> jono, that is an important question.
15:41 <skellat> mrpouit micahg-work: I guess we need to set a "point of no return" date for the ease of jono when we have to make a decision on XMir by whether we ship it or not
15:41 <micahg-work> jono, it's a rarely used power, but it is used
15:41 <elfy> jono: well it is part of the dicussion and an important part
15:41 <pleia2> skellat: +1
15:42 <knome> jono, we don't want to ship a half-broken mir in xubuntu 13.03.
15:42 <micahg-work> skellat, I think a week before feature freeze is good
15:42 <pleia2> knome: making up version numbers
15:42 <knome> i am
15:42 <micahg-work> that gives us 6 weeks before final freeze
15:42 <pleia2> hehe
15:42 <jono> ok, so Mark does use his sabdfl power occassionally, I agree, and he might use it for Mir
15:42 <jono> but I don't see how that affects Xubuntu making a decision about XMir
15:42 <pleia2> micahg-work: sounds good to me
15:42 <knome> jono, so doesn't that effectively lead us to the fact that you really can't promise that mir works with 13.10 ?
15:42 <knome> jono, or the mir team, or anybody
15:43 <jono> knome, I am promising you based on the information I have
15:43 <knome> jono, and also, nobody still stopping it from getting in
15:43 <micahg-work> jono, it doesn't, I think they were commenting to whether or not MIR will land is up to release + QA
15:43 <jono> I am not a fortune teller
15:43 <jono> sure, it could completely blow up if the Mir team get hit by a bus
15:43 <jono> :-)
15:43 <jono> my point is that based on the planning and trajectory, the Mir team is on track to deliver what they promise
15:43 <micahg-work> jono, anyways, I think we'd like to have XMir, if it's ready enough for us, otherwise, we'll reevaluate for 14.04
15:43 <jono> I am not denying that they may fail, there may be other issues at play
15:43 <knome> or if they simple can't deliver a stable product on time, which happens with tight schedules, even with the best engineers
15:44 <jono> knome, right
15:44 <skellat> micahg-work mrpouit: Feature Freeze hits on August 29th.  Do we want to call the "go/no-go" date as August 22nd then or what is your pleasure?
15:44 <jono> knome, as I say, I am basing everything on their planning and current progress
15:44 <jono> I am going to have to run in a second, folks
15:44 <micahg-work> skellat, that's what I'm thinking meeting on Aug 22
15:44 <jono> I am already really late for a call
15:44 <jono> I appreciate the feedback
15:45 <knome> jono, so basically, what you are saying is "i hope mir is ready for 13.10", not "i promise mir is ready for 13.10" ?
15:45 * skellat thanks jono for taking the time to join us
15:45 <pleia2> thanks jono
15:45 <micahg-work> jono, thanks
15:45 <elfy> jono: indeed, thanks
15:45 <lderan> thank you jono :)
15:45 <knome> jono, thanks, it's much appreciated (though i'd still like to get a yes/no answer to my last question)
15:45 <jono> knome, to be clear: the Mir team are targetting 13.10, that is what the full team are working towards, my confidence in that is unimportant, you should assess it yourself
15:45 <jono> no one cares what I think anyway
15:46 <knome> jono, we do, that's why you were invited to this meeting.
15:46 <jono> knome, I would recommend you reach out to the Mir team directly if you need further assurance
15:46 <knome> okay
15:46 <pleia2> #agree Call the "go/no-go" date for xmir as August 22nd
15:46 <jono> knome, I appreciate that, but it seems like every point I have made has been treated with skepticism
15:46 <jono> which is fine, which is why I am suggesting you look into it yourself
15:46 <knome> jono, sure, but isn't that expected? :)
15:47 <jono> my goal here was only to open the discussion
15:47 <elfy> you did that ;)
15:47 <jono> knome, tbh, not really
15:47 <knome> jono, anyway, thanks for joining us and have a nice day!
15:47 <jono> knome, but whatever :-)
15:47 <micahg-work> I would venture to say if it's not landed at least by Aug 15, that we defer to 14.04
15:47 <skellat> pleia2: Shall we have a blog post to announce that in the spirit of openness?
15:47 <pleia2> skellat: I'm thinking dev mailing list post that we'll share
15:47 <lderan> have a good day jono
15:47 <jono> thanks, all
15:47 <knome> +1 for pleia2
15:48 <knome> our website is for communicating with users, and i don't think development related deadline dates fall into that category
15:48 <pleia2> (our blog is more user-facing, most think Mir is just a space station that landed in the ocean :))
15:48 <skellat> #info (11:47:17 AM) micahg-work: I would venture to say if it's not landed at least by Aug 15, that we defer to 14.04
15:48 <skellat> knome pleia2: Understood
15:48 <bluesabre_work> thanks jono, have fun!
15:48 <xnox> knome: mir is ready enough for me, works fine on my desktop. intel graphics.
15:48 <knome> xnox, with xfce?
15:48 <pleia2> xnox: intel is the key
15:48 <knome> right, that's probably a fair point
15:49 <micahg-work> xnox, right, no binary drivers ATM
15:49 <knome> let's test it with non-intel
15:49 <GridCube> or non high end computers
15:49 <xnox> knome: pleia2: there a lot of work done with binary driver providers, but it's a relationship canonical is managing and those binary blobs are not released yet.
15:49 <lderan> i have some amd machine i can use, their a bit old to boot
15:49 <pleia2> alright, let's get this meteing back on track
15:49 <micahg-work> right, once we have a decision, we can blog about it
15:49 <pleia2> we can discuss mir later
15:50 <elfy> pleia2: agreed
15:50 <knome> xnox, so what you are basically saying that, as we know, "it's not working" :)
15:50 <knome> agreed as well.
15:50 <knome> should we discuss about the deadline date?
15:50 <xnox> knome: what i am saying "it's actually being actively worked on"
15:50 <knome> or is everybody fine with august 22?
15:50 <xnox> to get the binary blobs written & working.
15:50 <knome> xnox, yes, prefixed with "it's not working, but"
15:50 <pleia2> knome: I think we're all good with that
15:50 <knome> xnox, sorry, i'm not trying to be annoying. :)
15:51 <elfy> +1 to date
15:51 <knome> xnox, i hear you, and i think it's great people are actually working on it and not just "planning" stuff
15:51 <knome> ok, that's it for the mir discussion1
15:51 <knome> ! too
15:51 <knome> #topic Items carried on
15:51 <knome> #subtopic Open action items from previous meeting
15:51 <knome> #link https://wiki.ubuntu.com/Xubuntu/Meetings#Xubuntu.2BAC8-Meetings.2BAC8-Archive.2BAC8-Minutes.2BAC8-2013-06-13.Action_items.2C_by_person
15:51 <xnox> knome: the binary blobs do work with mir on nexus devices, so existing ones can be made to work with it. (case in point tegra platform of nexus7 has nvidia binary blobs)
15:51 <knome> anything that's actually been done?
15:51 <skellat> knome: I can report on the bugs team topic
15:52 <xnox> knome: *some* binary drivers already work with mir ;-)
15:52 <pleia2> boo, slow wiki
15:52 <bluesabre_work> #info lightdm-gtk-greeter 1.6 is in the saucy repos
15:52 <knome> xnox, *some* people already understand we need to cut down our gasoline usage...
15:52 <lderan> loaded fast for once, scary stuff
15:52 <knome> xnox, sorry for the low blow... :P
15:52 <lderan> ba'dum tish
15:52 <knome> skellat, sure, go ahead
15:52 <pleia2> saw the new login screen when trying to test xmir last night, very nice :)
15:53 <knome> yes, that's an improvement
15:53 <bluesabre_work> it will look even nicer when the updated artwork hits
15:53 <pleia2> #link https://wiki.ubuntu.com/Xubuntu/Meetings/Archive/Minutes/2013-06-13
15:53 * pleia2 browses action items
15:53 <skellat> knome: Actually, on second thought, I'll defer both to next meeting since I'm still pondering XMir at this point
15:53 <knome> skellat, sure. :)
15:53 <knome> pleia2, didn't the link i pasted work for you?
15:53 <skellat> #action skellat to continue work on items from 2013-06-13 meeting
15:53 * meetingology skellat to continue work on items from 2013-06-13 meeting
15:53 <pleia2> knome: oh, I r teh blind
15:54 <bluesabre_work> #info we do not have an interface for setting a user profile image
15:54 <bluesabre_work> but I can throw together a simple lightweight one if desired
15:54 <knome> bluesabre_work, for good, or... ?
15:54 <Unit193> cp Pictures/myface.jpg .face  ?  :P
15:54 <xnox> knome: I hope I understand what that meant. It's all funny and playful, yet each cycle we land millions of new lines of code and make all of that work. With massive amounts of porting work.
15:54 <knome> bluesabre_work, if that's trivial enough to not keep you away from other things you are planning to deliver this cycle
15:54 <GridCube> i say that that would be nice
15:54 <bluesabre_work> Unit193: thats for advanced users ;)
15:55 <xnox> knome: to be honest, I am always scared of each X/kernel/gcc/libc upgrades, cause I find things broken.
15:55 <bluesabre_work> knome: I'm not worried about it tbh
15:55 <xnox> knome: but at the same time we work hard on making it work.
15:55 <knome> xnox, i understand your point. but for me, as a non-technical person, if it doesn't work, i don't care how close we are to "it works". it's a boolean ;)
15:55 <xnox> knome: and Mir is no different. using and testing it is the only way to prove when it's ready & usable.
15:55 <knome> bluesabre_work, in that case, yes, we would like you to do that
15:56 <xnox> knome: nothing gets a magical label "stable" and everyone starts using it, instead typically "everyone is on $foo" thenst it's ready.
15:56 <micahg-work> xnox, normal upstreams have a concept of "stable"
15:57 <bluesabre_work> #action bluesabre to create a basic user-profile-image app
15:57 * meetingology bluesabre to create a basic user-profile-image app
15:57 <knome> xnox, sure. again, i'm not trying to be annoying. i definitely understand your point and respect both the mir developers and your work :)
15:57 <xnox> knome: =)))))
15:57 <knome> anything else on the action items?
15:57 <pleia2> mine was done, now GridCube is well on his way with the desktop image submission team
15:58 <knome> (each person, can you #action any items again that's NOT done)
15:58 <pleia2> #info completed completed submission guidelines for desktop image submissions
15:58 <knome> #action knome sends email about adding other members to xubuntu-release
15:58 * meetingology knome sends email about adding other members to xubuntu-release
15:58 <elfy> #action greeter testcase still to be done - waiting for artwork
15:58 * meetingology greeter testcase still to be done - waiting for artwork
15:58 <pleia2> too many words
15:58 <skellat> #action (11:47:17 AM) micahg-work: I would venture to say if it's not landed at least by Aug 15, that we defer to 14.04
15:58 * meetingology (11:47:17 AM) micahg-work: I would venture to say if it's not landed at least by Aug 15, that we defer to 14.04
15:58 <skellat> #undo
15:58 <xnox> knome: 13.10 will ship X server one will be able to boot, whether X or XMir or Mir is the _default_ is irrelevant politics. And that's the best non-technical promise one can have.
15:58 <elfy> #action elfy greeter testcase still to be done - waiting for artwork
15:58 * meetingology elfy greeter testcase still to be done - waiting for artwork
15:58 <micahg-work> #action micahg to ITP gtk-theme-config to Debian
15:58 * meetingology micahg to ITP gtk-theme-config to Debian
15:58 <knome> xnox, that's a good one.
15:59 <elfy> #action elfy talk to balloons re daily builds/cadence testing if necessary for us
15:59 * meetingology elfy talk to balloons re daily builds/cadence testing if necessary for us
15:59 <skellat> #action skellat to prepare blog article discussing updating & upgrading for users and why it is okay to do so
15:59 * meetingology skellat to prepare blog article discussing updating & upgrading for users and why it is okay to do so
15:59 <bluesabre_work> xnox, knome: but what happens when a user installs xubuntu-desktop from an ubuntu-desktop installation?
15:59 <knome> bluesabre_work, that's something we should've asked jono, but i doubt he would have had an answer
15:59 <skellat> #action skellat to develop a proposal for consideration for more structured handling of Xubuntu bugs
15:59 * meetingology skellat to develop a proposal for consideration for more structured handling of Xubuntu bugs
15:59 <knome> (or anybody at this point tbh)
15:59 <micahg-work> bluesabre_work, that's fine, it'll just work
16:00 <knome> everybody happy with the action items?
16:00 <skellat> Has anybody gotten an update since we last met about the status of Xfce 4.12?
16:00 <micahg-work> the main issue will be if XMir supports the hardware we want to support for 13.10
16:00 <GridCube> Havent heard any
16:01 <xnox> bluesabre_work: a package xubuntu-desktop is installed =) that doesn't directly changes/installs X server or Mir. All images at the moment are build with X by default, thus one will still have X
16:01 <knome> the status of xfce 4.12 is "we understand xubuntu's point of view, but we want to unbreak some more things and there is no estimate when that's done"
16:01 <elfy> bluesabre_work: as far as the greeter is concerned - do we need to wait for the artwork?
16:01 <skellat> knome: Please make that an INFO item
16:01 <xnox> bluesabre_work: the promise is that $flavour-desktop tasks are independs on X/XMir/Mir choice.
16:01 <knome> #info knome discussed xfce 4.12 release plans with nick, and the status is "we understand xubuntu's point of view, but we want to unbreak some more things and there is no estimate when that's done"
16:02 <bluesabre_work> elfy: the annoying thing is that any gtk3 menus in 13.10 right now will look bad (thanks to gtk 3.8)
16:02 <knome> skellat, thanks for reminding...
16:02 <bluesabre_work> fixed in the latest artwork stuff, yet to be uploaded from what I last heard
16:02 <lderan> oh dear
16:02 <micahg-work> bluesabre_work, is that a bug in our theme or gtk 3.8?
16:02 <knome> are we fine with the action items now?
16:02 <micahg-work> ah
16:02 <elfy> bluesabre_work: so leave it for the moment?
16:02 <elfy> knome: I'm happy with mine
16:03 <knome> #topic Team updates (All contributors)
16:03 <bluesabre_work> micahg-work, elfy: should be fine to test, just a theming change with gtk 3.8
16:03 <knome> any updates not yet covered on the action items?
16:03 <ochosi> bluesabre_work: wait, hasn't mrpouit uploaded a new version of shimmer-themes already?
16:03 <elfy> bluesabre_work: k - I'll get on tiwht the testcase and then we can look at asking for people to test it
16:03 <bluesabre_work> ochosi: not sure, has he? :)
16:03 <mrpouit> yea, I did
16:03 <bluesabre_work> oh
16:03 <mrpouit> unless it's outdated already?
16:03 <bluesabre_work> well there ya go
16:03 <bluesabre_work> ready to test :D
16:03 <knome> #info mrpouit uploaded a new version of shimmer-themes to saucy
16:04 <ochosi> mrpouit: no, it's not outdated. but did you use the git-releases or snapshots?
16:04 <lderan> i've started to write autopilot tests for the settings window
16:04 <mrpouit> ochosi, latest tags
16:04 <skellat> #info skellat is running Xfce on Jessie on his BeagleBoard and comparing how such runs with Xfce in Xubuntu
16:04 <knome> who's jessie?
16:04 <knome> :P
16:04 <ochosi> mrpouit: and not all themes were gtk3.8 compatible yet at that point, now Orion, Greybird, Numix and Bluebird should be
16:04 <knome> lderan, #info please!
16:05 * knome fills the cup with more coffee
16:05 <lderan> #info lderan has started to write autopilot tests starting with the settings window
16:05 <lderan> like that?
16:05 <elfy> #info elfy manual testcase call for help went out - plenty of response so far - we've got 18 left not claimed and I'd added 6 at the weekend
16:06 <knome> lderan, yes, thanks :)
16:06 <skellat> knome: Debian Testing
16:06 <lderan> woo
16:06 <skellat> #info skellat notes Jessie is Debian Testing
16:07 <knome> ah, right
16:07 <knome> :)
16:07 <knome> makes more sense now...
16:07 <knome> more updates?
16:07 <bluesabre_work> mrpouit, micahg-work: now that I have started doing packaging, what would be the roadmap for me to become an official "xubuntu-developer"?
16:08 <mrpouit> bluesabre, there are a few pending merges left (I have the list at home), you can take them if you want
16:08 <knome> bluesabre_work, can you go on with that after the meeting?
16:08 <bluesabre_work> knome: sure thing
16:08 <bluesabre_work> mrpouit: works for me
16:08 <knome> mrpouit, micahg-work: or do you think there's something that concerns the whole community?
16:09 <elfy> #info elfy would really like people to talk to him about anything that they think needs testing planned for
16:09 <skellat> mrpouit micahg-work: I just ask if the apt-offline merge into the seed & the related bug could be disposed of eventually
16:09 <knome> #action team to talk with elfy if anything needs testing
16:09 * meetingology team to talk with elfy if anything needs testing
16:09 <knome> #nick team
16:09 <elfy> knome: that's better :p
16:09 <micahg-work> skellat, yeah, that's easy enough to do
16:10 <knome> #topic New and emerging items
16:10 <knome> #subtopic Members for Xubuntu release team
16:10 <knome> so,
16:10 <knome> atm me and elfy are members of the release team able to push buttons
16:10 <knome> i'd like one developer to join us
16:10 <knome> micahg-work, mrpouit, bluesabre_work: volunteers?
16:10 <mrpouit> skellat, yep, I guess they are lost in my mailbox somewhere ;>
16:11 <micahg-work> knome, I'm not "around" for releases anymore, so it's hard for me
16:11 <bluesabre_work> knome: sure, I can help
16:12 <knome> mrpouit, you happy with bluesabre_work taking that spot?
16:12 <bluesabre_work> give it to mrpouit if you don't want to wait on a learning curve :)
16:12 <knome> we all need to learn, it's got tools that didn't exist before :P
16:13 <pleia2> I think you can handle it
16:13 <knome> and it's anyway more on being around and understanding code
16:13 <bluesabre_work> so, the fun stuff
16:13 <knome> just for the sake of it...
16:13 <bluesabre_work> :D
16:13 <lderan> :D
16:14 <knome> #vote Sean (bluesabre) to be the "developer member" of xubuntu-release? +1 for yes, -1 for no
16:14 <meetingology> Please vote on: Sean (bluesabre) to be the "developer member" of xubuntu-release? +1 for yes, -1 for no
16:14 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
16:14 <mrpouit> knome, yeah, I'm not sure to be around, but I can try too
16:14 <knome> team can vote.
16:14 <skellat> +1
16:14 <meetingology> +1 received from skellat
16:14 <knome> +1
16:14 <meetingology> +1 received from knome
16:14 <elfy> +1
16:14 <meetingology> +1 received from elfy
16:14 <lderan> well it will be a while before I can help with that i bet :P
16:14 <knome> mrpouit, i'm fine with four members :>
16:14 <pleia2> +1
16:14 <meetingology> +1 received from pleia2
16:14 <GridCube> +1
16:14 <meetingology> +1 received from GridCube
16:14 <ochosi> +1
16:14 <meetingology> +1 received from ochosi
16:14 <Unit193> +1
16:14 <meetingology> +1 received from Unit193
16:14 <knome> lderan, probably a bit, yes
16:14 <bluesabre_work> +1
16:14 <meetingology> +1 received from bluesabre_work
16:14 <bluesabre_work> why not ;)
16:14 <knome> lderan, but you're on your way there!
16:14 <elfy> :)
16:14 <knome> bluesabre_work, hehe
16:14 <knome> #endvote
16:14 <meetingology> Voting ended on: Sean (bluesabre) to be the "developer member" of xubuntu-release? +1 for yes, -1 for no
16:14 <meetingology> Votes for:8 Votes against:0 Abstentions:0
16:14 <meetingology> Motion carried
16:15 <knome> #vote Lionel (mrpouit) to be the "developer member" of xubuntu-release? +1 for yes, -1 for no
16:15 <meetingology> Please vote on: Lionel (mrpouit) to be the "developer member" of xubuntu-release? +1 for yes, -1 for no
16:15 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
16:15 <elfy> +1
16:15 <meetingology> +1 received from elfy
16:15 <knome> team can vote.
16:15 <knome> +1
16:15 <meetingology> +1 received from knome
16:15 <bluesabre_work> +1
16:15 <meetingology> +1 received from bluesabre_work
16:15 <GridCube> +1
16:15 <meetingology> +1 received from GridCube
16:15 <Unit193> +1
16:15 <meetingology> +1 received from Unit193
16:15 <skellat> +1
16:15 <meetingology> +1 received from skellat
16:16 <elfy> he didn't like that vote then :p
16:16 <bluesabre_work> lol
16:16 <pleia2> +1
16:16 <meetingology> +1 received from pleia2
16:16 <knome> anybody want to vote against? :P
16:16 <bluesabre_work> he didn't want to see the final results
16:16 <knome> #endvote
16:16 <meetingology> Voting ended on: Lionel (mrpouit) to be the "developer member" of xubuntu-release? +1 for yes, -1 for no
16:16 <meetingology> Votes for:7 Votes against:0 Abstentions:0
16:16 <meetingology> Motion carried
16:16 <micahg-work> oh, hrm
16:16 <knome> that's enough of us..
16:16 <elfy> bluesabre_work: the other one is here still
16:17 <knome> micahg-work, you can throw an unofficial +1 :P
16:17 <skellat> micahg-work: See: https://code.launchpad.net/~skellat/ubuntu-seeds/xubuntu.saucy-aptoffline-addition/+merge/165516 & https://bugs.launchpad.net/ubuntu/+source/xubuntu-meta/+bug/1183638
16:17 <ubottu> Launchpad bug 1183638 in xubuntu-meta (Ubuntu) "apt-offline needs to be added to metapackage" [Undecided,New]
16:17 <knome> anyway, let's go fast forward (we need to end the meeting today)
16:17 <knome> #subtopic Proposal for more structured handling of Xubuntu bugs
16:17 <knome> #info postponed to next meeting
16:17 <knome> #subtopic Xubuntu desktop showcase group progress
16:17 <GridCube> ok.
16:19 <GridCube> #info  a group on dA http://xubuntu-showcase.deviantart.com/ still waiting for those who applied to join me to a walkthrough
16:20 <skellat> #INFO GridCube: Work on the wallpaper showcase its being done, we created a new site: http://xubuntu-showcase.deviantart.com/ we still need all the people who volunteer to join me on a walkthrough of the managing of the site
16:20 <knome> what's the status on the guidelines? :)
16:20 <GridCube> Once i have enough people in the loop pleia2 will broadcast the news to all social site we own
16:21 <GridCube> guidelines are ready
16:21 <knome> pleia2? confirming that?
16:21 <GridCube> you can read them in the group already
16:21 <bluesabre_work> I swung by there the other day, looking good GridCube
16:22 <lderan> aye that it is
16:22 <GridCube> im sorry tht my internet isnt cooperating this week to get things done faster
16:22 <pleia2> knome: yep
16:22 <knome> ok, great
16:22 <knome> #action pleia2 and GridCube prepare the social media broadcasting
16:22 * meetingology pleia2 and GridCube prepare the social media broadcasting
16:23 <knome> is that it for that subject?
16:23 <GridCube> guess so
16:23 <knome> ok, great
16:23 <knome> #subtopic Changing the text on the settings menu
16:23 <GridCube> i do need the people to join me
16:23 <elfy> https://bugs.launchpad.net/ubuntu/+source/xfce4-settings/+bug/1173767
16:23 <ubottu> Launchpad bug 1173767 in xfce4-settings (Ubuntu) "Settings Manager description " [Undecided,Confirmed]
16:24 <elfy> is the bug for this topic
16:24 <lderan> GridCube: I can help out :) i even remembered my devart password :P
16:24 <knome> GridCube, since many of you aren't actively in IRC, i suppose it's better to cooperate that in the mailing list
16:24 <knome> what does people think?
16:24 <elfy> as long as it's in the -dev m/l I'm fine with that
16:24 <GridCube> yes. Will make a good mail then
16:24 <knome> now that we integrated system settings in the settings manager, the description isn't accurate
16:24 <knome> elfy, sure.
16:25 <knome> GridCube, if you want feedback/improving round, post it to pad and ping people here
16:25 <GridCube> ok
16:25 <knome> GridCube, but no need to, can also post directly
16:25 <knome> (whatever you wish)
16:25 <GridCube> Will see how long it turns out to be.
16:26 <knome> so what about the settings manager description?
16:26 <lderan> think it would be good to change the text, tho not sure to what
16:26 <knome> the current description is "Customize your desktop"
16:26 <lderan> also theres all the translations for it as well
16:26 <knome> i think we'd need somebody familiar with the code to tell if it's a patch we want to carry with xubuntu
16:26 <knome> that's my main issue
16:26 <knome> apart from that i'm all +1 for the change
16:27 <knome> elfy, can you work to confirm with mr_pouit (i suppose) if the patch is doable?
16:27 <bluesabre_work> if we carry the patch for that string, we'll have to hunt down translators as well
16:27 <elfy> knome: ok
16:28 <elfy> #action elfy talk to mr_pouit re Settings Manager
16:28 * meetingology elfy talk to mr_pouit re Settings Manager
16:28 <knome> bluesabre_work, that's probably the least of our worries... it's just one string, and we can shout the world to help us
16:28 <knome> great
16:28 <knome> #subtopic Schedule next meeting
16:28 <knome> any reasons we should have a meeting in one week?
16:28 <slickymaster> I can translate to Portuguese, if needed
16:28 <GridCube> in two weeks sound good?
16:28 <elfy> slickymaster: ty
16:28 <lderan> could it be a patch that I could do?
16:28 <bluesabre_work> jono said xmir should be in the archive in 2 weeks, right?
16:28 <knome> hmm, alpha 2 is in two weeks
16:29 <knome> let's have a meeting next week
16:29 <GridCube> Before that then?
16:29 <lderan> okay
16:29 <knome> a short one if nothing special turns up
16:29 <elfy> #info elfy include lderan with Settings discsussion
16:29 <bluesabre_work> sounds good to me
16:29 <elfy> knome: I'll be missing but forestpiskie will be here
16:29 <knome> #info Next community meeting is on Thursday 18 July, 15UTC
16:29 <elfy> if it's the same time ish
16:29 <knome> #endmeeting