14:59:39 <knome> #startmeeting Xubuntu community meetings
14:59:39 <meetingology> Meeting started Thu Jan 10 14:59:39 2013 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:59:39 <meetingology> 
14:59:39 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
14:59:54 <knome> #topic Items carried on
15:00:07 <knome> #subtopic Open action items from previous meeting
15:00:21 <knome> #action knome to draft flyer looks
15:00:21 * meetingology knome to draft flyer looks
15:00:26 <knome> not happened.
15:00:34 <knome> #chair pleia2
15:00:34 <meetingology> Current chairs: knome pleia2
15:00:39 <knome> so, who's here for the meeting?
15:00:47 <pleia2> me
15:00:47 <maddernick> o/
15:00:49 <knome> raise your hands or sth so you'll get logged
15:01:09 <bluesabre_> me
15:01:11 <bluesabre_> o/
15:01:26 <knome> ok, great
15:01:32 <knome> micahg, dingdong
15:01:34 <jjfrv8> o/
15:01:38 <knome> #topic Team updates
15:01:40 <knome> hey jjfrv8 :)
15:01:44 <knome> #subtopic Development
15:01:50 <micahg> hi
15:01:51 <knome> micahg, mr_pouit
15:02:12 <knome> i suppose there's a few things that has happened since the start of the R cycle
15:03:02 <knome> ....and we all can still use #action and #info. :)
15:03:31 <bluesabre_> #info parole 0.4.0 released, looking for testers (not enough bugs logged on it)
15:03:53 <micahg> #info mr_pouit has gotten newer versions of various components into raring
15:03:57 <knome> i'll talk a bit more about testing later
15:04:08 <micahg> #info i386 ISO is CD size again (minus fr langpacks)
15:04:10 <knome> but parole getting forward is a good idea!
15:04:24 <knome> err, s/idea/news/ :)
15:04:46 <micahg> #info micahg working on rebuild FTBFS failures, mostly related to multiarch python headers
15:05:14 <micahg> #action micahg to attempt to make amd64 ISO CD size by alpha2 (useful for its timing, but we're not shipping it)
15:05:14 * meetingology micahg to attempt to make amd64 ISO CD size by alpha2 (useful for its timing, but we're not shipping it)
15:05:43 <micahg> questions or comments?
15:06:05 <knome> #info just for general information, the alpha2 is most probably going to be postponed by a few days (read ubuntu-release archives for more info)
15:06:32 <knome> micahg, is there something that's building up the iso size by a lot again?
15:06:42 <knome> and/or can we expect something like that
15:06:55 <micahg> idk, I'd have to compare the manifest from quantal to raring
15:07:07 <knome> but we didn't go over by much anyway?
15:07:10 <micahg> we can expect it to increase over time due to new core system deps
15:07:19 <micahg> amd64 is only 10MB over
15:07:37 <knome> is there any hopes of getting python2 or sth else big dropped this cycle?
15:07:46 <micahg> doubtful
15:07:52 <bluesabre_> I should have a python3 catfish in the coming weeks
15:08:03 <knome> ..and/or should we seriously talk about (dropping) langpacks in the next weeks?
15:08:07 <micahg> I don't think I'm in a position to do massive python3 porting
15:08:36 <micahg> es zh-hans xh pt is all that's left
15:08:46 <micahg> we can drop es or pt and probably be CD sized now
15:08:53 <knome> i don't think anybody should take that responsibility alone
15:08:57 <micahg> or very close toit
15:09:07 <knome> do we have a general idea what needs to be ported from python2?
15:09:25 <knome> do you think it would make sense to list those, and try to get some people to work on it?
15:09:45 <knome> we've had quite many people interested in helping with xubuntu lately (don't know how many are familiar with python)
15:10:03 <knome> that could create some positive momentum if we had something to point the people to
15:10:25 <micahg> I could probably dig up a list, we could see if any of the upstreams of those components have ported to python3
15:10:46 <knome> so would you be willing to take an official action item for that?
15:10:47 <knome> ;)
15:11:00 <micahg> to get the list, sure
15:11:16 <bluesabre_> I look forward to seeing that list :)
15:11:29 <knome> #action micahg to create a list of things that needs porting from python2 to python3
15:11:29 * meetingology micahg to create a list of things that needs porting from python2 to python3
15:11:30 <micahg> #action micahg to get list of packages in Xubuntu using python2
15:11:30 * meetingology micahg to get list of packages in Xubuntu using python2
15:11:32 <knome> hehe
15:11:35 <knome> well...
15:11:41 <knome> some reminders.
15:11:55 <micahg> #action micahg to finish fixing FTBFS failures found in the rebuilds
15:11:55 * meetingology micahg to finish fixing FTBFS failures found in the rebuilds
15:12:47 <knome> #info we'll see how the python-port list looks like, then reconsider if we should consider dropping langpacks
15:12:52 <micahg> anything else?
15:13:09 <knome> mmh
15:13:22 <knome> i don't think that there's anything at this point
15:13:34 <micahg> we only have 1 webkit, but 2 GTKs and 2 python2
15:13:36 <micahg> *pythons
15:13:40 <knome> yeah
15:14:02 <knome> i don't think dropping gtk2 is realistic any time soon, that's why i started poking on the python side
15:14:11 <knome> (don't get that wrong...)
15:14:13 <micahg> surely not until Xfce is ported
15:14:15 <knome> anyway
15:14:20 <knome> thanks micahg :)
15:14:29 <knome> #subtopic Quality Assurance
15:14:43 * micahg wants to drop tcl..
15:14:55 <knome> what's blocking?
15:15:08 <micahg> it's a recommends of xchat, but that only gets up half way
15:15:12 <micahg> *us
15:15:21 <knome> nothing else is keeping that in?
15:17:11 <micahg> I think so
15:17:15 <knome> ok
15:18:01 <knome> #action micahg to see if anything else than xchat is keeping tcl in (recommends for xchat), team investigates possibility to drop tcl
15:18:01 * meetingology micahg to see if anything else than xchat is keeping tcl in (recommends for xchat), team investigates possibility to drop tcl
15:18:07 <knome> #nick team
15:18:16 <knome> so QA
15:18:41 <knome> #action knome gathers a list of things we want to test before alpha2
15:18:41 * meetingology knome gathers a list of things we want to test before alpha2
15:18:53 <knome> #action bluesabre_ lists things he wants tested in his projects
15:18:53 * meetingology bluesabre_ lists things he wants tested in his projects
15:19:09 <bluesabre_> #info parole 0.4 is out and available in raring, lots of new features and fixes, testers needed
15:19:20 <knome> #info we will do some specific cadence testing before a2
15:19:53 <knome> #info when a2 is out, we will do more of more general cadence testing
15:20:35 <knome> #action knome will send more information on the ML, team shouts out in social media etc. for anybody to help with testing
15:20:35 * meetingology knome will send more information on the ML, team shouts out in social media etc. for anybody to help with testing
15:20:49 <knome> is there anything else in QA?
15:20:58 <knome> questions about testing for R or sth?
15:21:06 <pleia2> do we want to do another blog post about testing?
15:21:14 <pleia2> (haven't had a post in a while)
15:21:15 <knome> pleia2, yes.
15:21:32 <knome> i'll switch the subtopic quickly.
15:21:34 <pleia2> ok, you can action me to draft it after you've sent the mailing list info
15:21:43 <knome> #subtopic Marketing, Promotion and Artwork
15:21:45 <pleia2> er, info to mailing list
15:22:08 <knome> #action pleia2 drafts a new blog article on testing after knome has sent information on testing to ML
15:22:08 * meetingology pleia2 drafts a new blog article on testing after knome has sent information on testing to ML
15:22:35 <knome> #info we contacted the identi.ca xubuntu group and will be co-admins of that soon
15:22:45 <bluesabre_> yay!
15:22:48 <pleia2> (hopefully :))
15:22:50 <knome> yeah.
15:23:02 <knome> but no reason why not, if people look at their email
15:23:16 <knome> is there some other social media outlets we should be on?
15:23:38 <knome> i'm not proposing to create anything new, but see if there's something existing we can make official, like the G+ page
15:23:41 <bluesabre_> diaspora (lol)
15:23:50 <knome> well, we are on facebook..
15:24:05 <pleia2> I haven't seen anything pop up lately
15:24:08 <knome> does anybody in the team have a diaspora account, or how does that stuff even work? :P
15:24:47 <bluesabre_> I have one, doesn't really work so well since its decentralized, and all it really seems to be is cat pictures
15:24:58 <knome> ok, so let's not go there
15:25:04 <pleia2> hehe
15:25:04 <knome> anything else on the subjects?
15:25:33 <bluesabre_> any new case badges or anything, pleia2?
15:25:41 <knome> oh
15:25:57 <pleia2> no new ones, still have a billion of the old ones :)
15:26:12 <knome> #info knome is seriously considering of ordering one more xubuntu t-shirt for testing quality etc
15:26:23 <pleia2> \o/
15:26:31 <knome> pleia2, seriously? i've almost given all of mine away..
15:26:46 <knome> and i don't go into LUG's, see people, or anything like that!
15:26:50 <knome> :P
15:26:58 <pleia2> I ordered a lot :)
15:27:01 <knome> 100?
15:27:07 <knome> or you did another batch?
15:27:13 <pleia2> still the 100
15:27:14 <knome> ok
15:27:29 <pleia2> holidays here make everyone disappear from events and I've been busy ;)
15:27:34 <knome> heh
15:27:35 <knome> right
15:27:55 <knome> it's the boring general weekday life that does it here
15:28:14 <pleia2> #info we have someone working on updated screenshots for the website for 12.10 (better late than never!)
15:28:15 <knome> anyway, any other things on m/p/a?
15:28:18 <knome> ooh!
15:28:45 <pleia2> #info as always, we could use more team members contributing blog posts, you know where to find me :)
15:29:08 <knome> #action team should work more on listing low-hanging fruit for new contributors to grow the community
15:29:08 * meetingology team should work more on listing low-hanging fruit for new contributors to grow the community
15:29:24 <pleia2> I think that's it for mpa
15:29:43 <knome> i've been blogging quite a lot about xubuntu'ish things on my blog and tweeting them with the xubuntu account
15:30:21 <knome> #info if you write about xubuntu (development) on your blog, it's possible to tweet about that @Xubuntu
15:30:47 <bluesabre_> I always write a xubuntu review post a few days following release, I'll keep that in mind.
15:30:58 <knome> yup, just remind us
15:31:17 <knome> #info or, if you're on twitter yourself, we can retweet too..
15:31:41 <knome> #info knome has been retweeting some nice comments for @Xubuntu anyway
15:31:47 <pleia2> :)
15:31:56 <knome> #subtopic Documentation, Website
15:32:01 <knome> anything on this?
15:32:12 <knome> well, the note about somebody working on the screenshots
15:32:30 <bluesabre_> knome, you mentioned considering moving the help documents to yelp at one point
15:32:31 <knome> am i failing on the categoriing again? :)
15:32:32 <knome> +z
15:32:38 <pleia2> #link https://blueprints.launchpad.net/ubuntu/+spec/other-r-xubuntu-docs
15:32:50 <knome> bluesabre_, right. we should talk about that in #ubuntu-docs
15:32:56 <knome> bluesabre_, somebody there suggested that
15:33:03 <bluesabre_> ah
15:33:23 <knome> for being able to have translations and stuff
15:33:39 <knome> bluesabre_, you interested in finding out more about that?
15:33:59 <bluesabre_> I might be able to help.  I've done some stuff with mallard
15:34:04 <knome> mh
15:34:31 <knome> #action bluesabre_ to investigate moving to yelp with docs to enable translations and stuff
15:34:31 * meetingology bluesabre_ to investigate moving to yelp with docs to enable translations and stuff
15:34:57 <knome> anything else?
15:35:32 <bluesabre_> brb
15:35:38 <knome> ok, probably not
15:35:44 <knome> #subtopic General updates
15:35:46 <knome> anything else?
15:36:08 <micahg> are we having a default apps discussion at all?
15:36:17 <knome> micahg, hurrrr
15:36:39 <knome> micahg, if you *really* want to :)
15:36:43 <knome> i mean
15:36:43 <pleia2> the Community Council has been meeting with teams this cycle, next Thursday (17th) it's Xubuntu's turn: https://wiki.ubuntu.com/CommunityCouncilAgenda
15:36:50 <pleia2> consider this your invite :)
15:37:15 <pleia2> I'll remind on the day too, 7 days a 1.5 hrs from now
15:37:18 <knome> pleia2, can i consider that as an invite, or should i consider that as a must since i asked for that?
15:37:21 <knome> ;)
15:37:26 <bluesabre_> back
15:37:28 <pleia2> :)
15:37:39 <bluesabre_> mousepad
15:37:40 <micahg> no, I'd rather not, but maybe there's something we're shipping that's not worthwhile
15:38:08 <knome> so that's more about "dropping things we don't need" than "default applications" talk
15:38:22 <knome> with def apps i'm thinking about somebody wanting to *replace* something
15:38:43 <knome> i think mousepad is a good proposal though
15:39:10 <knome> i mean, in the sense that it's a good proposal to look at it, not taking any side if it's good to include or not (yet)
15:39:26 <bluesabre_> I think it should be considered
15:39:39 <knome> micahg, let's schedule some time later to look at the seed togheter
15:39:42 <bluesabre_> Its minimalistic, but can actually be used for development
15:39:42 <knome> *together
15:40:02 <knome> #action team to schedule some time to look at the seed and consider dropping unneded things
15:40:02 * meetingology team to schedule some time to look at the seed and consider dropping unneded things
15:40:27 <knome> bluesabre_, leafpad is too, and i suppose that's what you're proposing to replace, so no problem with that.
15:40:30 <micahg> bluesabre: we switched to leafpad in oneiric to get rid of xfprint4
15:40:44 <knome> i there still that dep?
15:40:54 <micahg> no
15:41:09 <knome> in mousepad i mean
15:41:16 <micahg> no
15:41:23 <knome> ok, then np from my POV
15:42:06 <knome> if we move back to mousepad, i'm wondering if we should create a symlink for leafpad since many people have learnt *that* now
15:42:09 <knome> like me.
15:42:15 <micahg> mousepad is a bit bigger
15:42:25 <knome> define "a bit"
15:42:30 <knome> 1 byte?
15:42:30 <micahg> 100k
15:42:35 <micahg> with a few more deps
15:42:40 <knome> mmh
15:42:46 <knome> let's consider that
15:42:51 * micahg wonders why an editor needs a dep on dbus
15:42:57 <knome> #action team to consider switching leafpad to mousepad
15:42:57 * meetingology team to consider switching leafpad to mousepad
15:42:57 <pleia2> heh
15:43:12 <knome> #topic Announcements
15:43:20 <knome> #subtopic Changes of positions on the Xubuntu team
15:43:40 <knome> #info elfy dropped a line that he can't help in the R cycle; knome will take over the QA-related stuff (again)
15:44:00 <knome> #info The term for XPL ends at the end of this cycle
15:44:32 <knome> #info Since we changed the Strategy Document, the next term will only be 2 (two) releases, since the term is designed to end with an LTS release.
15:45:18 <knome> #info We will be voting on extending the current XPL's term at the end of the cycle; if not extended, a new XPL will serve for two cycles
15:45:42 <knome> anything you want to ask?
15:45:45 <micahg> why an extension instead of a new election?
15:45:56 <knome> well, you can consider that as a new election
15:45:59 <micahg> or is the new term supposed to be 2 years?
15:46:07 * micahg supposes he should read the doc
15:46:13 <knome> i'm partly disqualified in this thing
15:46:17 <knome> it used to be 1,5 years
15:46:42 <knome> but that doesn't make sense because it doesn't allow long-term planning (because it doesn't always end with an LTS release)
15:46:50 <knome> so yes, the term is supposed to be 2 years
15:47:05 <knome> but this is the exception, because the overruling rule is that the term should end with an LTS release
15:47:07 <micahg> ok, then extending your term to 2.5 years isn't unreasonable
15:47:32 <knome> no, but i'm completely okay with doing a vote, because i changed that thing in the SD myself
15:47:39 <knome> and i think we need to do one
15:47:49 <micahg> knome: oh, I agree that it should be put to a vote :)
15:47:56 <knome> there's a slight possibility that i'm saying "i won't!"
15:48:23 <knome> and then you *have to* elect somebody else, like micahg or bluesabre_
15:48:34 <knome> >:)
15:48:36 <pleia2> :P
15:48:40 <knome> or pleia2!
15:48:44 * micahg would vote for pleia2
15:48:45 <pleia2> noo
15:48:48 <knome> haha
15:48:50 <micahg> hehe
15:48:58 <bluesabre_> I'd vote for not me
15:48:58 <knome> i suppose the SD says one must be willing to serve... ;)
15:49:09 <knome> if it doesn't, we should change that before voting...
15:49:13 <pleia2> lol
15:49:21 <knome> anyway, that's it for announcements
15:49:34 <knome> any other team leads have other announcements?
15:49:43 <knome> pleia2, maybe post the CC invite here with #info?
15:49:56 <knome> if it's still on your history
15:50:29 <pleia2> right
15:50:38 <pleia2> #info the Community Council has been meeting with teams this cycle, next Thursday (17th) it's Xubuntu's turn: https://wiki.ubuntu.com/CommunityCouncilAgenda
15:50:42 <knome> thanks
15:50:53 <knome> #topic New and emerging items
15:51:06 <knome> #subtopic Serbian translation for Xfce 4.10
15:51:09 <knome> micahg?
15:51:16 <knome> what do you want to discuss
15:51:24 <knome> or is this something you should discuss with mr_pouit
15:52:14 <knome> #subtopic Discuss changing Xfce translations to a langpack system similar to KDE (makes it easier to update translations post release)
15:52:21 <knome> that's pretty much the same subject
15:52:42 <micahg> sorry, got distracted
15:52:46 <knome> no problem
15:53:00 <knome> we can simply postpone these, if you need other people to discuss with
15:53:14 <knome> i'm completely ok with changing the system if that's easier for you
15:53:25 <micahg> well, I'd like mr_pouit's opinion, but I think it might be worthwhile to switch to a Kubuntu style langpacks so that we can update the languages post release more easily
15:53:42 <knome> and i'm completely ok with getting the serbian translation in 13.04, and i'll help if i can
15:54:15 <knome> do we need to do that often / have we done that often / would we have needed to do that more often than we did?
15:54:30 <micahg> idk that it's been done before since we don't have the option ATM
15:54:46 <knome> it has or hasn't been done before? :)
15:54:48 <micahg> right now, we'd have to reupload everything with the languages in question
15:55:01 <micahg> as opposed to one new langpack source
15:55:50 <knome> that doesn't help me understand it thoroughly... but as said, if it makes the maintaining (much) more easy, it's probably worth it
15:56:10 <knome> would you follow up about this with mr_pouit?
15:56:13 <micahg> I think overall it does, it just will require a bit of work up front
15:56:34 <mr_pouit> (sorry for being late/silent) indeed, language packs are great, I'm still a bit skeptical about the lp/contributors' side.
15:56:39 <knome> yup, but maybe we could get other people to help, if there's some low-hanging fruit
15:56:52 <micahg> mr_pouit: not for that reason, we wouldn't end up with LP stuff unless we asked
15:57:10 <micahg> or set it up for that, it's more for post release updates from upstream
15:57:16 <mr_pouit> oh, great
15:58:10 <knome> so will you both/either of you take an action item for that?
15:58:13 <knome> :]
15:58:22 <micahg> mr_pouit: so we can grab stuff like this and update it: https://translations.xfce.org/projects/p/xfce/r/xfce-4-10/l/af/
15:59:17 <micahg> or this for a better example: https://translations.xfce.org/projects/p/xfce/r/xfce-4-10/l/sr/
15:59:21 <mr_pouit> micahg: yeah, if we can regularly sync .po from xfce-4.x branches, that's the best way
15:59:54 <mr_pouit> (I've done it once for nl.po when pjotr asked, but it's painful to patch each package)
15:59:58 <micahg> I'd have to look at how Kubuntu does it
16:00:14 <micahg> they have scripts to help and I think KDE upstream ships the languages separately
16:00:28 <micahg> mr_pouit: do you think corsac would be open to doing this in Debian?
16:01:13 <micahg> it might require patching the various xfce packages to not ship the po files (again, I have to see how Kubuntu handles this)
16:01:58 <mr_pouit> not sure he'll be happy about that (patch all packages I mean)
16:02:38 <micahg> well, I would think we only want to ship 1 copy of the translations per app
16:03:58 <mr_pouit> ubuntu langpacks install somewhere else and use pkgstriptranslations I think, isn't it feasible as well
16:04:03 <mr_pouit> +?
16:04:11 <mr_pouit> (or only when rosetta/lp is involved?)
16:04:17 <micahg> yeah, can be
16:06:08 <knome> so... will you take the needed action items for this? :)
16:06:39 <micahg> ok
16:07:02 <knome> thanks
16:07:06 <mr_pouit> (I can, although I'm not sure I can give it too much time before february)
16:07:11 <mr_pouit> fine then, thanks :P
16:07:23 <knome> no problem
16:08:15 <knome> umm.. would you write the nice little poems yourself? :P
16:09:05 <micahg> #action micahg to research converting to a Kubuntu style per-language source langpack
16:09:05 * meetingology micahg to research converting to a Kubuntu style per-language source langpack
16:09:19 <knome> do we need something else?
16:10:06 <micahg> that depends on the success of the above
16:10:40 <knome> heh,ok
16:10:48 <knome> #subtopic Schedule next meeting
16:10:57 <knome> two weeks from now sound fine for everybody?
16:11:12 <micahg> sure, are we participating in 12.04.2?
16:11:14 <pleia2> probably
16:11:18 <knome> micahg, why not?
16:11:18 <bluesabre_> yeah, that should work for me
16:11:42 <knome> isn't that today
16:11:48 <micahg> well, do we have any work that needs to be done?
16:11:52 <knome> oh, kernelfreeze
16:11:54 <knome> i don't think so
16:12:01 <micahg> it's Jan 31
16:12:02 <knome> at least i can't think anything from my head
16:12:06 <knome> we'll have a week
16:12:07 <micahg> SRU freeze is next week
16:12:12 <knome> aha
16:12:23 <knome> it's not in the release schedule... for some weird reason
16:12:26 <mr_pouit> any urgen SRu pending?
16:12:42 <micahg> well, I wanted to fix gvfs in thunar, but I ran into a dead end
16:13:00 <knome> and we wanted to port the docs to 12.04, but that's not happening for .2
16:13:11 <mr_pouit> micahg: the slow startup?
16:13:24 <micahg> mr_pouit: no, failure due to transport endpoint
16:13:34 <mr_pouit> ah, that too
16:13:57 <micahg> then I tried backporting later versions and had issues with that since the dependencies changed
16:14:02 <mr_pouit> I think this was fixed when mountpoints moved to /run/$user/...
16:14:09 <mr_pouit> (but not in precise)
16:14:36 <knome> so regardless, is meeting in 2 weeks ok?
16:14:41 <knome> i need to go... :)
16:14:43 <micahg> that makes sense, they're no longer in an encrypted area
16:15:02 <micahg> yes, makes sense
16:15:06 <knome> #info Next Xubuntu community meeting: Jan 24, 15 UTC @#xubuntu-devel
16:15:11 <knome> #endmeetings
16:15:12 <knome> #endmeeting