17:03 <popey> #startmeeting Clock app meeting
17:03 <meetingology> Meeting started Thu Feb  6 17:03:10 2014 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:03 <meetingology> 
17:03 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:03 <popey> Clock App links:-
17:03 <popey> Bugs: https://bugs.launchpad.net/ubuntu-clock-app/+bugs
17:03 <popey> Reviews: https://code.launchpad.net/ubuntu-clock-app/+activereviews
17:03 <popey> Blueprint: https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/coreapps-1404-clock-dev
17:03 <popey> General Links:-
17:03 <popey> Milestones: https://launchpad.net/ubuntu-phone-coreapps/+milestones
17:03 <popey> Burndown: http://status.ubuntu.com/coreapps-14.04/
17:03 <popey> Blockers: https://wiki.ubuntu.com/Touch/CoreApps/Blockers
17:03 <popey> How are things?
17:04 <nik90> good
17:05 <nik90> I am working on getting the alarm tests up and running
17:05 <popey> Ok, great.
17:05 <nik90> it is a bit harder than the other tests since it involves lots of UI elements
17:05 <nik90> but elopio and balloons are helping me
17:06 <popey> balloons is talking to me now
17:06 <popey> (in meatspace)
17:06 <nik90> oh
17:06 <nik90> do tell him that python is annoying as hell :)
17:06 <popey> haha
17:06 <popey> he knows this ☻
17:07 <balloons> perl 4ever!
17:07 <nik90> ;)
17:07 <nik90> btw The transition to u1db is complete. Clock app now uses u1db 100% for its local storage needs :)
17:07 <popey> Awesome!
17:08 <nik90> it reduced the storage code by 60% (-250 lines of code) according to my calculation
17:08 <nik90> which is not bad
17:09 <popey> golly
17:09 <nik90> The next focus of mine is to revamp the entire autopilot tests and writing alarms autopilots tests as well
17:10 <nik90> elopio pointed out some nice ways to get the more organised and also increase the use of uitk emulators
17:10 <nik90> this way even if the sdk changes (in the coming weeks) hopefully the tests shouldn't break
17:10 <balloons> nik90: ohh u1db switch!? excellent. I remember you talking about that
17:11 <nik90> balloons: yup...do we have to do any ap test changes in light of that?
17:11 <nik90> I remember the AP clearing some database at some point
17:14 <balloons> nik90: yes the ap tests assume local storage.. doesn't break anything persay... well, it might not have a default app each launch actually
17:14 <balloons> so yes, I suppose it could break something
17:15 <nik90> balloons: luckily all the test we have create and then delete them as well ;)..which is probably why the tests didnt break for now
17:16 <nik90> balloons: also the change required shouldn't be too much since both local storage and u1db use sqlite files
17:16 <nik90> balloons: so I assume that we will only need to change the file location perhaps
17:18 <balloons> nik90: ohh, well if it's the same place, have a look
17:18 <balloons> it wipes the folder I believe
17:18 <balloons> in which case, nothing has to change
17:18 <nik90> balloons: ok I will take a look...instead of it being in com.ubuntu.clock/Databases, it is now in com.ubuntu.clock
17:20 <balloons> nik90: backing up and restoring the folder probably works out fine
17:20 <nik90> #action nik90 fix autopilot test to consider u1db instead of local storage while setting up the environment
17:20 * meetingology nik90 fix autopilot test to consider u1db instead of local storage while setting up the environment
17:21 <nik90> #action nik90 Get the alarm autopilot tests up and running
17:21 * meetingology nik90 Get the alarm autopilot tests up and running
17:23 <nik90> Anything else?
17:23 <popey> nik90: balloons is looking to update the click apps in the store
17:23 <popey> so we need to co-ordinate that
17:23 <popey> rather than block on sergio
17:23 <nik90> popey: not yet
17:24 <popey> sure, just let us (me or balloons)
17:24 <nik90> popey: let me get a few more fixes like the alarm tests in  before updating
17:24 <nik90> okay
17:24 <balloons> nik90: yes, going to make some tweaks so things flow faster
17:24 <popey> be good to get those in for MWC ☻
17:24 <nik90> popey: definitely. Just give me a week and I will let you know
17:24 <popey> Great!
17:25 <nik90> I was hoping to complete all bugs in https://launchpad.net/ubuntu-clock-app/+milestone/1.6 before updating
17:25 <nik90> but I will try my best since that is a bit difficult
17:26 <popey> so mwc is 24-27, and it would be great to have a stable week before then
17:27 <popey> so put a release in by 14th?
17:27 <popey> Valentines update
17:27 <nik90> popey: one more thing. When you press the central button in the clocks do you expect a haptic feedback similar to pressing buttons?
17:27 <nik90> popey: definitely
17:27 <popey> Hm. Not sure.
17:28 <nik90> hmm ok. it is one of my bug report I wasnt sure what to do
17:28 <nik90> I could push it to the next milestone to give us time to think about it
17:29 <popey> i think the whole haptic thing needs a rethink
17:29 <popey> we currently overuse it a bit
17:30 <nik90> +
17:30 <popey> Ok. Anything else?
17:30 <nik90> nope
17:30 <popey> Brilliant. Ping us if you need anything.
17:31 <nik90> definitely
17:32 <popey> Thanks nik90
17:32 <popey> #endmeeting