15:04 <popey> #startmeeting Ubuntu Touch Dropping letters app meeting
15:04 <meetingology> Meeting started Wed Jul  3 15:04:53 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:04 <meetingology> 
15:04 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:05 <popey> Blueprint: https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/droppingletters-coreapps-development
15:06 <popey> bugs: https://bugs.launchpad.net/dropping-letters
15:06 <popey> reviews: https://code.launchpad.net/dropping-letters/+activereviews
15:06 <popey> burndown: http://status.ubuntu.com/coreapps-13.10/
15:07 <popey> So, I did some testing of the app and filed a few bugs
15:07 <popey> "app" hah.
15:07 <kenvandine> the music playback is a deeper issue
15:08 <popey> oh?
15:08 <popey> can we convert it to mp3 and play it?
15:08 <popey> I mean, on any device other than nexus 7
15:08 <kenvandine> not that deep :)
15:08 <kenvandine> the issue is that if media fails, it blows up
15:09 <kenvandine> on the n7 it just crashes
15:09 <popey> good
15:09 <kenvandine> but i didn't see a way to make that more robust
15:09 <popey> thats not the app at fault, thats platform, and that should be fixed
15:09 <kenvandine> looks like the platform needs to fail gracefully
15:09 <popey> although yes, apps should not blow up when they can't play audio ☻
15:09 <popey> yes
15:09 <popey> so maybe that bug needs putting against qtmultimedia?
15:10 <kenvandine> yeah
15:10 <kenvandine> i think so
15:10 <popey> ok, I'll sort that
15:10 <kenvandine> thanks
15:10 <kenvandine> enabling it again in dropping letters is trivial
15:10 <popey> #action popey move audio bug(s) to qtmultimedia
15:10 * meetingology popey move audio bug(s) to qtmultimedia
15:10 <kenvandine> i think i just commented it out
15:10 <popey> yeah, thought so
15:10 <popey> making progress, good.
15:10 <popey> https://bugs.launchpad.net/dropping-letters/+bug/1196872
15:10 <popey> did you see the diff I linked to?
15:11 <popey> https://code.launchpad.net/~dinko-metalac/sudoku-app/fix-bug-1196942/+merge/172552/+preview-diff/+files/preview.diff
15:11 <popey> might be a way we can maintain links in the app
15:11 <kenvandine> yes... we should do that sort of thing
15:12 <kenvandine> but it won't work on the device yet
15:12 <kenvandine> since there are no url handlers
15:12 <kenvandine> however
15:12 <kenvandine> when the platform provides that
15:12 <kenvandine> it'll magically start working :)
15:12 <popey> ok, I'll do that
15:12 <popey> looks like something easy enough I can break
15:12 <kenvandine> cool
15:12 <kenvandine> yeah
15:12 <kenvandine> i'll review it :)
15:13 <popey> win
15:13 <popey> https://bugs.launchpad.net/dropping-letters/+bug/1196867 is a game logic thing I haven't looked at yet
15:13 <popey> oh, just remembered another bug
15:14 <kenvandine> i haven't looked at that
15:14 <popey> https://bugs.launchpad.net/dropping-letters/+bug/1197440
15:14 <popey> just filed
15:14 <popey> should be possible with an icon on the toolbar?
15:16 <popey> I'll take a look at that one too
15:17 <kenvandine> yeah
15:18 <popey> will take a look at these, shouldn't be too bad for my little brain
15:18 <popey> dpm: do you know what "Clean up deprecatied APIs: TODO
15:18 <popey> means?
15:19 <popey> suspect it might be code that aq created which pre-dates the sdk
15:19 <dpm> popey, no sorry, I don't know :/
15:20 <popey> ok, will poke aq
15:21 <dpm> ok
15:22 <popey> done.
15:22 <popey> going to wrap up and take a look at these bugs..
15:22 <popey> #endmeeting