19:09:47 <popey> #startmeeting Ubuntu RSS Reader App meeting
19:09:47 <meetingology> Meeting started Thu Apr 25 19:09:47 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:09:47 <meetingology> 
19:09:47 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:09:52 <dragly> it might not be finalized, but all those items are working imo
19:10:06 <popey> the usual links...
19:10:10 <popey> blueprint: https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-rssreader-development
19:10:26 <popey> reviews: https://code.launchpad.net/~ubuntu-rssreader-dev/ubuntu-rssreader-app/trunk/+activereviews
19:10:38 <popey> bugs: https://bugs.launchpad.net/ubuntu-rssreader-app
19:10:44 <mhall119> hey guys, taking over for popey briefly
19:11:08 <popey> ok, marked all of month-0 done
19:11:13 <mhall119> \o/
19:11:14 <popey> nice one, that'll help the burndown chart
19:11:16 <popey> brb
19:11:29 <mhall119> so you guys had a meeting with the design team, is that correct?
19:12:10 <dragly> The only review we got seems to be to merge popey's fix-desktop-arch branch. Seems like a Jenkins failure to me.
19:12:51 <mhall119> I think his Exec line in the .desktop is wrong
19:12:59 <dragly> Yes, I only had time to "attend" to half the meeting. That is, I listened in because my Android tablet wouldn't connect to the Google Hangout, so I had no mic or cam :-p
19:13:35 <dragly> But Joey Chan and the design team got to discuss some ideas. I don't know if they made any conclusions, though.
19:14:05 <mhall119> ok
19:14:27 <mhall119> dragly: so can you tell me what's going on with the new view
19:14:33 <dragly> About the merge: Let's hear what popey thinks about whether he or somebody else should fix that.
19:14:47 <mhall119> I get the one with article blocks and side-scrolling when I load the app, but then I go back to my feeds and can't get there again
19:15:28 <dragly> Yeah. That is just temporarily to let Joey showcase his side-scrolling mosaic version to the design team.
19:15:35 <mhall119> ah, ok
19:16:05 <dragly> I haven't checked since he merged it, but I think the other view should let you scroll sideways to switch feeds?
19:16:11 * dragly starting the app now
19:17:47 * dragly having trouble pulling because I have some uncommited changes ... doing a fresh bzr branch
19:18:04 <mhall119> so you have a work item for "Main landing view" for the month-1 milestone, is that still on track?
19:19:10 <dragly> Yes, that is basically the screen which says "No feeds" until you pull up the toolbar and add a few feeds.
19:19:46 <mhall119> ok
19:20:07 <mhall119> I also see somebody made the change to open article content in a separate screen, do you know who did that?
19:20:54 <dragly> After adding a few feeds, it will be possible to scroll sideways in the main view to switch between feeds. One problem is that currently the code in trunk deletes the database whenever the app is restarted, so all saved feeds are lost on restart.
19:21:14 <mhall119> I did notice that
19:21:15 <mhall119> :)
19:21:17 <dragly> I did that. I just moved the WebView into its own Page in the PageStack
19:21:30 <mhall119> ok, I'll mark that as done and give you credit then
19:21:49 <dragly> Or perhaps you are seeing Joey's implementation of it - give me a sec ... :-p
19:22:42 <dragly> Ok, if you click the article in the mosaic view, you see Joey's imlpementation (no WebView, grey background). If you do the steps above and _then_ click an article, you see the WebView. But none of those are really finished.
19:23:19 <dragly> In any case there are, as you can see, some loose threads. I think getting some guidelines from the design team would be helpful.
19:23:52 <mhall119> ok, so there aren't many work items for month-1 right now, maybe we should just focus on them and general cleanup of the codebase
19:24:18 <mhall119> do you know if there was a timeframe for when you'll get something from design?
19:24:34 * popey returns
19:24:44 <dragly> No, sadly I had to leave the meeting before they talked about that. Perhaps popey knows about a timeframe?
19:24:46 <mhall119> popey: we assigned everything to you
19:24:47 <popey> will take a look at my merge
19:24:51 <popey> excellent
19:24:55 <popey> Assign all the things.
19:24:58 <mhall119> popey: is there an ETA for designs?
19:25:11 <popey> Hmm, no. Will chase for one
19:25:16 <mhall119> ok
19:25:29 <popey> #action popey speak to design to get a timeframe for RSS design work
19:25:29 * meetingology popey speak to design to get a timeframe for RSS design work
19:25:37 <mhall119> let's assume that implementing the designs won't happen until -month-2
19:25:55 <mhall119> and focus on what we currently have and get that working nicely
19:26:05 <popey> +1
19:26:14 <dragly> Ok. What we need then is to decide what to work with currently.
19:26:43 <mhall119> dragly: let's use your current work, without Joey's new side-scrolling view
19:26:54 <mhall119> so, the listview of feeds, a listview of articles, and a page with the content
19:27:16 <dragly> Ok.
19:27:39 <mhall119> also, I'd like to recommend that you look into using U1DB to store the list of subscribed feeds
19:27:47 <mhall119> http://developer.ubuntu.com/api/ubuntu-12.10/qml/u1db/overview.html has the API docs
19:28:01 <mhall119> that will allow you to sync your feed list between devices
19:28:13 <dragly> We could start working on the page with the content. The WebView isn't very nice-looking. And I think this view will be pretty independent of what the design team decides.
19:28:35 <mhall119> what's wrong with the WebView?
19:28:38 <dragly> Great! I think we have been waiting for u1db.
19:28:48 <mhall119> yeah, we all have
19:29:01 <mhall119> it's not syncing yet, but the API for you guys is stable and it'll store it locally in sqlite
19:29:32 <mhall119> so you can start using it now, while they finish the syncing bits
19:29:46 <mhall119> also, any feedback you have for them would be most welcome
19:29:51 <dragly> Currently there are issues such as the font being too small and styling it correctly. My thought was that it would be easier to build up the content on our own, but I might be wrong.
19:30:15 <dragly> Great, that is exactly what we need :)
19:30:44 <mhall119> dragly: WebView gives you the ability to zoom in on pages, I use it for my reddit app to display linked pages
19:30:45 <dragly> I have not used the WebView much, so it might be possible to give it some CSS and take it from there - I'm not sure.
19:31:17 <dragly> Do we need to zoom in the RSS reader?
19:31:49 <mhall119> when viewing a webpage, yeah
19:31:53 <popey> I'd imagine so, yes
19:32:11 <mhall119> usually you can double-tap a section of text, and it will intelligently zoom to make that section fill the screen width
19:32:15 <dragly> Ah, of course, when viewing the web page I completely agree (an alternative is to launch the webpages in the browser, though)
19:32:18 <mhall119> that's what WebView gives you
19:32:50 <dragly> But I think that when the content is viewed, it should be rendered the same way for all articles. That's at least my experience with other readers like the one on Meego, Google Reader and Feedly.
19:32:53 <mhall119> I think embedding a WebView in this would work best, and be what's expected by the user
19:33:03 <dragly> And the content, i believe, is mostly text + images (hopefully)
19:33:04 <mhall119> ah, I see what you mean
19:33:12 <popey> yeah, I dont think I'd like leaving to a browser each time
19:33:23 <mhall119> you can use the text that you get from rss/atom, but that's often only part of the article
19:34:07 <dragly> That's true. News-pages gives you only the abstract. Blogs however, fill it with images and all kinds of stuff.
19:34:41 <dragly> Just checked my own webpage now, it outputs <content:encoded> with usual HTML for links and images.
19:35:29 <mhall119> dragly: I'd recommending doing whatever is easiest on you for right now, then we'll revist after we get design feedback
19:35:36 <dragly> I think QML has the ability to render HTML with labels. Not so sure it copes well with the <img> tag though (I think Joey mentioned troubles with that).
19:36:26 <dragly> mhall119: Ok. I think we'll start with only rendering text to begin with and then get our hands dirty with whatever else an RSS feed might give us.
19:36:37 <mhall119> +1
19:36:40 <popey> yup
19:36:47 <popey> ok, anything else?
19:37:20 <dragly> I don't think so.
19:37:35 <popey> great.
19:37:39 <popey> thanks dragly
19:37:53 <mhall119> thanks dragly
19:37:57 <dragly> Oh, one thing. Is there a design meeting tomorrow too?
19:37:58 <popey> lets wrap up, and I'll let you know when we have a time line from design
19:38:08 * popey checks calendar
19:38:21 <dragly> I think David said something about weekly meetings.
19:38:22 <popey> yes, 14:00 UTC
19:38:39 <mhall119> Oranger: ah, I see you're in here already, got time for the doc viewer meeting?
19:38:40 <dragly> Ok, good.
19:38:49 <Oranger> mhall119: Yes of course :)
19:38:50 <popey> ok, see you tomorrow dragly
19:38:51 <dragly> Thanks popey and mhall119!
19:38:55 <popey> cheers
19:38:57 <popey> #endmeeting