19:30:26 <popey> #startmeeting Ubuntu Touch Clock / Alarm / Stopwatch app meeting
19:30:26 <meetingology> Meeting started Fri Apr 12 19:30:26 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:30:26 <meetingology> 
19:30:26 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:30:29 <popey> Some handy links..
19:30:44 <popey> blueprint: https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-clock-development
19:30:56 <popey> reviews: https://code.launchpad.net/~ubuntu-clock-dev/ubuntu-clock-app/trunk/+activereviews
19:30:58 <nik90> hi
19:31:06 <popey> bugs: https://bugs.launchpad.net/ubuntu-clock-app/+bugs
19:31:08 <popey> hi nik90
19:31:29 <popey> who's here for the clock meeting?
19:31:32 * popey tickles mhall119
19:31:56 <nik90> not heard from frals and Riussi_ since last week
19:32:25 <mhall119> I'm here
19:33:11 <nik90> renato wrote some initial autopilot tests which you can find in the MR currently being reviewed
19:33:29 <nik90> however I couldnt get it to work on my *new* 13.04
19:33:50 <popey> where did you get autopilot from?
19:33:53 <nik90> we tried some debugging together..perhaps you could try it out in your system and let us know what is wrong
19:34:01 <nik90> I got it from the official autopilot ppa.
19:34:22 <nik90> me and renato have the same packages (libautopilot-qt and autopilot-phablet) installed
19:34:36 <nik90> for some reason the test fails on my machine alone
19:34:48 <popey> what are the steps to reproduce?
19:35:30 <nik90> popey: the MR at https://code.launchpad.net/~renatofilho/ubuntu-clock-app/autopilot/+merge/157982 describes the commands which you need to run
19:35:48 <nik90> essentially you need to run autopilot run clock_app inside the tests/autopilot folder
19:36:20 <popey> ok, I'll have a go
19:36:26 <popey> but not right this moment
19:36:40 <popey> #action popey try out autopilot tests as per https://code.launchpad.net/~renatofilho/ubuntu-clock-app/autopilot/+merge/157982
19:36:40 * meetingology popey try out autopilot tests as per https://code.launchpad.net/~renatofilho/ubuntu-clock-app/autopilot/+merge/157982
19:36:48 <nik90> mhall119: were you able to find any info about the Base Clock , Timer API from last week's meeting?
19:37:01 <mhall119> no, sorry
19:37:15 <mhall119> I think we should just remove that work item
19:37:28 <nik90> ok
19:37:40 <nik90> we can always add them later if needed
19:37:48 <mhall119> yeah
19:37:57 <mhall119> I'm pretty sure it was Kevin just thinking of what was probably needed
19:38:09 <popey> +1
19:38:12 <nik90> yeah I guess so
19:38:51 <nik90> this month todo is basically the core of Alarm and Clock. However we might have some blockers with them
19:39:06 <popey> are there any items on hte milestone which we need to bump, or something you're blocking on?
19:39:32 <nik90> for clock, to get the timezone info we need to read files from the ubuntu system.. So Riussi_  was in the process of writing a C++ plugin for that
19:39:53 <nik90> however he wasnt sure of how to modify the debian folder for that
19:40:32 * nik90 having a look at blueprints
19:40:37 <mhall119> nik90: have you talked to anybody on the SDK team?
19:40:44 <mhall119> this seems like something the platform should be providing
19:41:12 <nik90> mhall119: no I havent talked to anyone yet about that..whom should I contact regarding this?
19:41:23 <popey> can we not use QTimeZone / QTimeZoneOffset / QTimeZoneTransition ?
19:42:06 <mhall119> nik90: bzoltan to start with
19:42:15 <mhall119> or use one of those ^^
19:42:25 <nik90> popey: I think we can use it..however we need to know which timezone a specific city is in ...
19:42:33 <nik90> to be honest I need to take a look at them
19:43:29 <popey> http://www.developer.nokia.com/Community/Wiki/How_to_get_list_of_Time_Zones_in_Qt_Maemo_application is interesting
19:43:53 <popey> an, not qt native. nvm
19:44:18 <nik90> #action nik90 contact bzoltan regarding timezone API
19:44:18 * meetingology nik90 contact bzoltan regarding timezone API
19:44:26 <popey> wise
19:44:42 <nik90> #action nik90 Investigate the use of QTimeZone, QTimeZoneoffset for timezone implementation
19:44:42 * meetingology nik90 Investigate the use of QTimeZone, QTimeZoneoffset for timezone implementation
19:44:51 * popey remembers he left the stopwatch running on his desktop about 3 hours ago
19:45:06 <nik90> popey: I'll have a look at them this weekend
19:45:08 <mhall119> lol
19:45:15 <nik90> popey: lol
19:45:18 <popey> I'm going to leave it running overnight
19:45:31 <popey> ←  example of people who do odd things
19:45:36 <mhall119> nik90: I've noticed that on my N7, the clock's second hand will every so often skip 2 seconds at a time
19:45:54 <nik90> mhall119: hmm..
19:46:03 <mhall119> I think it's because the interval is 100ms, but in reality it's probably 1001ms or so
19:46:14 <popey> related to that I've noticed the timer at the top changes before the hand moves
19:46:16 <nik90> actually I have noticed that happen on my S3 running Android as well..I think it is something to do with the animation
19:46:17 <mhall119> maybe setting it to 500ms will fix it
19:46:38 <popey> the digital time should change _after_ the hand arrives at the right digit, not as it leaves the previous digit
19:47:20 <nik90> popey: I think I might know the cause of that..I will have a look
19:47:32 <mhall119> otherwise it looks fantastic
19:48:13 <popey> oh yeah, lets not be too negative ☻
19:48:48 <nik90> #action nik90 Experiment with different Clock Time (related to second hand skipping etc) and Timer
19:48:48 * meetingology nik90 Experiment with different Clock Time (related to second hand skipping etc) and Timer
19:49:00 <nik90> Today's visual design made me so happy
19:49:12 <nik90> which actually raises one question
19:49:34 <nik90> I am assuming some of them will be done using images...how do images scale across devices?
19:49:55 <popey> excellent question
19:49:56 <popey> no idea
19:49:57 <nik90> Right now, everything you see visually are qml elements which handle different screen resolution properly
19:50:23 <nik90> I remember us having problem when using images at the beginning
19:50:33 <nik90> popey: Any idea who I should ask this to?
19:50:55 <popey> kaleo or zoltan
19:51:08 <popey> i will bring it up in our meeting with them on monday
19:51:23 <popey> #action popey discuss image scaling during monday meeting
19:51:23 * meetingology popey discuss image scaling during monday meeting
19:51:26 <nik90> alrite
19:52:54 <nik90> mhall119: I was reading your discussion about using HUD..I am guessing we will using this for the clock as welll
19:53:10 <nik90> mhall119: will you be updating your blog posts with how to use HUD?
19:54:12 <mhall119> nik90: once it's figured out I will, yes
19:54:31 <nik90> ok
19:54:54 <nik90> #action nik90 remove Base API, TImer API from blueprints
19:54:54 * meetingology nik90 remove Base API, TImer API from blueprints
19:55:48 <nik90> I think I have run out of question :P
19:55:50 * popey isnt going to ask what the easter egg is
19:56:07 <nik90> popey: wait u dont know? :D
19:56:25 <popey> its probably best i don't ☻
19:56:33 <nik90> hehe
19:56:50 <nik90> we already have one..but I wont say
19:56:54 <popey> ok, anything else before we wrap?
19:57:03 <nik90> nothing that I can think of
19:57:12 <popey> awesome, thanks nik90
19:57:17 <popey> #endmeeting