20:16:15 <popey> #startmeeting Ubuntu Touch File Manager App meeting
20:16:15 <meetingology> Meeting started Thu Apr 11 20:16:15 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:16:15 <meetingology> 
20:16:15 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:16:26 <popey> some links...
20:16:32 <popey> blueprint: https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-filemanager-development
20:16:50 <popey> reviews: https://code.launchpad.net/~ubuntu-filemanager-dev/ubuntu-filemanager-app/trunk/+activereviews
20:16:52 <ajalkane> I'll start with some good news. The upstream nemo plugin project has splitted the plugins into more manageable pieces, which will help us
20:17:04 <ajalkane> The filemanager plugin that we depend on is now in https://github.com/nemomobile/nemo-qml-plugin-folderlistmodel/tree
20:17:11 <popey> bugs: https://bugs.launchpad.net/ubuntu-filemanager-app/+bugs
20:17:22 <popey> oh excellent!
20:17:25 <ajalkane> Also they have merged all the changes I've submitted
20:17:32 <popey> even better
20:17:37 <ajalkane> The bad news of course it that Timo's repo must be updated
20:18:07 <popey> hm
20:18:14 <mhall119> popey: can we setup an automatic sync between that git repo and a bzr branch under this project?
20:18:16 <popey> do we need it to be owned by timo?
20:18:28 <popey> thats what I'm thinking
20:19:04 <popey> I'll speak to the necessary people to make that happen
20:19:33 <ajalkane> During this week I have not had time to do anything else except work on the upstream merging, and updating Carlos's branch so that it has all the changes from upstream and my branch so that it works with the QML UI
20:19:36 <popey> #action popey get automated sync between https://github.com/nemomobile/nemo-qml-plugin-folderlistmodel/tree and bzr in filemanager app friendly place on lp
20:19:36 * meetingology popey get automated sync between https://github.com/nemomobile/nemo-qml-plugin-folderlistmodel/tree and bzr in filemanager app friendly place on lp
20:19:55 <mhall119> ajalkane: the upstream merging is a big piece
20:20:27 <popey> yeah, and it's a valuable piece of work
20:21:11 <ajalkane> Upstream now has everything that is required by the current UI. But Carlos's improvements are not there yet, but neither is the UI yet using any features from that branch that doesn't work with upstream plugin.
20:22:33 <popey> ok
20:22:36 <mhall119> ajalkane: was upstream receptive and happy to get these contributions?
20:22:55 <popey> so on the blueprint...
20:22:57 <popey> [mhall119] Check with Mirv about automating new builds of the Nemo plugin: TODO
20:23:01 <popey> I'll take that
20:23:11 <mhall119> yeah, it's easy now :P
20:23:24 <popey> hah
20:23:31 <ajalkane> I'd like to issue a forewarning. I have mostly time to work on this during this month, and the next month. In my estimation it's enough to do the "single item" operations in blueprints, but multi-selection might not be doable. So I recommend trying to get more people involved to keep the project going - depending on the what the goals are for filemanager
20:24:00 <popey> I appreciate you letting us know up front ajalkane, it's very helpful
20:24:12 <ajalkane> mhall119: they were happy to accept the changes, some minor modifications were needed, but it was in good open source collaboration.
20:24:28 <ajalkane> They seem to be pretty busy though, so it took quite a while for some of the changes.
20:25:03 <mhall119> ajalkane: that's fantastic, you and Carlos both are doing an excellent job on this
20:25:09 <popey> +1
20:26:13 <ajalkane> mhall119: You're reviewer in one of my changes. If you're too busy I can review it myself :)
20:27:29 <mhall119> ajalkane: which one?
20:27:44 <ajalkane> CarlosMazieri: I think we might need in the plugin some way to get the amount of items in clipboard for QML UI. Otherwise it's hard to do UI with "Paste" visible only when there's something copied there
20:28:32 <ajalkane> mhall119: this one: https://code.launchpad.net/~ajalkane/ubuntu-filemanager-app/filedetails/+merge/156407
20:28:38 <CarlosMazieri> the progress signal has (current item , total items, percentage)
20:28:50 <popey> hey CarlosMazieri
20:28:58 <CarlosMazieri> hey
20:29:16 <CarlosMazieri> ajalkane: is the progress signal enough ?
20:29:25 <ajalkane> CarlosMazieri: I don't mean progress. But when user copies something to clipboard, the UI needs to know there's for example "5 items" in the clipboard ready for pasting. So that it can show the "Paste" button
20:29:37 <mhall119> ajalkane: I'll review it before I end work today
20:29:39 <ajalkane> At least that's my initial thought
20:29:45 <ajalkane> mhall119: thanks
20:29:48 <mhall119> np
20:30:07 <CarlosMazieri> OK, we do not have but we can put in place
20:30:40 <ajalkane> CarlosMazieri: Good. Because it seems to me having a "Paste" button there without any items to paste would be confusing.
20:30:40 <CarlosMazieri> I understand that you want to know how many items URLs are in the clipboard, right?
20:30:59 <ajalkane> CarlosMazieri: Yes exactly. I think preferably a property instead of Q_INVOKABLE
20:32:20 <CarlosMazieri> OK, put that please in the blueprint  to me
20:32:27 <ajalkane> Sure
20:35:47 <popey> ok..
20:36:29 <popey> anything else we need to do for you guys before we wrap up?
20:36:39 <CarlosMazieri> No from my side
20:37:10 <ajalkane> I think I've unloaded everything already
20:37:40 <popey> #action mhall119 find someone to find an additional developer given ajalkane's availability going forward
20:37:40 * meetingology mhall119 find someone to find an additional developer given ajalkane's availability going forward
20:37:50 <popey> great, thanks guys!
20:37:54 <popey> #endmeeting