19:34:22 <popey> #startmeeting Ubuntu Touch DocViewer App Meeting
19:34:22 <meetingology> Meeting started Thu Apr  4 19:34:22 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:34:22 <meetingology> 
19:34:22 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:34:22 <Robin_Watts> popey: tor8 is the originator of MuPDF.
19:34:34 <popey> ah of course
19:35:02 <popey> so have you guys been discussing with the doc team while I was away last week?
19:35:15 <mhall119> no
19:35:23 <mhall119> nobody was around except seb128 and I
19:35:42 <mhall119> Robin_Watts has talked to him a bit about muPDF though
19:35:49 <popey> do you know if seb had a chance to look at mupdf?
19:35:58 <Robin_Watts> mhall119: Only very briefly.
19:36:03 <mhall119> he said he did briefly
19:36:59 <popey> ok.
19:37:00 <mhall119> Robin_Watts: are you working on the doc viewer otherwise?
19:37:25 <Robin_Watts> No.
19:37:47 <mhall119> would you be interested in doing so?
19:38:06 <mhall119> I'd like to at least get plain text document viewing to work
19:38:13 <Robin_Watts> Alas, I have no time for such.
19:38:13 <mhall119> so we can put it on the daily phablet images
19:38:25 <mhall119> ok, no worries
19:39:16 <Robin_Watts> I can probably help make any changes/enhancements to mupdf may be required, but I can't actually get into coding for the doc-viewer itself.
19:39:23 <mhall119> ok
19:39:33 <seb128> hey
19:39:35 <popey> hiya
19:39:54 <seb128> (sorry, a bit late, mostly lurking but available for questions/discussions if there is any)
19:40:17 <mhall119> hey seb128
19:41:14 <popey> seb128: have you had a chance to take much of a look at mupdf?
19:41:36 <seb128> popey, I wouldn't say "much"
19:41:51 <seb128> but I looked a bit a it and noticed that:
19:42:00 <mhall119> seb128: do you know what possible libs we can use to render office docs?
19:42:01 <seb128> - there is no "desktop client"
19:42:23 <seb128> e.g no full feature interface using gtk/qt we could use on the desktop
19:42:39 <seb128> - the ubuntu source doesn't seem to have tests
19:43:19 <seb128> - the viewer available there seems to do the job for rendering the pdfs I tried though
19:43:35 <seb128> mhall119, I'm not sure there is any good one for that...
19:44:03 <seb128> I guess we should have a look to goffice (I think that's what abiword/gnumeric are using)
19:44:16 <seb128> but I think we will find the support suboptimal
19:44:38 <mhall119> trying to get those to work under Qt/QML is likely to be a pain too
19:44:46 <seb128> yeah
19:44:57 <mhall119> we might have better luck looking for KOffice libs
19:45:11 <seb128> I was going to say that
19:45:17 <seb128> I never looked at those though
19:45:20 <mhall119> as long as they don't depend on all the rest of KDE
19:45:31 <popey> caligra even?
19:45:33 <seb128> I can have a look to see how good the support is and how much KDE they use if you want
19:45:47 <seb128> note me down to have a look for next week
19:46:07 <popey> there is already a caligra based viewer for android..
19:46:32 <mhall119> does it support MS Office docs?
19:46:52 <popey> "Calligra uses the OpenDocument format as its default file format for most applications and can import other formats, such as Microsoft Office formats."
19:47:22 <mhall119> worth looking into
19:47:53 <mhall119> seb128: can you give a cursory look over both options and see which one might be worth looking into?
19:47:59 <seb128> yes
19:48:19 <mhall119> thanks
19:48:24 <seb128> yw ;-)
19:51:45 <seb128> was there a meeting when I joined? ;-)
19:51:59 <mhall119> yes
19:52:01 <mhall119> I think
19:52:04 * mhall119 scrolls up
19:52:04 <popey> yeah, but the main developers aren't around
19:52:08 <mhall119> yes
19:52:08 <seb128> k
19:52:21 <mhall119> popey: let's add work items anyway
19:52:25 <popey> #action popey send out meeting reminders
19:52:25 * meetingology popey send out meeting reminders
19:52:25 <seb128> is there any blueprint/list of workitems/code for that app?
19:52:30 <popey> yes..
19:52:41 <seb128> sorry I'm new around
19:52:53 <mhall119> launchpad is being slow for me...
19:53:01 <seb128> I'm mostly just have a look on what is happening and see if I can have any useful input
19:53:02 <popey> https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-docviewer-development
19:53:06 <seb128> thanks
19:53:15 <popey> lean on items
19:53:44 <mhall119> popey: can we add a WI for a plain text display component for -month-0 ?
19:53:50 <mhall119> I think that's do-able
19:53:56 <popey> will do
19:54:30 <seb128> it might be a question for #ubuntu-touch rather than the meeting (if that's the case just say so)
19:54:49 <seb128> but is there any plan to have the work in progress apps on the touch image?
19:56:23 <popey> yes
19:56:30 <popey> selecting the ones which are most advanced
19:56:39 <popey> in terms of functioning
19:56:47 <seb128> good
19:56:54 <seb128> popey, thanks ;-)
19:59:13 <popey> anything else we need to discuss - we're at the end of our time?
20:00:36 <popey> ok then..
20:00:38 <popey> #endmeeting