21:31:44 <mhall119> #startmeeting Weather App
21:31:44 <meetingology> Meeting started Thu Mar 28 21:31:44 2013 UTC.  The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:31:44 <meetingology> 
21:31:44 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:31:47 <mhall119> \o/
21:31:51 <m-b-o> :)
21:32:43 <mhall119> alright, to start things off I wanted to let you know that I moved the blueprint to the ubuntu-phone-commons project on Launchpad
21:33:02 <mhall119> this will make it easier for popey and I to track work items for all the core apps projects
21:33:04 <m-b-o> yes, saw that already
21:33:19 <mhall119> I also created milestones for each month of the 13.10 development cycle
21:33:35 <mhall119> so we'll be doing a monthly planning, just like the rest of Ubuntu has started
21:34:01 <m-b-o> okay
21:34:02 <mhall119> the milestones range from month-0 (April) to month-6 (October)
21:34:21 <mhall119> what we had originally been calling alpha-1 is now month-1, still Math though
21:35:12 <m-b-o> still may?
21:35:16 <mhall119> yup
21:35:22 <mhall119> just a different name for the milestone
21:35:32 <mhall119> I just can't type :)
21:35:52 <m-b-o> well, one still has to count the months.. ;)
21:36:16 <mhall119> #topic progress update
21:36:28 <mhall119> popey can't be here for this meeting, so I'm filling in for him
21:36:42 <mhall119> can you give me an update on the work that's been done since the last meeting?
21:36:53 <m-b-o> https://code.launchpad.net/~martin-borho/ubuntu-weather-app/weather-data-api/+merge/155997
21:37:04 <m-b-o> weather api and storage is ready for review
21:37:32 <m-b-o> should be usable
21:37:58 <mhall119> nice!
21:38:14 <mhall119> is there another active member of the team who can do a review?
21:38:35 <m-b-o> I hope so...
21:39:08 <mhall119> if not, you can always ping me and ask me to do one
21:39:16 <m-b-o> okay
21:39:29 <m-b-o> had a problem last week with this one https://code.launchpad.net/~bzoltan/ubuntu-weather-app/namig-fix/+merge/153774
21:39:36 <mhall119> also, the Canonical design team has produced a detail set of workflows for the weather app
21:39:41 <mhall119> http://design.canonical.com/2013/03/app-patterns-applied-weather-key-journeys/
21:39:46 <mhall119> #link http://design.canonical.com/2013/03/app-patterns-applied-weather-key-journeys/
21:39:54 <mhall119> well I hope meetingology got that
21:40:31 <m-b-o> so no chart anymore?
21:40:42 <mhall119> I'll look at bzoltan's branch, I have a work item to do something similar for the other core apps
21:40:50 <m-b-o> okay
21:41:09 <mhall119> hmmm, I didn't notice that was missing
21:41:53 <mhall119> I saw you emailed them about available data
21:42:12 <mhall119> were you going to have the data to produce such a graph?
21:42:31 <m-b-o> the data for the graph is available
21:43:10 <mhall119> ok, we should ask about that, make sure there was a reason for removing it
21:44:30 <mhall119> m-b-o: can you email christina about it?
21:45:10 <m-b-o> yes, I can. "We’ll post some teasers of the apps in action soon, and visual design!!!" Perhaps it will be back then
21:45:44 <mhall119> perhaps
21:46:02 <mhall119> #action m-b-o to email designers about missing temperature graph in new workflows
21:46:02 * meetingology m-b-o to email designers about missing temperature graph in new workflows
21:46:24 <m-b-o> actually, the dailyforecast is also missing
21:46:31 <mhall119> and also with any other questions you have about the new designs
21:46:45 <mhall119> it looks drastically different from the first set up mockups
21:49:35 <mhall119> oh, another thing I wanted to let you know about, there's an alpha version for U1DB, which will let you store settings and have them sync'ed between devices
21:49:43 <mhall119> docs for that are here: http://people.ubuntu.com/~mhall119/u1db-qt/u1db-qt-cheatsheet.html
21:49:44 <m-b-o> oh, cool
21:50:04 <m-b-o> that's nice
21:50:10 <mhall119> it uses a local sqlite db, so performance should still be the same
21:50:16 <mhall119> but it'll allow easy syncing
21:50:39 <m-b-o> performance wise it should not be critical for the weather app
21:50:39 <mhall119> currently it only supports a simple key=value document, but that should be all you need for settings
21:51:04 <mhall119> being able to have lists of docments, and filter/index them is coming soon
21:51:36 <m-b-o> sounds good, I'll look at it the next week
21:51:55 <mhall119> #action mhall119 to review API branch and bzoltan's renaming branch
21:51:55 * meetingology mhall119 to review API branch and bzoltan's renaming branch
21:52:18 <mhall119> is there anything else that is blocking you guys, or that you need popey or I to look into for you?
21:53:03 <m-b-o> hmm, nothing on my side atm
21:53:28 <mhall119> ok, feel free to email or ping me any time if you need something
21:53:38 <m-b-o> alright
21:53:41 <mhall119> and thanks for your contributions :)
21:54:16 <m-b-o> no problem :)
21:54:17 <mhall119> if you want to add work items for things in the new designs, feel free
21:54:55 <m-b-o> okay. is tomorrow a holiday too in UK?
21:54:58 <mhall119> anything you don't think will be ready by May, just put in the bottom "Work items" section and we can assign them to specific milestones as we get closer to being able to do them
21:55:07 <mhall119> yeah
21:55:14 <mhall119> so you may not get a response until Monday
21:55:21 <mhall119> or Tuesday
21:55:26 <mhall119> I don't know how their holidays work
21:55:30 <m-b-o> yes, should be fine
21:55:40 <mhall119> ok
21:55:42 <mhall119> thanks agian m-b-o
21:55:51 <mhall119> #endmeeting