17:03:15 <mhall119> #startmeeting Calendar App Meeting
17:03:15 <meetingology> Meeting started Thu Mar 28 17:03:15 2013 UTC.  The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:03:15 <meetingology> 
17:03:15 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:03:38 <frankencode> i'm here
17:04:54 <mhall119> hi frankencode
17:05:27 <frankencode> not much happened with the calendar this week
17:05:33 <frankencode> but steady progress
17:05:33 <mhall119> so you guys may have noticed, I moved the Blueprint for the initial development to the ubuntu-phone-commons app
17:05:49 <mhall119> the blueprint is now at https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-calendar-development
17:05:52 <frankencode> yes, i already edited in the new location
17:06:24 <frankencode> i reflashed my phone last week
17:06:35 <frankencode> the onscreen keyboard seems not to work as expected...
17:06:36 <mhall119> the goal is to get work item tracking for these core apps on status.ubuntu.com
17:07:07 <mhall119> frankencode: file a bug for anything like that
17:07:28 <frankencode> yeh, i noticed there was work ongoing affecting the keyboard
17:07:31 <mhall119> put it on ubuntu-ui-tookit, and then the SDK devs can sort out which are SDK bugs and which are touch image bugs
17:07:36 <frankencode> and it already improved...
17:07:44 <mhall119> #topic progress update
17:07:58 <mhall119> ok, so what's been happening since last week?
17:08:35 <frankencode> i spent most of my time with the sqlite local storage
17:08:40 <frankencode> and getting it work in the gui
17:08:57 <mhall119> is that for storing events?
17:09:02 <frankencode> i forget how long it takes to get an sql query processed
17:09:07 <frankencode> yes
17:09:11 <frankencode> events, todos, config
17:09:32 <mhall119> ok, as far as I know they're still evaluating calendar backends (evolution-data-server, akonadi, etc)
17:09:54 <frankencode> yes, that is another component
17:09:54 <mhall119> is it going to be difficult to switch from sqlite to one of those once a decision is made?
17:10:20 <frankencode> the api is designed to fully encapsulate the sqlite stuff
17:10:31 <mhall119> perfect
17:10:36 <frankencode> the gui code shouldn't worry about where the data is coming from
17:11:20 <mhall119> so as far as what's in trunk right now, I noticed there was something for creating test events, but I don't know how to get that working
17:11:40 <frankencode> qmlscene calendarTests.qml
17:12:01 <frankencode> that will load the schedule of the qt devdays of last year
17:12:06 <frankencode> just for testing...
17:12:34 <frankencode> but i'm trying the get the "new event" dialog working next
17:12:48 <frankencode> kunal already created one, but it doesn't works on the touch
17:13:03 <frankencode> onscreen keyboard does not appear when focus enters a line edit
17:13:07 <mhall119> what day does it put them on?
17:13:24 <frankencode> i think the today and next day
17:13:25 <mhall119> hmm, keyboard should appear whenever a text input has keyboard focus
17:13:47 <frankencode> yes, i'm looking into that issue next
17:14:05 <frankencode> thereafter everyone can enter their own events...
17:14:14 <mhall119> ok
17:14:30 <mhall119> so the "create event" view is in progress?
17:14:37 <frankencode> yes
17:14:49 <mhall119> can you update the blueprint work item from TODO to INPROGRESS?
17:14:55 <frankencode> as i said there is already a test version, but it works only on the desktop
17:15:05 <frankencode> yes inprogress
17:15:35 <mhall119> is mariob helping with that?
17:16:15 <frankencode> lets see
17:17:06 <frankencode> for sure i set him to review the code
17:17:20 <frankencode> question about that bot (jenkings?)
17:17:26 <frankencode> how does it work?
17:17:38 <frankencode> sometimes it does wonders, most of the time it does nothing
17:18:07 <frankencode> some reviewed branches never get merged, some other get merged immediately
17:18:39 <mhall119> it's *supposed* to periodically check for approved MP's and automatically merge them into trunk
17:18:57 <mhall119> we've had some technical difficulties with it lately though
17:19:25 <frankencode> ok i have a feature request then: add a fat "kick bot ass" button
17:19:26 <mhall119> the MP needs to have a commit message, in addition to a description, so that's the first thing to check
17:19:43 <frankencode> commit message for merge, no conflict
17:19:49 <mhall119> frankencode: ping fginther on IRC, he's our "kick bot ass" button
17:19:50 <frankencode> yet the branch stays there for weeks
17:20:15 <frankencode> human interface to a bot?, COOL!
17:20:26 <mhall119> ok, any other work items that were worked on in the past week?
17:20:27 <frankencode> jokes aside
17:21:01 <frankencode> kunal did some experimentation on the layout change for the event view vs. the moth view
17:21:35 <frankencode> no idea what else went on
17:21:39 <mhall119> was that a work item on the blueprint?
17:21:50 <frankencode> yes, i put that to DONE
17:21:56 <mhall119> ah, ok, that one
17:22:03 <mhall119> how about the event API?
17:22:16 <frankencode> that's DONE, too
17:22:34 <mhall119> awesome
17:22:44 <mhall119> and the Implement backend data model?
17:23:05 <frankencode> DONE 75%
17:23:51 <mhall119> ok
17:24:05 <mhall119> #topic miletone targets
17:24:22 <frankencode> what milestones?
17:24:24 <mhall119> so part of the blueprints move is to get the coreapps on the same monthly planning cycle as the rest of Ubuntu is adopting
17:24:39 <mhall119> which means we'll have milestones for each month between now and 13.10
17:24:49 <frankencode> ok with me, though i don't plan my hobbies;)
17:25:37 <frankencode> next things in my pipe: a) get all the stuff from kunal working in trunk
17:25:45 <mhall119> frankencode: understood, it just helps organize what can be done in the near-term, and what will require longer-term work
17:25:48 <frankencode> b) prepare a list of assets for the designers
17:26:17 <frankencode> yea, understood, makes it also more transparent
17:26:56 <mhall119> ok, I just updated the blueprint
17:27:00 <frankencode> is there already a common icon set, or something?
17:27:07 <mhall119> there are currently 2 milestones, with work items divided between them
17:27:35 <mhall119> frankencode: not yet, design has told us to just use what we can find until they can provide a them
17:28:11 <mhall119> so, milestone coreapps-13.10-month-0 corresponds to April, so things we think we can get done next month
17:28:52 <frankencode> ok
17:28:54 <mhall119> the rest of the calendar work items are in coreapps-13.10-month-1, which is what we had originally been calling alpha-1, and represents work to be finished in May
17:29:00 <frankencode> i need to add a few things
17:29:16 <mhall119> you can move them around, or push things out to month-[0-6]
17:30:01 <frankencode> clear
17:31:09 <mhall119> so currently you're waiting on a decision on event-storage, and also waiting on design for image assets
17:31:59 <mhall119> is that correct?
17:32:36 <frankencode> yes
17:32:52 <frankencode> well, i'm going to wait, once i know which assets i need
17:33:07 <frankencode> i guess the prototype has to grow a little bit further...
17:33:34 <mhall119> is there anything else that you are currently either waiting on or blocked on?
17:34:05 <frankencode> not really
17:34:25 <frankencode> i'd like to see some more tests on the theme engine
17:34:27 <mhall119> alright, anything I or popey can do for you?
17:34:48 <frankencode> i've noticed progress on the theme engine in uitoolkit
17:35:21 <frankencode> e.g. the Ubuntu.components label is an order of magnitude to slow to be useful
17:35:36 <mhall119> oh, really?
17:35:57 <frankencode> it was even unreliable in my initial tests, so i had to work around
17:36:05 <frankencode> i have to check back with the latest version
17:36:31 <mhall119> did you file a bug?
17:36:56 <frankencode> yes, once i get my lazy ass into creating some reproducible tests
17:37:05 <mhall119> the SDK team needs us all to report bugs for things like this, so they know where they need to improve
17:37:07 <frankencode> or someone else does...
17:38:04 <frankencode> i think when i scrolled a few hundret times (i was testing something else) I got strange font attributes in the labels on the calendar
17:38:12 <frankencode> that sucks, difficult to reproduce
17:38:22 <mhall119> was that on the desktop or on a device?
17:38:40 <frankencode> i think on the desktop
17:38:49 <frankencode> anyway the real killer was performance on device
17:39:13 <frankencode> so i took a Text  and copied over the font attributes from a single label created once
17:39:15 <mhall119> I'll ask and see if we have any automated performance testing for the SDK codebase
17:39:44 <frankencode> the tab widget is also horrible slow and the initial tab seems to be place randomly
17:40:00 <frankencode> yes, that's one big TODO: test the uitoolkit things...
17:40:05 <mhall119> I noticed that on the calendar, but not on other apps, which is strange
17:40:26 <frankencode> well there are lots of labels for each month;)
17:40:35 <frankencode> ah the tab widget
17:40:48 <frankencode> yes maybe a problem on how we use it...
17:41:06 <mhall119> #action mhall119 to investigate performance testing on the Ubuntu UI toolkit
17:41:06 * meetingology mhall119 to investigate performance testing on the Ubuntu UI toolkit
17:42:02 <mhall119> alright, we're well past time on this meeting, is there anything else you would like to discuss before we wrap it up?
17:42:17 <frankencode> that's all
17:42:30 <mhall119> #endmeeting