11:01:26 <popey> #startmeeting Ubuntu Touch Facebook App meeting
11:01:26 <meetingology> Meeting started Thu Mar 28 11:01:26 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
11:01:26 <meetingology> 
11:01:26 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
11:01:34 <popey> so, who is here for the meeting?
11:01:35 <popey> o/
11:01:36 <popey> dpm?
11:01:46 <barbarrica> Hugo here !
11:02:32 <popey> ok, we had a few action items from last time...
11:02:39 <popey> "barbarrica to send a wishlist of features required by facebook app of friends"
11:02:50 <popey> I saw the thread on the mailing list, are you happy with the info you got?
11:04:06 <popey> " popey speak to friends-developers for a qml-friends plugin roadmap" - also spoke to ken, and he pointed to the thread on the list..
11:04:10 <barbarrica> Friends is lacking some important features
11:04:22 <barbarrica> they are still working
11:05:14 <popey> https://lists.launchpad.net/ubuntu-touch-coreapps/msg00193.html for reference
11:06:01 <barbarrica> eg. notifications, search for people
11:06:27 <popey> indeed.
11:06:39 <barbarrica> photos...
11:07:14 <barbarrica> I am having some other problems
11:07:15 <popey> "popey speak to ken about getting qml2-friends installable on raring" - I understood previously that it didn't work on raring, but this isn't the case, it's in raring as qtdeclarative5-friends-plugin
11:07:19 <popey> oh?
11:07:21 <barbarrica> related with the sdk
11:08:10 <barbarrica> after upgrading to the latest ppas, things like tabs stoped behaving like they did
11:08:37 <popey> when running your app in qmlscene?
11:08:42 <barbarrica> yep
11:09:25 <barbarrica> apparently it is not possible anymore to hide a tab component
11:09:50 <popey> I dont know if that's intentional or a bug..
11:09:59 <popey> https://bugs.launchpad.net/ubuntu-ui-toolkit/+bugs is the place to file it if you believe it's a bug..
11:10:13 <popey> I can get one of the UI toolkit guys to look at it once filed
11:10:31 <barbarrica> i tried to figure a workaround but none yet
11:10:32 <dpm> hey, sorry, I was away for a bit, I'm back
11:11:09 <popey> hey, hi dpm
11:11:38 <barbarrica> popey: have you tried my latest branch ?
11:11:40 <popey> barbarrica: I'd recommend you file a bug and we can track it easily.
11:12:00 <popey> not this week..
11:12:02 * popey updates
11:12:28 <dpm> barbarrica, you might want to ping bzoltan on #ubuntu-touch as well, he might be able to tell you more
11:12:44 <barbarrica> ok I'll do that
11:12:48 <popey> https://code.launchpad.net/~hmiguellima/ubuntu-facebook-app/hlima-initial  that one?
11:12:53 <barbarrica> yes
11:13:53 <popey> hmm, you're using quantal barbarrica ?
11:14:07 <barbarrica> raring
11:14:20 <barbarrica> 13.04
11:14:34 <popey> i get a blank window in qmlscene with a facebook account > tab title
11:15:09 <popey> i can pull down and see "Please create a new account" when I do
11:15:35 <barbarrica> you have to add an account to online accounts
11:15:59 <barbarrica> the online accoutns plugin dosent have create account functionality
11:16:04 <popey> ah of course
11:17:12 <popey> ok, now I get a facebook logo when I pull down
11:17:22 <popey> and my fb username next to it
11:23:45 <popey> http://popey.com/~alan/fb1.png that is what I see
11:23:46 <popey> http://popey.com/~alan/fb2.png that is what I see when I pull down
11:23:46 <popey> so i can't click on that because when i let go, it goes back up again
11:23:46 <barbarrica> yes, that werent happening before the latest update
11:23:46 <barbarrica> it messed the layout
11:23:46 <popey> ahh
11:23:46 <barbarrica> if I add a topmargin to the listview it works
11:23:46 <barbarrica> but it's a hack
11:23:46 <barbarrica> i guess the problem is related to me using two tab components
11:23:46 <barbarrica> i hide one and show the other
11:23:46 <barbarrica> but after the update it messed up
11:23:48 <popey> Ok, I'd do as dpm suggested and ping kaleo / bzoltan in #ubuntu-touch, if you can't get hold of them then file a bug against ubuntu-ui-toolkit and give me the bug number and I'll get an answer
11:24:30 <barbarrica> the development is beeing slow down because of this kind of hacks/bugs
11:24:38 <popey> understood
11:24:45 <barbarrica> i'm spending hours to solve
11:24:53 <popey> are you planning to merge your branch into trunk soon?
11:25:15 <barbarrica> after I get the layout working again...
11:25:19 <popey> ok, cool.
11:26:02 <popey> We've been looking at the work items for the facebook app - you'll notice we moved the blueprint to https://blueprints.launchpad.net/ubuntu-phone-commons/+spec/initial-facebook-development ..
11:26:19 <popey> I have copied the work items into http://pad.ubuntu.com/A4WMMZz2av to make it easier to edit
11:26:28 <popey> we wanted to set some milestones, to break up the work items
11:26:40 <barbarrica> yes i was there yesterday
11:26:43 <popey> I wanted to get you to take a look and see if you agree with the split I did
11:27:01 <popey> we can re-visit the list again later, but as a first cut
11:27:34 <barbarrica> the list seems ok
11:27:51 <barbarrica> manageable
11:28:07 <popey> can you join the etherpad doc and you can see the milestones..
11:32:05 <barbarrica> etherpad link?
11:32:05 <popey> http://pad.ubuntu.com/A4WMMZz2av
11:32:06 <popey> sorry, "pad"
11:32:06 <barbarrica> is this only available in pad ?
11:32:06 <popey> no, I just copied it there to let us edit together
11:32:06 <popey> will copy it back to launchpad after the meeting
11:32:07 <barbarrica> ok
11:32:07 <popey> so i have broken it into monthly milestones
11:32:07 <popey> it's possible we may move things about of course, but this is a starting point, to give us somethin to aim for
11:32:07 <barbarrica> UI Layout D - Component 4  depends on unavailable functionality
11:32:07 <popey> Any changes you want to make?
11:32:16 <barbarrica> sorry
11:32:42 <barbarrica> the missing functionality is creating a new account
11:33:58 <popey> the account management icon is in the backlog at the bottom..
11:34:05 <popey> but you mean, missing functionality in friends, right?
11:35:51 <barbarrica> no missing in the online-accounts plugin
11:36:55 <popey> i think it's reasonable to have it where it is, and I can take an action to chase down that feature and if it needs to move then we can move it
11:41:19 <barbarrica> what about sharing a post
11:41:55 <popey> [hmiguellima] Functionality to like, comment etc. other people’s posts: TODO
11:42:00 <popey> I think "etc" covers that ☺
11:42:22 <popey> that should probably be more explicit
11:42:36 <barbarrica> i mean what kind of interfaces are available to share a post ? (email, sms, etc)
11:43:04 <popey> oh, I thought you meant the three options under a post in facebook
11:43:10 <popey> "Like, Comment, Share"
11:43:28 <popey> I don't think sharing outside of FB is something we should be looking at.
11:43:30 <barbarrica> yes, i just dont know how to implement the share part
11:43:59 <popey> Is it not simlar to creating a new status update?
11:44:06 <popey> just with pre-created content?
11:44:40 <barbarrica> ok share is only within facebook my bad :(
11:44:46 <popey> yeah.
11:44:46 <popey> np
11:45:46 <popey> you happy with the milestones?
11:48:17 <barbarrica> yes
11:48:36 <popey> awesome.
11:48:54 <popey> any other blockers / issues?
11:49:15 <barbarrica> other than the ones I said before, no
11:49:34 <popey> ok. I'll copy these work items back into the blueprint
11:50:21 <barbarrica> did you manage to get anyone from the twitter team to help ?
11:50:32 <popey> not yet, will chase them down
11:50:48 <popey> #action popey get volunteers from twitter app to help with fb app
11:50:48 * meetingology popey get volunteers from twitter app to help with fb app
11:51:29 <popey> lets wrap up, and jump in #ubuntu-touch to see if we can get an answer to your current issue..
11:51:33 <popey> #endmeeting