20:31:58 <popey> #startmeeting Ubuntu Touch Clock app meeting
20:31:58 <meetingology> Meeting started Fri Mar 22 20:31:58 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:31:58 <meetingology> 
20:31:58 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:32:04 <popey> whose here for the meeting?
20:32:14 <frals> o/
20:32:20 <nik90> me
20:32:36 <frals> wonder if Riussi is around
20:32:53 <popey> So I hope you've all seen http://design.canonical.com/2013/03/app-patterns-applied-clock-key-journeys/ ?
20:33:13 <nik90> frals: he is in the room but afk I guess
20:33:17 <frals> yeah, looks good!
20:33:22 <nik90> popey: yes...looks amazing
20:33:49 <popey> the work items at https://blueprints.launchpad.net/ubuntu-clock-app/+spec/initial-clock-development will likely need some modification as a result of having those wireframes
20:33:51 <frals> gives us some more stuff to implement in the views.. good timing since we were running out ;)
20:33:58 <popey> excellent!
20:34:00 <nik90> there were some queries in the mailing list regarding setting the time for the alarm ... but I guess that should be solved within the next few days
20:34:14 <popey> nik90: yes, I don't expect that to be a blocker?
20:34:32 <nik90> no no :) should be fine...we can get started with coding them
20:35:07 <popey> So really, the first thing to do is review the tasks and make sure everyone has plenty to do
20:35:22 <nik90> popey: currently we have a working timer, stopwatch and the clock....but they need to revamped with the new guidelines
20:35:55 <popey> yes.
20:36:21 <frals> popey: theres a few questions, like, what libraries are in the "base" of the distro?
20:36:41 <popey> frals: is there anything in particular you're looking for?
20:36:53 <frals> eg where we should get the list of locations from
20:36:56 <popey> because at the moment the preview image is likely to be in some state of flux
20:37:03 <popey> locations?
20:37:15 <frals> cities for the clock view
20:37:18 <popey> ah
20:37:25 <nik90> when the user wants to add another clock, he need a list of cities with their timezone info
20:37:31 <popey> Well, that's application specific.
20:37:43 <popey> Oh you mean the global list of cities?
20:37:50 <popey> not the ones that have been selected by the user?
20:37:52 <nik90> yeah global list of cities
20:37:54 <frals> popey: i would imagine its the same list the user can chose his regional settings from
20:38:00 <popey> yes
20:38:57 <popey> tzdata I would imagine
20:39:33 <frals> ok
20:39:43 <nik90> I was looking at tzselect which provides that sort of info...I just need to see how we can use javascript with it
20:39:51 <popey> /usr/share/doc/tzdata/README.Debian says "This package contains data required for the implementation of
20:39:54 <popey> standard local time for many representative locations around the
20:39:57 <popey> globe."
20:40:17 <frals> so this settings stuff where the user could set all kind of nice locale etc, do you happen to have any info where thats being developed?
20:40:22 <popey> http://qt-project.org/wiki/Qt-5-QTimeZone
20:41:47 <popey> i believe there is a 'settings' app
20:42:09 <popey> but I need to find out more about it
20:42:46 <popey> I would expect the clock user to set some of these within the app though
20:43:05 <popey> there's the system wide locale of course, but I might like to know the time in 5 cities
20:43:16 <frals> yeah
20:43:19 <popey> but that would be separate from (for example) the 5 cities I have in the weather app
20:43:36 <frals> but we would all use the same source, probably
20:43:44 <popey> probably not actually
20:43:50 <marcobiscaro2112> why?
20:43:54 <popey> I would imagine the weather app to pull list of cities from weather provider API
20:43:58 <popey> 3rd party tool
20:43:59 <frals> yeah true
20:44:18 <popey> they have a pre-defined list of cities which have weather stations, which won't necessarily map to the cities you may be interested in
20:44:34 <nik90> popey: the problem with 3rd party tool API is that they only provide for non-commercial uses and come with a usage restriction
20:44:47 <popey> the cities the clock app is interested in would be the same as for (for example) the clock in the ubuntu desktop, or the ubuntu installer (ubiquity) which has a tz selection screen
20:44:58 <popey> nik90: we can deal with that later ☺
20:44:58 <frals> but the clock and setting the device tz would probably be the same list
20:45:08 <popey> i agree frals
20:45:35 <nik90> frals: in that case we should see how the ubuntu desktop clock and installer obtain their timezone info
20:45:46 <popey> i dont think the clock needs to use any 3rd party APIs for cities
20:45:53 <popey> nik90: i agree
20:46:19 <nik90> because I had a look /usr/share/timezone which is used by tzdata and it has a list of all the cities we need in binary format
20:46:21 <frals> nik90: yeah, and check how the settings app integrates with it and make sure we only implement it once :)
20:46:54 <nik90> frals: I will add that the todo...I will update the blueprint tomorrow morning in light of the new design guidelines so that everyone know what needs to be done.
20:47:46 <popey> As per the mail earlier, if you want to converse / co-ordinate on IRC, I'd recmomend using #ubuntu-touch
20:48:04 <frals> ubuntu-touch tends to be a tad noisy though
20:48:12 <popey> sometimes can be, yes
20:48:18 <popey> not on the weekend
20:48:25 <nik90> popey: okay.I will do that but I am with frals regarding the noise...
20:48:39 <nik90> to be honest  it is mostly regarding phablet images rather than the core apps
20:48:49 <frals> me and Riussi and nik90 are in #ubuntu-phone-clock which is working fine
20:48:55 <popey> ok
20:49:13 <frals> me and Riussi have been chatting there for a few weeks and its working good
20:49:18 <popey> I'll lurk there if you don't mind, feel free to ping me if you need to, i leave my irc client connected
20:49:21 <popey> ok, fine :D
20:49:32 <frals> and no messages are getting lost among "how do i install x on y and why cant i do z" :D
20:49:34 <nik90> sure popey..
20:49:42 <popey> Yeah, no problem.
20:49:59 <popey> hi mhall119
20:50:34 <frals> btw, any possibility of getting another timeslot for the designer meeting we have on fridays? i understand their time is precious, but ~15 UTC on a friday is.. sub-optimal :)
20:50:43 <popey> Yes!
20:50:47 <popey> When would be a good time?
20:51:23 <popey> The design team are london based, and I'm in the UK, so during UK office hours would be most convenient for us..
20:51:31 <frals> for me a weekday evening or sunday ~anytime, but we should float it with Riussi as well
20:51:54 <nik90> frals: but I am guessing they would like it during office hours (weekdays)
20:52:01 <frals> im in .SE, but mostly busy with working during office hours ;)
20:52:07 <popey> understood
20:52:15 <frals> but any day is better than friday more or less :)
20:52:54 <popey> I am just looking at the design team calendars...
20:52:57 <frals> (ive come to realise, i was stupid enough to say friday was a good day in the initial planning so i guess its partly my fault its on fridays :))
20:53:05 <nik90> popey: can we get back to you on this in an email later on... I can check with Riussi and other clock developers as well
20:53:35 <popey> Looking at the calendars, Wednesday lunchtime bentween 12-14 GMT is good right now
20:53:43 <popey> if that's more convenient?
20:54:01 <nik90> +1
20:54:04 <popey> same for thursday
20:54:42 <popey> but yes, we can sort this out via email, no problem.
20:54:52 <frals> 13 GMT either day is probably doable for me, but lets decide over email
20:54:53 <popey> shall I email everyone and suggest a few times?
20:55:07 <frals> sounds excellent
20:55:10 <popey> ok
20:55:13 <nik90> popey: yup
20:55:25 <popey> #action popey email clock team and designers to get a better slot for design review meeting
20:55:25 * meetingology popey email clock team and designers to get a better slot for design review meeting
20:56:20 <popey> anything else we need to mention? we're low on time
20:56:53 <nik90> nothing on my mind for now... the main concern was the system level stuff like alarm, timezone etc
20:56:58 <frals> id love to get an architectural overview of whats suppose to be in the 'touch' distro
20:56:59 <nik90> but that is something we need to investigate
20:57:15 <popey> frals: me too! :D
20:57:23 <frals> based on mails i saw on mailing list the guideline seems to be "if its in ubuntu, it can be on the phone"
20:57:40 <frals> and well, coming from nokia and meego, that sounds crazy scary ;)
20:57:42 <popey> in general yes, but we have some guidelines, and some flexibility, and some inflexibility..
20:57:45 <popey> haha
20:57:48 <popey> I can imagine so
20:58:06 <popey> everything is pretty much in a state of flux at the moment
20:58:22 <popey> we're working on system level components, and as they're finalised we'll start talking more about them
20:58:33 <nik90> #action nik90 update blueprints to match the latest design guidelines
20:58:33 * meetingology nik90 update blueprints to match the latest design guidelines
20:58:34 <popey> but if there's anything specific you want answers on, I may be able to dig out the right people
20:58:40 <popey> oh, excellent task!
20:59:02 <frals> i think we are good for now, Riussi got answer on the alarm scheduling part from the mailing list iirc
20:59:05 <popey> It's great that things are really coming together.
20:59:22 <popey> I can't wait to be woken up in the morning by an Ubuntu alarm :D
20:59:30 <popey> Well.. you know. ☺
20:59:33 <frals> hehe :)
20:59:46 <nik90> me tooooo ..excited to see how all the core-apps are turning
20:59:54 <popey> so lets wrap up there, and keep in touch, let me know if you need anything.
20:59:57 <popey> #endmeeting