21:02:56 <popey> #startmeeting Ubuntu file app meeting
21:02:56 <meetingology> Meeting started Thu Mar 21 21:02:56 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:02:56 <meetingology> 
21:02:56 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:02:59 <popey> hi CarlosMazieri
21:03:05 <CarlosMazieri> hi
21:03:19 <popey> anyone else around?
21:03:28 <ajalkane> I am for FileManager meeting.
21:03:33 <popey> hey, great
21:04:10 <popey> So firstly.. you may have noticed we got nemo packaged and in the ppa
21:04:26 <popey> https://code.launchpad.net/~ubuntu-filemanager-dev/ubuntu-filemanager-app/nemo-qml-plugins-packaging
21:04:26 <ajalkane> I didn't notice
21:04:37 <popey> good, i am the bearer of good news then ☺
21:04:37 <CarlosMazieri> I did not
21:04:53 <ajalkane> The plugin is under much development. Whose responsible of updating it?
21:05:03 <popey> https://launchpad.net/~ubuntu-touch-coreapps-drivers/+archive/daily
21:05:06 <popey> package in the ppa there
21:05:35 <CarlosMazieri> I am developing the plugin
21:05:38 <ajalkane> Is it update from upstream or from somewhere else?
21:06:04 <CarlosMazieri> No, I got the last version from ajalkane and started updating it
21:06:06 <popey> we took it from your branch linked from the filemanager app README I believe
21:06:16 <popey> you can push updates to the branch above
21:06:28 <popey> and we'd obviously expect changes to be passed upstream
21:06:28 <ajalkane> Ok
21:06:38 <CarlosMazieri> I will keep working on my branch, then merge at some point
21:06:48 <ajalkane> Yes... I've passed changes I've made step by step upstream
21:06:50 <popey> the packaging is in there too
21:06:55 <popey> great ajalkane, thanks
21:06:56 <ajalkane> Yeah we must eventually merge
21:07:21 <popey> we put the code in the ~ubuntu-filemanager-dev team area so you guys can update as you see fit
21:07:29 <popey> we'll also be doing the same autolanding as with the apps
21:07:41 <ajalkane> Ok... well... that's really great news
21:08:02 <ajalkane> So I guess that's the official OK for using nemo's plugin in the project?
21:08:13 * mhall119 late, but here
21:08:38 <popey> I have had no negative feedback, should be fine.
21:08:53 <mhall119> ajalkane: yes, I got an official okay to use it
21:08:58 <popey> ah great.
21:09:00 <ajalkane> That's great
21:09:29 <CarlosMazieri> I am implementing regression tests in the plugin
21:09:56 <mhall119> as long as it's packaged and in the repos, we're good
21:10:13 <ajalkane> CarlosMazieri: unit testing? Is there some common unit testing framework in Ubuntu context specified now how we should go about it?
21:10:17 <CarlosMazieri> YES
21:10:44 <ajalkane> Great to hear
21:10:50 <CarlosMazieri> I am using QTest C++ framework
21:11:07 <popey> hmm, i had an action last meeting to chase that up, sorry, missed that.. will do
21:13:04 <popey> we also asked the design team this week about icons for apps..
21:13:18 <popey> That subject came up last week in a few places..
21:13:33 <ajalkane> Any news on image runnable on Virtual Box etc... I find it great impediment in doing "platform conforming UI" that there is no way to look how the platform generally behaves
21:13:57 <popey> The general advice was for now they're working on the core apps, and aren't focussed on creating icons yet, so we're okay to use stock / placeholders for the moment
21:14:10 <popey> which will get replaced later when design have some capacity
21:14:12 <ajalkane> Ok, that's good information
21:15:02 <popey> i spoke to the sdk guys about using Virtualbox and there's no plan in the short term to setup a Vm for the phone/tablet
21:15:17 <popey> given we have qmlscene which is considered "good enough for now" for testing apps
21:15:52 <ajalkane> It's good enough for testing... and of course majority of work can be done on that. Fine-tuning when designs finalize etc. can of course be done later.
21:16:04 <popey> indeed.
21:16:25 <popey> and there are enough nexus 7 and nexus 4 devices in the company that we can get some testing amongst our people, or get people in the community to help out
21:16:29 <mhall119> and we expect visual design changes to come, probably largely to be done on the theme itself, but might still require some work on the apps
21:16:50 <popey> there seem to be plenty of people around who are keen to test this stuff out assp
21:16:53 <popey> *asap
21:17:03 <mhall119> yeah, I want a file manager on my N7
21:17:10 <ajalkane> Yeah... so basically we shouldn't worry too much on the looks of apps right now, but on the functionality
21:17:17 <mhall119> ajalkane: yeah
21:17:17 <popey> exactly
21:18:53 <popey> anything else we need to discuss? any concerns or blockers?
21:19:06 <CarlosMazieri> No from my side
21:19:17 <ajalkane> I am personally pretty much done with what I can do currently on FileManager. Carlos is working on the backend so until its merged there's not much to do.
21:19:19 <mhall119> not from me
21:19:42 <mhall119> is everything being reviewed and merged into trunk on a regular basis?
21:20:17 <ajalkane> I've been pushing my stuff to trunk, but Carlos's branch is still separate - since it's the backend and we didn't have centralized place
21:20:24 <CarlosMazieri> No. I am working only on my branch
21:20:27 <mhall119> oh, I also wanted to stress than any changes to the Nemo code should be submitted upstream, we don't want to carry a code delta
21:20:41 <mhall119> ajalkane: are you getting your code reviewed?
21:20:54 <ajalkane> Jenkins gets my code reviewed. I get it approved :P
21:21:12 <mhall119> well, Jenkins only knows if it passes tests, not if it make sense
21:21:15 <ajalkane> Our team seems to be pitiful
21:21:21 <mhall119> it's best to get another member of the team to review it before it lands
21:21:21 <ajalkane> I mean it's basically me and Carlos
21:21:30 <mhall119> that's enough :)
21:21:39 <popey> you're doing better than some!
21:21:42 <ajalkane> If Carlos is willing to take the time to review my changes, that's great
21:22:14 <CarlosMazieri> I do not have time, I am sorry.
21:22:18 <mhall119> if you guys could set aside time to review eachother's code, it will benefit you in the long run
21:22:30 <mhall119> we can recruit more people to the team if necessary
21:23:01 <CarlosMazieri> I hope to finish copy/cut/paste this Weekend, so I will have more time
21:23:05 <mhall119> if it's not possible, that's understandable too, but as a best practice somebody should do a visual review of the diff
21:23:09 <ajalkane> I have relatively good amount of time during this spring (after that not so much), so I can review Carlos's code when it lands.
21:23:37 <CarlosMazieri> ajalkane: ok, Thanks.
21:24:28 <ajalkane> Don't thank me yet, I'm a strict reviewer :P
21:25:01 <CarlosMazieri> no problem, you are welcome
21:25:25 <mhall119> ok, down to 5 minutes
21:25:35 <mhall119> I don't have anything else, popey?
21:25:39 <popey> Ok, well give us a shout if you need anything, and if you do need additional developers, let us know and we can recruit..
21:25:45 <popey> no mhall119, nothing else
21:25:54 <ajalkane> What about unit testing QML code... I feel it's futile at the moment as I feel it can change quite a bit before release
21:26:13 <mhall119> I'm also available to do cursory reviews of the diff, if you guys need one and nobody's available to help
21:26:23 <popey> mhall119: shall I speak to balloons about unit tests on qml?
21:26:41 <mhall119> ajalkane: I think that's something the SDK team is planning for, but they need to build something to do it
21:27:07 <mhall119> popey: yeah, I know there's been talk about getting autopilot support for QML apps
21:27:23 <ajalkane> ok... in context of filemanager, most of functionality is C++ and QML is only visuals. Unlike some apps that have business logic in JavaScript (where unit testing makes sense early)
21:27:25 <popey> ok, I'll hook up with Nick then, will update you guys when I know more
21:27:45 <popey> #action popey speak to balloons about unit tests for file manager app
21:27:45 * meetingology popey speak to balloons about unit tests for file manager app
21:28:02 <mhall119> ajalkane: does the nemo plugin have unit tests?
21:28:19 <CarlosMazieri> my implementation has
21:28:23 <ajalkane> mhall119: no, but Carlos has implemented some if I understood correctly the above
21:28:41 <mhall119> ok, is that something that we can contribute upstream as well?
21:29:02 <ajalkane> I see no reason why we couldn't contribute them upstream
21:29:31 <mhall119> CarlosMazieri: is that something you can do?
21:29:46 <CarlosMazieri> upstream to nemo repo ?
21:29:55 <mhall119> to the project
21:30:17 <mhall119> send them a patch, pull request, whatever they like, to get your tests included in their repo
21:30:24 <CarlosMazieri> I do not know how to merge, if someone helps me it would be great
21:30:47 <CarlosMazieri> I will upstream into my local branch
21:31:03 <ajalkane> I can help somewhat. They live in #nemomobile and surely help also if asked.
21:31:20 <popey> ok, if you need further help from our side, then just give us a shout
21:31:21 <CarlosMazieri> OK, thanks, I will ask you.
21:31:23 <mhall119> ok, the nemo devs should be able to help you submit it to their main branch, I can help with communication if needed
21:31:25 <ajalkane> My changes have been so small that I've managed to do manual pull requests
21:31:48 <popey> lets wrap up..
21:31:52 <CarlosMazieri> I have heavy changes, I do not know if they will accept
21:32:16 <mhall119> thanks for your work on this guys, I'm really looking foward to having this running on my Nexus 7
21:32:22 <popey> I realise this team is small, but it's made some great progress.
21:32:26 <popey> yeah, me too ☺
21:32:38 <popey> thanks guys
21:32:40 <ajalkane> Thanks, until next week
21:32:40 <popey> #endmeeting