17:59:41 <popey> #startmeeting Ubuntu calculator app meeting
17:59:41 <meetingology> Meeting started Thu Mar 21 17:59:41 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:59:41 <meetingology> 
17:59:41 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:59:45 <popey> who's here?
17:59:57 <ravirdv> hi
18:00:07 <daliusd> hi
18:00:38 <popey> hey, so i had a couple of action items last time
18:00:46 <popey> http://ubottu.com/meetingology/logs/ubuntu-touch-meeting/2013/ubuntu-touch-meeting.2013-03-14-18.01.html
18:00:57 <popey> "ACTION: popey speak to SDK team about OSX support"
18:01:04 <popey> Short answer, "not yet".
18:01:21 <popey> if someone else wants to have a go at porting things over to OSX, they are welcome to try
18:01:33 <ravirdv> alright, that means I'll have to start using VM
18:01:40 <popey> but nobody on the SDK team has a mac, and motivation is currently high to get it perfect on Ubuntu first
18:01:49 <daliusd> People have ported SDK to win and bb10 to some degree
18:01:50 <ravirdv> I did try and will still work on it... some packages are missing while compiling
18:01:59 <popey> ravirdv: I'd be interested to know which VM you use, VMWare, parallels etc?
18:02:08 <rferrazz> here i am
18:02:11 <popey> hi rferrazz
18:02:13 <popey> we just started
18:02:18 * mhall119 is here
18:02:20 <popey> the other action I had was..
18:02:24 * popey popey speak to SDK about location aware apps
18:02:25 <rferrazz> phew
18:02:26 <daliusd> I would recommend VmWare against VirtualBox
18:02:29 <daliusd> hi
18:02:49 <ravirdv> I use vbox
18:02:54 <daliusd> Ubuntu under VirtualBox works very slow but reasonably on VMWare
18:03:08 <ravirdv> that's a reason I'm looking for OSX sdk
18:03:11 <popey> spoke to SDK team, and they pointed me at qtlocation, but the whole location awareness process is a bit unfinished at the moment
18:03:31 <popey> so location based stuff will likely have to wait for "version 2"
18:03:36 <daliusd> well we can put location for post alpha
18:03:40 <popey> yup
18:03:49 <popey> I have ubuntu running pretty quick in vbox here
18:03:51 <daliusd> It looks like we agree here :)
18:04:02 <daliusd> popey, with Unity?
18:04:07 <popey> the only snag is that the 3d passthrough works fine for the desktop, and yes, unity
18:04:10 <mhall119> why do we need location for calculator anywya?
18:04:11 <popey> but doesnt work for qmlscene
18:04:22 <popey> mhall119: design asked for it as a nice to have
18:04:34 <popey> for when you're in a restaurant and tot up the bill
18:04:41 <mhall119> popey: for what feature?
18:04:43 <popey> it can tag where you were.. you could potentially share that later
18:04:49 <mhall119> oh, ok
18:04:58 <mhall119> yeah, definitely something to push back to version 2
18:05:01 <popey> yup
18:05:06 <popey> good, glad we agree on that :D
18:05:16 <popey> ok.
18:05:31 <popey> So you probably all noticed I filed a bunch of bugs in the calculator app this past week
18:05:44 <rferrazz> noticed, a long list :-)
18:05:46 <popey> that was after the meeting with design last friday, many of them came from design.
18:05:50 <popey> keeping you busy :D
18:05:56 <daliusd> :)
18:06:14 <rferrazz> sure!
18:06:18 <popey> Any blockers / questions / issues?
18:06:31 <daliusd> about tear-off
18:06:31 <mhall119> daliusd: I did some work on the drag-to-tear-off design
18:06:32 <rferrazz> i'm playing around with the result bug
18:06:33 <mhall119> did you see it?
18:06:38 <daliusd> I did see it
18:06:46 <daliusd> I have even wrote something to you I believe
18:06:50 <daliusd> Anyway thanks
18:06:55 <daliusd> saves some time
18:07:02 <daliusd> I have implemented it differently finally
18:07:04 <rferrazz> so 3+= will result 3 right?
18:07:07 <mhall119> ok
18:07:27 <daliusd> Here is diff: https://code.launchpad.net/~dalius-sandbox/ubuntu-calculator-app/tear-off-formula/+merge/154774
18:08:17 <popey> Good progress on tear-off
18:08:24 <popey> The "equals bug" is a tricky one
18:08:32 <popey> because the behaviour is somewhat complex
18:09:21 <popey> I'd like to get some input from design on exactly how they want it to be, because the "roll of paper" style of calculator might not lend itself too well to the way they asked for = to work
18:09:21 <rferrazz> i ended up removing the last operand if there was a syntax error and it seems fine
18:09:31 <rferrazz> not yet committed
18:09:38 <popey> there is an expectation that:-
18:09:54 <popey> 1+2+3=6,   then if you press = again you get 9, then 12, then 15
18:10:01 <popey> without any other buttons pressed,
18:10:10 <mhall119> daliusd: does yours work even when dragging around the middle?
18:10:13 <popey> so 1+2+3====  would produce 15
18:10:28 <popey> how that would move up the display I'm not sure
18:10:37 <daliusd> what it means to drag around the middle ?
18:11:15 <mhall119> daliusd: if you scroll half-way up, then stop, and then start another movement event
18:12:00 <daliusd> mhall119: if I understand correctly tear-off will not work if you have scrolled somewhere up
18:12:10 <mhall119> when I was working on it, I had that problem, where it would drag up, but not to the point where it was over-scrolling, but would still trigger the tear off
18:12:19 <mhall119> daliusd: and your code works like that?
18:13:27 <daliusd> mhall119: I will test more but I believe there is no such problem
18:13:40 <mhall119> ok
18:13:55 <daliusd> I can only make one improvement
18:13:57 <daliusd> add text
18:13:58 <mhall119> yours looks much simpler, I'll have to see if I can use it in my reddit app :)
18:14:22 <daliusd> "pull to refresh" and "release to refresh" but then I need to implement "release to refresh" as it is not implemented
18:14:29 <daliusd> it is enough to pull over specific point
18:14:38 <rferrazz> popey, i can make it work like you say but pressing === just changes the current result or adds more lines to the screen?
18:14:55 <popey> rferrazz: that's what I'm not sure about
18:15:19 <daliusd> mhall119: I'm pretty sure it is completely reusable. If you have any questions about it - ask. I will explain the code :)
18:15:26 <popey> so I'll try and get an answer from design. will write it up before hand and let them have time to think about it
18:15:37 <mhall119> thanks daliusd
18:15:56 <rferrazz> popey, if it just changes the result it ends up being not clear when you see it in the history plot
18:16:18 <popey> indeed
18:16:30 <popey> I think it would need to go.. bear with me...
18:17:00 <rferrazz> hi, tell me when you have a response from design team!
18:18:02 <popey> 1
18:18:02 <popey> +2
18:18:03 <popey> +3
18:18:03 <popey> =6
18:18:03 <popey> =9
18:18:05 <popey> =12
18:18:09 <popey> ----
18:18:10 <popey> like that
18:18:36 <daliusd> I just learned that I rejected merge proposal from someone working in Canonical :)
18:18:42 <popey> \o/
18:18:47 <popey> daliusd: that's a rite of passage
18:18:51 <popey> you earn points for that
18:18:58 <mhall119> +1
18:19:30 <popey> rferrazz: so I'll let you know when I get an answer from design
18:19:40 <popey> #action popey contact design about the "equals" bug
18:19:40 * meetingology popey contact design about the "equals" bug
18:19:48 <rferrazz> popey, thanks
18:20:19 <popey> Any other issues / blockages?
18:20:35 <rferrazz> not now
18:20:46 <daliusd> not yet
18:21:22 <daliusd> tear-off was block but somehow figured out how to handle it
18:21:59 <popey> awesome.
18:22:01 <mhall119> did we have a work item for the tear-off?
18:22:14 <popey> no, i filed a bug for it
18:22:18 <mhall119> ok
18:22:28 <mhall119> I see only 2 work items still in progress
18:22:37 <mhall119> is that all we have left of the initial feature development?
18:22:52 <popey> there's a bunch more bugs..
18:23:02 <popey> https://bugs.launchpad.net/ubuntu-calculator-app
18:23:21 <daliusd> mhall119: one item is invalid most probably as we won't have backspace
18:23:40 <daliusd> we just need to fix "C" to clean last entry not the whole equation
18:23:42 <daliusd> (we have bug for that)
18:23:53 <mhall119> so I would like to get this app into the default touch images, but we need a list of "features that must be working first" to check off
18:24:00 <daliusd> other item in blueprint is about "equals" bug
18:24:17 <popey> we also need to have the app reviewed formally by the design team
18:24:19 <mhall119> can we add work items for anything that needs to be implemented before we propose this for inclusion in the daily touch images?
18:24:27 <daliusd> popey: +1
18:24:35 <mhall119> popey: are they not doing that as we develop features?
18:24:55 <popey> yes, but there is a final review
18:25:06 <mhall119> ok
18:25:26 <mhall119> so we need a feature list, and when all of those are done we get final review from design, then we can include it by default?
18:25:32 <popey> which, at the rate these guys are going, could be fairly soon
18:25:40 <mhall119> yeah, that's my thinking
18:26:26 <popey> shall I take the action to build the feature list and agree it with design?
18:26:33 <popey> (and devs) :D
18:26:38 <mhall119> please
18:26:45 <mhall119> might also get pat to review it
18:26:54 <mhall119> make sure it has all the features he would want
18:26:58 <popey> #action popey draw up feature list for calculator app and get sign off from mgmt, dev and design
18:26:58 * meetingology popey draw up feature list for calculator app and get sign off from mgmt, dev and design
18:27:35 <popey> ok, anything else?
18:27:52 <mhall119> not from me
18:27:58 <rferrazz> me neither
18:28:06 <mhall119> I'm thoroughly impressed with you guys, you've done so much in such a short amount of time
18:28:11 <popey> +1
18:28:17 <rferrazz> :)
18:28:22 <daliusd> :)
18:28:22 <rferrazz> thanks!
18:28:33 * popey secretly ponders which app we can get them making next ㋛
18:28:45 <mhall119> scientific calculator :P
18:28:49 <popey> hah!
18:28:49 <rferrazz> rocket louncher app?
18:28:57 <rferrazz> launcher
18:28:57 <popey> Angry Penguins ☺
18:29:02 <mhall119> oh, I like that idea
18:29:12 <rferrazz> +1
18:29:21 <mhall119> I wonder if box2d works on the touch image
18:29:28 <popey> hah, he's off...
18:29:35 <popey> ok, thanks everyone!
18:29:37 <popey> #endmeeting