21:02:50 <popey> #startmeeting Ubuntu Touch File App Meeting
21:02:50 <meetingology> Meeting started Thu Mar  7 21:02:50 2013 UTC.  The chair is popey. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:02:50 <meetingology> 
21:02:50 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:02:55 <popey> #introductions
21:03:04 <popey> 20:01:47 < popey> I'm Alan Pope, I'm an Engineering Manager at Canonical, and have been asked to act as a Developer Liaison for all the touch apps..
21:03:07 <popey> 20:03:17 < mhall119> like popey said, I'm from Canonical, specifically I'm on the Community Team, which means it's my job to work with you and help you
21:03:10 <popey> :D
21:03:17 <Jaffa> :)
21:03:26 <popey> Jaffa: CarlosMazieri__ ajalkane would you like to introduce yourself..
21:03:51 <Jaffa> In my day-job, I'm a senior architect at a London-based consultancy, mostly focused on Java stack and Java EE. Been a mobile fanatic since the Psion days and started following Nokia as a user and developer on the Nokia 770. With the move to Qt, I followed and have been doing Qt dev for MeeGo, Symbian, Harmattan, BlackBerry 10 - and now Ubuntu Phone.
21:04:57 <ajalkane> Introduced in the last irc meeting, but short summary in relevant stuff is that I've been doing Qt/QML stuff on N9 from 2011 summer.
21:05:37 <popey> heh
21:05:43 <CarlosMazieri__> I am an old developer working with software for more than 20 years.
21:05:43 <CarlosMazieri__> I work every day with Qt for Linux Desktop.
21:05:43 <CarlosMazieri__> I worked with Sony Ericsson phones OSE, Symbian and Android.
21:05:43 <CarlosMazieri__> I am based in Brazil.
21:05:57 <popey> awesome! thanks!
21:06:03 <popey> #topic work items
21:06:31 <popey> so I copied the work items from https://blueprints.launchpad.net/ubuntu-filemanager-app/+spec/initial-filemanager-development to http://pad.ubuntu.com/W0fql2iriw
21:06:39 <popey> so we can easily edit them together now..
21:06:46 <popey> The goal being to get some of them assigned.
21:07:16 <ajalkane> Either you have not been granted access to this resource or your entitlement has timed out. Please try again.
21:07:19 <popey> if you are unable to get into the http://pad.ubuntu.com/W0fql2iriw link, you may need to join this team on launchpad http://launchpad.net/~ubuntu-etherpad (which we use to avoid spam/bot abuse)
21:07:25 <ajalkane> I couldn't get in, in other words
21:07:31 <Jaffa> Ah, OK
21:07:46 <popey> sorry about that, it got abused so we had to make it a bit harder to use
21:07:49 <AlanBell> ajalkane: please to be joining the group http://launchpad.net/~ubuntu-etherpad
21:08:16 <AlanBell> try now
21:08:23 <Jaffa> Yay, works
21:08:31 <ajalkane> Thanks, works now
21:09:04 <popey> So in my mind the initial functionality needs to be able to read the contents of folders, display them and allow the user to navigate around
21:09:23 <ajalkane> I agree
21:09:33 <Jaffa> Yup
21:09:36 <popey> being able to open files via the document viewer - or just xdg-open is a bonus, modifying or deleting files is an even bigger bonus
21:09:50 <popey> so we need to allocate the work items to reflect that target
21:09:50 <AlanBell> CarlosMazieri__: you are in too now
21:09:57 <popey> thanks AlanBell
21:10:16 <ajalkane> We have the basics for those items... but it needs polishing
21:10:57 <ajalkane> They're in the trunk, which I'm sorry about, I meant to push them to my own branch
21:11:28 <ajalkane> But I'm again pushing for resolution on the licensing issue as it's pretty critical on our future progress
21:11:53 <popey> licensing issue?
21:12:11 <ajalkane> The prototype we have there now uses Nemo Mobile's QML FolderList plugin
21:12:19 <Jaffa> popey: Specifically, can we use (and improve and contribute to) Nemomobile's existing plugin
21:12:43 <ajalkane> It is under BSD license
21:13:14 <popey> mhall119: are you aware of this? have any discussions taken place I've not seen?
21:13:21 <mhall119> popey: no
21:13:35 <mhall119> is the code part of your branch, or in a separate package?
21:13:51 <popey> #action popey find out whether we can use & improve & contribute to Nemomobile existing qml folderlist plugin
21:13:51 * meetingology popey find out whether we can use & improve & contribute to Nemomobile existing qml folderlist plugin
21:13:56 <popey> I'll deal with that issue
21:14:05 <ajalkane> bzr branch lp:~ajalkane/ubuntu-filemanager-app/qml-folderlistmodel
21:14:08 <popey> I'll get back to you via email about it
21:14:21 <Jaffa> popey: On the ML?
21:14:28 <popey> yup
21:14:32 <Jaffa> Cool
21:15:04 <CarlosMazieri__> I thinking about starting  a new prototype with other Model from scratch, what do guys think about?
21:15:27 <ajalkane> I dislike duplication of work without good rationale.
21:15:39 <popey> I wouldn't want you to re-code stuff if we don't need to..
21:15:40 <ajalkane> But if there's good reasons, of course
21:16:08 <mhall119> at the very least I think we'd need the nemo plugin in a separate package in Ubuntu
21:16:24 <Jaffa> CarlosMazieri__: Ubuntu's often accused of NIH syndrome, it'd be good if we didn't contribute to that _and_ collaborated with the similar OSS mobile Linux platforms at the same time
21:16:35 <popey> hah!
21:16:39 <popey> wise
21:17:36 <popey> so the question really is who is going to grab the outstanding work items, and are there any additional ones we've not thought of yet?
21:17:57 <ajalkane> Icons
21:18:07 <ajalkane> I saw there's some bug reports about how to use common icons
21:18:14 <ajalkane> But that's obviously something that we need in file manager
21:18:17 <Jaffa> The work items there are just ones I came up with OTTOMH; not sure they necessarily align ith where we've got to
21:18:23 <popey> yeah, we had a question about that in one of the other app meetings
21:18:43 <popey> Jaffa: we should fix that ☺
21:19:30 <Jaffa> popey: If we want the work item list to be useful, yeah :-)
21:20:52 <mhall119> ok, everbody pick the one you want most
21:20:52 <Jaffa> I guess ajalkane's got the best overview of where we've got to so far (been a hectic week for me)
21:21:28 <ajalkane> One thing that immediately comes to mind is current FilePath. Probably C++ module. Right now the navigation is stupid to the bone, with back being adding in JS ".." to the path
21:21:34 <mhall119> ajalkane: IIRC, we already have a work item to find out about common icons from another app
21:21:42 <mhall119> so for now just include some temporary ones to use
21:22:04 <ajalkane> Yeah that's what we have... temporary for folder. But nothing else.
21:22:17 <mhall119> you can just use the ones from the desktop icon theme for now
21:22:26 <mhall119> until we get something better
21:22:50 <mhall119> is that what the "Get icon" work item was for?
21:23:39 <mhall119> let me re-phrase, what are the bare minimum work items to get to where we can browse the file system?
21:23:53 <mhall119> navigation UI
21:23:56 <ajalkane> Icons, proper file path handling
21:24:08 <ajalkane> Otherwise it's there
21:24:25 <mhall119> ajalkane: can you expand on what "proper file path handling" entails?
21:24:25 <ajalkane> Crudely, but there anyway
21:25:09 <mhall119> ajalkane: by "there" are you talking about the stuff from Nemo?
21:25:16 <ajalkane> For example, when you press "go back" button it will provide to the pluging a proper path. Now it's just stupid JS which appends ".." to the path. So in time browsing up and down your path strings grows unlimitedly
21:25:27 <ajalkane> Both nemo and our prototype that uses nemo
21:25:38 <ajalkane> I mean our QML interface + nemo plugin
21:25:47 <mhall119> ok
21:26:21 <mhall119> so we need navigation UI, who wants to do that?
21:26:54 <ajalkane> We have a crude navigation UI
21:27:01 <mhall119> who's working on it?
21:27:11 <mhall119> I'll mark it as in progress
21:27:43 <CarlosMazieri__> I prefer doing directory operations like: recursive delete/ move in C++
21:27:55 <ajalkane> I think polishing of the UI should be left for later because the SDK is still changing and the final designs seem to be fluctuating
21:28:12 <ajalkane> CarlosMazieri__: I agree. And in its own thread.
21:28:16 <mhall119> CarlosMazieri__: anything in C++ should be done in a separate branch and build a QML plugin
21:28:22 <mhall119> can you manage that?
21:28:43 <Jaffa> ajalkane: Trying to build your plugin - when I open the project I'm asked to configure it as "no valid kit found"
21:28:48 <ajalkane> Well we have a separate branch for the nemo plugin. If that can be used, that's logical place for it. If not, we have to start from scratch
21:28:52 <CarlosMazieri__> Yes, but I need some help with bazar, I have not tried yet
21:29:13 <mhall119> ajalkane: agreed, if we can re-use the Nemo plugin, it would make sense ot contribute recursive delete/move back to that
21:29:17 <ajalkane> Jaffa: humm... have you tried in command-line?
21:29:37 <ajalkane> qmake && make
21:29:39 <mhall119> CarlosMazieri__: so which of those operation work items can you do?
21:30:00 <CarlosMazieri__> no, if someone creates the repository I can get it down and them start coding
21:30:44 <mhall119> CarlosMazieri__: look at adding it to the Nemo plugin for now
21:30:56 <CarlosMazieri__> YES, that is the idea
21:31:15 <mhall119> if we get the ok to use it, we'll open a dialog with those developers to make sure we're collaborating effectively
21:31:26 <mhall119> ok, so we're out of time, and I need to assign some work items
21:31:36 <ajalkane> Right now the nemo plugin port to qt5 is in my own branch... I'm unsure how bzr works and how it could be pushed to some common repo
21:31:56 <mhall119> ajalkane: ping me later and I'll help
21:32:06 <mhall119> ok, Navigation UI, who's on that?
21:32:45 <mhall119> I won't hesitate to assign randomly :)
21:33:14 <Jakub> Hello all, is there anyone here from Weather App team?
21:33:17 <ajalkane> I can do the file path C++ backend to enable sane navigation
21:33:20 <mhall119> CarlosMazieri__: can I put you down for the directory operations?
21:33:25 <m-b-o> hi jakub!
21:33:43 <CarlosMazieri__> YES
21:33:46 <mhall119> Jakub: we're running a few minutes late on the file manager app, will start on weather momentarily
21:33:50 <mhall119> thanks CarlosMazieri__
21:34:26 <mhall119> ajalkane: can you take navigation and entry info then?
21:35:00 <CarlosMazieri__> I need to leave
21:35:01 * Jaffa can get ajalkane's work up & running and verify next steps (don't feel confident about stating what they are without having seen where we are ;-))
21:35:08 <CarlosMazieri__> Thank you All
21:35:11 <mhall119> and are any of the other "Old Work Items" necessary for an alpha?
21:35:57 <ajalkane> mhall119: What is entry info?
21:35:58 <popey> m-b-o: Jakub in preparation for the weather app meeting can you please visit http://pad.ubuntu.com/h7daOF9RCq and if you get access denied error, visit https://launchpad.net/~ubuntu-etherpad and "join" the team..
21:36:16 <mhall119> ajalkane: file info, properties, permissions, etc
21:36:25 <mhall119> #endmeeting
21:36:32 <mhall119> popey: I think you have to do that still
21:36:34 <popey> #endmeeting