18:37:38 <mhall119> #startmeeting Twitter app
18:37:38 <meetingology> Meeting started Wed Feb 20 18:37:38 2013 UTC.  The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:37:38 <meetingology> 
18:37:38 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:37:54 <jaakko_kui> I have read them once
18:37:58 <mhall119> #topic progress review
18:38:00 <KevinWright> mhall119: thanks
18:38:32 <mhall119> #link https://wiki.ubuntu.com/Touch/CoreApps/Twitter
18:38:40 <KevinWright> jaakko_kui, fmunozs: If there are any questions about any of the info please don't hesitate to ask myself or mhall119
18:38:41 <mhall119> #link https://blueprints.launchpad.net/ubuntu-twitter-app/+spec/initial-twitter-development
18:38:56 <KevinWright> jaakko_kui, fmunozs: mhall119 is pasting some of the links now
18:39:03 <fmunozs> thanks
18:39:07 <jaakko_kui> ok
18:39:11 <mhall119> those are links wo the wiki spec page and the blueprint
18:39:21 <mhall119> the work items for the initial development are listed at the bottom of the Blueprint
18:39:29 <KevinWright> jaakko_kui, fmunozs: Are there any questions you had on your mind we can help answer?
18:39:52 <KevinWright> jaakko_kui, fmunozs: We can discuss the project specifics in a moment
18:40:29 <mhall119> has everybody been able to install the SDK and grab a copy of the app's branch?
18:40:37 <mhall119> and get that running
18:40:54 <fmunozs> yes, Qt5 and SDK running on Ubuntu 12.10
18:41:14 <jaakko_kui> i have sdk, but not apps branch yet
18:41:16 <mhall119> and did you bzr branch lp:ubuntu-twitter-app?
18:41:24 <mhall119> jaakko_kui: ^^ do that
18:41:29 <jaakko_kui> ok
18:41:35 <KevinWright> mhall119: Maybe you can answer a question for me actually
18:41:46 <mhall119> then you can either run it from QtCreator, or just run "qmlscene twitter.qml" from inside the directory
18:42:42 <jaakko_kui> ok
18:42:44 <mhall119> KevinWright: sure?
18:42:59 <KevinWright> mhall119: Did someone already do some work towards a Twitter client?
18:43:16 <KevinWright> mhall119: I thought someone mentioned it to me before.
18:43:30 <mhall119> there was a twitter app written in Qt4, gatox and mandel wrote it before the SDK was released
18:43:44 <mhall119> I think they're on the team for this version too
18:43:59 <KevinWright> mhall119: OK so it may or may not be useful for us here
18:44:06 <mhall119> I'm sure some of it will be useful
18:44:12 <KevinWright> mhall119: OK cool
18:44:13 <mhall119> how much, I can't say
18:44:24 <KevinWright> mhall119: OK, we can check on it later
18:44:31 <KevinWright> mhall119: Thanks
18:44:32 <mhall119> any other progress updates?
18:44:55 <KevinWright> jaakko_kui, fmunozs: Did you have a chance to look at the work items that were proposed?
18:45:06 <mhall119> #topic Work Items
18:45:20 <KevinWright> mhall119: thanks again
18:45:23 <mhall119> :)
18:45:24 <jaakko_kui> yes
18:45:45 <mhall119> there are 13 work items currently on https://blueprints.launchpad.net/ubuntu-twitter-app/+spec/initial-twitter-development
18:45:49 <KevinWright> fmunozs: Did you have a chance to see them?
18:45:59 <fmunozs> KevinWright, you mean the functional requirements?
18:46:04 <mhall119> we need to get those assigned to members of the team
18:46:25 <fmunozs> I see them now
18:46:34 <KevinWright> fmunozs:  mhall119 pasted a link to the work items, but they are from the functional requirements
18:46:52 <KevinWright> jaakko_kui, fmunozs: Take a look and volunteer yourself for something that sounds interesting to you
18:47:06 <jaakko_kui> I can do test related tasks
18:47:18 <KevinWright> jaakko_kui, fmunozs: at the start of the line in the blueprint put your Launchpad ID in [] brackets
18:47:38 <KevinWright> jaakko_kui: Cool. Testing is very important
18:48:02 <KevinWright> So the format will be [you-lp-id] This is a work item: TODO
18:48:08 <jaakko_kui> ok
18:48:22 <fmunozs> yea, just noticed pretty much the same, I don't see anything about sharing stuff from other applications, I saw in the tablet announcement there will be a sharing framework, right? somebody else will take care of that?
18:48:23 <KevinWright> fmunozs: Anything there look interesting?
18:48:24 <mhall119> #action jaakko_kui to self-assign work items
18:48:24 * meetingology jaakko_kui to self-assign work items
18:48:31 <mhall119> #action fmunozs to self-assign work items
18:48:31 * meetingology fmunozs to self-assign work items
18:48:43 <mhall119> who can email the rest of the team and ask them to each take 2 work items?
18:49:06 <KevinWright> mhall119: I can do that. I already sent one or two about this topic.
18:49:30 <mhall119> #action KevinWright Email the ubuntu-twitter-dev team, ask each member to assign themselves to 2 work items
18:49:30 * meetingology KevinWright Email the ubuntu-twitter-dev team, ask each member to assign themselves to 2 work items
18:49:33 <KevinWright> jaakko_kui, fmunozs: Also don't be shy about suggesting new work items
18:49:44 <jaakko_kui> ok
18:49:51 <KevinWright> jaakko_kui, fmunozs: Or modifying the wording, expanding details etc.
18:49:52 <mhall119> yeah, these aren't set in stone, we can add/remove and reassign as needed
18:50:00 <mhall119> they are just there to keep things on track
18:50:19 <KevinWright> jaakko_kui, fmunozs: Some of what I put in there was done quite quickly and might not read like a proper work item
18:50:25 <fmunozs> ok I will see the items and select one today
18:50:39 <KevinWright> jaakko_kui, fmunozs: I'll fix them up, but we need some additional detail in many cases
18:50:48 <jaakko_kui> any guide etc for the test documents ?
18:50:49 <KevinWright> fmunozs: great!
18:51:06 <KevinWright> jaakko_kui: Let me send an email about testing
18:51:12 <mhall119> # Testing
18:51:16 <jaakko_kui> great
18:51:17 <KevinWright> jaakko_kui, fmunozs: Testing is an important topic that everyone should know about
18:51:17 <mhall119> #topic Testing
18:51:43 <mhall119> #action KevinWright send email to ubuntu-twitter-dev providing information on testing
18:51:43 * meetingology KevinWright send email to ubuntu-twitter-dev providing information on testing
18:51:45 <KevinWright> One more time for the meeting bot :) Testing is an important topic that everyone should know about
18:52:10 <KevinWright> jaakko_kui, fmunozs: I would like to send something to all the app devs on all teams about this
18:52:23 <jaakko_kui> ok
18:52:28 <KevinWright> jaakko_kui, fmunozs: OK we have just a few minutes left
18:52:44 <KevinWright> jaakko_kui, fmunozs: Any final questions for today?
18:53:07 <jaakko_kui> nope :)
18:53:10 <mhall119> #topic other Q&A
18:53:10 <fmunozs> no, I'm ok
18:53:15 <KevinWright> jaakko_kui, fmunozs: I'm available any time by email of course, or IRC (this week I am not on very often, but next week back on a regular schedule)
18:53:20 <KevinWright> jaakko_kui, fmunozs: Alright great!
18:53:27 <KevinWright> jaakko_kui, fmunozs: Thanks for joining today
18:53:34 <jaakko_kui> ok bye!
18:53:37 <KevinWright> jaakko_kui, fmunozs: I'm looking forward to working with you both!
18:53:40 <KevinWright> jaakko_kui, fmunozs: Cheers!
18:53:41 <mhall119> I'm also available if you guys have any questions about using bzr or Launchpad
18:53:54 <KevinWright> jaakko_kui, fmunozs: Yes mhall119 is also there for you
18:54:01 <jaakko_kui> good!
18:54:17 <fmunozs> Thanks
18:54:24 <KevinWright> (sorry mhall119, forgot to add that in!)
18:54:37 <KevinWright> jaakko_kui, fmunozs: Bye all!
18:54:48 <jaakko_kui> bye
18:54:52 <KevinWright> Thanks mhall119 for the meeting help
18:54:59 <mhall119> alright, thanks everyone
18:55:07 <mhall119> #endmeeting