19:16:15 <mhall119> #startmeeting
19:16:15 <meetingology> Meeting started Tue Feb 19 19:16:15 2013 UTC.  The chair is mhall119. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:16:15 <meetingology> 
19:16:15 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:16:36 <mhall119> #topic RSS Reader updates
19:17:21 <mhall119> QtRoS: can you give an update about what was discussed in the last meeting?
19:18:37 <mhall119> #meetingtopic RSS Reader development
19:19:28 <mhall119> QtRoS: were you there for the last meeting?
19:19:34 <QtRoS> mhall119: subject of first meeting were general development plan, targets, teamwork and so on.
19:19:53 <mhall119> ok, were there any work items discussed then?
19:21:01 <QtRoS> mhall119: sorry for slow answers, sometimes I need to correct my English speech with translator
19:21:05 <QtRoS> No
19:21:21 <mhall119> ok, no worries
19:21:44 <mhall119> ok, so the wiki spec for the RSS Reader is here:
19:21:45 <mhall119> https://wiki.ubuntu.com/Touch/CoreApps/RSSReader
19:22:15 <mhall119> there is also a blueprint for the initial development of this app, where we are listing work items:
19:22:18 <mhall119> https://blueprints.launchpad.net/ubuntu-rssreader-app/+spec/initial-rssreader-development
19:23:03 <mhall119> we have 13 work items and 6 members of the development team
19:23:15 <mhall119> so we need to give everybody a couple of things to work on
19:24:21 <QtRoS> In mailing list I already talked about my question - shall we use C++ or not?
19:24:29 <mhall119> QtRoS: you should be able to edit that blueprint's work items (little yellow edit icon on the right side of the "Work Items" header)
19:24:45 <mhall119> QtRoS: the goal is to do as much as possible in QML+Javascript
19:25:18 <mhall119> it makes it more accessible to new developers, and highlights what we consider the strong parts of our developer offering
19:25:39 <mhall119> if, however, there is something that we can't do in QML, we can write it in C++ and expose it to QML by making a plugin
19:25:44 <QtRoS> Yes, sure, I can do any of this items, but we need to decide with team, how we will realize some of them
19:25:55 <mhall119> in those cases, the plugin code should be in a separate bzr branch, and be as re-usable as possible
19:27:02 <mhall119> #topic work items and implementation
19:27:12 <mhall119> should have done that several minutes ago
19:27:24 <mhall119> QtRoS: does that answer your question about C++ vs. QML/
19:27:26 <mhall119> ?
19:27:27 <QtRoS> Yes, plugin is right way, because we can't view list of all news from few sources via QML, XmlListModel able to load only one
19:28:12 <QtRoS> Yes, I think we need to create that branch for C++ part
19:28:20 <QtRoS> as fast as possible
19:28:32 <mhall119> QtRoS: you and anybody else on the team should be able to edit these work items
19:28:44 <mhall119> so the goal for this week is to get them all assigned to somebody
19:28:51 <QtRoS> I can edit work items, I think)
19:29:14 <QtRoS> W8, I'll check them again and pick something
19:29:14 <mhall119> this doesn't mean the assigned person is going to have to implement them, just that they'll need to investigate and either implement it, change the work item, or hand it off to somebody else
19:29:57 <mhall119> it sounds like the work items themselves will need to be changed some too, since some work will be done in the plugin and some will be done in QML
19:30:23 <QtRoS> Yes, you are right
19:30:28 <mhall119> QtRoS: can I give you an action item to email the team and ask everybody to assign themselves to 2 or 3 of the current work items?
19:30:38 <mhall119> I'd like to have them all assigned to somebody
19:30:53 <mhall119> since you showed up for the meeting, you get first pick :)
19:31:12 <QtRoS> Okay, I can use mailing list for this purpose...
19:31:16 <mhall119> yes
19:31:17 <QtRoS> Oh, ok =)
19:31:36 <mhall119> #action QtRoS to email dev team asking everybody to self-assign work items
19:31:36 * meetingology QtRoS to email dev team asking everybody to self-assign work items
19:31:44 <mhall119> thanks QtRoS
19:32:26 <mhall119> QtRoS: was there anything the team was waiting on Kevin to provide?
19:32:50 <QtRoS> Nope, we can start now, I think :)
19:33:03 <mhall119> excellent, can you include that encouragement in your email to the team?
19:33:54 <mhall119> in the next meeting we can go over changes to the work items that the team makes
19:34:19 <QtRoS> Repeat please, how I can peek one? Just replace TODO with my id?
19:34:36 <mhall119> put your launchpad username in square brackets at the start of the line
19:34:42 <mhall119> so for me it would look like this:
19:34:48 <mhall119> [mhall119] Do this work item: TODO
19:35:08 <mhall119> make sense?
19:35:10 <QtRoS> Ok, I'll try to lead our team first time :)
19:35:25 <mhall119> QtRoS: feel free to ping me or email me if you need help
19:36:08 <QtRoS> Check list, I picked two :)
19:36:11 <mhall119> I'll follow up with Kevin when he's online again about what happened in this meeting
19:36:14 <mhall119> QtRoS: \o/
19:36:31 <mhall119> #action mhall119 to update Kevin about this meeting
19:36:31 * meetingology mhall119 to update Kevin about this meeting
19:36:50 <QtRoS> And no need for C++ part to realize them, so I can work independently at the beginning
19:37:05 <mhall119> fantastic, is there anything else that you can think of that we need to discuss?
19:38:22 <QtRoS> Nope, I will write to another guys now in mailing list!
19:38:56 <mhall119> alright, thanks for attending this meeting QtRoS
19:39:05 <mhall119> do you know if Kevin has a schedule already for the next meeting time?
19:41:10 <QtRoS> No, in last message from Kevin he wrote "Chat with you soon" only)
19:41:35 <mhall119> ok, I'll leave it to him to schedule the next one then
19:41:39 <QtRoS> And sorry for my mistakes in English, read is much easier for me rather than write
19:41:43 <QtRoS> Ok!
19:41:43 <mhall119> thanks again QtRoS
19:41:46 <QtRoS> It's good!
19:41:49 <mhall119> #endmeeting