16:00 <rbasak> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Aug 29 16:00:31 2017 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <rbasak> #topic Review ACTION points from previous meeting
16:00 <rbasak> * nacc to write a release notes entry on ipv6 netboot (carried over)
16:00 <rbasak> * nacc to write a server guide entry on ipv6 netboot (carried over)
16:00 <rbasak> * rbasak to add maintainership info to mysql triage page (carried over)
16:00 <rbasak> I still need to carry over mine
16:01 <rbasak> nacc?
16:01 <cpaelzer> well we are short of next release notes now
16:01 <nacc> rbasak: carry :/
16:01 <nacc> i'll try and actually do it this week
16:01 <cpaelzer> "close to" I meant
16:01 <rbasak> #action nacc to write a release notes entry on ipv6 netboot (carried over)
16:01 * meetingology nacc to write a release notes entry on ipv6 netboot (carried over)
16:01 <rbasak> #action nacc to write a server guide entry on ipv6 netboot (carried over)
16:01 * meetingology nacc to write a server guide entry on ipv6 netboot (carried over)
16:01 <rbasak> #action rbasak to add maintainership info to mysql triage page (carried over)
16:01 * meetingology rbasak to add maintainership info to mysql triage page (carried over)
16:01 <rbasak> #topic Artful Development
16:01 <rbasak> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:01 <rbasak> #subtopic Current Work
16:01 <rbasak> #link https://trello.com/b/U9HhWyT0/daily-ubuntu-server
16:02 <rbasak> #info Feature freeze has hit, so bugfixes only now
16:02 <rbasak> Any planned FFEs?
16:02 <rbasak> I see ahasenack's squid3 merge has landed - thanks!
16:02 <cpaelzer> yeah
16:02 <cpaelzer> I plan FFE on slof
16:02 <ahasenack> just in time :)
16:02 <rbasak> #info cpaelzer plans an FFe for slof
16:03 <rbasak> Anything else for current work for Artful?
16:03 <cpaelzer> reasoning for the slof FFE (among others) is bug 1706248
16:03 <ubottu> bug 1706248 in slof (Ubuntu) "SLOF dhcp request doesn't include client architecture code 93" [Medium,Confirmed] https://launchpad.net/bugs/1706248
16:03 <rbasak> Thanks cpaelzer!
16:03 <rbasak> #subtopic Release Bugs
16:03 <rbasak> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:04 <rbasak> Any bugs for release that need attention?
16:04 <rbasak> #info No bugs were called out for specific attention
16:04 <rbasak> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd, ddstreet)
16:04 <chiluk> I plan an ffe on haproxy.
16:04 <rbasak> slashd sent his apologies. I'm not sure if ddstreet is taking this topic, or we should skip it?
16:04 <rbasak> #info chiluk plans an FFe for haproxy
16:04 <rbasak> Thanks chiluk!
16:05 <ahasenack> chiluk: for the reload bit?
16:05 <chiluk> yep
16:05 <ddstreet> rbasak nothing from me or slashd as far as i know
16:05 <chiluk> I tried to get it finished last week, but things just didn't happen.
16:05 <rbasak> Thanks ddstreet!
16:05 <rbasak> #info No updates on this topic from slashd or ddstreet
16:05 <rbasak> #topic Weekly Updates & Questions for the QA Team (powersj)
16:05 <powersj> Last week got mirroring of Launchpad recipe build results into our jenkins and attended the cloud-init summit.
16:06 <powersj> This week more cloud-init work on generic integration tests
16:06 <powersj> questions comments?
16:07 <rbasak> #link https://jenkins.ubuntu.com/server/
16:07 <rbasak> #info Last week got mirroring of Launchpad recipe build results into our jenkins and attended the cloud-init summit.
16:07 <cpaelzer> I wanted to add on the testing
16:07 <rbasak> #info This week more cloud-init work on generic integration tests
16:08 <cpaelzer> I analyzed the current failing cases on the server jenkisn virt cases  - all are current known cases and I hope to resolve them by fixing up artful
16:08 <cpaelzer> but I have a reglar schedule to check and improve so it will converge on green at some point in time
16:08 <powersj> o/ woohoo thanks cpaelzer
16:08 <rbasak> #info cpaelzer analyzed the current failing cases on the server jenkins virt cases. All are current known cases and he hopes to resolve them by fixing up artful
16:08 <rbasak> Thanks cpaelzer and powersj!
16:08 <rbasak> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:09 <smb> Nothing new from kernel directly, but I had a few things outside kernel which I wanted to mention:
16:09 <smb> One is that we observed some test failures of ubuntu-fan on
16:09 <smb> s390x. The reasons for those I suspect beyond fan or kernel.
16:09 <smb> I believe this is because I set up the two guests which show
16:09 <smb> issues, using netplan. The result is that resolv.conf now
16:09 <smb> only has systemd-resolvd as nameserver. And I suspect, but
16:09 <smb> no proof yet, that for some reason that maybe rejects queries
16:09 <smb> issued from within docker (and maybe lxc, too) containers.
16:09 <smb> I would file a LP bug if this is not something known already.
16:09 <smb> - Second, flashcache: thats a (dkms) package which used to
16:09 <smb> provide some way to add a SSD/NVMe cache to a spinning block
16:09 <rbasak> #info Nothing new from kernel directly
16:09 <smb> device (mostly like bcache but without adding meta-data
16:09 <smb> anywhere). It is no longer comiling with 4.12/4.13 kernels,
16:09 <smb> which actually is a good thing. Problem is this is abandoned
16:09 <smb> upstream and when I "fixed" the compile to work with some
16:09 <smb> pretty heavy upstream kernel changes, I actually converted
16:09 <smb> it into a complicated /dev/null for any kernel between 4.8
16:09 <smb> and 4.11. So plan is to pretty soon make it not compile at
16:09 <rbasak> #info some observed some test failures of ubuntu-fan on s390x
16:09 <smb> all for those kernels. If there is some documentation any-
16:09 <smb> where which should be updated, please let me know. Does
16:09 <smb> not need to be here.
16:09 <smb> Ok, thats all I had. Are there any other questions?
16:10 <xnox> smb, is ubuntu-fan at all supported, since i did not think we ever released anything for z with ubuntu-fan support?
16:10 <rbasak> #info flashcache: thats a (dkms) package which used to provide some way to add a SSD/NVMe cache to a spinning block device: no longer compiling
16:10 <xnox> smb, and no, nothing of the sort is known yet. Then again I do not believe anybody has tried using ubuntu-fan on s390x.
16:10 <smb> xnox, its a generic package and the smoke test was working before
16:11 <xnox> smb, my understanding it was aws specific, yet the reason for ubuntu-fan is now moot.
16:11 <smb> xnox, also note that I do not think its a problem of the package
16:11 <xnox> ack,
16:11 <smb> xnox, its failing because docker cannot resolve dns names
16:11 <xnox> smb, finding and fixing bugs is always good. and docker not doing resolvy things sounds bad.
16:12 <smb> xnox, ack, so I will file something soonish and subscribe you to it for the know
16:14 <rbasak> Thanks smb and xnox!
16:14 <cpaelzer> ah smb you remember I mentioned https://lists.gnu.org/archive/html/qemu-devel/2017-08/msg05286.html
16:14 <cpaelzer> It seems to be to "only" be queued to 4.14 and -stable
16:14 <smb> cpaelzer, I remember you mentioned it but I might have blanked for what reason
16:14 <cpaelzer> but the impact of this could be huge, so you probably want that on release instead of SRU'ing later
16:15 <cpaelzer> TL;DR Bug, solution is disable empty zero-page for KVm on s390x
16:15 <cpaelzer> which on a bunch of guests not fully using their mem can be quite a lot of extra mem
16:15 <sforshee> cpaelzer: best thing to do is file a bug and subscribe me
16:15 <cpaelzer> but the assumption is that real guests over time consume (cache) all their mem anyway
16:15 <cpaelzer> I'll do so sforshee
16:16 <sforshee> cpaelzer: actually just assign it to me
16:16 <cpaelzer> it was only heads up before, but yeah a bug might be good at this point
16:16 <smb> Ah I was about to say something like that. Or submit the patch as [unstable] ... to kernel-team mailing list
16:17 <smb> but bug reports are alway a good thing to remember stuff at that stage
16:18 <rbasak> #topic Upcoming Call For Papers
16:18 <rbasak> #link https://lwn.net/Calendar/Monthly/cfp/
16:18 <rbasak> #link http://www.open-zfs.org/wiki/OpenZFS_Developer_Summit
16:19 <rbasak> I see that the deadline for this is #link http://www.open-zfs.org/wiki/OpenZFS_Developer_Summit
16:19 <rbasak> Uh, Sep 4, 2017
16:19 <rbasak> Any other CfPs to mention?
16:20 <rbasak> #topic Ubuntu Server Team Events
16:20 <rbasak> Any upcoming events?
16:20 <rbasak> #info No upcoming events were mentioned
16:20 <rbasak> #topic Open Discussion
16:20 <rbasak> AOB?
16:20 <rbasak> #info No further discussion
16:20 <rbasak> #topic Announce next meeting date, time and chair
16:21 <rbasak> #info Next meeting: Tue  5 Sep 16:00:00 UTC 2017
16:21 <rbasak> #info smoser will chair
16:21 <rbasak> #endmeeting