16:00 <rharper> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Feb 21 16:00:16 2017 UTC. The chair is rharper. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology>
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <rharper> #topic Review ACTION points from previous meeting
16:00 <rharper> let's review
16:01 <rharper> last weeks log has 6 items to review if I'm reading the log right
16:01 <nacc> o/
16:01 <rharper> #link https://ubottu.com/meetingology/logs/ubuntu-meeting/2017/ubuntu-meeting.2017-02-14-16.00.html
16:02 <rharper> rbasak: did you get to review MRs ?
16:03 <rbasak> I did
16:03 <rbasak> I updated the minutes
16:03 <rbasak> I have one item remaining - handle seeds with powersj
16:03 <powersj> ah! yes
16:03 <rharper> excellent
16:03 <rbasak> powersj: can do that after this meeting if you're free?
16:03 <powersj> yep
16:04 <rharper> #info rbasak completed MRs
16:04 <rharper> #info rbasak to work with powersj on seeds (iotop & nicstat)
16:04 <rharper> jgrimm: any update on server packages for new or missing merges?
16:04 <rbasak> The second one should probably be an #action? So it gets carried over if I fail.
16:05 <rharper> y
16:05 <rharper> #action rbasak to work with powersj on seeds (iotop & nicstat)
16:05 * meetingology rbasak to work with powersj on seeds (iotop & nicstat)
16:05 <jgrimm> rharper, sorry on another meeting atm. i did a sweep last week, but I'll do another one weekly.
16:05 <rharper> ok, I'll re-action that
16:05 <jgrimm> ack, that works
16:05 <rharper> #info jgrimm reviewed server packages for new/missing MRs
16:06 <rharper> #action jgrimm to review server packages for new/missing items that need merging
16:06 * meetingology jgrimm to review server packages for new/missing items that need merging
16:06 <rharper> ok, that's all of the previous actions, let's move on
16:06 <rharper> #topic Zesty Development
16:07 <cpaelzer> nacc: should we inform a bit on the postgres 9.6 cleanup that is needed?
16:07 <rharper> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:07 <nacc> cpaelzer: probably worth it, yeah
16:07 <nacc> cpaelzer: although that's post-z, right?
16:07 <rharper> #subtopic blueprints
16:07 <rharper> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:07 <cpaelzer> nacc: somebody (=us) has to get in touch with an AA soon or the release Team will hate us in the release week
16:07 <cpaelzer> for all the blockers on that in proposed
16:08 <cpaelzer> the real 9.6 is zesty+1 - that is true
16:08 <rharper> cpaelzer: shall I record an action for you then ?
16:08 <rharper> or you can add one yourself with the right words
16:08 <rharper> I think
16:08 <cpaelzer> rharper: na, we would carry that a too long time to qualify as action here
16:08 <cpaelzer> let me just inform a rough summary
16:08 <rharper> ok
16:09 <cpaelzer> so a fallout from pitti leaving is that we decided to stick with postgres 9.5 in zesty
16:09 <nacc> cpaelzer: i thnk we shoudl ask to remove 9.6 from z-p
16:09 <cpaelzer> 9.6 in proposed has various issues and unblocking it so late will cause issues
16:09 <nacc> cpaelzer: and then we can fix up excuses, right?
16:09 <cpaelzer> nacc: exactly
16:09 <nacc> cpaelzer: i can file the bug today
16:09 <nacc> cpaelzer: if you haven't already
16:09 <cpaelzer> that would be perfect nacc
16:09 <nacc> rharper: action, please :)
16:09 <cpaelzer> into the future nacc and I will do an explicit 9.6 transition in zesty+1
16:09 <rharper> #info postgres 9.6 not ready for zesty, stick with 9.5 for zesty
16:10 <cpaelzer> and later on postgres 10.0 gets released on november 8th
16:10 <rharper> #action nacc to file bug to remove 9.6 from zesty-proposed
16:10 * meetingology nacc to file bug to remove 9.6 from zesty-proposed
16:10 <cpaelzer> towards that we need to decide if that is stable and good for 18.04 LTS
16:10 <cpaelzer> I think that is the summary and the action is good
16:10 <cpaelzer> thanks nacc and rharper
16:10 <cpaelzer> BTW last stable release MRE is complete
16:11 <nacc> cpaelzer: nice work!
16:11 <cpaelzer> pg-repack need sponsoring on bug 1664478
16:11 <ubottu> bug 1664478 in pg-repack (Ubuntu) "New upstream microreleases 9.3.16, 9.5.6" [Undecided,In progress] https://launchpad.net/bugs/1664478
16:11 <cpaelzer> if one could look
16:11 <nacc> cpaelzer: yep, was on my list for today
16:11 <rharper> we're past Freeze, so hopefully folks already landed any FFEs needed
16:11 <cpaelzer> I'm already preparing upload permission things
16:11 * cpaelzer is silencing, lets go with rharper FFE question
16:12 <rharper> jgrimm: do we have a list of FFEs we're tracking ?
16:12 <rharper> if any at this point for our blueprint ?
16:12 <cpaelzer> hm, could we quickly query what FFEs others filed to get a feeling what might be coming
16:12 <jgrimm> rharper, yes the bp will be a good place to put them. off the top of my head, python-django
16:13 <nacc> cpaelzer: fyi, LP: #1666566 filed
16:13 <ubottu> Launchpad bug 1666566 in postgresql-9.6 (Ubuntu) "Please remove postgresql-9.6 from zesty-proposed" [Undecided,New] https://launchpad.net/bugs/1666566
16:13 <rharper> #action jgrimm to add python-django FFE to server blueprint
16:13 * meetingology jgrimm to add python-django FFE to server blueprint
16:13 <cpaelzer> subscribing
16:13 <rharper> anyone else here have an FFE for server packages?
16:14 <rharper> if so, please add it to the blueprint
16:14 <rharper> #info ensure to add link to FFE for server-related packages to the blueprint (servercloud-z-server-core)
16:14 <rharper> #subtopic Release Bugs
16:15 <rharper> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:16 <rharper> I don't see anything there that doesn't already have attention
16:16 <rharper> #info no items of interest at this time
16:16 <rharper> #topic Server & Cloud Bugs & SRU/Pending Uploads (caribou)
16:17 <caribou> outstanding SRU followed by STS :
16:17 <caribou> #info SRU are pending for : ifupdown, systemd, sosreport, cups, multipath-tools, sssd
16:18 <caribou> that's all I have
16:18 <rharper> ok
16:18 <cpaelzer> I was on several SRUs as well this week
16:18 <cpaelzer> #info DONE Qemu (3/2) 1587039 1640382 1655225 Libvirt (1/4) 1637601 1659769 1620407 1641618 Postgres (3/1) 1664478
16:18 <cpaelzer> #info INPROGRESS Qemu (2/1) 1641532 Qemu (2/4) 1490611 1646240 1660946 1664622 pg-repack (1/1) 1664478 Libvirt (1/4) 1665410 + one more that needs analysis
16:18 <cpaelzer> notation is package (#releases/#bugs)
16:19 <rharper> great
16:20 <rharper> #action rharper to verify systemd in bug #1649931
16:20 * meetingology rharper to verify systemd in bug #1649931
16:20 <ubottu> bug 1649931 in resolvconf (Ubuntu Yakkety) "systemd-networkd needs to ensure DNS is up before network-online.target" [Medium,Fix committed] https://launchpad.net/bugs/1649931
16:20 <rharper> heh, well, systemd in xenial which has an SRU in flight
16:20 <rharper> ok
16:20 <rharper> #topic Weekly Updates & Questions for the QA Team (powersj)
16:21 <powersj> Last week completed 16.04.2 ISO testing, triaged Zesty ISO failures, and got ppc64el ISO tests 100% pass on xenial and yakkety. Submitted merge request to add git support to jenkins-launchpad-plugin (jlp), and reviewed MAAS' testing with respect to curtin.
16:21 <rharper> #link https://jenkins.ubuntu.com/server/
16:21 <powersj> Zesty LVM bug LP: #1664731
16:21 <ubottu> Launchpad bug 1664731 in debian-installer (Ubuntu Zesty) "zesty lvm install hangs while creating device mapper device" [Critical,New] https://launchpad.net/bugs/1664731
16:21 <powersj> This, short, week I will be looking at curtin vmtest failures at the moment; trying to triage some and will send email out shortly to get some help/pointers. Need to fix up my jlp merge request after the review caught some test failures, and then I will complete bug triage.
16:22 <rharper> #info qa to inspect curtin-vmtest failures this week
16:22 <rharper> any questions for powersj ?
16:23 <rharper> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:23 <smb> Nothing to report from us
16:23 <rharper> thanks
16:23 <rharper> #info None
16:23 <rharper> #topic Upcoming Call For Papers
16:24 <rharper> #link https://lwn.net/Calendar/Monthly/cfp/
16:24 <rharper> #info no discussion
16:25 <rharper> #topic Ubuntu Server Team Events
16:25 <rharper> anyone heading to events?
16:26 <rharper> #info nothing mentioned
16:26 <rharper> #topic Open Discussion
16:26 <rharper> Alright, open mic time
16:26 <cpaelzer> I think we missed an action item last week, teward showed https://wiki.ubuntu.com/ServerTeam/NGINX and jgrimm suggested to get one for qemu
16:26 <cpaelzer> I already had important comments about the understanding and proper update of the machine types delta at https://wiki.ubuntu.com/QemuKVMMigration
16:26 <rharper> cpaelzer: sorry
16:26 <cpaelzer> It wasn't in the actions, so you didn't miss it
16:26 <cpaelzer> but I did that already, so let me just point to the new page
16:27 <cpaelzer> the reason to do so was
16:27 <cpaelzer> due to the qemu & libvirt cleanup in the zesty cycle I actually had some good content for such a page.
16:27 <cpaelzer> So I created one for (advanced) Bug reports and packaging guidance
16:27 * cpaelzer is seacrhing the link
16:27 <cpaelzer> #link https://wiki.ubuntu.com/ServerTeam/CoreVirtualizationPackaging
16:27 <cpaelzer> Feedback welcome, but it is also a Wiki so feel free to help directly.
16:28 <rharper> #info cpaelzer brought up additional information around qemu/libvirt machine type migration, requests feedback
16:28 <rharper> cpaelzer: excellent
16:28 <cpaelzer> and packaging, but I think the info is fine
16:29 <rharper> any others
16:29 <cpaelzer> I really recommend to read this if one is going to touch libvirt/qemu packaging
16:29 <cpaelzer> avoid my faults :-)
16:29 <rharper> hehe
16:30 <rharper> alright, I've bungled this enough
16:30 <rharper> #topic Announce next meeting date, time and chair
16:31 <rharper> #info Meeting again in a week, roughly: date -d "+1 week -30 minutes" -> Tue Feb 28 10:00:59 CST 2017
16:31 <rharper> #info Chair will be powersj
16:31 <rharper> and that's it!
16:31 <powersj> \o/
16:31 <rharper> #endmeeting