16:02 <arosales> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Nov 26 16:02:08 2013 UTC.  The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02 <arosales> #topic Review ACTION points from previous meeting
16:02 <arosales> No actions from previous meeting
16:03 <arosales> #topic Trusty Development
16:03 <arosales> #link https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule
16:04 <arosales> we have an alpha coming up I think . . .
16:04 <arosales> Dec 19th
16:04 <arosales> opt in for flavors
16:04 <arosales> smoser, jamespage is server opting in?
16:05 * arosales doesn't see utlemming for cloud image confirmation
16:05 <jamespage> as a core flavor we don't normally opt in - I'm happy to stick with that for alpha1
16:05 <arosales> jamespage, ack
16:05 <arosales> #subtopic Release Bugs
16:05 <arosales> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-t-tracking-bug-tasks.html#server
16:05 <smoser> jamespage, well, i like to create cloud images.
16:06 <arosales> smoser, I think cloud images has done an alpha in the past .  . .
16:06 <smoser> i'd like for us to opt in for alpha1 cloud images, with some actual targets.
16:06 <jamespage> sure
16:06 <smoser> the seed-review and gpt
16:06 <smoser> jamespage, have you done a seed-review email ?
16:07 <arosales> #action smoser sync with utlemming on building cloud images for alpha 1, targets = seed-review, gpt
16:07 * meetingology smoser sync with utlemming on building cloud images for alpha 1, targets = seed-review, gpt
16:07 <jamespage> smoser, urgh - not yet
16:07 <jamespage> arosales, please action me todo that asap
16:07 <arosales> will do
16:07 <arosales> #action jamespage do seed-review email
16:07 * meetingology jamespage do seed-review email
16:07 <arosales> onto bugs :-)
16:08 <arosales> got two high @ http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-t-tracking-bug-tasks.html#server
16:08 <arosales> no critical
16:08 <arosales> http://launchpad.net/bugs/1243762
16:08 <ubottu> Ubuntu bug 1243762 in juju-core (Ubuntu Trusty) "[MIR] juju-core, golang" [High,Confirmed]
16:08 <jamespage> that will stick on the report until either we decide not to or it gets in main
16:09 <arosales> jamespage, ok, thanks
16:09 <arosales> bug 1062336
16:09 <ubottu> bug 1062336 in nova (Ubuntu Trusty) "nova-compute expects libvirtd group" [High,Triaged] https://launchpad.net/bugs/1062336
16:09 <arosales> zul ^
16:09 <rbasak> We should perhaps track bug 1248283, since at the moment it seems to affect all MAAS/juju on Saucy, and presumably Trusty too. I don't know how much this needs to be tracked by us as opposed to juju upstream, though.
16:09 <ubottu> bug 1248283 in juju-core "Juju deploy of Charm in MAAS fails because dbus fails" [High,Triaged] https://launchpad.net/bugs/1248283
16:09 <arosales> nevermind jamespage looks like your marked won't fix
16:09 <jamespage> zul, that will get fixed up under the kvm packaging review
16:09 <zul> rbasak:  its been removed in trusty
16:10 <rbasak> zul: what's been removed exactly?
16:10 <zul> arosales: the xcp stuff has been removed in nova
16:10 <zul> rbasak:  sorry not you :)
16:10 <arosales> zul, thanks
16:11 <arosales> rbasak, you are referring to https://bugs.launchpad.net/maas/+bug/1248283
16:11 <ubottu> Ubuntu bug 1248283 in juju-core "Juju deploy of Charm in MAAS fails because dbus fails" [High,Triaged]
16:11 <rbasak> Yes
16:11 <arosales> good one to track
16:12 <arosales> jamespage, which team to we add to get in on the bug tracking list?
16:13 <arosales> ~ubuntu-server ?
16:13 <arosales> smoser, ^
16:14 <jamespage> no - dbus should not be on the server list
16:14 <jamespage> raise a task for juju-core - I think that will do it
16:14 <smoser> there is a task for juju-core thre.
16:14 <arosales> juju-core has a task
16:15 <arosales> while we work on that is there any other bugs we want to cover?
16:15 <jamespage> juju-core in Ubuntu
16:15 <arosales> there are a few other mediums and lows
16:15 <jamespage> not upstream
16:15 <rbasak> I think you might need a packaging task against a package that ~ubuntu-server subscribes to that also has a Trusty task.
16:15 <rbasak> I'm not sure this is a good way to do it, mind.
16:15 <arosales> jamespage, ah ok
16:16 <jamespage> rbasak, is the bug in dbus?
16:16 <rbasak> Debatable. I'd say the primary bug is in juju-core.
16:16 <rbasak> (or perhaps the MAAS provider in juju if that's separate)
16:16 <arosales> rbasak, could you add a task for juju-core in Ubuntu?
16:16 <rbasak> dbus would ideally not fail, and ideally log a message explaining what happens when it does.
16:17 <rbasak> But juju should not try to restart networking. It doesn't need to do that anyway.
16:17 <jamespage> rbasak, raise a distro bug task for Ubuntu and target to trusty
16:17 <jamespage> so we can track it
16:17 <rbasak> ack
16:17 <arosales> rbasak, thanks
16:18 <arosales> any other bugs we should cover
16:18 <rbasak> Done. Importance?
16:18 <arosales> got the highs and critical ones done @ http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-t-tracking-bug-tasks.html#server
16:18 <rbasak> I'll say Triaged/High.
16:18 <arosales> rbasak, thanks for brining in one we needed to track too
16:18 <arosales> ok we covered those
16:18 <arosales> not the others on the list are openstack
16:19 <arosales> less websockify
16:19 <arosales> moving on
16:19 <arosales> #subtopic Blueprints
16:19 <arosales> jamespage, to my failing did you create a topic bp?
16:19 <jamespage> yes
16:19 <arosales> #link http://status.ubuntu.com/ubuntu-s/group/topic-t-servercloud-overview.html
16:19 <arosales> ah and you must have updated the notes
16:19 <arosales> well done -- thank you
16:19 <arosales> :-)
16:20 <arosales> http://status.ubuntu.com/ubuntu-s/group/topic-t-servercloud-overview.html
16:20 <arosales> hmm not loading for me atm
16:20 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/topic-t-servercloud-overview
16:20 <arosales> working for others?
16:21 <arosales> hmm http://status.ubuntu.com/ubuntu-t/ looks to may need a kick
16:21 <jamespage> arosales, no
16:21 * arosales doesn't see any topic BPs there
16:21 <jamespage> arosales, gaughen: we need to go through all blueprints and priortize and accept for trusty
16:22 <jamespage> so as its only UDS + 2 days really
16:22 <arosales> #action jamespage, gaughen review blueprints and accept for trusty
16:22 * meetingology jamespage, gaughen review blueprints and accept for trusty
16:22 <gaughen> okay
16:22 <smoser> yeah.
16:22 <jamespage> can respectfully suggest that everyone write up their blueprints from last week by thursday
16:22 <jamespage> using the blueprint spec
16:22 <jamespage> and mark 'Pending Approval'
16:22 <arosales> #action gaughen file bug with status.u.c to get ubuntu server topic tracking in there
16:22 * meetingology gaughen file bug with status.u.c to get ubuntu server topic tracking in there
16:23 <arosales> gaughen, I hope you don't mind that action
16:23 <jamespage> then smoser, gaughen and I will know which ones to review
16:23 <arosales> gaughen, https://bugs.launchpad.net/launchpad-work-items-tracker/+filebug
16:23 <arosales> gaughen, ping me if you have any questions
16:23 <jamespage> so I guess for folks in the US that means be end of wednesday
16:23 <jamespage> ....
16:23 <jamespage> sorry
16:23 <gaughen> nope don't mind but i will have questions :-)
16:23 <jamespage> actually - this makes no sense
16:23 <arosales> #action all: write up blueprints, and have them ready for review by November 28
16:23 * meetingology all: write up blueprints, and have them ready for review by November 28
16:24 <jamespage> end of week - then we can review early next week
16:24 <smoser> end of week.
16:24 <smoser> (which may be in a few hours for some US folk)
16:25 <arosales> # all write up bluerprints, using blueprint spec, mark 'pending approval', and have complete by November 29
16:25 <arosales> any other BP topics?
16:25 <arosales> #topic Server & Cloud Bugs (caribou)
16:26 <arosales> caribou any bugs to bring up here that we didn't already cover?
16:26 * arosales doesn't see caribou online atm
16:26 <arosales> #topic Weekly Updates & Questions for the QA Team (psivaa)
16:26 <psivaa> No updates from us,
16:26 <arosales> psivaa, ok thanks
16:27 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:28 <arosales> smb any updates?
16:28 * arosales doesn't seem smb here atm
16:29 <arosales> any folks from kernel
16:29 <arosales> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:29 <rbasak> No updates from me. Any questions?
16:29 <arosales> any questions for rbasak ?
16:29 <arosales> #topic Ubuntu Server Team Events
16:30 <arosales> we had a lot of events we just came back from
16:30 <arosales> ODS, uVDS, RubyConf, AWS re:Invent
16:30 <arosales> I don't know of any upcoming in the next week
16:30 <arosales> any other folks have any events to bring up here?
16:31 <arosales> #topic Open Discussion
16:31 <arosales> any other agenda items?
16:32 <arosales> going once
16:32 <arosales> twice
16:32 <arosales> thrice
16:32 <arosales> #topic Announce next meeting date and time
16:32 <arosales> NEXT MEETING: Tuesday 2013-12-03 at 1600 UTC
16:32 <arosales> Thanks for joining the ubuntu server team meeting!
16:32 <arosales> #endmeeting