16:00:07 <rbasak> #startmeeting ubuntu-server-team
16:00:07 <meetingology> Meeting started Tue Apr  9 16:00:07 2013 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00:07 <meetingology> 
16:00:07 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:00:15 <rbasak> #topic Review ACTION points from previous meeting
16:00:32 * rbasak ALL, please look to hijack a dep-8 test from https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-seeded-qa-workflow (Daviey, 16:24:44)
16:00:33 <Daviey> o/
16:00:39 <arosales> hello
16:00:53 <Daviey> jamespage: can you summarise that BP?
16:01:04 <Daviey> should it be postponed in all?
16:01:05 <smoser> o/
16:01:28 <jamespage> OK - so I went through my WI's and postponed stuff I won't get to in the next 3 days
16:01:33 <jamespage> as the is my time window
16:02:10 <jamespage> adam_g, roaksoax, zul, rbasak all have WI's as well - please can you review and POSTPONE or implement prior to 13.04 pls
16:02:28 <zul> ack
16:02:39 <hallyn> (i actually do to, which i'll postpone)
16:02:48 <rbasak> OK
16:03:06 * rbasak arosales to follow up with Norvald regarding SRU (Daviey, 16:28:55)
16:03:06 <jamespage> hallyn, sorry - missed you off the list
16:03:52 <arosales> rbasak, I still need to catch up with norvald
16:04:15 <rbasak> #action (carried forward) arosales to follow up with Norvald regarding SRU
16:04:15 * meetingology (carried forward) arosales to follow up with Norvald regarding SRU
16:04:24 * rbasak zul to review complexity of packaging perconia for Ubuntu NEW (Daviey, 16:30:30)
16:04:41 <rbasak> (thanks arosales)
16:04:52 <zul> did that i have my notes somewhere
16:05:07 <zul> where should I send my notes
16:05:11 <arosales> rbasak, thanks
16:05:29 <Daviey> zul: notes?
16:05:30 <rbasak> How about the Ubuntu server list? Would that be suitable?
16:05:38 <rbasak> And where do we go from here for that?
16:05:43 <zul> Daviey:  about the percona review
16:05:45 <zul> rbasak:  sure
16:05:55 <rbasak> Thanks zul!
16:05:57 <Daviey> Ah, ubuntu-server list sounds GREAT
16:06:16 <rbasak> #action zul to send notes from review of  complexity of packaging perconia for Ubuntu to the ubuntu-server list
16:06:16 * meetingology zul to send notes from review of  complexity of packaging perconia for Ubuntu to the ubuntu-server list
16:06:23 * rbasak Smoser to reach out to juju-core and discuss what integration with ubuntu image meta data can be done for Raring. (Daviey, 16:34:33)
16:06:38 <smoser> not done. will do today.
16:06:46 <rbasak> OK. Thanks smoser!
16:06:56 <rbasak> #action (carried forward) smoser to reach out to juju-core and discuss what integration with ubuntu image meta data can be done for Raring.
16:06:56 * meetingology (carried forward) smoser to reach out to juju-core and discuss what integration with ubuntu image meta data can be done for Raring.
16:07:03 * rbasak Daviey to follow up on bugs bug 1160373 and bug 1160378 (Daviey, 16:40:14)
16:07:05 <ubottu> bug 1160373 in xen (Ubuntu) "Support for APIC Virtualization in Xen" [Wishlist,Fix released] https://launchpad.net/bugs/1160373
16:07:07 <ubottu> bug 1160378 in xen (Ubuntu) "TSC offset support for Xen" [Wishlist,Fix released] https://launchpad.net/bugs/1160378
16:07:24 <Daviey> Fix released (thanks smb, zul)
16:07:34 <rbasak> Great. Thanks!
16:07:43 <rbasak> #topic Raring Development
16:07:51 <rbasak> #subtopic Release Tracking Bug Tasks
16:07:59 <rbasak> #link http://reports.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:08:18 <rbasak> jamespage: would you like to go through these, please?
16:08:22 <jamespage> ok
16:08:43 <jamespage> bug 1157918
16:08:45 <ubottu> bug 1157918 in horizon (Ubuntu Raring) "Network selection tab when starting instance renders incorrectly" [High,Confirmed] https://launchpad.net/bugs/1157918
16:09:01 <jamespage> assigned to me - the ubuntu theme for horizon is still broken - I need to hassle huwshimi
16:09:25 <jamespage> roaksoax, bug 1064527 and bug 1073463
16:09:28 <ubottu> bug 1064527 in maas (Ubuntu Raring) "detect_ipmi needs improvement. detects non-existant device in nested kvm" [High,Triaged] https://launchpad.net/bugs/1064527
16:09:29 <ubottu> bug 1073463 in maas (Ubuntu Raring) "User-configurable files are not installed in /etc" [High,Triaged] https://launchpad.net/bugs/1073463
16:09:38 <jamespage> roaksoax, likely to be fixed for raring?
16:09:52 <jamespage> rbasak has bug 1162139
16:09:53 <ubottu> bug 1162139 in mysql-5.5 (Ubuntu Raring) "mysql-5.5 still built using GCC-4.4, should be built with the default GCC" [High,Triaged] https://launchpad.net/bugs/1162139
16:10:16 <rbasak> I'm made some progress but am still looking at it. None of the possible ways forward look easy
16:10:33 <jamespage> rbasak, ack
16:10:35 <jamespage> and bug 1163768
16:10:37 <ubottu> bug 1163768 in ntp (Ubuntu Raring) "ntp ftbfs in raring" [High,In progress] https://launchpad.net/bugs/1163768
16:10:39 <rbasak> I may have to come back and say that a raring target is unrealistic
16:11:00 <rbasak> I Looks like the ntp ftbfs is fixed
16:11:49 <roaksoax> jamespage: detect_ipmi I have a fix for it...
16:11:50 <jamespage> indeed - closing bug
16:12:06 <roaksoax> jamespage: the latter, I talked to bigjools and needs upstream support to be able to do that as it is not just packaging
16:12:07 <rbasak> Thanks!
16:12:12 <jamespage> and finally bug 1121874
16:12:14 <ubottu> bug 1121874 in mysql-5.5 (Ubuntu Raring) "MySQL launch fails silently if < 4MB of disk space is available" [Medium,Triaged] https://launchpad.net/bugs/1121874
16:12:41 <rbasak> This is relatively trivial, assuming that we're happy with the log going to /var/log/upstart, since that's the only place we can log to from an upstart job that I could see (am I correct)?
16:12:56 <jamespage> rbasak, sounds good
16:12:56 <rbasak> If so, I'll fix with the bigger mysql bug fix, or just on its own if I don't get that done
16:13:11 <rbasak> #subtopic Blueprints
16:13:18 <rbasak> #link http://status.ubuntu.com/ubuntu-raring/group/topic-raring-servercloud-overview.html
16:13:21 <jamespage> sweet
16:13:45 <jamespage> roaksoax, OK - defer the config files one for raring I suggest
16:13:50 <rbasak> It looks like a lot of outstanding WIs need to be marked postponed?
16:14:10 <roaksoax> jamespage: indeed
16:14:33 <rbasak> jamespage: are there any blueprints you'd like to go through?
16:15:25 <jamespage> looking
16:16:34 <jamespage> nope
16:16:51 <rbasak> OK. Thanks for going through them and the bugs!
16:17:00 <rbasak> #topic Ubuntu Server Team Events
16:17:01 <jamespage> as you state postpone anything that ain't going to happen in the next few days
16:17:17 <jamespage> openstack design summit in portland next week
16:17:22 <jamespage> LOADS of people going
16:17:29 <Daviey> +1!
16:17:49 <rbasak> Any other events?
16:18:20 <rbasak> #topic Weekly Updates & Questions for the QA Team (plars)
16:18:26 <plars> hi
16:18:31 <rbasak> plars: hello! Any updates from you? Or does anyone have any questions for plars?
16:18:35 <plars> So I have a couple of things
16:18:41 <plars> mostly on the subject of iso testing
16:18:51 <plars> I tried to run the iscsi tests for raring beta
16:18:58 <plars> and got the unauth mode to pass on one of them
16:19:19 <plars> but for all the rest, it hung for me on reboot and I was unable to complete the tests
16:19:20 <jamespage> plars, do you use my helper scripts?
16:19:25 <plars> jamespage: yes
16:19:46 <jamespage> more than likely bugs then
16:19:49 <plars> jamespage: I'm *fairly* certain I'm running them correctly, but couldn't see an easy way to debug anything past "it doesn't boot"
16:19:53 <jamespage> I'll take a quick run through
16:19:58 <plars> I was wondering if I could get some help with that
16:20:04 <plars> thanks
16:20:14 <plars> On the subject of MAAS tests:
16:20:19 <plars> http://iso.qa.ubuntu.com/qatracker/testcases/1461/info
16:20:19 <plars> http://iso.qa.ubuntu.com/qatracker/testcases/1462/info
16:20:19 <plars> http://iso.qa.ubuntu.com/qatracker/testcases/1463/info
16:20:47 <plars> I was able to run through the first one mostly - though either I was not finding some options in MAAS (possible since I've not used it much before) or the tests need a lot of updating
16:21:17 <plars> Is there a MAAS expert on the team that could help review the tests and make sure they are valid for what's currently in raring?
16:21:29 <jamespage> roaksoax, please could you help plars out this this?
16:21:47 <roaksoax> jamespage: definitely, it was on my todo for this week
16:22:04 <plars> Finally, there's a whole lot of ec2 tests on http://iso.qa.ubuntu.com Can someone  see that those are attempted when we get to the release candidate?
16:22:07 <jamespage> roaksoax, great
16:22:18 <plars> I'd like to get the server stuff as close to 100% covered as possible for the raring release
16:22:29 <plars> this would be the week leading up to April 25
16:22:36 <jamespage> plars, sure - utlemming normally deals with the ec2 testing
16:22:42 <plars> awesome
16:22:44 <plars> that's all I have
16:23:08 <rbasak> Thanks roaksoax and jamespage for helping plars with QA.
16:23:09 <utlemming> plars: that tests are running
16:23:17 <plars> jamespage: I'll also try the iscsi tests again on todays image, so if you get something different from me then we'll know it must be something on my end
16:23:18 <utlemming> plars: they are on the build server jenkins instance
16:23:30 <utlemming> plars: but IS has yet to enable pushing them to the public instance
16:23:37 <utlemming> plars: I'll get with you on the EC2 testing
16:23:39 <jamespage> utlemming, do we need to disable them in the old QA setup?
16:23:39 <plars> utlemming: fair enough
16:23:47 <plars> utlemming: ok, sounds good
16:23:50 <rbasak> Thanks utlemming!
16:24:01 <rbasak> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:24:04 <smb> Nothing to report this week (nothing I can remember at least ;-P). Would there be questions?
16:24:23 <rbasak> Thanks smb. Does anyone have any questions?
16:24:45 <jamespage> smb, do you know if there are plans
16:24:55 <smb> there are many
16:24:56 <jamespage> smb, to provide the raring 3.8 kernel on precise
16:25:02 <jamespage> like with did with 3.5?
16:25:23 <smb> jamespage, Yes I afaik that is the plan
16:25:47 <jamespage> smb, hmm - OK - I think we need to consider what we do with the important DKMS packages for server
16:26:09 <jamespage> I'd like to table that we look at upgrading things like openvswitch to the latest releases that support 3.8
16:26:31 <jamespage> I'm concerned that we are going to get into cherry pick hell trying to keep up with kernels every 6 months
16:26:48 <jamespage> i.e. openvswitch would bump to 1.9.0 in 12.04 for example
16:27:32 <smb> jamespage, that might be simpler to keep up with than just fixing the build issues. openvswitch might be more affected there than other dkms packages
16:28:22 <smb> iscsi_target could be another one to look for, though the block layer changes a little slower imo
16:28:25 <jamespage> smb, OK - I'll draw up a list an review/propose where we might go next then :-)
16:28:31 <smb> jamespage, ack
16:28:42 <rbasak> OK. Thanks smb!
16:28:46 <rbasak> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:28:52 <jamespage> smb, it needed an update for raring :-)
16:29:06 <smb> jamespage, slower not not... :-P
16:29:26 * jamespage stops hijacking rbasaks session
16:29:44 <rbasak> I have no updates. I'd like to just mention though that my mongodb patch is just a workaround to make it work. I need to look again at actually making it performant - I suspect I destroyed ARM performance in my alignment workaround.
16:29:46 <rbasak> Any questions for me?
16:30:17 <rbasak> I guess not.
16:30:20 <rbasak> #topic Open Discussion
16:30:47 <rbasak> I had one question. Are we tracking outstanding merges to make sure that we don't ship (or are at least aware of) packages that are older than Debian?
16:31:13 <rbasak> I did exim4, and have puppet upload pending review, both of which picked up bugfixes from Debian
16:34:36 <jamespage> I've not been that hot on it lately
16:34:49 <jamespage> its hard to track due to the mixture of sources from unstable and experimental
16:35:40 <rbasak> I wondered if we should keep a list of what Debian version of a package we're happy with for each package
16:36:02 <rbasak> Then it might be easier to track it, and for a Debian revision we've opted not to merge, we won't be bothered by it.
16:36:07 <rbasak> Anyway, just a thought for next cycle maybe.
16:36:13 <rbasak> Any other items for open discussion anyone?
16:36:40 <rbasak> #topic Announce next meeting date and time
16:36:47 <rbasak> The next meeting will be at Tue, 16 Apr 2013 16:00:00 +0000. The chair will be yolanda.
16:36:50 <rbasak> #endmeeting