14:00:18 <Laney> #startmeeting
14:00:18 <meetingology> Meeting started Mon Mar 11 14:00:18 2013 UTC.  The chair is Laney. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:00:18 <meetingology> 
14:00:18 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
14:00:45 <darkxst> Hi
14:01:01 * stgraber waves
14:01:52 <Laney> !dmb-ping is bdrung, Laney, micahg, barry, tumbleweed, ScottK, stgraber: DMB ping
14:01:59 <ScottK> \o
14:02:03 <bdrung> o/
14:02:15 <Laney> #topic Review of previous action items
14:02:25 <Laney> #subtopic Micah to send summary of PPU decoupling discuss to the DMB list
14:02:32 * Laney looks for it
14:02:58 <bdrung> i can't remember reading one
14:03:04 <Laney> bad micahg
14:03:22 <Laney> so, carried I suppose ... This discussion drags on
14:03:35 <Laney> what about The Feedback? I still haven't seen that
14:03:48 <bdrung> me neither
14:04:53 <Laney> #action Micah to send summary of PPU decoupling discuss to the DMB list
14:04:53 * meetingology Micah to send summary of PPU decoupling discuss to the DMB list
14:05:15 <Laney> #action Micah to urgently send feedback on Bjorn's PPU application
14:05:15 * meetingology Micah to urgently send feedback on Bjorn's PPU application
14:05:20 <Laney> let's move on
14:05:27 <Laney> #topic PerPackageUploader Applications
14:05:33 <Laney> erm
14:05:38 <Laney> #topic Ubuntu Contributing Developer Applications
14:05:50 <Pici> Laney: factoid updated
14:05:52 <Laney> #subtopic Tim Lunn (darkxst)
14:05:55 <Laney> Pici: merci
14:06:00 <Laney> darkxst: you're up - howdy
14:06:02 <Laney> can you introduce yourself?
14:06:35 <darkxst> I am one of the main developers working on Ubuntu GNOME, and more generally just trying to make GNOME work great on Ubuntu
14:07:15 <Laney> #link https://wiki.ubuntu.com/TimLunn/DeveloperApplication
14:07:33 <Laney> anyone got a question to start us off?
14:09:10 <ScottK> darkxst: Have you been following Bug 1153224 and do you have an opinion on it?
14:09:13 <ubottu> bug 1153224 in systemd (Ubuntu) "[FFE] Move to logind for session tracking" [Undecided,New] https://launchpad.net/bugs/1153224
14:09:20 <Laney> darkxst: so - a lot of the GNOME remix work is done in the team's PPAs. Do you have any plans / ideas about how to do more of it in the archive? (ah, answer ScottK first)
14:11:13 <darkxst> ScottK, yes I think that will actually help us, but probably there will be some fall out with systemd checks getting confused
14:11:33 <darkxst> Generally consolekit support is entirely untested right now
14:11:39 <ScottK> If I read the bug right, you guys prety much NEED it?
14:15:33 <darkxst> ScottK, yes, however I don't think ConsoleKit has actually been dropped yet
14:15:48 <ScottK> No.  We're discussing it.
14:15:51 <ScottK> Thanks.
14:16:06 <darkxst> ScottK, I meant from the gnome side
14:16:13 <ScottK> Ah.  Right.
14:16:18 <Laney> I don't understand that dropping CK is a necessary part of the logind work
14:16:52 <jbicha> darkxst: do we need to move to logind for 13.04 or can that wait until 13.10?
14:17:38 <Laney> let's keep this on topic though
14:18:08 <Laney> excuse me for one minute - wind has just knocked a load of stuff over ...
14:18:14 <stgraber> Laney: you can technically run both (I'm doing that here), however you get into trouble if your session is registered only in CK and the rest of the desktop uses the logind API. That's why I don't think we'd release with both but would rather just ship one and make sure everything uses it.
14:19:09 <darkxst> jbicha, I suspect it can wait until 13.10, but who knows what gnome will drop after freeze
14:19:10 * Laney 's bathroom has a nice layer of snow
14:19:54 <tumbleweed> it's a stunning warm, sunny day here :P
14:20:14 <Laney> stgraber: you're saying that "logind and ConsoleKit work fine side by side" is inaccurate?
14:20:38 <Laney> darkxst: you can answer my previous question now :)
14:20:38 * ogra_ sends some grumbling tumbleweed's way
14:20:47 <bdrung> we have snow _outside_
14:20:52 <Laney> we'll move that other conversation to #-devel ...
14:20:56 <ogra_> same here
14:21:38 <darkxst> Laney, that is kinda of hard, we already push as much as we can straight to the ubuntu archive, but the split in versions means much is stuck in the ppa
14:21:50 <ogra_> we had a temp. drop of 15 deg, C
14:21:57 <ogra_> over two days
14:22:36 <ScottK> darkxst: What split in versions (for those of us not familiar)?
14:22:37 <ogra_> (oops, sorry, missed whch channel i'm in)
14:23:08 <darkxst> Ok so Ubuntu sticking mostly with gnome 3.6 for Raring
14:23:09 <Laney> Do you think the current situation with the level of patching Ubuntu has in the system components (gsd/gcc/other) is sustainable? Or will we see forks? Would that be good or bad from a GNOME remix POV?
14:23:10 <tumbleweed> ScottK: I'm assuming the latest GNOME vs what the ubuntu-desktop team want?
14:23:36 <darkxst> and the ppa packaging is mostly gnome 3.8
14:24:03 <darkxst> Laney, the level of patching is insane
14:24:14 <darkxst> I can't see how that is sustainable in the long run
14:25:01 <barry> darkxst: that might be a good topic for the next vUDS
14:25:09 <bdrung> do you think that getting the amount of patches down to a maintainable amount?
14:25:10 <darkxst> I think to some extent forks would help, but also perhaps more effort to upstream patches
14:26:51 <bdrung> darkxst: you mentioned in your application that it takes too long to get patches reviewed. have you used the sponsoring queue? have you ping the patch pilots?
14:28:08 <darkxst> bdrung, yeh I ping the patch pilots, its more the SRU's etc that take forever
14:28:35 <tumbleweed> yeah, SRU review seems quite backlogged atm
14:28:38 <bdrung> darkxst: there are many steps in the SRU process. which steps took forever?
14:28:38 * Laney nods
14:28:58 <bdrung> the waiting to get approved in -proposed?
14:29:12 <tumbleweed> yup
14:29:19 <darkxst> bdrung, yeh
14:29:40 <bdrung> that should be fixed.
14:30:06 <Laney> darkxst: I'd appreciate seeing you more in #ubuntu-desktop btw - with some direct contributions you could get desktop team membership like jbicha did
14:30:25 <bdrung> darkxst: my next question is: do you collaborate with Debian?
14:30:27 <Laney> s/some/some more/ - not minimising the work you already did :P
14:31:06 <darkxst> bdrung, not really so far, mostly just upstream gnome
14:31:48 * Laney is ready to vote once bdrung is done
14:32:01 * stgraber too
14:32:05 <bdrung> darkxst: i think that it would make sense to collaborate with Debian to not duplicate packaging work.
14:32:19 <bdrung> Laney: i am done.
14:32:31 <Laney> right
14:32:53 <darkxst> bdrung, yes, I agree, however they are well behind in gnome packages for the most part
14:33:02 <Laney> #vote Should Tim Lunn (darkxst) become an Ubuntu Contributing Developer?
14:33:02 <meetingology> Please vote on: Should Tim Lunn (darkxst) become an Ubuntu Contributing Developer?
14:33:02 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
14:33:07 <Laney> +1
14:33:07 <meetingology> +1 received from Laney
14:33:10 <ScottK> +1
14:33:10 <meetingology> +1 received from ScottK
14:33:11 <bdrung> +1
14:33:11 <meetingology> +1 received from bdrung
14:33:13 <tumbleweed> +1
14:33:13 <meetingology> +1 received from tumbleweed
14:33:17 <barry> +1
14:33:17 <meetingology> +1 received from barry
14:33:19 <stgraber> +1
14:33:19 <meetingology> +1 received from stgraber
14:33:44 <Laney> #endvote
14:33:44 <meetingology> Voting ended on: Should Tim Lunn (darkxst) become an Ubuntu Contributing Developer?
14:33:44 <meetingology> Votes for:6 Votes against:0 Abstentions:0
14:33:44 <meetingology> Motion carried
14:33:50 <Laney> darkxst: welcome \o/
14:33:58 <bdrung> darkxst: debian experimental would be currently a good target.
14:34:06 <bdrung> congrats, darkxst
14:34:07 <Laney> They're doing 3.7.x in experimental ATM
14:34:09 <darkxst> Thanks!
14:34:18 <Laney> but spend your time however you see it being most profitable
14:34:27 <Laney> #topic Chair for next meeting
14:34:29 * tumbleweed looks forward to Ubuntu GNOME 's first official release
14:34:31 <Laney> that's stgraber!
14:34:33 <Laney> #topic AOB
14:34:40 <Laney> ?
14:34:52 <tumbleweed> DST? barry was saying something about US having DST change
14:34:54 * barry sends his apologies for 25-march meeting
14:35:04 <Laney> oh, yes, I'll be on holiday in 2 weeks
14:35:18 <tumbleweed> \o/
14:35:20 <barry> tumbleweed: right, us went into dst this past weekend, i think eu goes into dst on 31-march
14:35:23 <Laney> yeah
14:35:27 <Laney> what's the problem?
14:35:57 <bdrung> there is no - just that the local time of the meeting will shift by one hour
14:36:12 <barry> only that there may be some confusion about start time until the tz shuffle quiets down.  i don't personally mind that the meeting is 1 hour later for me now
14:36:33 <ScottK> It doesn't matter either way for me either.
14:37:02 <stgraber> I'm perfectly happy with the current meeting time personally, 10am is much better than 9am for me :)
14:37:18 <Laney> heh
14:37:31 <Laney> For some reason this calculation always breaks my brain
14:37:38 * bdrung prefers the time shift
14:37:48 <Laney> It becomes an hour later after this change, right?
14:38:01 <barry> i can't complain about 10am rather than 9am either :)
14:38:01 <bdrung> Laney: i can do the dmb-ping before the meeting if that will help you
14:38:09 <bdrung> Laney: yes
14:38:18 <Laney> so for me 1400 -> 1500, 1900 -> 2000
14:38:22 <bdrung> yes
14:38:29 <Laney> righto
14:38:43 <Laney> anyway, if that's it
14:38:49 <Laney> #endmeeting