17:04:08 <pleia2> #startmeeting
17:04:08 <meetingology> Meeting started Thu Feb 28 17:04:08 2013 UTC.  The chair is pleia2. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:04:08 <meetingology> 
17:04:08 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:04:32 <pleia2> #chair czajkowski dholbach cprofitt
17:04:32 <meetingology> Current chairs: cprofitt czajkowski dholbach pleia2
17:05:11 <pleia2> #chair YokoZar Gwaihir
17:05:11 <meetingology> Current chairs: Gwaihir YokoZar cprofitt czajkowski dholbach pleia2
17:05:14 <pleia2> there we go
17:05:23 <czajkowski> smart ;)
17:05:24 <pleia2> #topic Docs team catch-up
17:05:25 <Gwaihir> o/
17:05:40 <pleia2> #chair beuno
17:05:40 <meetingology> Current chairs: Gwaihir YokoZar beuno cprofitt czajkowski dholbach pleia2
17:05:45 <czajkowski> lol
17:06:06 <pleia2> so at these catch-ups with teams we pretty much just check in to see how things are going, if there are blockers or anything we can help with
17:06:26 <pleia2> jbicha: can you tell us a bit about how core "official docs we ship" are doing?
17:07:24 <jbicha> like many areas of Ubuntu, we are undermanned
17:07:43 <jbicha> I think for the Ubuntu Desktop docs though, we are critically undermanned
17:08:39 <jbicha> I am intending to resign from being the defacto Docs lead this week, both because I have too many responsibilities now and to make it a little more obvious that we need help
17:09:18 <jbicha> I'll be available for the next month or so to help with transition if anyone else wants to jump in
17:09:31 <pleia2> seeing that there are folks working on the wiki and other projects springing up like ubuntu-manual, do you think it may partially be an onboarding issue?
17:09:31 <dholbach> jbicha, are there others in the team who have taken on leadership roles or started to take care of some of the organisation?
17:09:35 <jbicha> I believe other parts are doing a little better (Server docs & the Manual)
17:09:57 <beuno> jbicha, interesting, do you have a feeling as to why?
17:10:01 <pleia2> (I have seen concerns that "docs are too hard to get involved with")
17:10:29 <jbicha> dholbach: for ubuntu-docs itself, not really, just look at the commit log: https://code.launchpad.net/~ubuntu-core-doc/ubuntu-docs/quantal
17:11:00 <phillw> o/
17:11:10 <jbicha> mdke is still sort of around and he's nearly an expert at this but he's been less active than he used to be
17:12:32 <YokoZar> I have heard in multiple places now that the easier you make doc contributing the more likely you are to get results (eg more like wikipedia and less like...well the rest of Ubuntu)
17:12:54 <dholbach> is there some kind of TODO list for the docs project?
17:13:18 <jbicha> ubuntu-docs (and similarly for the server guide or xubuntu, kubuntu, etc.) does require a fair bit of knowledge: the format (docbook or mallard) is similarish to html but different, bzr and LP have a rough learning curve (even though they are easier than some things), good English skills, and you have to know your topic or devote time to learn it
17:14:16 <pleia2> jbicha: is there a "how to contribute" page that defines the skills needed and gives links to resources?
17:14:22 <phillw> yeah, I'm not looking forward to bzr and LP :/ Once I've mastered it, I may be help out a bit for obvious typos etc.
17:14:26 <jbicha> dholbach: not really, there's some LP bugs and the regular "figure out what's different in Ubuntu this cycle and make updates"
17:15:00 <dholbach> pleia2, there's https://wiki.ubuntu.com/Jams/Docs I know of
17:15:00 <jbicha> pleia2: it's a bit out-dated but there's some things at https://wiki.ubuntu.com/DocumentationTeam/
17:15:05 <dholbach> which might be nice for this weekend
17:15:29 <pleia2> yeah, https://wiki.ubuntu.com/DocumentationTeam/Organization#Requirements_for_Ubuntu_Documentation_Committers doesn't even mention mallard
17:15:37 <jbicha> for mallard, #docs on irc.gnome.org can help a lot, we've effectively needed to fork the GNOME Desktop Guide for the Ubuntu one any way
17:16:04 <pleia2> jbicha: if I drafted some easier instructions, would you be willing to review them so we can get this updated?
17:16:08 <jbicha> http://projectmallard.org/
17:16:34 <jbicha> pleia2: yes I should be able to review that
17:16:40 <hannie> At the manual we use bzr and LP. There are extensive instructions on the manual side and newcomers can ask help via mailing list
17:16:52 <hannie> *site
17:18:00 <pleia2> (I've been interested in improving this for a while, worked with j1mc a few UDSs ago but unfortunately didn't make a huge amount of progress and he's mostly moved on)
17:18:10 <jbicha> the other problem is that when you have people that learn bzr and lp too well, they may jump into contributing elsewhere (like I did)
17:18:55 <pleia2> hannie: yeah, I think that helps a lot (and I'll take a look at those again :))
17:19:11 <hannie> It really works
17:19:11 <jbicha> j1mc might come back if we need him, I think he just thought it's more useful to contribute upstream
17:19:26 <pleia2> jbicha: yeah, that's the impression I got
17:19:31 <jbicha> he also went against the grain and switched from XFCE *to* GNOME when GNOME Shell came out
17:19:41 <pleia2> hehe
17:19:54 * pleia2 just added the Unity keybindings to her Xfce
17:20:54 <YokoZar> I am beginning to think most people don't quite get the difference between docs and the manual
17:21:00 <YokoZar> or even help.ubuntu.com
17:21:10 <pleia2> the docs are help.ubuntu.com :)
17:21:12 <jbicha> also if anyone's interested in docs, check out http://openhelpconference.com/ I went last year and it was great, even though it was in Ohio, we had several from Canada and a few from Europe and even further come
17:21:16 <pleia2> /community is the wiki
17:21:23 <Gwaihir> I think there is some confusion between wiki, the help we ship in the distro, and the manual project
17:21:28 <YokoZar> It seems intuitive to only expect one writing source
17:21:35 <jbicha> it's run by shaunm, the guy who created Mallard for GNOME
17:22:59 <jbicha> bkerensa was working on adding yet another help source using the Mozilla Support framework but that may have been abandoned by now
17:23:12 <pleia2> jbicha: what does a release cycle for docs look like?
17:23:57 <jbicha> historically we don't necessarily do much until Feature Freeze or UI Freeze, and then it's a mad dash to get things done before Docs Freeze
17:24:04 * pleia2 nods
17:24:31 <pleia2> so I'm thinking the rest of the cycle is good time to start getting people up to speed with how to use tools, fixing small errors and things we know changed
17:25:04 <dholbach> the current discussion on u-devel@ might benefit the docs team then? :)
17:25:07 <beuno> jbicha, had any time to reflect how rolling releases is going to affect this?  :)
17:25:21 * beuno high-fives dholbach
17:25:26 <dholbach> beuno, o/ \o
17:26:19 <jbicha> beuno: well at least we don't have to worry about the version number being out of date...
17:26:32 <dholbach> what do you think might be a good way to recruit new doc team members?
17:26:39 <jbicha> it would also allow someone to contribute at any time and get their work in to Ubuntu fairly quickly
17:26:54 <jbicha> but I'm not sure the translators will be very thrilled about that..
17:27:31 <pleia2> yeah, I'm thinking docs may still need to stay on some sort of freeze schedule for translators
17:27:36 <pleia2> even if it turns into yearly
17:28:16 <jbicha> I'm figuring that we'll have some sort of train like the mozilla train and docs freeze may be on the early side to give docs translators time
17:28:19 <hannie> Translators usually finish the GUI first, before they start with docs
17:28:23 <YokoZar> I'm more worried that without a regular release process we'll simply lose track of what is and isn't irrelevant
17:29:17 <YokoZar> So, say new feature X lands in Ubuntu some day; I don't think it's part of anyone's process to go "hmm X replaced Y, we better mark the docs for Y as needing update" or whatever
17:29:33 <YokoZar> and indeed the feature landing in Raring may be the first opportunity the docs team has to actually document it!
17:29:46 <YokoZar> *raring = rolling current unstable
17:29:57 <pleia2> does anyone else attending this meeting have comments about the current status of the doc team? (or Ubuntu docs in general?)
17:31:57 <YokoZar> As an upstream Wine guy, I will say that when we moved our FAQ from source control to a wiki it became less than 5 years out of date
17:32:30 <YokoZar> wikis have dead pages and obsolete pages and all that entails, of course, but the FAQ itself was reasonably updated
17:33:17 <pleia2> the community-maintained docs are pretty extensitive (though there is still a lot that's unmaintained, the wiki team has a tagging system to identify out of date pages)
17:33:30 <hannie> Can anyone give me a link to docs-wiki?
17:33:39 <pleia2> hannie: help.ubuntu.com/community
17:33:46 <hannie> thanks
17:34:11 <phillw> o/
17:34:52 <phillw> back a while back, there was discussion of having the ability to convert from wiki format to docbook / mallard.... did anything come of this?
17:35:17 <phillw> I know there is a convert routine from Vbulletin (forum) to wiki that is up and running.
17:36:52 <hannie> you mean https://launchpad.net/~ubforums2ubwiki
17:37:55 <phillw> hannie: I assume so, I know of it from the forum guys doing a convert of a tutorial for lubuntu into wiki format (I think we were one of the guinea pigs).
17:38:16 <YokoZar> I seem to remember some people saying the migration tools for wiki -> mallard weren't the best
17:38:41 <phillw> YokoZar: okies, thanks. Just a line of thought I had :)
17:39:12 <YokoZar> phillw: Yeah I think it would be quite nice if that was the workflow and only one person had to bother with mass script conversion, but it doesn't seem to be the case.
17:39:57 <phillw> yeah, I have yet to endure learning  bzr / LP / commits etc. But it is on my list of things to do.
17:39:59 <YokoZar> It's certainly easier for a less technical person to edit a wiki page and review it periodically than to decipher a new format, bzr, and our merge process
17:40:20 <pleia2> for the xubuntu docs rewrite last year we did a mostly manual moin to docbook conversion, it got the docs written (woo, goal!) but docbook conversion fell to one guy and I'm glad it wasn't me :)
17:41:21 <hannie> phillw, you can always ask help on ubuntu-manual@lists.launchpad.net
17:41:49 <pleia2> phillw: it's less scary once you just dive in, and there are lots of people in the community who can help :)
17:41:51 <phillw> hannie: I've got to learn the quality system 1st, but I'm sure most of that will transfer over.
17:42:19 <phillw> pleia2: nicholas skaggs has wriiten up some tutorials for me to follow :)
17:42:45 <pleia2> yay
17:42:57 <phillw> I'm sure they would be of use to help updating the 'intoduction to docs' team as well.
17:43:18 <hannie> Has anyone thought of using LaTeX?
17:43:52 <YokoZar> pleia2: that seems like something that might be partially automateable
17:44:17 <pleia2> YokoZar: yeah, it was "mostly manual" so there was a script that caught a lot of things but then manual fixing of a lot
17:45:52 <cprofitt> very good conversation about the docs team
17:46:48 <cprofitt> Gwaihir: sorry for scrolling back, but I agree that many do not understand the difference between the manual and the wiki
17:48:23 <hannie> What do you mean by "difference"? there is no relation between manual and wiki
17:49:57 <cprofitt> hannie: exactly that
17:50:15 <cprofitt> the team has people who work on one or the other, or both
17:50:38 <cprofitt> but many people looking to join do not realize that both the wiki and the manual are part of the docs team
17:50:48 <cprofitt> they are familiar with one or the other of the resources
17:50:57 <cprofitt> other people think they have to do both to be on the docs team
17:51:42 <pleia2> I don't think the manual is strictly part of the ubuntu doc team
17:52:11 <pleia2> the doc team governs official docs that are shipped (and posted to help.ubuntu.com) and the community maintained help wiki at help.ubuntu.com/community
17:52:31 <hannie> Ok, I see what you mean. Can you use the Ubuntu weekly to do some explaning on manual and wiki, and contributors needed?
17:52:40 <hannie> *explaining
17:52:47 <pleia2> hannie: if you give me a blog post link, we'll include it :)
17:53:10 <pleia2> (or if you need me to blog about it, I could use some reviewers)
17:53:11 <dholbach> is there anything you feel the CC could help you with?
17:53:49 <hannie> pleia2, I mean someone from the docs team should write an article on this for the Ubuntu weekly
17:53:58 <pleia2> hannie: oh, I see
17:54:14 <pleia2> I'll see about writing something up
17:54:51 <cprofitt> this wiki page does a nice job, but many do not find it
17:54:52 <cprofitt> https://wiki.ubuntu.com/DocumentationTeam/Organization
17:55:50 <pleia2> yeah, perhaps just pointing that out would be enough
17:56:06 <pleia2> hannie: can I bug you to do a review once I have a draft to make sure it answers your questions?
17:56:18 <hannie> pleia2, sure
17:56:31 <pleia2> great
17:56:51 <pleia2> #action pleia2 to draft improvements to doc team getting involved and have jbicha review
17:56:51 * meetingology pleia2 to draft improvements to doc team getting involved and have jbicha review
17:57:06 <pleia2> #action pleia2 to draft blog post explaining parts of the ubuntu doc team
17:57:06 * meetingology pleia2 to draft blog post explaining parts of the ubuntu doc team
17:57:21 <pleia2> no more actions for pleia2
17:57:37 <pleia2> anyone else have any comments before we wrap this up?
17:57:58 <pleia2> I'm very glad we had this conversation, thanks everyone :)
17:58:21 <jbicha> pleia2: thank you
17:58:21 <dholbach> yes, thanks a lot everyone! and thanks for your hard work on this!
17:58:26 <phillw> nice to touch base with the others, thanks for arranging it pleia2
17:58:45 <hannie> do we get a link to the meeting logs shortly?
17:59:06 <phillw> hannie: as soon as the meeting ends :)
17:59:12 <hannie> right
17:59:34 <pleia2> #endmeeting