16:04:23 <arosales> #startmeeting ubuntu-server-team
16:04:23 <meetingology> Meeting started Tue Dec  4 16:04:23 2012 UTC.  The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:04:23 <meetingology> 
16:04:23 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:04:39 <arosales> #topic Review ACTION points from previous meeting
16:05:13 <arosales> hmm, where the action points updated from the previous meeting . . . ?
16:05:20 <arosales> Daviey to fix the release bugs report
16:05:24 <jamespage> thats the one
16:05:32 <arosales> everyone look through http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:05:37 * jamespage proposes we scrap that report
16:05:48 <jamespage> its actually working aside from the fact it says 'Quantal'
16:06:04 <jamespage> but we are not using the subscribe ubuntu-server-release method any more
16:06:08 <arosales> hmm is the release team using that report still?
16:06:18 <jamespage> use this report instead: http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:06:36 <jamespage> arosales, thats not the report Daviey is mean't to be fixing
16:06:54 <jamespage> arosales, thats this one -http://reqorts.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:07:08 <arosales> jamespage: to confirm what report were you suggesting to scrap?
16:07:18 <jamespage> http://reqorts.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:07:46 <arosales> and that was the one Daviey was going to review, correct?
16:08:10 <jamespage> he was going to fix yes
16:08:34 <arosales> #action move to http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server for release bug tracking
16:08:34 * meetingology move to http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server for release bug tracking
16:08:41 <zul> i like that one less nova/openstack bugs
16:08:47 <arosales> #action deprecate http://reqorts.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:08:47 * meetingology deprecate http://reqorts.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:09:04 <arosales> jamespage: is that the correct actions?
16:09:08 <Daviey> +1, i agree with that
16:09:11 <jamespage> +!
16:09:16 <jamespage> +1 even
16:09:34 <arosales> ok, got those logged as actoins
16:09:41 <arosales> *actions :-)
16:09:49 <arosales> #topic Raring Development
16:09:59 <arosales> #link https://wiki.ubuntu.com/RaringRingtail/ReleaseSchedule
16:10:14 <arosales> Alpha one coming up
16:10:49 <arosales> Daviey: do we need to notify the release team of server participating in A1, or is that just for flavors?
16:10:56 <jamespage> which server is not opting in to right?
16:10:57 <arosales> December 6th
16:10:58 <arosales> Alpha 1 (for opt-in flavors)
16:11:31 <arosales> sounds like we need to opt in too then .. .
16:11:48 <arosales> jamespage: to confirm server is _not_ going to opt into A1, correct?
16:12:03 <jamespage> correct AFAIK
16:12:14 <arosales> any other comments on A1?
16:12:15 <smoser> i dont think we've had this discussion. i dont see a strong reason for a fire drill.
16:12:38 <jamespage> +1
16:12:39 <smoser> but my general feeling is that milestones are useful targets. but not if they're 2 days from now.
16:12:57 <arosales> thats reasonable
16:13:10 <arosales> smoser: so we should plan on A2 then?
16:13:11 <arosales> February 7th
16:13:12 <arosales> Alpha 2 (for opt-in flavors)
16:13:29 <smoser> i would say we should definitely opt in to a feb 7 date.
16:13:42 <arosales> utlemming: not cloud images will also not opt in for A1, but lets plan on A2 to be in-line with server
16:13:47 <arosales> s/not/note/
16:14:01 <jamespage> sounds sane to me
16:14:01 <arosales> onto bugs
16:14:04 <smoser> worthy note, next set of cloud images should reliably boot. thakns to mountall fix.
16:14:04 <arosales> #subtopic Release Bugs
16:14:12 <jamespage> smoser, \o/
16:14:13 <utlemming> arosales: ack
16:14:34 <arosales> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:14:51 <arosales> since we are deprecating http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:15:21 <arosales> #action arosales update https://wiki.ubuntu.com/ServerTeam/Meeting/IRCCommands with new release bug link of  http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:15:21 * meetingology arosales update https://wiki.ubuntu.com/ServerTeam/Meeting/IRCCommands with new release bug link of  http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:15:57 <arosales> jamespage: smoser: should we at least step through the critical and maybe high bugs?
16:16:07 <arosales> bug http://launchpad.net/bugs/1081212
16:16:09 <ubottu> Launchpad bug 1081212 in maas (Ubuntu Quantal) "The address of the API in pserv.conf (tftp/generator) is http://localhost/MAAS/api/1.0/pxeconfig/" [Critical,Triaged]
16:17:02 <arosales> looks to be fixed in trunk and 1.2 mass, but uncertain of Ubuntu
16:17:17 <arosales> Daviey: ^
16:17:25 <smoser> arosales, i'd say that the maas bugs are probalby not worth going through here.
16:17:31 <jamespage> arosales, I'd ask roaksoax for general comment on the maas bugs; most of then are in hand upstream
16:17:38 <jamespage> and will land in the stablization release
16:18:05 <arosales> #action roaksoax to review MAAS bugs, and sync with upstream
16:18:05 * meetingology roaksoax to review MAAS bugs, and sync with upstream
16:18:22 <arosales> 1064224 is maas
16:18:23 <Daviey> arosales: hola
16:18:36 <arosales> 1069734 is maas
16:18:53 <arosales> sorry /me just noticed the package column . .
16:19:11 <arosales> so all these bugs are mass on the server list except http://launchpad.net/bugs/671065
16:19:13 <ubottu> Launchpad bug 671065 in dovecot (Ubuntu) "deliver broken because dovecot.conf uses !include_try" [Medium,In progress]
16:19:20 <arosales> and http://launchpad.net/bugs/1066845
16:19:21 <ubottu> Launchpad bug 1066845 in nova (Ubuntu Raring) "nova-novncproxy is not running; Suggest: novnc should be Depends" [Low,Triaged]
16:20:10 <arosales> 671065 looks like it wasn't going to be fixed in Quantal, any ideas on Raring?
16:20:40 <arosales> jamespage: It looks like you commented on it being to late for Quantal and bumping to Raring
16:20:52 <jamespage> arosales, I'll take it
16:21:18 <arosales> ivoks was also working on it.
16:21:48 <arosales> zul any comments on 1066845
16:21:55 <arosales> low priority . .  .
16:22:05 <zul> arosales: should already be fixed in raring
16:22:36 <arosales> zul: could you please update the bug with that info?
16:22:43 <zul> yep
16:22:52 <arosales> thanks
16:22:57 <arosales> thats it for bugs.
16:23:04 <arosales> unless anyone has any others.
16:23:47 <arosales> ok moving on
16:23:47 <arosales> #link http://status.ubuntu.com/ubuntu-raring/ubuntu-server.html
16:24:14 * arosales noticed http://status.ubuntu.com/ubuntu-raring/ wasn't picking up the servercloud area
16:24:30 <arosales> #action arosales to investigate why status tracker is not picking up servercloud area
16:24:30 * meetingology arosales to investigate why status tracker is not picking up servercloud area
16:25:20 <arosales> the "todos" are currently staying below the trend line, which is nice
16:26:09 <arosales> actually the topics at http://status.ubuntu.com/ubuntu-raring/ubuntu-server.html don't look correct
16:26:37 <arosales> hmm status tracker doesn't look to be in a healthy state, I don't think we can trust the info atm.
16:27:30 <arosales> https://blueprints.launchpad.net/~ubuntu-server?searchtext=servercloud+r
16:27:32 <arosales> sorry
16:27:35 <arosales> #link https://blueprints.launchpad.net/~ubuntu-server?searchtext=servercloud+r
16:28:01 <arosales> and possibly https://blueprints.launchpad.net/~ubuntu-server/+upcomingwork
16:28:20 <arosales> if the BPs are targetted correctly ;-)
16:28:36 <arosales> assuming the BPs are targetted correctly
16:28:48 <arosales> WI due for A1 (dec 6) look to be done
16:29:03 <arosales> as there are none ;-)
16:29:17 <arosales> juju-core as some upcoming for dec 13
16:29:57 <arosales> any BPs folks want to bring up here?
16:30:22 <arosales> btw: smoser, jamespage: Daviey: are you guys targetting BPs?
16:30:28 <jamespage> arosales, yes
16:30:43 <jamespage> but they need to be reviewed as the month ones did not exists when we did it first time
16:30:56 <arosales> cool, so perhaps https://blueprints.launchpad.net/~ubuntu-server/+upcomingwork may be a good review of upcoming work that needs addressed . ..
16:30:57 <arosales> thoughts?
16:30:59 <jamespage> Daviey, smoser: we need to review/approve the final few for the release and then retarget
16:31:11 <smoser> yeah.
16:31:38 <arosales> who would like the action there?
16:31:46 <smoser> me is fine
16:31:47 <jamespage> yes please
16:32:01 <arosales> #action jamespage, smoser: we need to review/approve the final few BPs for the release and then retarget
16:32:01 * meetingology jamespage, smoser: we need to review/approve the final few BPs for the release and then retarget
16:32:17 <arosales> ok, any BPs folks would like to bring up?
16:32:54 <arosales> #action jamespage, arosales confirm if https://blueprints.launchpad.net/~ubuntu-server/+upcomingwork should be used in ubuntu-server team IRC meeting for BP status
16:32:54 * meetingology jamespage, arosales confirm if https://blueprints.launchpad.net/~ubuntu-server/+upcomingwork should be used in ubuntu-server team IRC meeting for BP status
16:33:19 <arosales> moving to next topic
16:33:21 <arosales> #topic Ubuntu Server Team Events
16:33:59 <jimbaker> scalex cfp deadline is next monday (dec 10)
16:34:07 <arosales> negronjl: will be at Lisa Dec 9-14 doing a BOF (http://www.usenix.org/event/lisa12/cfp/)
16:34:15 <m_3> ah, thanks for the reminder jim
16:34:45 <arosales> m_3: and jcastro at scale it looks like from https://juju.ubuntu.com/Events/
16:34:57 <arosales> any other events for server?
16:35:19 <arosales> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:35:31 <hggdh> hi
16:36:02 <hggdh> no real news, except that I want to look at the ec2 test automation to drive kernel tests. Will chat with jamespage later on
16:36:07 <hggdh> ..
16:36:13 <arosales> hggdh: is that via UTAH?
16:36:25 <hggdh> arosales: no, it is outside UTAH
16:36:55 <hggdh> arosales: move to UTAH will depend on the kernel team
16:37:06 <arosales> hggdh: is cloud deployments on UTAH's road map?
16:37:42 <hggdh> arosales: it is beneath the horizon right now, but it has been considered
16:38:04 <arosales> hggdh: ok, thanks for the update. We'll also ask smb about kernel and utah in the next topic :-)
16:38:10 <arosales> any questions/comments for hggdh?
16:38:11 <hggdh> heh
16:38:26 <arosales> thanks hggdh for the update
16:38:31 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:38:33 <smb> Hello. I wanted to bring up two things. First to clarify the slight confusion I was causing last time with respect to rolling kernel. So the ISOs for 12.04.2 will have the quantal kernel and quantal x stack but that is under the name of enablement stack, not the rolling kernel as I incorrectly brought up.
16:39:06 <smb> The plan with rolling kernel updates really has been put back.
16:39:24 <hggdh> smb: so default kernel keeps the same, correct?
16:39:31 <smb> https://wiki.ubuntu.com/KernelTeam/Specs/QuantalLTSEnablementStack  (#9)
16:39:32 <arosales> smb: so folks can keep on the precise kernel, and still get updates
16:39:54 <smb> If they use the 12.04 or 12.04.1 cds for install and upgrade yes
16:40:08 <smb> When using the 12.04.2 cds they get the newer kernel
16:40:17 <arosales> smb: great, thanks for the clarification
16:40:26 * hggdh is quite confused now
16:40:28 <arosales> #link https://wiki.ubuntu.com/KernelTeam/Specs/QuantalLTSEnablementStack
16:40:31 <smb> Ok, the second thin, I am not sure it was already discussed
16:40:40 <smb> (brain unfortunately has multitasking issues)
16:40:53 <smb> So right now Xen-4.2 is in raring-proposed
16:41:22 <smb> This causes xen-api (xcp-xapi) to have issues because the xl api is incompatible
16:41:40 <smb> And this is probably also keeping nova back in proposed
16:42:29 <smb> AFAIK this is known to the xcp guys but until resolved everything is kept back in proposed
16:42:35 <smb> ..
16:42:39 <arosales> hggdh: any clearer now?
16:42:47 <hggdh> aye
16:43:08 <arosales> I think the important piece for server is point 9 in https://wiki.ubuntu.com/KernelTeam/Specs/QuantalLTSEnablementStack
16:43:25 <hggdh> but I do not see much difference from before -- new installs get the new kernel, updates from 12.04/12.04.1 get the old
16:43:43 <arosales> in that folks can continue to use the precise kernel and get updates
16:44:07 <smb> I think the big difference is what and how things get enforced. The rolling kernel plan would have moved people automatically
16:44:11 <arosales> I think the main point is an LTS getting non-LTS stack option (ie rolling)
16:44:42 <hggdh> yes, and the need to support both on all
16:45:20 <arosales> smb: ya forcing folks to upgrade their LTS kernel would have been a bit scary, thanks for keeping the option to stay on the precise kernel.
16:45:54 <arosales> smb: hggdh had a question regarding UTAH and kernel testing
16:46:08 <smb> yep
16:46:20 <arosales> smb: is kernel team going to be using UTAH in their testing?  (perhaps smb can provide some more context)
16:46:38 <arosales> sorry perhaps hggdh can provide more context :-)
16:46:48 <smb> arosales, I can forward that question to the people doing it
16:46:50 <smb> :)
16:46:58 <arosales> smb: ok thanks
16:47:08 <arosales> any other questions for smb?
16:47:22 <hggdh> I do not think the kernel team is looking at porting to UTAH right now
16:47:43 <arosales> smb: thanks for the update
16:47:48 <arosales> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:48:04 <rbasak> The highbank installer is broken in quantal and we should have a fix shortly (bug 1084106). Nothing else to report. Any questions for me?
16:48:05 <arosales> rbasak: any news on the ARM front ?
16:48:07 <ubottu> Launchpad bug 1084106 in The Eilt project "highbank installer broken" [Undecided,Triaged] https://launchpad.net/bugs/1084106
16:48:33 <arosales> I'll take it no further questions for rbasak.
16:48:38 <arosales> rbasak: thanks for the update.
16:48:47 <arosales> #topic Open Discussion
16:49:37 <arosales> any topics folks would like to discuss
16:49:50 <arosales> going 1 . .
16:49:51 <arosales> 2 . .  .
16:49:53 <arosales> 3. . .
16:50:03 <arosales> #topic Announce next meeting date and time
16:50:03 <TheLordOfTime> guess not :P
16:50:10 <arosales> :-)
16:50:23 <arosales> next meeting is: Tuesday 2012-12-11 at 1600 UTC
16:50:38 <arosales> thanks for joining, and your time
16:50:44 <arosales> #endmeeting