16:02:33 <roaksoax> #startmeeting
16:02:33 <meetingology> Meeting started Tue Aug 21 16:02:33 2012 UTC. The chair is roaksoax. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02:33 <meetingology>
16:02:33 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02:33 <arosales> hello
16:02:46 <roaksoax> [TOPIC] Review ACTION points from previous meeting
16:03:05 <roaksoax> it seems there were no actions. Unless missing from the wikipage
16:03:15 <roaksoax> if there are none, lets move on
16:03:24 <roaksoax> [TOPIC] Quantal Development
16:03:33 <roaksoax> [LINK] Release Bugs - http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:03:50 <roaksoax> bug 1028453
16:03:52 <ubottu> Launchpad bug 1028453 in ubuntu-meta (Ubuntu) "Quantal Ubuntu Server minimal install oversized" [High,Confirmed] https://launchpad.net/bugs/1028453
16:04:04 <roaksoax> is assigned to the whole team, has anyone been able to look at it
16:04:05 <roaksoax> ?
16:04:32 <arosales> I think Daviey said he had taken a look recently
16:05:02 <roaksoax> Daviey: ^^
16:05:04 <roaksoax> smoser: ^^
16:05:11 <roaksoax> who's taking care of that bug
16:05:44 <smoser> well, it wasn't me .
16:05:48 <roaksoax> let's move on in the meantime since they seem to be afk
16:05:51 <smoser> yeah.
16:05:57 <smoser> you can #action me
16:05:58 <roaksoax> bug 1028503
16:05:59 <ubottu> Launchpad bug 1028503 in cloud-init (Ubuntu) "support creating initial user if not present" [High,Triaged] https://launchpad.net/bugs/1028503
16:06:12 <smoser> #action smoser follow up on bug 1028453
16:06:12 * meetingology smoser follow up on bug 1028453
16:06:13 <ubottu> Launchpad bug 1028453 in ubuntu-meta (Ubuntu) "Quantal Ubuntu Server minimal install oversized" [High,Confirmed] https://launchpad.net/bugs/1028453
16:06:20 <roaksoax> smoser: thanks smoser
16:06:25 <utlemming> roaksoax: in progress and will have an MP on that later today
16:06:40 <roaksoax> utlemming: awesome, could you please assign it to you? :)
16:06:50 <roaksoax> alright, moving on: bug 1030914
16:06:52 <ubottu> Launchpad bug 1030914 in python-glanceclient (Ubuntu) "trying to overwrite '/usr/bin/glance', which is also in package glance-client" [High,Confirmed] https://launchpad.net/bugs/1030914
16:06:53 * utlemming begrudgingly assigns to self
16:07:12 <roaksoax> zul: ^^?
16:07:37 <roaksoax> adam_g: or you?
16:08:01 <zul> roaksoax: on it
16:08:08 <roaksoax> great thanks!
16:08:10 <roaksoax> bug 1034701
16:08:10 <zul> sorry i just lost track of time on the meeting
16:08:11 <ubottu> Launchpad bug 1034701 in horizon (Ubuntu Quantal) "ImportError: Could not import settings 'openstack_dashboard.settings': missing dependency on python-glanceclient" [High,Triaged] https://launchpad.net/bugs/1034701
16:08:20 <roaksoax> zul: i guess that's yours too? :)
16:08:40 <zul> roaksoax: im thinking thats already fixed but ill double check
16:08:59 <roaksoax> alright, thank you
16:09:12 <roaksoax> bug #1028509
16:09:13 <ubottu> Launchpad bug 1028509 in nova (Ubuntu) "'nova rescue' fails if an instance image does not have a kernel_id" [Medium,Confirmed] https://launchpad.net/bugs/1028509
16:09:21 <roaksoax> zul is the winner again :)
16:09:28 <zul> effing
16:09:43 <roaksoax> and bug #995285
16:09:45 <ubottu> Launchpad bug 995285 in nova (Ubuntu Quantal) "if /etc/sudoers.d/nova_sudoers is removed, upgrades fail" [Low,Triaged] https://launchpad.net/bugs/995285
16:09:55 <roaksoax> zul: sounds like fun times
16:10:10 <zul> no...it isnt
16:10:21 <roaksoax> hehe
16:10:24 <roaksoax> anyways, bug #1014005
16:10:26 <ubottu> Launchpad bug 1014005 in ipxe (Ubuntu) "Please generate and include ipxe.dsk to the ipxe binary package" [Wishlist,Triaged] https://launchpad.net/bugs/1014005
16:10:36 <roaksoax> anyone would like to take care of it?
16:10:48 <hallyn> oh hm. i guess that will have to be me
16:11:01 <roaksoax> thanks hallyn
16:11:04 <roaksoax> bug #1024281
16:11:06 <ubottu> Launchpad bug 1024281 in python-glanceclient (Ubuntu) "Bug during installation. conflicts: python-glanceclient + glance-client" [Undecided,Confirmed] https://launchpad.net/bugs/1024281
16:11:17 <zul> dupe
16:11:26 <roaksoax> alright,
16:11:28 <roaksoax> bug #858867
16:11:30 <ubottu> Launchpad bug 858867 in cobbler (Ubuntu) "XMLRPC allows unauthed users access to various methods (which it shouldn't) " [Medium,Triaged] https://launchpad.net/bugs/858867
16:11:31 <roaksoax> fix released
16:11:42 <roaksoax> bug #1023066
16:11:43 <ubottu> Launchpad bug 1023066 in quantum (Ubuntu) "python-quantum fails to install due to python syntax errors" [High,Triaged] https://launchpad.net/bugs/1023066
16:11:45 <roaksoax> adam_g: updates?
16:12:02 <roaksoax> guess he is not around, let's skip.
16:12:05 <roaksoax> bug 1025203
16:12:07 <ubottu> Launchpad bug 1025203 in quantum (Ubuntu) "Trying to overwrite '/etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini', which is also in package quantum-server" [High,Triaged] https://launchpad.net/bugs/1025203
16:12:09 <roaksoax> zul: any updates?
16:12:27 <zul> roaksoax: not yet hopefully will have a fix this week
16:12:37 <roaksoax> alright, finally
16:12:41 <roaksoax> bug 844995
16:12:43 <ubottu> Launchpad bug 844995 in python-couchdb (Ubuntu) "Drop support for couchdb related packages" [Undecided,Triaged] https://launchpad.net/bugs/844995
16:13:21 <roaksoax> anyone taking care of it
16:13:27 <roaksoax> it doesn't seem to be much to be done
16:13:41 <zul> i thought it was done...daviey did an upload
16:13:47 <SpamapS> how can any of us do anything?
16:13:52 <roaksoax> yeah it seems so
16:13:53 <SpamapS> seems like its just an archive admin thing
16:13:57 <roaksoax> indeed
16:14:03 <roaksoax> alright, let's move on then
16:14:07 <adam_g> roaksoax: sorry, the quantum upload are still blocked on MIRs AFAIK
16:14:08 <roaksoax> [LINK] Blueprints - http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:14:12 <Daviey> I did the upload required for the other task
16:14:17 <Daviey> that is an AA task
16:14:27 <roaksoax> Daviey: thanks ;)
16:14:38 <arosales> roaksoax: I have a few high /essentials in the red to go over if thats ok.
16:14:47 <Daviey> <--- on a call
16:14:52 <roaksoax> arosales: please do
16:15:03 <arosales> So feature freeze is this Thursday and beta1 is next week. 68% way through the release.
16:15:24 <arosales> If we could start evaluating which work items will need to be postponed this will help notify folks at a reasonable time that a feature won't make it instead of surprising them close to time of release.
16:15:48 <arosales> zul: are the following openstack BPs progressing ok? Perhaps these are items that land late in the cycle due to the OpenStack release schedule.
16:16:00 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-qa
16:16:00 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-folsom
16:16:00 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-stable
16:16:28 <zul> arosales: the openstack-qa and opestack-stable doesnt affect feature freeze and i think we are ok for openstack-folsom
16:16:41 <arosales> zul: ok thanks.
16:16:47 <arosales> roaksoax: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-ha
16:17:10 <roaksoax> arosales: 1 thing waiting on AA work
16:17:26 <arosales> roaksoax: thanks
16:17:28 <roaksoax> the rest waiting on Debian, so I'll catch up today/tomorrow and make necessary uploads
16:17:41 <arosales> great, thanks
16:17:45 <arosales> bug-triage-review and iso-tests-review I will follow up with jamespage when he returns.
16:17:54 <arosales> Spamaps, I think we already hit on https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charms-release-policy yesterday
16:18:03 <arosales> m_3: jimbaker: is https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charm-unit-tests up to date?
16:18:36 <SpamapS> we did
16:18:40 <SpamapS> email drafting today :)
16:18:59 <arosales> SpamapS: thanks
16:19:23 <arosales> utlemming: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-jenkins-cloud-builder
16:20:07 <utlemming> arosales: it'll make it
16:20:26 <arosales> looking ok for beta1 next week?
16:20:34 <arosales> utlemming: ^
16:20:35 <utlemming> arosales: its almost done, I just need to flip the switch, which I think will happen tomorrow
16:20:44 <utlemming> arosales: yup
16:21:03 <jimbaker> arosales, i'm looking now
16:21:06 <utlemming> arosales: I was waiting till 12.04.1 to be safe
16:21:28 <arosales> utlemming: makes sense, and the external read-only jenkis and notifications coming post beta1?
16:21:51 <jimbaker> arosales, i don't think m_3 has gotten a chance to work on it. i know i haven't :)
16:22:05 <utlemming> arosales: no eta on the external jenkins instance, but that is not a blocker. That can be implemented any time with out affecting the build service.
16:22:12 <jimbaker> arosales, in terms of the blueprints update
16:22:15 <arosales> jimbaker: ok I'll sync up with you and m_3 later today on the pregress -- thanks
16:22:37 <arosales> those were the red high/essential BPs
16:22:54 <jimbaker> (our BPs are further behind than we are, fortunately)
16:22:58 <arosales> just one last suggestion to postpone work items that we know we aren't going to make :-)
16:23:19 <arosales> jimbaker: better that way then reverse :-)
16:23:24 <arosales> roaksoax: back to you
16:23:27 <jimbaker> arosales, for sure ;)
16:23:28 <roaksoax> alright
16:23:43 <arosales> did anyone else have any BPs to go over?
16:23:57 <roaksoax> so if there's no more to bring to the table on quantal development, let's move on, shall we?
16:24:10 <roaksoax> [TOPIC] 12.04.1 Development (jamespage & smoser)
16:24:12 <roaksoax> smoser:
16:24:12 <m_3> arosales: no, that unit test blueprint isn't up to date
16:24:27 <smoser> well, we're almost there.
16:24:27 <roaksoax> jamespage:
16:24:34 <arosales> m_3: roger that
16:24:36 <roaksoax> [LINK] http://people.canonical.com/~jamespage/server-sru/precise-sru.html
16:24:39 <smoser> its shipping on thursday.
16:24:42 <roaksoax> m_3: sorry about that
16:25:03 <roaksoax> smoser: do you want me to go over the SRU bugs?
16:25:04 <SpamapS> seriously impressive amount of bug fixes shipped
16:25:10 <smoser> i really dont think there is much to say, as there is not much that can be done at this point.
16:25:23 <roaksoax> alright, lets move on then
16:25:25 <smoser> if the bug isn't in -proposed, it is -updates, which is fine.
16:25:32 <smoser> er... -updates even.
16:25:51 <roaksoax> [TOPIC] Ubuntu Server Team Events
16:25:56 <roaksoax> any events coming up?
16:26:04 <SpamapS> CloudOpen/LinuxCon next week!
16:26:19 <SpamapS> adam_g and myself will be speaking about OpenStack and Juju respectively
16:26:34 <roaksoax> awesome
16:26:38 <SpamapS> I believe Canonical's VP of Cloud will also be keynoting
16:26:49 <Daviey> \o/
16:26:52 <SpamapS> http://events.linuxfoundation.org/events/cloudopen
16:27:03 <roaksoax> alright!
16:27:05 <arosales> also jimbaker @ https://sea.ucar.edu/event/service-orchestration-cloud-environments-juju next week giving a Juju preso.
16:27:06 <smb> XenSummit and Plumbers too
16:27:07 <SpamapS> Linux Plumbers is also co-located
16:27:25 <roaksoax> seems like there's good presence
16:27:26 <jimbaker> i was just asked to give a guest lecture on juju for the data center computing class at univ of colorado
16:27:33 <jimbaker> sometime end of sept
16:27:54 <roaksoax> that's nice!
16:28:00 <roaksoax> alright then! we hvae a whole bunch of events!
16:28:04 <SpamapS> And its in San Diego :)
16:28:04 <roaksoax> let's move on
16:28:17 <roaksoax> [TOPIC] Weekly Updates & Questions for the QA Team (hggdh)
16:28:22 <roaksoax> hggdh: you are up :)
16:29:01 <roaksoax> seems he is not around, let's get back to him later
16:29:06 <roaksoax> [TOPIC] Weekly Updates & Questions for the Kernel Team (smb)
16:29:12 <roaksoax> smb: howdy!
16:29:15 <smb> hi
16:29:18 <smb> Spent some time looking at bug 1011792. Only having stack traces
16:29:18 <smb> (even more so since those usually are from older kernels) does not
16:29:18 <smb> help too much. There are currently a few things which I asked them
16:29:18 <smb> to do try. Waiting on those answers (not too actively as I am
16:29:18 <smb> prematurely leaving towards San Diego tomorrow to have a few days
16:29:19 <smb> off before XenSummit and Plumbers which I am at. And maybe it can
16:29:20 <ubottu> Launchpad bug 1011792 in linux-lts-backport-oneiric (Ubuntu) "Kernel lockup running 3.0.0 and 3.2.0 on multiple EC2 instance types" [Critical,Confirmed] https://launchpad.net/bugs/1011792
16:29:21 <smb> be discussed there for more ideas in some hallway discussion.
16:29:27 <smb> utlemming, if lightning strikes and fires start burning during the
16:29:29 <smb> rest of this week, apw knows a bit about the topic now.
16:29:51 <smb> Apart from this, zul, if you remember that libvirt source package
16:29:52 <smb> you wanted to look at one of those days... IIRC you now need to
16:29:52 <smb> tweak it because there was yet another upload to Quantal. The
16:29:52 <smb> outdated version still is at chinstrap:~smb/4review.
16:29:58 <utlemming> smb: I was pinged last night after hours, but I missed it
16:30:15 <zul> frig
16:30:52 <smb> utlemming, I think there is now enough to let them gather data
16:31:03 <smb> At least enough to cover until next week... :-P
16:31:26 <smb> ..
16:32:43 <roaksoax> Alright, if theres nothing else to discuss with smb, lets move on! [TOPIC] Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:32:46 <roaksoax> err
16:32:55 <roaksoax> [TOPIC] Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:32:58 <rbasak> Nothing new to report. Any questions for me?
16:32:59 <roaksoax> rbasak: howdy!
16:33:43 <roaksoax> anyone questions for rbasak ?
16:33:45 <hallyn> rbasak: woudl you mind running the lxc-testsuite against arm if you get a chance?
16:33:58 <hallyn> i *think* a team is doing that regularly, but i like to make sure
16:34:05 <rbasak> hallyn: we were just discussing this today. I believe we already are, but perhaps an old version
16:34:36 <hallyn> ok, if it's being discussed, i'm happy :) thanks
16:34:42 <rbasak> it's on mreed's todo (I don't think he's here or in #ubuntu-server but he's working on it)
16:34:43 <hallyn> (that reminds me i have a fix i need to push to bzr in the tests)
16:34:48 <hallyn> great, thanks
16:35:16 <roaksoax> alright, if there's nothing else to discuss here
16:35:19 <roaksoax> lets move on
16:35:22 <roaksoax> [TOPIC] Open Discussion
16:35:29 <roaksoax> anyone has anything to discuss?
16:35:36 <SpamapS> meetings are too short
16:35:38 <SpamapS> lets make them longer
16:35:44 <SpamapS> and have more people talk at once
16:36:00 <SpamapS> maybe lots of ascii art diagrams?
16:36:01 <zul> i think its the right length
16:36:18 <zul> but then again whats the sound of one hand clapping
16:36:40 <roaksoax> \o/
16:37:08 <SpamapS> roaksoax: thanks for chairing
16:37:19 <roaksoax> glad to help :)
16:37:23 <roaksoax> alright, so
16:37:30 <arosales> roaksoax: thanks
16:37:33 <roaksoax> [TOPIC] Announce next meeting date and time
16:37:42 <roaksoax> same time/place, see you all next week
16:37:46 <roaksoax> #endmeeting