19:09:33 <micahg> #startmeeting
19:09:33 <meetingology> Meeting started Mon Aug 13 19:09:33 2012 UTC.  The chair is micahg. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:09:33 <meetingology> 
19:09:33 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:10:04 <micahg> #topic Review of previous action items
19:10:12 <micahg> #subtopic micahg to document the zentyal packageset
19:10:14 <micahg> carried
19:10:22 <micahg> #subtopic micahg to ping beuno regarding CC discussion on whether upload rights should confer membership
19:10:41 <micahg> this is now yokozar who agreed to start the discussion, so done
19:10:51 <micahg> #subtopic tumbleweed to contact ubuntu developers who haven't signed the CoC
19:10:56 <tumbleweed> contacted
19:11:09 <tumbleweed> no reply from scott
19:11:28 <micahg> right, so should we discuss at the end what to do about this?
19:11:55 <tumbleweed> sounds good
19:12:01 <micahg> moving on
19:12:07 <stgraber> sure, though I can only thing of one thing we can do...
19:12:10 <stgraber> *think
19:14:22 <micahg> #topic MOTU application for Jean-Louis Dupond
19:14:51 <dupondje> Approved ;)
19:16:44 <dupondje> You can view my application on https://wiki.ubuntu.com/JeanLouisDupond/MOTUApplication
19:16:59 <dupondje> Been active quite some time for Ubuntu, and a daily user.
19:17:23 <dupondje> Doing merges/syncs mostly, and also cryptsetup/remmina maintainer upstream (debian)
19:17:24 <micahg> #link https://wiki.ubuntu.com/JeanLouisDupond/MOTUApplication
19:18:07 <dupondje> And i'm working on Ubuntu when I have some spare time, so sometimes alot, sometimes a bit less :'(
19:18:52 * xnox lurks in due to highlight on cryptsetup
19:19:05 <dupondje> hello xnox  :)
19:20:53 <stgraber> dupondje: are you subscribed to ubuntu-devel-announce?
19:21:13 * xnox has a question for the candidate. 0/
19:21:27 <dupondje> And there is still much work todo on MOTU (https://merges.ubuntu.com/universe.html)
19:21:31 <dupondje> stgraber: https://lists.ubuntu.com/archives/devel-permissions/2012-August/000381.html
19:21:45 <dupondje> but not subscribed indeed
19:22:06 <stgraber> dupondje: I said ubuntu-devel-announce, not devel-permissions :)
19:23:07 <dupondje> i'm not no
19:23:33 <stgraber> ok, please make sure you're subscribed to it and read it daily
19:23:52 <stgraber> that's where the freeze announcements are announced, anyone who intends to upload to the archive should be reading it
19:23:57 <dupondje> Not much traffic on it it seems :)
19:24:09 <stgraber> indeed, it's low but very important traffic
19:24:27 <dupondje> Your subscription request has been received, done!
19:24:34 <stgraber> good
19:25:01 <stgraber> now, an hopefully quick other question
19:25:23 <dupondje> i'm open for it :)
19:25:28 <stgraber> let's say you're for some reason working on python-gevent
19:25:46 <stgraber> it's on the 4th of september
19:25:55 <stgraber> and your upload is a non critical bugfix
19:26:11 <bdrung> dupondje: image you want to upload vlc on September, 1st. are you allowed to do that?
19:26:21 <stgraber> assuming, you're a MOTU by then, will you be able to upload it?
19:26:40 <stgraber> bdrung: I see some overlap between our questions ;)
19:26:54 * bdrung nods.
19:28:01 <dupondje> bdrung: no, gotto ask permission first (and only bugfix releases (normally))
19:28:33 <bdrung> dupondje: assume that it's just a bug fix. permission for what?
19:28:57 <dupondje> stgraber: think a non-critical is not wanted, if its critical, I could consider asking the release team
19:29:11 <stgraber> dupondje: ok, why?
19:30:46 <dupondje> If the patch is small (and doesn't change any functionallity/api or break other things) its fine
19:31:07 <stgraber> actually, it's not, now guess why :)
19:32:32 <dupondje> stgraber: in general or for the python-gevent?
19:32:32 <dupondje> :)
19:32:58 <stgraber> in this case, python-gevent :)
19:33:23 <stgraber> though the same applies to vlc, as bdrung's question touches the same problematic
19:33:37 * stgraber shuts up now, that's way enough hints ;)
19:36:30 <stgraber> right, so we need to move on with the questions.
19:36:50 <stgraber> the answer to both bdrung and my questions is that we're in a freeze period at that point
19:37:08 <stgraber> and python-gevent is a dependency of python-x2go which is seeded by Edubuntu and so is covered by the freeze even if it's in universe
19:37:09 * dupondje checked https://wiki.ubuntu.com/FeatureFreeze
19:37:31 <stgraber> same thing for vlc that's part of mythbuntu
19:37:51 <stgraber> so these packages should only be touched with approval of the product manager and/or release team during the freeze periods
19:38:02 <stgraber> which are anonunced on ubuntu-devel-announce (hence the need to subscribe and read it)
19:38:56 <dupondje> Ok :) That was not very clear after reading https://wiki.ubuntu.com/FeatureFreeze
19:40:37 <micahg> dupondje: Feature Freeze != Milestone freeze
19:41:02 <stgraber> right, milestone freeze is completely different from feature freeze
19:41:16 <stgraber> and is also valid for alpha releases way before we get into feature freeze
19:42:31 <micahg> dupondje: you mention that you don't like the dev cycle since the whole cycle isn't available to do syncs/merges, how do you propose that the distro stabilize for a release?
19:42:39 <dupondje> milestone freeze is announced on the devel-announce, so I keep an eye on that
19:42:43 <barry> https://wiki.ubuntu.com/MilestoneProcess
19:43:23 <dupondje> micahg: I think the way debian does it is a nice option
19:43:34 <micahg> dupondje: Debian freezes for 6 months :)
19:43:55 <bdrung> (or more)
19:43:57 <dupondje> true, but advanced users can use the devel version (aka testing)
19:44:14 <bdrung> advanced users are not the main target of ubuntu
19:44:19 <micahg> testing (which is the next release) is what's frozen for months on end
19:46:04 <dupondje> well yea, but there should be a 'rolling version', where everything gets in after some testing
19:46:40 <micahg> dupondje: well, we do have the option for backports if we ever start opening that post feature freeze for things that qualify
19:46:43 <dupondje> but its indeed not the focus of ubuntu. Which isn't a problem ofcourse :)
19:47:40 <bdrung> dupondje: our 'rolling version' is currently called 'quantal' ;)
19:48:06 <dupondje> thats what i'm using atm :)
19:48:23 <dupondje> with almost no issues in fact
19:49:31 <dupondje> Its nice to see new stuff gets added, and everything is moving. But near to the release its getting a bit 'boring' :)
19:50:00 <dupondje> maby the next version should be started before the release of the next version (so it overlaps a bit)
19:50:33 <dupondje> cause now its perferred to do syncs/merges in the early dev stage :)
19:51:13 <dupondje> But a perfect solutions for everybody is indeed not possible :)
19:51:23 <micahg> dupondje: you do realize the intent of new uploads is to provide the best user experience, not be not-boring, right?
19:52:35 <dupondje> Its ofcourse most important that the release version is stable and gives a good user experience
19:52:46 <dupondje> but I also think some people prefer bleeding edge :)
19:55:19 <bdrung> dupondje: would it make sense to upload audacity 2.0.2 RC1 to quantal?
19:57:42 <dupondje> I think its preferred to stay in sync with debian, also better stay with stable releases (no beta/rc) if there is not a good reason
19:59:21 <micahg> xnox: did you have a quesiton?
19:59:31 <bdrung> dupondje: imagine that i upload audacity 2.0.2 RC1 to debian. should i do the sync?
19:59:55 <bdrung> dupondje: which are good reasons to upload beta/rc packages?
20:01:13 <dupondje> If the release of the stable version is soon (before ff), and if it fixes quite soms bugs :)
20:01:43 * bdrung nods.
20:02:42 <bdrung> xnox: you can ask your question now.
20:02:51 <micahg> well, RCs could also be useful if the final version is after feature freeze, but the upstream release is feature frozen and they keep to their timetables well enough to ensure a release before final freeze
20:03:44 <dupondje> alot of projects doesn't have a strict timetable tho :)
20:04:16 <bdrung> dupondje: they can be judged by their previous releases.
20:04:39 <micahg> see why we have Xfce 4.8 in precise :)
20:06:12 * dupondje is still using gnome-shell
20:06:17 <dupondje> feeling quite alone these days :)
20:08:22 <micahg> #voters barry tumbleweed Laney cody-somerville micahg stgraber bdrung
20:08:22 <meetingology> Current voters: Laney barry bdrung cody-somerville micahg stgraber tumbleweed
20:08:41 <micahg> #vote Grant MOTU upload rights to dupondje
20:08:41 <meetingology> Please vote on: Grant MOTU upload rights to dupondje
20:08:41 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:08:52 <bdrung> +1
20:08:52 <meetingology> +1 received from bdrung
20:09:34 <dupondje> and if I doubt on something, i'll stalk you guys in #ubuntu-motu :)
20:09:46 <stgraber> -1 [ I appreciate the technical skills and I'm not worried about that side of things. But I want to see more knowledge about the ubuntu release process before giving a +1 ]
20:09:46 <meetingology> -1 [ I appreciate the technical skills and I'm not worried about that side of things. But I want to see more knowledge about the ubuntu release process before giving a +1 ] received from stgraber
20:09:57 <dupondje> np
20:10:16 <barry> +0 [ for similar reasons ]
20:10:16 <meetingology> +0 [ for similar reasons ] received from barry
20:10:34 <micahg> +0 what stgraber said
20:10:34 <meetingology> +0 what stgraber said received from micahg
20:12:44 <tumbleweed> +0 [ I a also would like to see more knowledge of the release processes ]
20:12:44 <meetingology> +0 [ I a also would like to see more knowledge of the release processes ] received from tumbleweed
20:12:54 <micahg> #endvote
20:12:54 <meetingology> Voting ended on: Grant MOTU upload rights to dupondje
20:12:54 <meetingology> Votes for:1 Votes against:1 Abstentions:3
20:12:54 <meetingology> Deadlock, casting vote may be used
20:14:06 <bdrung> with the two remaining members +4 can't be reached any more.
20:14:11 <micahg> dupondje: sorry that we weren't able to grant this today, but please come back in a few months, you've done good work
20:14:34 <dupondje> ok np
20:15:21 <bdrung> dupondje: btw, it's good to see a good collaboration with debian
20:15:25 <dupondje> I keep it up :) and will read some more about the release process. Also I keep subscribed to the deval-announce :)
20:15:51 <bdrung> *devel-announce ;)
20:15:58 <dupondje> well yea :)
20:16:10 <tumbleweed> given the feature freeze coming up, there's lots of opportunity to see the process in action :)
20:16:18 <dupondje> bdrung: keeping the delta 0 is gives us less work :)
20:16:40 <bdrung> dupondje: i totally agree
20:17:00 <dupondje> and the debian guys are also happy their bugs gets fixed :)
20:17:36 <dupondje> and fixing the things in upstream (not debian, but the devel itself) is even better :)
20:18:03 <micahg> ok, moving on
20:18:10 <micahg> #topic what to do when uploaders no longer have the CoC signed
20:18:59 <micahg> so, as stgraber said, there seems to be only one course of action once they've been notified and given a chance to correct this, remove their upload rights until the sign the CoC
20:19:22 * bdrung agrees
20:19:57 <tumbleweed> as scott isn't using his upload rights, we also have the option of just ignoring it
20:19:58 <stgraber> +1
20:20:12 <stgraber> well, as he's not using it anyway, we might as well remove it :)
20:20:16 <tumbleweed> quite
20:20:18 * xnox will poke ev to poke scott about it =)
20:20:41 <micahg> ok, I think we can dispense with the formal vote here
20:20:49 * xnox just as another thing to make fun of =)
20:21:43 <tumbleweed> stgraber: have we dealt with all the inconsistencies that your report picked up?
20:22:00 <stgraber> tumbleweed: all but the langpack team
20:22:20 <stgraber> oh and I still need to cleanup coredev/motu duplicate package set rights
20:22:30 <micahg> #action remove scott from ubuntu-core-dev until he signs the CoC
20:22:30 * meetingology remove scott from ubuntu-core-dev until he signs the CoC
20:22:45 <tumbleweed> do I need to roll any of this into the membership check e-mail?
20:22:54 <micahg> #action stgraber to clean up coredev/motu duplicate package set rights
20:22:54 * meetingology stgraber to clean up coredev/motu duplicate package set rights
20:23:05 <micahg> #topic aob
20:23:53 <stgraber> tumbleweed: I don't think so, I can check from time to time but it shouldn't get any worse as long as we don't screw up ;)
20:24:10 <stgraber> it's really the historic stuff that's a bit of a mess, I think that all additions have been sane
20:24:16 <micahg> yeah, as long as we see who's expired, we just need to follow up on that
20:24:35 <tumbleweed> well, that's the main purpose of the weekly e-mail
20:26:23 <micahg> I think that's a wrap then
20:26:28 <tumbleweed> do we want to discuss scrapping any packagesets?
20:26:36 <micahg> tumbleweed: oh, we could I guess
20:26:58 <tumbleweed> I suppose the thing to do here is contact uploaders of packagesets that we don't think are used
20:27:16 <micahg> sounds good, want an action?
20:27:42 <tumbleweed> sure, I'll take it (pity Laney isn't here)
20:27:58 <micahg> tumbleweed: we have the option to voluntold :)
20:28:17 <tumbleweed> let's try that first. he seemed keenest
20:28:47 <micahg> #action laney (tumbleweed) to contact the uploaders of unused packagesets
20:28:47 * meetingology laney (tumbleweed) to contact the uploaders of unused packagesets
20:29:31 <tumbleweed> ok, i've had enough of this meeting, and want to go to bed
20:29:44 <micahg> #action next chair: cody-somerville (laney)
20:29:44 * meetingology next chair: cody-somerville (laney)
20:29:55 <micahg> #endmeeting