21:00:27 <soren> #startmeeting
21:00:27 <meetingology> Meeting started Mon Aug  6 21:00:27 2012 UTC.  The chair is soren. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:00:27 <meetingology> 
21:00:27 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:00:49 <soren> Short agenda today:
21:00:54 <soren> #link https://wiki.ubuntu.com/TechnicalBoardAgenda
21:01:10 <soren> pitti seems to be on holiday
21:01:21 <cjwatson> here
21:01:31 <cjwatson> boring agenda
21:01:35 <soren> I haven't seen apologies from anyone else.
21:01:56 <soren> #topic Action review
21:02:05 <soren> Soren: Brainstorm review
21:02:22 <soren> No progress. Vacation and conferences and whatnot. :(
21:02:31 <soren> #action Soren to finish brainstorm review
21:02:31 * meetingology Soren to finish brainstorm review
21:02:50 <soren> Anything else? Meetbot isn't very helpful from last meeting.
21:03:05 <soren> Guess not.
21:03:45 <soren> Gah, laggy connection. Crappy timing.
21:03:46 <cjwatson> anything in IRC logs?
21:03:47 <soren> Sorry guys.
21:04:12 * cjwatson has a quick look
21:04:14 <soren> There's the thing abut gut 252368
21:04:18 <soren> gut? bug!
21:04:26 <soren> bug 252368
21:04:27 <ubottu> Launchpad bug 252368 in Launchpad itself "Automatically associate DD and DM accounts with GPG keys in keyring packages to allow DDs to use the Launchpad Email interface" [Low,Triaged] https://launchpad.net/bugs/252368
21:04:59 <soren> It seems mdz was to follow up to the mailing list.
21:05:13 <cjwatson> IMO this is low priority and we should stop caring
21:05:13 <mdz> I didn't
21:05:20 <mdz> OK with me
21:05:30 <cjwatson> I can't understand why we're continuing to worry about it; there are many other more important things to do on LP
21:05:42 <soren> Alright. Officially intentionally not going to carry this over.
21:06:01 <cjwatson> I know we've been asked about it and there is some social importance to it
21:06:10 <cjwatson> But there are lots of other things in a similar position
21:06:39 * cjwatson skim-reading last fortnight's logs
21:06:45 <soren> I see no other action items
21:07:18 <soren> Moving on
21:07:18 <cjwatson> I don't see anything else carried over either
21:07:25 <soren> #topic MRE for point release mythtv in LTS
21:07:38 <soren> https://lists.ubuntu.com/archives/technical-board/2012-August/001357.html
21:07:59 <soren> It wasn't added to the agenda, but I guess we can still discuss it.
21:08:25 <soren> Is anyone here to represent this topic?
21:08:33 <kees> I've been pretty happy with the process (I use MythTV myself).
21:08:39 <stgraber> yeah, would be good to have this approved or rejected soon as they want to update mythtv for the 12.04.1 point release which is getting really close
21:08:46 <kees> I've found upstream to be good about doing fixes only.
21:09:10 <kees> I would be happy to approve a provisional MRE; though it would be nice if they had some kind of test suite.
21:09:32 <soren> superm1: Just in time :)
21:09:36 <stgraber> hey superm1
21:09:39 <superm1> hi folks
21:09:57 <stgraber> superm1: we're discussing your MRE request at the moment
21:10:27 <stgraber> do you know what kind of testing is done upstream for their stable release? do they have any kind of automated testing or strong manual testing prior to release?
21:10:27 <soren> (/msg'ed relevant scrollback)
21:10:33 <superm1> stgraber: yeah soren just shared with the scrollback, thanks soren
21:10:42 <soren> np
21:10:57 <superm1> stgraber: they have automated build testing, but other than that it's strong manual testing prior to point releases
21:11:19 <superm1> they heavily push the community to use their stable branch at all times when a problem comes up
21:11:52 <soren> Do they have multiple branches, so this is a maintenance branch while there's another one where the dev focus is?
21:12:14 <superm1> yes
21:12:22 <superm1> they have a fixes branch for every major release
21:12:26 <superm1> and a master branch for development
21:12:44 <superm1> no new features come to the fixes branch for any of the releases for any reason, it's solely bug fixes
21:13:06 <soren> How long are these branches usually maintained?
21:13:20 <superm1> up until the next major release
21:13:26 <soren> Is that time-based?
21:13:44 <superm1> they're moving to time based now i believe
21:13:54 <superm1> they were previously feature based (it'll be done when it's done)
21:14:08 <superm1> but they're pushing features out for later releases if they're not going to be ready in time, and doing development in topic branches to merge
21:14:51 <soren> Cool.
21:15:22 <soren> I don't have any other questions.
21:15:26 <soren> Anyone else?
21:15:35 <superm1> and to be clear, this is just for asking for the micro releases of the 0.25 release (which only one is expected), i don't think it will be appropriate to push to 0.26 ever to -updates, only maybe -backports
21:16:39 <soren> Oh, one more thing:
21:17:07 <soren> Is this just a single source package or do we need a list somewhere?
21:17:12 <cjwatson> It sounds reasonable enough to me
21:17:15 <superm1> single source package
21:17:38 <superm1> it used to be multiple source packages, but was a mess to sync up with archive skew
21:18:02 <soren> Cool.
21:18:04 <soren> Alright.
21:18:32 <soren> #vote Approve MRE for MythTV
21:18:32 <meetingology> Please vote on: Approve MRE for MythTV
21:18:32 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
21:18:49 <soren> +1
21:18:49 <meetingology> +1 received from soren
21:18:51 <stgraber> +1
21:18:51 <meetingology> +1 received from stgraber
21:19:08 <soren> mdz, kees:
21:19:23 <mdz> +1
21:19:23 <meetingology> +1 received from mdz
21:19:47 <soren> Going once..
21:19:57 <soren> Going twice
21:20:02 <soren> #endvote
21:20:02 <meetingology> Voting ended on: Approve MRE for MythTV
21:20:02 <meetingology> Votes for:3 Votes against:0 Abstentions:0
21:20:02 <meetingology> Motion carried
21:20:15 <superm1> great, thanks guys
21:20:25 <stgraber> superm1: FWIW I'm also granting you a 12.04.1 exception, so if you want it in the point release, please make sure it's uploaded ASAP
21:20:37 <superm1> stgraber: it's in the queue, just needs accepting
21:20:45 <soren> Lovely.
21:20:52 <soren> Moving on.
21:21:03 <soren> #topic check up on community bugs
21:21:54 <soren> So, given our discussion earlier, I'm going to go ahead an unassing us from https://bugs.launchpad.net/ubuntu-community/+bug/252368
21:21:55 <ubottu> Launchpad bug 252368 in Launchpad itself "Automatically associate DD and DM accounts with GPG keys in keyring packages to allow DDs to use the Launchpad Email interface" [Low,Triaged]
21:22:27 <soren> As for https://bugs.launchpad.net/ubuntu-community/+bug/174375
21:22:28 <ubottu> Launchpad bug 174375 in Launchpad itself "Distribution drivers permissions may need redesign" [Low,Triaged]
21:22:31 <mdz> I'm having network issues right now
21:22:31 <mdz> lagging a lot
21:23:19 <soren> I'm not sure what we need to discuss here still.
21:24:05 <soren> I guess I'm not the only one.
21:24:48 <cjwatson> We still need to get ubuntu-release-nominators out of ubuntu-release somehow; that team is a hack
21:25:17 <cjwatson> To some extent we've just moved the problem (albeit to somewhere less damaging)
21:26:15 <soren> I guess I'm not actually clear on what *we* are meant to do here.
21:26:35 <cjwatson> Specify what should be done on behalf of Ubuntu
21:26:58 <cjwatson> I think I might be able to take an action to progress this
21:27:24 <cjwatson> Since I think I understand both the security model we want and the relevant bits of LP code
21:27:42 <soren> Perfect!
21:28:19 <soren> Given that the individual stakeholders are who they are, it seems a bit awkward for us to have to drive it.
21:28:32 <cjwatson> But I currently have a toddler sitting on my lap so not so much right now
21:28:59 <soren> Well, this too has been sitting in LP for years.
21:29:09 <soren> Another day won't matter much.
21:29:11 <soren> Great.
21:29:26 <soren> #action cjwatson to look into https://bugs.launchpad.net/ubuntu-community/+bug/174375
21:29:26 * meetingology cjwatson to look into https://bugs.launchpad.net/ubuntu-community/+bug/174375
21:29:27 <ubottu> Launchpad bug 174375 in Launchpad itself "Distribution drivers permissions may need redesign" [Low,Triaged]
21:29:28 <cjwatson> We can't in general assume that the LP team understands what Ubuntu wants to get out of their security model - we have to tell them
21:30:13 <cjwatson> And the TB is the owner of the Ubuntu object in LP
21:30:37 <soren> cjwatson: Understood. I was rather thinking it would be delegated to the stakeholders on the Ubuntu side.
21:30:43 <cjwatson> Please no
21:30:46 <soren> ..but if you're doing it, we're covered for sure.
21:30:49 <cjwatson> We understand it better :)
21:31:00 <soren> Very well.
21:31:10 <cjwatson> The stakeholders are liaisons, not necessarily decision-makers
21:31:17 <cjwatson> (With that hat on, anyway)
21:31:30 <cjwatson> (Or at least that's how I understand it)
21:32:10 <soren> Well, we'd certainly have final say in it, but it's hard for us as a group to actually drive this issue forward.
21:32:24 <soren> But this is all academic since you've accepted the action item :)
21:32:26 <cjwatson> Yes; but nobody else really can either :)
21:32:28 <cjwatson> Yeah
21:32:42 <soren> #topic Any other business?
21:32:58 <cjwatson> We made excellent progress on it a while back in an in-person TB meeting, actually - we just haven't finished the job
21:33:05 <cjwatson> Nothing else from me
21:33:08 <mdz> none here
21:33:16 <soren> Who's the next chair? stgraber?
21:33:24 <stgraber> sounds right
21:33:57 <soren> #info Next meeting is set for Aug 20th, 2100 UTC. Chair is stgraber
21:34:04 <soren> #endmeeting