16:05:09 <coolbhavi> #startmeeting MOTU meeting
16:05:09 <meetingology> Meeting started Thu Jul 26 16:05:09 2012 UTC.  The chair is coolbhavi. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:05:09 <meetingology> 
16:05:09 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:05:19 <coolbhavi> hi all
16:05:35 * coolbhavi checks the latest agenda
16:06:06 <asomething> doesn't seem to have anything up for discussion...
16:06:27 <coolbhavi> yes asomething
16:06:32 <maco> mono: go!
16:06:42 * cody-somerville is here but in another meeting concurrently.
16:07:08 <coolbhavi> I had a couple of work items myself
16:07:19 * micahg hasn't gotten to his WI yet
16:07:36 <micahg> umm, how about scheduling an event where MOTU help Debian close RC bugs?
16:07:44 <micahg> most of them are RC in Ubuntu as well
16:07:58 <micahg> err...well, at least a good portion
16:08:25 <coolbhavi> micahg, certainly yes :)
16:08:39 <tumbleweed> micahg: I like that
16:08:45 <asomething> +1
16:09:24 <bdrung> sounds good (besides that it needs manpower which is a rare resource)
16:09:34 <micahg> by MOTU I mean the MOTU community, not just MOTUs as I'm sure most of those present understand
16:11:09 * bdrung nods.
16:11:31 <coolbhavi> micahg, sounds good.. are you willing to take a session on the same in MOTU school?
16:12:05 <micahg> coolbhavi: my biggest problem ATM is time, I can try to be around to help when the event happens, but can't commit to a session right now
16:12:13 <tumbleweed> I don't know if one can teach "fixing RC bugs"
16:12:31 <micahg> well, show how to find them, what to do once you have a patch...
16:12:37 <tumbleweed> but it would be easy enough to do a quick overview of how to find Debian RC bugs, what makes them RC, and how to contribute
16:12:56 <ScottK> tumbleweed: You can teach finding which ones are RC bugs and sorting through them to find the one you can ifx.
16:12:59 <coolbhavi> tumbleweed, just a process workflow insight would help I guess
16:13:16 <ScottK> That's hard enough if you don't know the tools.
16:13:48 <tumbleweed> yes
16:14:15 * tumbleweed can volunteer for that session
16:14:50 <coolbhavi> ScottK, agreed but as micahg said one can always show a bug or two as an example and interested people can pickup I guess
16:17:07 <coolbhavi> any further inputs on the same anyone?
16:18:43 <bdrung> no
16:19:08 <tumbleweed> picking a date would be good
16:19:49 <coolbhavi> tumbleweed, how about next tuesday or anyday of next week?
16:20:59 <tumbleweed> next tuesday works for me. from midday UTC?
16:21:15 <coolbhavi> fine with me too
16:21:20 <bdrung> why not the whole day?
16:21:33 <tumbleweed> if one wants a training thing, it starts with that
16:21:42 <bdrung> agreed
16:21:48 <tumbleweed> but I suppose, it doesn't have to
16:24:58 <coolbhavi> bdrung, we initially thought of a series of intro sessions (maybe around 4 or 5) with introduction to some development topics this cycle as a part of relaunch of MOTU school. take a look at the response and then plan it forward the next cycle
16:26:53 <coolbhavi> tumbleweed, any time proposal for the session in your mind?
16:28:13 <tumbleweed> my proposal was midday UTC, it suits me well, just after lunch. But I can make any time after 8am UTC
16:28:50 <coolbhavi> tumbleweed, how about 2PM UTC then?
16:28:59 <coolbhavi> next tuesday>
16:31:37 <tumbleweed> coolbhavi: sure, that's afternoon for europe and morning for the US
16:32:22 <coolbhavi> I'll make an action item then
16:33:19 <coolbhavi> #action tumbleweed to take a session on RC bug fixing workflow on tuesday 31st at 1400 UTC
16:33:19 * meetingology tumbleweed to take a session on RC bug fixing workflow on tuesday 31st at 1400 UTC
16:35:02 <coolbhavi> other point of discussion was spreading the word around MOTU School
16:35:11 <coolbhavi> IIRC
16:35:29 <coolbhavi> any thoughts anyone?
16:35:38 <tumbleweed> what are you needing for that. People to sign up?
16:35:58 <tumbleweed> is there a schedule and has a call for speakers been posted? I don't recall it
16:37:23 <coolbhavi> tumbleweed, something like a blogpost would do I had called for speakers during 1st session https://lists.ubuntu.com/archives/ubuntu-motu/2012-July/007273.html
16:37:37 <coolbhavi> #link https://lists.ubuntu.com/archives/ubuntu-motu/2012-July/007273.html
16:39:15 <tumbleweed> coolbhavi: can I propose having a schedule wiki page like we do for UDW
16:39:32 <tumbleweed> then it's obvious when there are gaps that should be filled
16:39:42 <tumbleweed> or do sessions only happen when we have speakers offering?
16:39:56 <coolbhavi> tumbleweed, sure +1 here
16:41:18 <coolbhavi> tumbleweed, A schedule list on the wiki and a call for speakers before each session on the list would be fine I guess
16:42:17 <tumbleweed> coolbhavi: it'd be great
16:42:37 <tumbleweed> I'll happily sign up for a session or two, if I saw the huge gaps that needed filling :)
16:42:47 <coolbhavi> tumbleweed, thanks a lot :)
16:43:37 <coolbhavi> #action tumbleweed to set up a MOTU school schedule page on the wiki
16:43:37 * meetingology tumbleweed to set up a MOTU school schedule page on the wiki
16:44:28 * tumbleweed shuts up so he stops getting action items
16:44:33 <tumbleweed> :)
16:45:25 <coolbhavi> other thing we discussed was merging of packaging training and MOTU school pages on the wiki which I hope to finish by next monday
16:45:49 <coolbhavi> tumbleweed, sorry for those :)
16:46:09 <tumbleweed> no, that's how it works...
16:46:21 <coolbhavi> :)
16:47:47 <coolbhavi> so those were the discussion points from the last meeting afaik. Is there anything anyone wants to discuss?
16:48:52 <tumbleweed> there are also standing agenda items on the wiki page
16:50:06 <bdrung> i like to discuss merges
16:50:40 <bdrung> how many package are modified in Ubuntu? does this number increase or decrease? can we get the changes back into Debian?
16:51:06 <tumbleweed> have you seen the graphs at the bottom of https://merges.ubuntu.com/universe.html
16:51:18 * micahg thinks MoM is broke again
16:51:42 <tumbleweed> don't forget debian is frozen
16:52:15 <tumbleweed> which makes it suprising that so many things need merging
16:52:25 <micahg> nope, it's broke :), last graphs generated 7 days ago
16:52:26 <tumbleweed> we should post some reminders about that...
16:52:29 * tumbleweed hides
16:54:35 <micahg> well, we can push patches up while Debian is frozen, but they probably won't be integrated until after DIF for R when Debian unfreezes
16:54:52 <bdrung> tumbleweed: the graphs is too small
16:55:05 <tumbleweed> what I mean is, we should be easily able to catch up on the merges
16:55:15 <ScottK> bdrung: You have access to the source, so you can fix that.
16:55:20 <tumbleweed> there should be few incoming changes from Debian that aren't very important to us
16:56:13 <ScottK> BTW, I've found in my RC bug fixing in Debian a few cases where when I went to sync the fix to Ubuntu, it was already in Ubuntu (and recently so).
16:56:23 <ScottK> No patch was ever sent.
16:56:33 <ScottK> So that could be better still.
16:57:14 <coolbhavi> ScottK, +1 here
16:57:21 <ScottK> blockdiag beint the one I hit last night.
16:57:29 <ScottK> ... being ...
17:00:38 <coolbhavi> ScottK, how about notifying the developer (from the changes list) when he does patch a ubuntu package and the patch would be applicable in debian too (like ftbfs patches) to forward it to debian as a remainder after checking the BTS if the developer hasnt done so?
17:00:51 * coolbhavi thinks its a weird idea
17:01:21 <tumbleweed> calling out poor behavior ++
17:01:25 <ScottK> I can take care of the specific case, but there's obviously more work to be done.
17:02:09 <coolbhavi> tumbleweed, ScottK agreed
17:05:38 <coolbhavi> any inputs from anyone regarding the same? and any other topic to discuss?
17:06:42 <tumbleweed> I still see a few standing items on https://wiki.ubuntu.com/MOTU/Meetings thath we haven't covered
17:06:46 <tumbleweed> but I need to run off
17:07:26 <coolbhavi> tumbleweed, I thought those are fixed items
17:10:43 * coolbhavi sees that the meeting is well past time :)
17:12:13 <coolbhavi> btw anyone volunteering to chair next meeting?
17:13:24 <coolbhavi> tumbleweed, bdrung ScottK ^^^^^
17:13:36 * ScottK is not.
17:13:58 <coolbhavi> micahg,
17:14:09 * bdrung hides.
17:14:31 <ScottK> That leaves tumbleweed.
17:14:43 <micahg> I guess I can chair if I'm around next time
17:15:01 <coolbhavi> micahg, great :)
17:16:27 * coolbhavi searches around for tumbleweed
17:17:12 <coolbhavi> tumbleweed, is afk hmm
17:18:05 <coolbhavi> #action micahg to chair the next MOTU meeting on 10th July
17:18:05 * meetingology micahg to chair the next MOTU meeting on 10th July
17:18:37 <coolbhavi> alright, thats it from me then
17:18:51 <coolbhavi> thanks all
17:19:25 <coolbhavi> #endmeeting