14:00:40 <stgraber> #startmeeting 12.04.1 team meeting
14:00:40 <meetingology> Meeting started Thu Jul 12 14:00:40 2012 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:00:40 <meetingology> 
14:00:40 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
14:00:40 <jamespage> o/
14:00:52 <arges> o\
14:00:53 <arges> o/
14:01:08 <stokachu> did you just hi-five yourself
14:01:24 <arges> stokachu, yes you win
14:01:27 <stgraber> ;)
14:01:29 <stokachu> lol
14:01:34 <stgraber> #topic Action items review
14:01:46 <stgraber> arges to work on a 12.04.1 bug report, showing targeted bugs and information on status in development release, patches attached and branches linked
14:02:02 <arges> http://people.canonical.com/~arges/point-release/milestone-12.04.1.html
14:02:40 <arges> We can still fix if needed, but have it ready. I've proposed a merge for the code into the Arsenal project so anyone can look at it. (Patches welcome)
14:03:30 <arges> The code is here for now:
14:03:36 <arges> https://code.launchpad.net/~christopherarges/arsenal/arsenal
14:03:38 <arges> ..
14:04:08 <stgraber> what are the current criteria for a bug to show up on the list? (total bugs: 57 vs 112 in my current list)
14:04:48 <arges> stgraber, targeted to 12.04.1 && status is  ["New", "Confirmed", "Triaged", "In Progress", "Fix Committed"]
14:04:58 <arges> and targed to precise
14:05:33 <smoser> o/
14:05:47 <stgraber> smoser: go
14:05:59 <stokachu> lol
14:06:21 <smoser> i was a bit confused.
14:06:23 <stgraber> smoser: or was that just a "I'm around o/" ? :)
14:06:29 <smoser> i'm around.
14:06:30 <smoser> yeah.
14:06:33 <stgraber> ok :)
14:06:40 * smoser wipes forehead.  whew!
14:07:14 <skaet> looks good arges.   Will do some correlations with the other data sources.  :)
14:07:24 <stgraber> arges: odd, it doesn't match my LP search but I can't really tell which of my LP search or the arsenal report is wrong to be honnest ;)
14:07:33 <stokachu> looks like several are missing tags
14:07:39 * skaet is a bit worried about bug 1017001
14:07:41 <ubottu> Launchpad bug 1017001 in apt (Ubuntu Quantal) "package resolvconf 1.63ubuntu14 failed to install/upgrade: ErrorMessage: pre-dependency problem - not installing resolvconf" [Critical,Confirmed] https://launchpad.net/bugs/1017001
14:07:47 <stokachu> i see a bunch with fix committed but no verification needed
14:07:59 <arges> I'll work on it and make it more accurate. but for the time being hopefully it can still be useful
14:08:05 <arges> in addition, where should I host it?
14:08:10 <arges> right now its just generated on my desktop here
14:08:14 <stokachu> geocities.com
14:08:38 <stgraber> stokachu: I'll try and take a pass through all the bugs, fix them where needed... I'm guessing some are marked fix commited but haven't actually been uploaded yet...
14:08:40 <stokachu> arges: canonistack
14:08:48 <stokachu> stgraber: ok
14:08:50 <skaet> stokachu,  I think the columns need to be switched to make it more intuitive.  (Verification Needed before Verification Done).   Is that the source of confusion?
14:09:07 <stokachu> skaet: ah
14:09:13 <stokachu> skaet: yea that does make more sense
14:09:16 <skaet> :)
14:09:20 <stokachu> haha
14:09:21 <arges> i can switch them
14:09:42 <stokachu> running off fumes this morning
14:09:42 <arges> I wanted to sort them by 'most actionable items' on top
14:09:59 <arges> so if it has the patch and the verification is done and there are lots of branches linked, then its on the top
14:10:15 <stokachu> ive been linking related branches of merge proposals
14:10:20 <stokachu> is there a way to tell a difference?
14:10:25 <skaet> clicking the column headers works for resorting ...  :)  hence me finding that critical that looks like its stalling out.
14:10:30 <stgraber> arges: you should be able to run the report on lillypilly initially, though it should then be moved to reports.qa.ubuntu.com/reports with the others
14:10:30 <stokachu> that could be a +1 for patch column
14:11:18 <arges> stokachu, what do you mean?
14:11:58 <arges> stgraber, ok
14:12:11 <stokachu> arges: can you tell ifa related branch is a merge proposal or not
14:12:23 <stokachu> rather than seeing if an attachment is set to patch
14:12:44 <stokachu> you could set to 'has patch' if no attachment but there is a merge proposal
14:13:12 <arges> stokachu, yea right now the logic is patch_attached || patch tag
14:14:01 <arges> anyway. there are a lot of comments. so maybe I can summarize some actions for the next few weeks to work on this
14:14:21 <arges> - Verify this matches the list on https://launchpad.net/ubuntu/+milestone/ubuntu-12.04.1
14:14:35 <arges> - Get this hosted on lillypilly or another machine.
14:14:59 <arges> - Switch the Verification Done/Needed columns?
14:15:26 <arges> What else?
14:15:40 <stgraber> you may also want to check for verification-needed-precise/verification-done-precise
14:15:51 <arges> stgraber, yes I do that as well
14:16:16 <stgraber> cool! I wish all our other reports did :)
14:16:18 <skaet> looks like a good summary for now to me....  I suspect that after we start working with it,  there will be more ;)
14:16:48 <arges> ok great. feel free to ping /email me with more ideas
14:16:57 <stgraber> yeah, that report looks good and will surely be useful for monitoring other point releases or even non-LTS releases in the future
14:17:05 * skaet nods
14:17:12 <stgraber> next action is:
14:17:13 <stgraber> xnox to liase with ballons, gema and jibel w.r.t. fs/storage testing
14:17:18 <arges> thanks
14:17:36 <stgraber> though xnox is at debconf so probably not much changed on that one. Keeping it around for next meeting
14:17:44 <stgraber> #topic Review of upcoming deadlines
14:17:49 <stgraber> 2012/08/02: Beginning of PointReleaseProcess and DesktopInfrastructureFreeze
14:17:52 <stgraber> 2012/08/09: KernelFreeze, LanguageTranslationDeadline, SRU Fix Validation Testing
14:17:55 <stgraber> 2012/08/16: FinalFreeze, ReleaseNoteFreeze
14:17:58 <stgraber> 2012/08/23: Ubuntu 12.04.1
14:18:40 <stgraber> as usual, if you have any other Ubuntu or downstream deadline to add, please let me know
14:18:48 <stgraber> #topic Quick look through the current bug lists, checking for progress
14:19:06 <stgraber> So, looking at the LP bug lists, it doesn't look particularly good...
14:19:10 <stgraber> Bug list went from 106 bugs targeted to 12.04.1 to 112.
14:19:10 <stgraber> 26 of these are currently marked fix commited (vs 27 two weeks ago).
14:19:11 <stgraber> 50 of the 112 bugs aren't currently assigned to someone.
14:19:37 <stokachu> only 1 fix committed?
14:19:45 <smoser> -1
14:19:50 <stokachu> err yea
14:20:30 <stgraber> I'm hoping these fix commited are different ones from last week, but I don't have an easy way to check that
14:20:43 <stokachu> tbh i haven't seen much movement on sru's last week
14:20:50 <stokachu> i assume b/c of holidays etc
14:21:18 <skaet> in particular,  a bit worried about bug 1017001.   There are also some bugs that QA is encountering yesterday that they're worried about:  bug 1021718,  bug 1022864, bug 1022927
14:21:19 <stgraber> I think at this point we really really need every team to go through the list, assign the work to their team members, target any missing bug and re-target any bug that won't be fixed in time
14:21:22 <ubottu> Launchpad bug 1017001 in apt (Ubuntu Quantal) "package resolvconf 1.63ubuntu14 failed to install/upgrade: ErrorMessage: pre-dependency problem - not installing resolvconf" [Critical,Confirmed] https://launchpad.net/bugs/1017001
14:21:24 <ubottu> Launchpad bug 1021718 in linux (Ubuntu Precise) "Ubuntu Precise ISO test failed in Jenkins due to debian installer failed to get debconf answer 'base-installer/kernel/linux/initrd'." [Critical,Confirmed] https://launchpad.net/bugs/1021718
14:21:24 <ubottu> Launchpad bug 1022864 in gsettings-desktop-schemas (Ubuntu Quantal) "Oneiric to Precise upgrade test failed: User settings are not preserved on upgrade" [High,New] https://launchpad.net/bugs/1022864
14:21:26 <ubottu> Launchpad bug 1022927 in ubuntu-release-upgrader (Ubuntu) "Precise to quantal upgrade test failed: obsolete files left after the upgrade" [Undecided,New] https://launchpad.net/bugs/1022927
14:22:06 <stokachu> yea the lack of ownership is worrisome
14:22:47 <skaet> I think stgraber's recommendation that the teams go through and assign individuals to each of the flagged bugs is what's needed.
14:23:01 <stokachu> agreed
14:23:07 <stgraber> 1017001 should probably be assigned to mvo or should at least be escalated to mvo. I'll take care of that when going through the foundations bugs
14:23:19 <skaet> thanks stgraber
14:24:23 <skaet> if when doing the pass to assign the bugs,  if folks could make sure the priority is accurate as well,  it would help.
14:25:06 * skaet figures its probably worth bringing up at the meeting tomorrow,  that we're in the last push for 12.04.1 and there are lots of worrisome bugs out there.
14:25:08 <seb128> doh
14:25:24 <seb128> was there a meeting today? why didn't anyone ping me?
14:26:11 <stgraber> also don't hesitate to move things to 12.04.2 or -updates, I'm guessing we have quite a few of these bugs that aren't realistically going to make it to the point release and I'd prefer to have the list reflect that (instead of being over-optimistic as it seems to be at the moment)
14:26:35 <skaet> stgraber,  should we also be switching to weekly now?
14:26:38 <skaet> for the meeting
14:26:41 <stgraber> seb128: yep, there's a meeting. Google should have pinged you 10 minutes before the meeting... wan me to copy/paste the log so far?
14:27:00 <seb128> stgraber, google did, I got carried up in other discussions and forgot to join
14:27:09 <seb128> stgraber, that's fine, I will read the log online
14:27:18 <seb128> stgraber, just let me know if there was any question for me ;-)
14:27:21 <stgraber> skaet: I think it'd be a good idea to ensure that everyone is focused on getting these done
14:27:38 <stgraber> seb128: the only think desktopy I saw so far is bug 1022864 that Kate mentioned a bit earlier
14:27:39 <ubottu> Launchpad bug 1022864 in gsettings-desktop-schemas (Ubuntu Quantal) "Oneiric to Precise upgrade test failed: User settings are not preserved on upgrade" [High,New] https://launchpad.net/bugs/1022864
14:28:14 <seb128> stgraber, ok, I started following up on this, will keep doing that
14:28:19 <seb128> stgraber, is the meeting over?
14:28:26 <seb128> (sorry to step in the middle)
14:28:41 <skaet> seb128,  there wasn't a question,  but an action ;)  please go through the 12.04.1 bugs and clean up assignments/priority/milestone targets.  :)
14:28:53 <seb128> ok
14:28:55 <stgraber> seb128: nope, we're in the middle of it (going through the bug lists)
14:29:01 <ScottK> skaet/stgraber: There's a postfix microversion update pending acceptance that really ought to go into 12.04.1 because if it doesn't, upgraders are likely to have TLS problems.
14:29:13 <seb128> stgraber, ok, sorry for the noise then, please get going, I'm around now ;-)
14:29:19 <skaet> ScottK,  bug number?
14:29:27 <stgraber> ScottK: are the relevant bugs targeted to 12.04.1?
14:29:36 * ScottK looks
14:30:08 <jamespage> ScottK, bug 1022772
14:30:10 <ubottu> Launchpad bug 1022772 in postfix (Ubuntu Precise) "Microversion release update for postfix 2.9.3-2" [High,In progress] https://launchpad.net/bugs/1022772
14:30:18 <ScottK> That's the SRU bug.
14:31:05 <jamespage> original bug report - bug 991754
14:31:06 <ubottu> Launchpad bug 991754 in postfix (Ubuntu Precise) "Add support to turn off the TLSv1.1 and TLSv1.2 protocols" [Medium,Triaged] https://launchpad.net/bugs/991754
14:31:22 <ScottK> That's the one.
14:31:43 <ScottK> I think Bug #1001040  is related too.
14:31:45 <ubottu> Launchpad bug 1001040 in postfix (Ubuntu) ""TLS library problem" drops incoming mail when sender uses RC4-MD5 cipher" [Undecided,Confirmed] https://launchpad.net/bugs/1001040
14:32:09 <ScottK> I think we definitely want this resolved before server upgrades start in earnest.
14:32:36 <stgraber> ok, status looks good and it's targeted, so assuming it gets tested quickly, there'll be no problem to have it in 12.04.1
14:33:19 <ScottK> First some other SRU person needs to accept it ...
14:33:34 <ScottK> Maybe bdmurray would do it.
14:35:04 <stgraber> we seem to have almost 2 weeks worth of SRU backlog in the queue, that's getting a bit scary... hopefully it'll get better when debconf is over and we get back slangasek and infinity
14:35:14 <skaet> ScottK,  yup, its his day for SRU vanguarding... https://wiki.ubuntu.com/SRUTeamProcess
14:35:27 <ScottK> Perfect.
14:35:34 <bdmurray> ScottK: postfix is it?
14:35:42 <ScottK> bdmurray: yes.  For Precise.
14:35:43 <skaet> stgraber,  ok,  I'll start beating the drums, and seeing if we can get some focus.
14:36:11 <seb128> yeah, SRU backlog is concerning
14:36:15 <stgraber> skaet: would be great. Apparently nagging directly for a given package seems to work quite well, but that means that people who aren't nagging in #ubuntu-release have to wait weeks to have their stuff accepted...
14:36:27 <seb128> we are at constant level around  30 items backlog
14:36:38 <skaet> yeah,  infinity had some ideas on this,  but I haven't seen any updates about it.
14:36:40 <seb128> it's going to be an increasing issue as we get close from the freeze date
14:36:46 <stokachu> good we are getting fixes proposed, bad we dont have the bandwidth
14:37:32 <stokachu> is it possible to check for valid sru's in the first comment and dismiss those missing any one of the 3 required
14:37:42 <stokachu> or description, whatever
14:38:04 <stokachu> was thinking maybe launchpad janitor or some other bot
14:38:38 <stokachu> also having a form submission for SRU's would help to keep required fields
14:38:43 <stgraber> stokachu: I'd expect one that doesn't have these fields set to be rejected, not left in the queue. I don't think the format is strict enough that it can easily be detected at this point though
14:39:10 <stokachu> stgraber: yea im just curious if they haven't been touched yet though
14:39:56 <ScottK> I think I did leave a couple in the queue that needed work on the bug, but made comments there/set them to incomplete.
14:40:24 <stokachu> ScottK: do those actually show in the queue waiting for someone in SRU team to work on?
14:40:24 <stgraber> at some point we'll want to automatically get these test cases and push them to packages.qa.ubuntu.com, so requiring a well structured description will help achieve that. Though I guess that's something to discuss at the next UDS.
14:40:48 <stokachu> i recommended an updates system at the previous one
14:40:59 <stokachu> QA didn't seem to impressed though :)
14:41:45 <stokachu> anyway, stgraber those bugs i posted yesterday for you are the ones relevant to 12.04.1 as well
14:41:53 <stokachu> should i post them again for archival's sake?
14:41:57 <ScottK> stgraber: I think it would be nice to have a page like the one for SRU status in -proposed that serves a a control panel for what needs working on.  It could mark incomplete bugs yellow or something so people don't relook.
14:42:30 <stgraber> #action skaet to poke the SRU team and see what can be done to process the current backlog
14:42:30 * meetingology skaet to poke the SRU team and see what can be done to process the current backlog
14:42:50 <skaet> yup
14:42:54 <stgraber> #action stgraber to review and sponsor bug 977947, bug 977952 and bug 977940
14:42:54 * meetingology stgraber to review and sponsor bug 977947, bug 977952 and bug 977940
14:42:56 <ubottu> Launchpad bug 977947 in libbonobo (Ubuntu Quantal) "Please transition libbonobo to multi-arch" [Medium,Triaged] https://launchpad.net/bugs/977947
14:42:57 <ubottu> Launchpad bug 977952 in libbonoboui (Ubuntu Precise) "Please transition libbonoboui to multi-arch" [Medium,Triaged] https://launchpad.net/bugs/977952
14:42:59 <ubottu> Launchpad bug 977940 in gnome-vfs (Ubuntu Precise) "Please transition gnome-vfs to multi-arch" [Medium,In progress] https://launchpad.net/bugs/977940
14:43:02 <stokachu> stgraber: thanks :D
14:43:16 <stokachu> seb128 could probably help with 977940 if he has time
14:43:52 <stgraber> ScottK: yeah, having tried to do some of that in queuebot, the main pain is that the API doesn't let us query much from the queue at this point. Though that may have changed with cjwatson's work on the queue API
14:44:26 <stgraber> ScottK: the main problem in the past was that you would only get the URL to the .changes file and would then have to parse it to get anything out of it (and then query LP again based on that)
14:44:54 <ScottK> Not very helpful.
14:45:52 <stgraber> yeah :) I wanted to show the IRC nickname of the uploader in queuebot but decided not to do it as I'd have had to: grab the .changes => parse it => extract e-mail => match against LP => get the user object => query ircnickname
14:46:09 <stokachu> seb128: you mentioned multi-arch bugs at the previous meeting, are there any that you are aware of that I haven't touched yet
14:46:12 <stgraber> instead of being able to do the usual .uploader.irc_name :)
14:46:37 <ScottK> stgraber: ./queue info shows stuff like " 4373718 | S- | qemu-kvm             | 1.0+noroms-0ubuntu14 | 17 hours         | * qemu-kvm/1.0+noroms-0ubuntu14 Component: main Section: misc" now.
14:46:44 <seb128> stokachu, what's the status of those atm? I uploaded libart-lgpl and reviewed gnome-vfs that you updated yesterday
14:46:54 <ScottK> That seems like a useful basis for something.
14:46:56 <stokachu> ah
14:46:58 <seb128> stokachu, what about the libbobobo,ui ones, did slangasek review it again?
14:47:12 <stokachu> seb128: stgraber added it to his list to review
14:47:22 <seb128> ok
14:47:27 <stokachu> i saw you reviweed gnome-vfs but did you review the merge proposal?
14:47:35 <stokachu> he addressed your changes mentioned
14:47:38 <stokachu> it*
14:48:02 <stokachu> the only other 2 i know of are libgnome2 and appmenu-gtk
14:48:07 <stgraber> gnome-vfs is on my list for today, so I'm happy to review it too
14:48:17 <stokachu> which im current working
14:48:38 <seb128> stokachu, ok, yeah, appmenu-gtk seems to be the one coming often
14:48:46 <seb128> stokachu, thanks, seems those are on track then
14:48:58 <stokachu> ok cool, please lemme know if any other come up
14:49:21 <stgraber> stokachu: let me know when they're ready to be looked at and I'll look and sponsor (I have a few more questions on the testing you did, but I'll poke you post-meeting)
14:49:36 <stgraber> #topic Round table
14:49:37 <stokachu> ok
14:49:43 <stgraber> stgraber@castiana:~$ echo $(shuf -e NCommander seb128 stgraber arges jibel skaet smoser jamespage)
14:49:46 <stgraber> NCommander arges jibel skaet seb128 smoser stgraber jamespage
14:50:04 <stokachu> aww no love 4 stokachu
14:50:24 <skaet> stokachu, why don't you start then...  I suspect NCommander's offline
14:50:28 <stgraber> stokachu: oops :) let's pretend you're after arges
14:50:32 <stokachu> LOL
14:50:35 <stgraber> or now, whatever :)
14:50:55 <stokachu> I think im covered for now
14:51:11 <stgraber> arges:
14:51:24 <arges> i'm good
14:51:25 <arges> ..
14:51:38 <stgraber> no jibel around
14:51:40 <stgraber> skaet:
14:51:52 <skaet> back from vacation,   getting concerned about all the recent failures (as mentioned);  about to start beating the drum....
14:52:11 <skaet> need to get the QA daily tests working reliably again as first priority.
14:52:13 <skaet> ..
14:52:21 <stgraber> seb128:
14:52:40 <seb128> desktop SRUs still go well, on a regular basis
14:52:45 <seb128> we are a bit behind for compiz,unity
14:52:55 <seb128> we should have an unity SRU with a big pile of fixes next week
14:53:02 <seb128> then a compiz one
14:53:23 <seb128> (we got an issue with the current compiz  SRU this week, that's going to be addressed with a follow up upload rsn)
14:53:47 <seb128> then we aim at another round of unity uploads at the end of the month, mostly backports from quantal performance improvements
14:54:05 <seb128> otherwise as mentioned before the SRU team backlog and delay to do review is still concerning
14:54:31 <seb128> it really slow down work and breaks the dynamic, it also makes hard to follow errors.ubuntu.com since lot of the issues are addressed with fixes blocked in the queue for weeks
14:54:32 <seb128> ..
14:54:34 <skaet> seb128,  please remind unity/compiz teams of the 08/02 date to get all the desktop infrastructure changes in by.
14:54:56 <seb128> skaet, yes, we have that in mind and we will make sure to be in time ;-)
14:55:04 <skaet> :)
14:55:33 <stgraber> smoser:
14:56:15 <smoser> jamespage, and i just went through the server team bugs.
14:56:39 <smoser> significant amount are juju or maas.
14:56:53 <smoser> and we'll follow up with those teams to push a bit and get a sense of urgency
14:57:18 <smoser> that really just about covers the list at http://status.qa.ubuntu.com/reports/kernel-bugs/reports/rls-p-tracking-bugs.html
14:57:52 <smoser> thats it.
14:58:53 <stgraber> stgraber:
14:59:31 <stgraber> must admit being a bit behind on tracking SRUs at the moment... I still have at least one in the queue. Started reviewing stokachu's multi-arch SRUs (should be uploaded today)
15:00:06 <stgraber> I'll also go through the whole list and make sure the bugs have all proper target/tags/importance/status and assign these that are foundation-y
15:00:42 <stgraber> will probably be talking a bit with skaet on these that I think we'd need to drop from 12.04.1
15:01:20 <stgraber> I remember some of the listed ones requiring significant upstream changes that haven't even started, so pretty unlikely to be ready (thinking of one of the dnsmasq bug)
15:01:23 <stgraber> ..
15:01:24 <stgraber> jamespage:
15:03:33 <stgraber> going to assume that it's mostly the same as smoser
15:03:38 <stgraber> #topic AOB
15:04:11 <stgraber> so as Kate suggested earlier, the meeting will now become a weekly meeting
15:04:23 <stgraber> I'll update the wiki and the calendar
15:04:31 <stgraber> same place, same time, just every week now
15:04:39 <stgraber> #action stgraber to change the meeting to a weekly meeting
15:04:39 * meetingology stgraber to change the meeting to a weekly meeting
15:04:46 <stgraber> anything else?
15:05:07 <jamespage> stgraber, sorry - it was - got called away for a second...
15:05:37 <stgraber> #endmeeting