16:02:26 <jamespage> #startmeeting ubuntu-server-team
16:02:26 <meetingology> Meeting started Tue Jul 10 16:02:26 2012 UTC.  The chair is jamespage. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02:26 <meetingology> 
16:02:26 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02:32 <jamespage> #topic Review ACTION points from previous meeting
16:02:35 <jamespage> none
16:02:37 <jamespage> \o/
16:02:44 <jamespage> #topic Quantal Development
16:02:50 <jamespage> #topic Release Bugs - http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:03:19 <Daviey> It's mostly MIR bugs which are causing woe
16:03:21 <jamespage> So we have quite a few MIR's to support cep work
16:03:36 <jamespage> bug 1017972 1017978 1022493
16:03:38 <ubottu> Launchpad bug 1017972 in libunwind (Ubuntu) "[MIR] google-perftools, libunwind" [Medium,New] https://launchpad.net/bugs/1017972
16:03:43 <Daviey> jamespage: perhaps someone should try to interface closer with the MIR team to get these progressing ?
16:03:58 <jamespage> Daviey, as they are all mine I will do that
16:04:09 <Daviey> jamespage: super!
16:04:14 <jamespage> and then
16:04:17 <jamespage> bug 974584
16:04:22 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged] https://launchpad.net/bugs/974584
16:04:29 <Daviey> hallyn: ^
16:04:40 <jamespage> #action jamespage to checkin with MIR team on expected review timescales for server MIR's
16:04:40 * meetingology jamespage to checkin with MIR team on expected review timescales for server MIR's
16:04:45 <hallyn> Daviey: should be fixed ind ebian
16:04:47 <hallyn> in debian
16:04:56 <zul> there is quantum/quantumclient MIRs as well
16:05:17 <jamespage> zul: please make sure you subscribe ubuntu-server-release
16:05:29 <Daviey> zul: can you action following them up?
16:05:30 <zul> jamespage: ack
16:05:54 <zul> Daviey: i tried to get them moving today but no one from the MIR answered my query
16:05:56 <jamespage> #action zul to make sure relevant MIR bugs have ubuntu-server-release subscribed
16:05:56 * meetingology zul to make sure relevant MIR bugs have ubuntu-server-release subscribed
16:05:56 <Daviey> jamespage: well, technically ubuntu-server-release is for issues we are blocking on.. MIR bugs mostly block on others, no?
16:06:13 <jamespage> Daviey, I don't see much differentiation
16:06:32 <Daviey> jamespage: Well, there is a separate section on the report specifically for tracking MIR's
16:06:40 <Daviey> (without us having to subscribe ubuntu-server*)
16:06:43 <jamespage> Daviey, oh - I see
16:07:04 <jamespage> Daviey, what magic makes things appear their?
16:07:28 <Daviey> jamespage: that is for packages that we are bug subscribers for and has ~ubuntu-mir subscribed to the bug, and not Fix'd
16:07:32 <Daviey> ie, just works.
16:07:56 <jamespage> Daviey, OK - so we just need to sub ~ubuntu-server to those packages then
16:08:03 <jamespage> zul: ^^ got that?
16:08:08 <jamespage> I'll update mine as well
16:08:09 <Daviey> yah.. which is usually a prerequisite for MIR
16:08:14 <zul> jamespage: yeah
16:08:17 <jamespage> Daviey, ack
16:09:21 <jamespage> hallyn: re bug 974584 - can I assign that bug to you or is there someone else more appropriate?
16:09:23 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged] https://launchpad.net/bugs/974584
16:09:41 <hallyn> jamespage: assigning me wouldn't help :)  it's fixedin debian, just needs to be merged
16:09:44 <hallyn> i just commented on the bug
16:10:01 <hallyn> (needs to be merged, and i don't have upload rights)
16:10:05 <Daviey> jamespage: hallyn is mostly on plus1 for now.. better someone else
16:10:22 <jamespage> hallyn, ah - rightoh - its actually sysvinit not lxc - my mistake
16:10:51 <jamespage> zul: bug 1020313
16:10:53 <ubottu> Launchpad bug 1020313 in horizon (Ubuntu) "openstack-dashboard hijacks the web root" [Medium,Triaged] https://launchpad.net/bugs/1020313
16:11:12 <jamespage> OK to sweep that up in the next set of updates?
16:11:49 <zul> jamespage: is that in precise?
16:12:02 <Daviey> I don't think we can reasonably SRU that
16:12:14 <jamespage> Daviey, I agree
16:12:32 <Daviey> soren: ^^
16:12:58 <Daviey> next?
16:13:02 <jamespage> OK _ while we figure that out
16:13:16 <jamespage> Still have a couple of FTBFS issue we are tracking
16:13:29 <jamespage> I know the genshi one is not moving forward upstream
16:13:42 <jamespage> so we may need to spend some time working a patch ourselves
16:13:51 <jamespage> so if anyone wants to volunteer....
16:14:08 <jamespage> other than that ... moving on
16:14:11 <jamespage> #topic Blueprints - http://status.ubuntu.com/ubuntu-precise/ubuntu-server.html
16:14:28 <jamespage> bah wrong ling
16:14:29 <jamespage> link
16:14:33 <arosales> trend line is still a bit off
16:14:40 <jamespage> http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:14:46 <zul> oooh...lets do the time war again
16:14:53 <jamespage> lol
16:15:05 <arosales> Daviey: did you mention we need re-classify topics?
16:15:12 <rbasak> smoser: I've been meaning to suggest that we redo the work items for the apt blueprint once we have feedback
16:15:20 <Daviey> arosales: no
16:15:42 <arosales> or reorder BPs under topics
16:15:46 <arosales> or neither :-)
16:15:59 <smoser> rbasak, that seems reasonable.
16:16:12 <Daviey> -Action arosales, update the topics/blueprints? :)
16:16:40 <jamespage> Daviey, arosales: please can we understand the context for this change?
16:17:10 * Daviey hands the mic to arosales.
16:17:25 <arosales> Daviey: I already put the dependencies on the BPs
16:17:42 <arosales> perhaps I classified then under the incorrect topic though
16:18:12 <arosales> I'll take an action to get this straigned out and get the trend line to track our work correctly
16:18:54 <jamespage> #action arosales to sort out blueprints and get the trend line working correctly
16:18:54 * meetingology arosales to sort out blueprints and get the trend line working correctly
16:18:56 <jamespage> ta
16:19:26 <Daviey> lets have a @daily reset-trend-line.py cronjob
16:19:44 <jamespage> I'm not going to focus on any specific blueprints; but I would recommend everyone review ~weekly
16:19:54 <jamespage> I've also been using the +upcomingwork view in Launchpad
16:19:56 <jamespage> https://launchpad.net/~ubuntu-server/+upcomingwork
16:19:59 <jamespage> for example
16:20:18 <jamespage> which gives you more of a time based view of whats next....
16:20:34 <jamespage> anyone have anything else for blueprint status?
16:20:39 <jamespage> .....
16:20:42 <jamespage> ....
16:20:44 <jamespage> ...
16:20:46 <jamespage> ..
16:20:47 <jamespage> .
16:20:51 <jamespage> nope
16:20:52 <jamespage> OK
16:20:58 <Daviey> hometime \o/
16:21:00 <jamespage> #topic 12.04.1 Development (jamespage & smoser)
16:21:33 <smoser> i believe i was probably supposed to have done something here. i think i said i'd look at our list of items. but I have not.
16:21:35 * ScottK uploaded postfix 2.9.3 for a MRE SRU yesterday.  Waiting for someone else in ubuntu-sru to accept it.
16:21:36 <jamespage> We have managed to push few quite a few SRU's
16:21:52 <jamespage> thanks ScottK
16:22:02 <jamespage> *push through
16:22:15 <jamespage> smoser - lets do that tomorrow
16:22:32 <jamespage> #action smoser and jamespage to review and assign SRU bug across team.
16:22:32 * meetingology smoser and jamespage to review and assign SRU bug across team.
16:22:33 <smoser> jamespage, ok.
16:22:55 <smoser> http://status.qa.ubuntu.com/reports/kernel-bugs/reports/rls-p-tracking-bugs.html is the/one list, and as you can see, server has a nice long list of bugs
16:22:57 <smoser> wee!
16:23:29 <jamespage> smoser: most of those bugs are also on
16:23:38 <jamespage> http://people.canonical.com/~jamespage/server-sru/precise-sru.html
16:23:57 <jamespage> maas and juju specifically have a large number of unassigned high priority items
16:24:13 <jamespage> anyway - looks like folk will have bugs coming their way tomorrow onwards....
16:24:16 <zul> bugs are overated
16:24:28 <jamespage> #topic Ubuntu Server Team Events
16:24:39 <jamespage> any events in the next two weeks we should be aware of?
16:25:04 <arosales> OSCON coming up on the 16th
16:25:13 <arosales> m_3 and jcastro attending
16:25:21 <jimbaker> i will also be at oscon
16:25:37 <jamespage> a veritable server-team fest!
16:25:43 <jamespage> OK
16:25:48 <jamespage> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:25:54 <jamespage> hggdh, around for an update?
16:26:44 <jamespage> ...
16:26:45 <jamespage> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:26:49 <jamespage> smb?
16:26:49 <smb> yup
16:26:52 <smb> So I have been chasing some quantal regression of an older (b44) nic, trying to get kexec/kdump working in precise/quantal, chasing some 32bit Xen HVM problem and err, that might be all. Something else I should be aware (iow questions)? Oh, and /me being in Portland, OR next week.
16:26:54 <smb> ..
16:27:44 <jamespage> any questions for smb?
16:28:13 <jamespage> nope - next!
16:28:23 <jamespage> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:28:27 <rbasak> I've been working on a hacky patch against MAAS trunk that will make it provision ARM machines. The idea is that this can eventually be adapted into first class support. The patch is currently up-to-date against MAAS trunk, and I'm just waiting on the last cobbler-replacement pieces to land.
16:28:36 <rbasak> Nothing else to report.
16:28:38 <rbasak> Any questions for me?
16:29:05 <jamespage> rbasak, I have a question - would it be possible to get the openvswitch kernel module enabled for the ARM kernels?
16:29:24 <jamespage> I believe its upstream for the 3.4 series we are currently using
16:29:32 <rbasak> That's something I'll have to ask of the kernel team
16:29:48 <jamespage> rbasak, that would be helpful (only hit this today)
16:30:11 <rbasak> In quantal? Or do you need a precise SRU?
16:30:21 <jamespage> #action rbasak to find out whether openvswitch module can be enabled for quantal ARM kernels
16:30:21 * meetingology rbasak to find out whether openvswitch module can be enabled for quantal ARM kernels
16:30:27 <jamespage> rbasak, quantal is OK
16:30:33 <rbasak> This is for the openstack module I presume? I forget its name
16:30:41 <jamespage> quantum
16:30:46 <rbasak> Yeah that's it
16:30:51 <rbasak> OK I'll find out
16:31:04 <jamespage> plus openvswitch is way cooler than doing old style bridging... :-)
16:31:12 <rbasak> apw: ^^? :)
16:31:17 <jamespage> any other questions for rbasak?
16:31:33 <rbasak> jamespage: which kernels in particular?
16:31:43 <rbasak> jamespage: omap4, armadaxp, highbank, all of the above? :)
16:31:47 <Daviey> rbasak: whilst i remember, shall we have a quick catchup tomorrow morning?
16:31:48 <jamespage> rbasak, all of the above
16:31:53 <rbasak> :)
16:31:59 <rbasak> Daviey: sure
16:32:11 <jamespage> OK
16:32:13 <jamespage> #topic Open Discussion
16:32:27 <jamespage> anyone have anything for open discussion?
16:32:30 <Daviey> nope
16:32:53 <jamespage> right-oh
16:32:55 <jamespage> #topic Announce next meeting date and time
16:33:16 <zul> jamespage: we should be able to test if the dkms modules build
16:33:24 <jamespage> zul: it does not
16:33:35 <zul> oh...poop
16:33:49 <jamespage> July 17th 2012, 1600 UTC right here
16:33:58 <jamespage> until then...
16:34:00 <jamespage> #endmeeting