17:59:59 <AlanBell> #startmeeting IRCC
17:59:59 <meetingology> Meeting started Sun Jun 24 17:59:59 2012 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:59:59 <meetingology> 
17:59:59 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:00:00 <Unit193> Howdy.
18:00:14 <AlanBell> hi all
18:00:19 <AlanBell> who is here for the meeting?
18:00:21 <topyli> hey
18:01:00 <DJones> /
18:01:01 <Pici>18:01:03 <Pici> er, \o
18:01:06 <IdleOne> o/
18:01:59 <m4v> hi
18:02:23 <jussi> o/ vaguely, crying baby
18:03:24 <AlanBell> #topic Review last meetings action items
18:03:52 <AlanBell> so actions from last time, lets see
18:04:10 <AlanBell> alanbell to sort out removal of eir
18:04:17 <AlanBell> #fail
18:04:34 <AlanBell> so I was going to do this because uBOTu-fr was going to take over, but it was missing
18:04:54 <AlanBell> lets come back to that whole question a bit later when we have a topic dedicated to it
18:05:17 <AlanBell> #topic Welcome to the new IRCC member
18:05:24 <AlanBell> welcome Tm_T \o/
18:05:29 <IdleOne> Welcome and congrats Tm_T !
18:05:35 <topyli> yay Tm_T !
18:05:36 <Pici> Woo, Tm_T!
18:05:42 <DJones> Congrats Tm_T
18:05:48 <IdleOne> No new taxes!
18:06:04 <topyli> finns love taxes, beware
18:06:06 <AlanBell> the results of the election were announced by the Community Council the other day and Tm_T is now our 5th IRCC member
18:06:57 <AlanBell> launchpad groups and channel access and suchlike has been set up
18:07:25 <Pici> launch codes, etc.
18:07:36 <AlanBell> if only
18:07:39 <IdleOne> Pici: not the abort codes right?
18:07:45 <AlanBell> #topic Open items in the IRCC tracker
18:07:48 <pleia2> just a quick note, I added his expire time as the same as the rest of you, but that's just because it's not something we've discussed
18:08:03 <pleia2> we (CC and IRCC) should probably pick that up at some point
18:08:05 <AlanBell> pleia2: yeah, I saw that, thanks
18:08:09 <Pici> Yep
18:08:34 <AlanBell> pleia2: setting the expire time the same was something we had planned and stated a few times
18:08:46 <topyli> hm, wasn't that in the initial announcement that we're looking for the missing member?
18:08:49 <pleia2> even better
18:09:02 <Pici> ooh, problem solved already? I like this.
18:09:11 <pleia2> me too :)
18:09:17 <TheLordOfTime> heh
18:09:19 <IdleOne> item closed.
18:09:23 <jussi> too good to be true, watch it...
18:09:35 <AlanBell> ok, so the tracker, we do have an open item in it relating to the user mcloy
18:09:46 <AlanBell> I closed it once and it reopened :(
18:10:11 <AlanBell> and we have another email today relating to some kind of appeal
18:10:22 <IdleOne> what is the issue exactly with mcloy?
18:10:29 <IdleOne> or can we not discuss that here?
18:10:30 <Pici> Which was sent to both lists, but we'll be taking it
18:10:44 <AlanBell> so it was
18:11:11 <topyli> i rejected the message to the irc-team list and accepted the one to the council
18:11:33 <topyli> public vs private and all that
18:11:37 <AlanBell> good stuff
18:11:57 <Pici> topyli: oh, good, good.
18:12:03 <AlanBell> Shano56 is the user involved in that appeal
18:12:20 <topyli> personally i think it's being handled just fine by ops
18:12:54 <AlanBell> IdleOne: I would rather not discuss individual stuff here as a general rule, just being open about what appeals are going on
18:12:56 <Pici> I think we should just talk about it 'offline' (so to speak).
18:13:20 <Pici> AlanBell: which is what I was trying to get at.
18:13:27 <IdleOne> sounds good. the Shano56 thing I think was handled properly.
18:13:52 <AlanBell> ok, so that is the tracker
18:13:54 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
18:14:11 <AlanBell> no new bugs
18:14:19 <AlanBell> #subtopic bug 892500 eir is still not fit for purpose in #ubuntu -ikonia
18:14:21 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:14:26 <AlanBell> lets come back to that one in a sec
18:14:38 <AlanBell> #subtopic bug 913541 there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group
18:14:40 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
18:14:47 <AlanBell> Pici: have you had a poke at this one?
18:15:16 <Pici> AlanBell: I did, and then I got terribly busy with work stuff.  Keep it on my docket, I'll make some time to deal with it.
18:15:23 <AlanBell> ok
18:15:34 <AlanBell> #topic alignment of launchpad teams and channel access lists
18:15:49 <AlanBell> I did some of this and sent a few mails to the lists about it
18:15:56 <AlanBell> I ticked off the big channels
18:16:18 <IdleOne> ticked off as in upset?
18:16:25 <AlanBell> heh, hope not
18:16:26 <Pici> as in marked the checkboxx.
18:16:31 <IdleOne> ah, k.
18:16:46 <AlanBell> then there was the IRCC election stuff and other things which distracted me
18:17:03 <AlanBell> but I will continue with that and get it to a point where we can automate it
18:17:22 <AlanBell> there was also a kubuntu council election which changed some kubuntu stuff
18:17:43 <IdleOne> Congrats to jussi for being elected to Kubuntu Council
18:17:46 <IdleOne> :)
18:17:51 <Pici> Grats Jussi!
18:17:51 <AlanBell> yes indeed!
18:18:03 * jussi blushes and hides
18:18:13 <topyli> :)
18:18:52 <AlanBell> any comments on the access list processing so far?
18:19:04 <Pici> No issues from over here.
18:19:54 <AlanBell> #topic Review #ubuntu-ops-team (Quarterly)
18:20:22 <AlanBell> this is a standing item we insert quarterly
18:20:47 <topyli> we've done this a couple of quarters now, and been generally happy. i think we could stop reviewing it
18:20:48 <AlanBell> the #ubuntu-ops-team channel is an invitation only channel for operators and a few others who are invited
18:20:56 <jussi> Pici mentioned about offtopic in there - do we want to talk about that?
18:20:59 <topyli> that doesn't mean we shouldn't address any specific issues
18:21:34 <Pici> knome, Unit193 and I had a good discussion the other day about offtopicness in -ops-team
18:21:34 <AlanBell> jussi: sure
18:21:46 <topyli> jussi: well, there are a couple of valid but somewhat contradicting views, so it deserves discussion
18:22:47 <topyli> 1) offtopic stuff isn't coordination. 2) not all ops are in the same offtopic channels and thus will miss each other lolcats if they're not allowed in -ops-team
18:22:50 <Pici> I had originally suggested to move the offtopicness into #ubuntu-offtopic, but there were problems with that suggestion, mainly that its very #ubuntu centric (Rather than #x/#k#/l etc).  So the comprimise that we agreed on was to try to seed some of the good conversations that we have been having there into the various offtopic channels.
18:23:58 <AlanBell> I am quite comfortable with the concept of #ubuntu-ops-team, I think it is really useful to separate that from the #ubuntu-ops channel
18:23:59 <guntbert> seeding good conversations into ot channels sounds *very* good
18:24:34 <topyli> AlanBell: absolutely. that's why i'm suggesting we stop reviewing its existance
18:25:20 <Pici> But publicly reviewing anything that we may have brought up in there (that should be made public) isn't probably good.
18:25:24 <Pici> er, s/isn't/is/
18:26:03 <Tm_T> sorry for my late arrival
18:26:09 <AlanBell> hi Tm_T
18:26:19 <IdleOne> o/ Tm_T
18:26:20 <topyli> hi Tm_T. welcome to the meeting and to the council :)
18:26:24 <Pici> Anyway, the point was to be conscious of the offtopicness, and try to bring it into our offtopic channels if the parties involved are there as well.
18:26:51 <AlanBell> does anyone think we should review the #ubuntu-ops-team channel in a further three months, or not bother as per topyli's proposal?
18:26:53 <jussi> the point of the review is to make sure it isnt becoming clique and being abused
18:26:56 <Pici> And again, this isn't a blanket ban on being able to socialize in there, just something to keep in the back of your head.
18:27:38 <topyli> i think jussi and Pici are saying the same thing
18:27:39 <IdleOne> AlanBell: I think keeping the review process is a good thing and won't hurt.
18:27:59 <AlanBell> topyli: I am thinking that 5 minutes per quarter isn't a big deal, but we should focus on how we are using it rather than whether it should exist
18:28:11 <topyli> yes
18:28:19 <IdleOne> Will serve as a reminder to us to try and keep the channel on topic as much as possible.
18:28:20 <Tm_T> that
18:28:45 <AlanBell> ok lets move on, and I will swap the next two agenda items
18:28:49 <jussi> AlanBell: ++
18:28:55 <AlanBell> #topic Make #ubuntu-offtopic +r (discussion on the merits of this)
18:29:15 <AlanBell> this was something ikonia asked us to think about
18:29:37 <TheLordOfTime> i'm not on the ircc, but would ikonia care to explain the background of this?
18:29:39 <Pici> We breifly weighed the pros and cons, but we suggested that he add it to the meeting agenda anyway.
18:29:44 <AlanBell> as one possible way to improve conversations in -offtopic and stop a little bit of random abuse
18:30:02 <IdleOne> making the channel +r will make it more difficult for the #ubuntu ops to direct new users to the channel when needed
18:30:16 <TheLordOfTime> i agree with IdleOne on this one
18:30:25 <TheLordOfTime> a majority of #ubuntu is unregistered
18:30:34 <jussi> whatever happened to #ubuntu-discuss? wasnt it part of the master plan?
18:30:37 <AlanBell> I asked ikonia to figure out how much of #ubuntu-offtopic was unregistered
18:30:52 <Pici> jussi: still up in the air.
18:30:58 <topyli> there is some obvious merit. less random noise, and also easier bans :)
18:31:03 <IdleOne> meaning, not only do we have to explain that they are off topic and to change channel but then explain how to register. if the channel is open then we can take the registration "support" and help the user in -ot
18:31:15 <TheLordOfTime> ^ that
18:31:24 <Tm_T> I don't like restricting -ot nor necessarily the idea of extra -discuss
18:31:28 <Pici> IdleOne: I think we already have enough pain when trying to direct folks to ##java, and simiular channels.
18:31:34 <topyli> IdleOne: good point
18:31:40 <DJones> There's a lot of occasions when new users are directed to -ot rather than #u when they want just general info, they're unlikely to be registered (new to IRC etc), which will cause confusion & potentially push them away from ubuntu
18:32:01 <IdleOne> Pici: in #u you mean? yes, why add to it by restricting -ot?
18:32:18 <Pici> IdleOne: Exactly.
18:32:22 <IdleOne> ok :)
18:32:29 <guntbert> to my eyes "abuse" has diminished significantly - there have even been some quality discussions
18:33:10 <Pici> Well yeah, but only when we're not scaring off our -offtopic operators ;)
18:33:29 <Pici> guntbert: but seriously, I agree.
18:33:52 <Tm_T> I have my hope on leading by example (not by me necessarily)
18:33:59 <IdleOne> -1 to setting -ot +r
18:34:23 <Pici> And the folks who are determined to troll aren't going to be deterred by it being set +r, just the folks who want to casually chat.
18:34:52 <IdleOne> also, sometimes a two hour chat about kittens is quality
18:34:57 <AlanBell> ok, it sounded quite an appealing suggestion to me, but those are good points about directing new people to it
18:35:21 <topyli> i'll say -1 too. -ot is an old channel and hasn't really become any *worse* over the years. this whispers to me not to rock the boat
18:35:26 <AlanBell> but I do think that new people should be directed to somewhere to discuss Ubuntu rather than kittens
18:35:30 <Tm_T> it would just make -ot even more of a place for limited circle instead of whole community
18:35:38 <AlanBell> (or other small fluffy/feathery creatures)
18:36:15 <topyli> AlanBell: i think the lolcat discussions most often pause when real ubuntu discussion is starting to take place
18:36:15 * TheLordOfTime agrees with Tm_T's view
18:36:20 <IdleOne> AlanBell: We discuss Ubuntu a lot in -ot, just that some people take great offense to Ubuntu being put down. e.g. UNITY SUCKS!
18:36:44 <guntbert> AlanBell: as long as one discussion doesn't drown the other, I see no problem with discussing pets
18:36:55 <Pici> A UNITY SUCKS discussion is neither a) constructive nor b) something that 99% of the folks there want to discuss.
18:36:58 * AlanBell is all in favour of chicken related discussions
18:37:00 <IdleOne> many of the people who start out with that sort of comment about Ubuntu end up having excellent points
18:37:30 <DJones> Possibly a different thought process needs to be gone through from #u etc when directing people to -ot, at times it possibly gets used to redirect non-coc comliant conversations to to -ot rather than just asking them to stop the conversation all-together, not by ops, but by general #u users
18:37:51 <topyli> there's very good unity criticism there as well, worthy of being directed to #ubuntu-desktop or similar really :)
18:37:53 <Pici> IdleOne: true, but then again we've heard most of the arguments for/against it already. but lets not get too sidetracked.
18:38:06 <IdleOne> Pici: I hear you
18:38:27 <AlanBell> yeah, this item was about setting it +r, and it seems on balance that isn't going to be a good idea, so lets not do that then
18:38:33 <Pici> DJones: I've been pretty quick to point that out to folks who mash !ot instead of telling people to stop.
18:38:42 <IdleOne> Anyway, I want to be able to send new Ubuntu/IRC users to -ot without having to send them to #freenode first to get help registering
18:38:43 <guntbert> DJones: so we should decide if !ot is to be used or some other factoid (in #u)
18:39:00 <Pici> AlanBell: agreed.
18:39:20 <AlanBell> ok, so moving on once more
18:39:22 <AlanBell> )
18:39:25 <AlanBell> #topic ubottu, uBOTu-fr and eir
18:39:27 <Pici> Lets try to get through the rest of the agenda, and then we can move back to the State of Offtopic afterwards if we have time.
18:39:37 <AlanBell> so, bots
18:39:51 <Pici> yep
18:40:06 <Pici> can't live with'em, oh... wait, thats somethinjg else...
18:40:13 <topyli> eir database is growing by the minute, as ikonia reminded us today in -irc-council
18:40:18 <AlanBell> I was going to get eir removed so we could focus on uBOTu-fr
18:40:54 <AlanBell> but uBOTu-fr was missing in action, and m4v raised some points about the test suite not passing
18:41:00 <IdleOne> AlanBell: do we have a working ubotu-fr to use in #ubuntu yet?
18:41:07 <Pici> Sounds like we might not.
18:41:41 <AlanBell> I grabbed a copy of the source today to have a look at what it does
18:41:46 <IdleOne> then I say we hold off until there is a known working replacement for eir
18:41:48 <Tm_T> I'd say first u-fr up to shape and then drop eir
18:42:14 <IdleOne> eir is not perfect but it is better than nothing for now
18:42:17 <m4v> I don't want to maintain a supybot fork for stuff that should be in a plugin.
18:42:20 <Pici> I think it might be good to trial u-fr (once it gets back up to spec) in some of our other high traffic channels
18:43:04 <oCean> We should not start with trials with any bot, until we have a agreed on set of requirements
18:43:17 <AlanBell> https://docs.google.com/spreadsheet/ccc?key=0ApW_s9q9E0zEdE9naVF4c0xjTUhpelZnZTFoYzZWNVE#gid=0
18:43:20 <Pici> oCean: I thought we already had a list somewhere
18:43:21 <AlanBell> requirements ^^
18:43:31 <Unit193> May see if you can get some of that into a plugin, and general stuff into an existing fork.
18:44:19 <oCean> Pici: we had a list of bugs for eir, the link AlanBell posted is where I started a little while ago
18:44:45 <oCean> This could be where to start from. Decide which are the Must/Could/Should haves etc
18:44:55 <AlanBell> yeah, I like the list oCean
18:45:17 <m4v> well, there's the stuff we wrote for the next bt http://ubottu.com/devel/wiki/Spec/Bantracker
18:46:04 <oCean> m4v: yeah, that is another point. The BT
18:46:18 <oCean> we should not see those to apart from each other, is what I think
18:46:23 <IdleOne> the requirements look good to me
18:46:53 <oCean> those two*
18:46:56 <m4v> oCean: another? isn't the BT the point we're discussing?
18:47:21 <oCean> m4v: we have focussed on bot functionality a lot
18:47:43 <m4v> there's the idea of using ubotu-fr because our bt doesn't have automatic removal of bans
18:47:59 <oCean> for example, we started with eir, while we knew there was no integration with the BT
18:48:21 <AlanBell> yeah, I am not sure why we don't just write ban expiry into the existing ubottu channel plugin
18:48:26 <AlanBell> or a separate plugin
18:48:40 <oCean> Yes, I'm all for that, AlanBell
18:49:11 <oCean> however, I don't have the knowledge/skill to do that
18:49:59 <m4v> AlanBell: ubottu bantracker plugin, ubotu-fr channel plugin is a rewrite of a supybot core plugin.
18:50:16 <AlanBell> yeah, I saw that
18:50:24 <Pici> I think we have enough python/supybot skill here to make that happen, but the issue was that we sort of felt that the current Bantracker system needed a lot of love in various places to bring it up to spec.
18:50:50 <IdleOne> which m4v gave it did he not?
18:50:56 <oCean> Pici: Indeed, it still does
18:50:58 <m4v> well, I have been looking how to add automatic removal in ubottu, I think it can be done, but are we going to have ubottu +o all the time?
18:51:17 <oCean> m4v: eir isn't +o all the time
18:51:17 <Pici> I personally don't have a problem with that, as long as she doesn't go haywire.
18:51:18 <AlanBell> m4v: maybe, or can it just talk to chanserv?
18:51:22 <IdleOne> m4v: ubottu only needs +o when setting the modes
18:51:44 <Pici> AlanBell: chanserv can't unban people.
18:51:54 <Pici> Well, other than yourself.
18:51:56 <AlanBell> orly
18:52:04 <m4v> ok, so needs to request op when needed.
18:52:04 <TheLordOfTime> yep
18:52:39 <IdleOne> AlanBell: something about accountability and not abusing chanserv to do nasty things
18:52:40 <Pici> Being opped all the time is less noise that opping up, unbanning, and deopping.
18:53:01 <AlanBell> ah, ok, unban is only for self
18:53:03 <m4v> Pici: is also easier to implement, that's why I asked
18:53:10 <Pici> m4v: right.
18:53:16 <IdleOne> I would be fine with ubottu holding @
18:53:22 <AlanBell> any downside to always being @
18:53:35 <Pici> oblivious people ask it questions.
18:53:36 <Tm_T> more private messages
18:53:38 <Unit193> Questions may be directed directly more.
18:53:41 <Pici> like we get with the floodbots.
18:53:56 <TheLordOfTime> AlanBell:  not unless the bot starts spitting out random errors
18:53:57 <TheLordOfTime> ;P
18:54:02 <AlanBell> ubottu: do people talk to you already?
18:54:02 <ubottu> Error: I haven't seen people.
18:54:03 <ubottu> AlanBell: I am only a bot, please don't think I'm intelligent :)
18:54:06 <oCean> I don't think eir opping and deopping is too much noise for anyone
18:54:06 <Tm_T> have to be afk now, sorry
18:54:07 <m4v> AlanBell: well, maybe the channel's "temperature"?
18:54:43 <IdleOne> wouldn't be any more noisy then eir
18:54:57 <guntbert> m4v: she cannot get into an argument, so will not raise the temperature, I guess
18:55:03 <DJones> I can't see a problem with ubottu being +o other than spam from users, most regulars know that ubottu is a bot and will normally advise users of that when they see somebody speaking directly to her
18:55:20 <m4v> guntbert: I guess so :P
18:56:08 <AlanBell> it seems fine to me, I can't imagine any security concerns about it, if someone can impersonate ubottu then they can cause a similar amount of nusiance either way
18:56:13 <oCean> Getting into the details already :(
18:56:40 <Pici> Why don't we see how feasible it is to make ubottu's current bantracker handling unbanning (and all that jazz), and then we can see how we want to handle the opping status.
18:56:48 <AlanBell> yup
18:56:50 <m4v> oh right, I'll get ops in #ubuntu through ubottu >D j/k
18:57:02 <AlanBell> :O
18:57:21 <IdleOne> I still don't know why you don't have ops in #u
18:57:45 <AlanBell> so m4v, want to have a crack at implementing that? I am happy to help a bit and I am sure others will too
18:57:56 <Pici> As am I.
18:59:07 <m4v> AlanBell: I already started looking at it, it will be a hack, but meh.
18:59:20 <Pici> Isn't everything ;)
18:59:21 <DJones> If ubottu fell off freenode and somebody was alert enough to spot it, could they /nick to ubottu and gain ops in the 30 seconds before nick enforce took priority
18:59:34 <Pici> no
18:59:41 <m4v> DJones: nope, it would need to identify
18:59:43 <IdleOne> not without knowing the nickserv pass
18:59:55 <IdleOne> which is not HUNTER2
18:59:58 <IdleOne> I tried.
19:00:08 <topyli> yeah i changed it the other day
19:00:09 <Pici> The enteries in the access list are account names, not nicks.
19:00:09 <TheLordOfTime> lol
19:00:16 <jussi> its not 123456789 either :P
19:00:29 <Pici> jussi: thats the same password I have on my luggage :o
19:00:31 <DJones> That sounds like it would restrict any 3rd party potential for abuse anyway
19:01:39 <AlanBell> lets do some actions
19:01:41 <topyli> ok, so eir stays and a mega ubottu hackfest is commensing. we can then retire eir tuesday by lunchtime? :)
19:01:58 <oCean> (:
19:02:07 <AlanBell> #action m4v Pici AlanBell to look into adding ban removal to ubottu cababilities
19:02:07 * meetingology m4v Pici AlanBell to look into adding ban removal to ubottu cababilities
19:02:14 <AlanBell> by tuesday lunchtime
19:02:23 <topyli> :)
19:02:55 <AlanBell> #agreed ubottu can hold +o in channels where ban expiry will be used
19:03:01 <m4v> ok, you guys never took a look at bantracker code? welcome to the madhouse.
19:03:28 <Pici> m4v: no, I've already lost my mind looking at it a few times before.
19:03:31 <jussi> bantracker is a huge mess
19:03:38 <topyli> by lunch is not realistic?
19:03:47 <IdleOne> Why can't something new be used in its place?
19:03:48 <Pici> It always has been, lets blame Seveas, hes not really heere.
19:04:02 <Pici> IdleOne: because we can't seem to do that fast enough for anyone's liking.
19:04:04 <jussi> topyli: give them till dinner :P
19:04:17 <AlanBell> this is just adding ban removal, how hard can it be?
19:04:25 <AlanBell> #topic Linking IRCC 'contact this team' in launchpad with osticket
19:04:25 <TheLordOfTime> AlanBell:  on a timer, HARD
19:04:28 <IdleOne> Pici: sucks to be them.
19:04:28 <topyli> ok fine, volunteers and all
19:04:32 <m4v> IdleOne: something new would take a lot of more time.
19:04:45 <AlanBell> so who added this suggestion?
19:04:49 <topyli> i did
19:04:51 <oCean> What is the progress with the BT, can both bot and bt developments combined?
19:05:01 <IdleOne> m4v: I understand that but it would be better than hacking stuff together and hope it doesn't explode
19:05:03 <oCean> oh
19:05:07 <oCean> nvm
19:05:12 <Pici> I though the 'contact this team' thing just sent all the team members an email.
19:05:25 <AlanBell> it does, but it seems we can direct it to a specific email address
19:05:30 <TheLordOfTime> |^ that
19:05:30 <topyli> this item is about avoiding mail via launchpad in our inboxen and into the ticket system
19:05:43 <Pici> topyli: that sounds like a much better idea to me.
19:05:53 <Pici> can I send all my own mail there too? ;)
19:05:55 <jussi> I like this idea
19:06:03 <jussi> Pici: no :P
19:06:06 <Pici> darn.
19:06:09 <AlanBell> A confirmation message has been sent to 'ircc-appeals@ubottu.com'. Follow the instructions in that message to confirm the new contact address for this team.
19:06:10 <topyli> heh
19:06:15 <AlanBell> hmm
19:06:34 <AlanBell> ok, we have a new appeal to deal with ;)
19:06:43 <topyli> denied!
19:07:28 <Pici> topyli: you need to actually read the appeal message first ;)
19:07:28 <jussi> Noooo!!! :(
19:07:37 <AlanBell> ok, so we can finish that off later, but it seems like a good idea
19:07:53 <AlanBell> #topic Any Other Business
19:07:56 <Pici> cool cool fcool
19:07:59 <topyli> yeah we can handle it ourselves
19:08:52 <AlanBell> does anyone else have any other topics they would like to raise?
19:09:15 <jussi> argh, I had somethign, but Ive forgotten
19:09:21 <IdleOne> AlanBell: We have been having issues with certain persistent people trolling our less active channels that have hardly any access for the ops team. Would it be possible to create a spec ops team account and add this account to those smaller channels?
19:09:31 <jussi> no doubt it will come to me after the meeting
19:09:43 <Pici> IdleOne: Isn't that what the ircc account is for?
19:10:00 <IdleOne> Pici: there are only 5 of you and they seem to know your schedules
19:10:08 <topyli> jussi: it always does doesn't it :)
19:10:13 <AlanBell> some don't have the ubuntuirccouncil account in the access list (-beginners is the example that springs to mind)
19:10:45 <Pici> IdleOne: Is freenode-staff on those access lists?
19:10:49 <IdleOne> AlanBell: which brings me to my next suggestion make it mandatory that IRCC be in all channel access list in the namespace
19:11:03 <IdleOne> Pici: some but staff is not always available either
19:11:26 <jussi> IdleOne: can you name specific time when this has happened?
19:11:50 <Tm_T> back
19:11:50 <AlanBell> right now it is suggested that we are in the access lists, and we can get staff assistance if we are not and need to be
19:11:55 <TheLordOfTime> oh, i have one other thing of business to bring up, when you're done with this issue you're discussing.
19:11:57 <TheLordOfTime> regarding access lists.
19:12:03 <TheLordOfTime> (you just reminded me AlanBell)
19:12:06 <IdleOne> jussi:19:00 to 21:00 my time
19:12:17 <IdleOne> UTC-5
19:12:45 <topyli> i would enjoy being sure without checking that ubuntuirccouncil is on the access list of any channel with an emergency
19:13:25 <IdleOne> jussi: the times vary
19:13:31 <TheLordOfTime> there are a few channels which have Ubuntu Members in their access lists.  Given that freenode has been starting a policy of secondary-cloaks being project.accountname rather than project.role.accountname, Ubuntu Members with newer secondary cloaks are not able to have access to channels which use the primary-cloak, and old-secondary-cloak access formats
19:13:53 <TheLordOfTime> i.e. if we see the -irc access list, you see ubuntu/member/* and ubuntu.member.*
19:14:00 <IdleOne> point is that channels are being harassed for far longer then should be allowed IMO
19:14:06 <jussi> TheLordOfTime: ahh yes, those need fixing
19:14:19 <Pici> I thought we updated those somewhere...
19:14:28 <TheLordOfTime> jussi:  indeed, and preferably globally, there's a few other channels still having that
19:14:34 <AlanBell> so what would be the correct mask?
19:14:48 <TheLordOfTime> AlanBell:  for newer secondary cloak formats (as an example, mine),
19:14:51 <Pici> ubuntu/* and ubuntu.* should cover everything
19:14:59 <TheLordOfTime> ^ that
19:15:24 <TheLordOfTime> or rather for the secondary format...
19:15:27 <TheLordOfTime> */ubuntu.*
19:15:36 <Pici> er, right
19:16:09 <AlanBell> Pici: can you take that one, needs fixing in -meeting and -irc for starters
19:16:17 <Pici> sure
19:16:21 <AlanBell> I will only get the mask wrong
19:16:42 <AlanBell> #action pici to review masks for Ubuntu Member access to channels
19:16:42 * meetingology pici to review masks for Ubuntu Member access to channels
19:17:03 <jussi> Id also like to have the discussion/decision about #ubuntu-discus
19:17:06 <jussi> err
19:17:13 <jussi> #ubuntu-discuss
19:17:29 <jussi> #ubuntu-discus could be fun though :D
19:17:51 <AlanBell> IdleOne: can we start by finding channels that lack ubuntuirccouncil and see if we can just fix them one by one?
19:18:16 <AlanBell> maybe search with alis for #ubuntu-* having more than 10 people in the channel and check the access lists
19:18:22 <IdleOne> AlanBell: sure but it won't help solve the problem. What i am suggesting is lightning the load for the IRCC
19:19:05 <topyli> i'm still a bit sceptical about -discuss. we have topical channels and -ot
19:19:28 <AlanBell> having a second account for op access across other channels is a bit of a big topic for the any other business section IdleOne :)
19:19:43 <Tm_T> is
19:20:00 <jussi> topyli: I think it is a very topical channel - its for discussion of specifically ubuntu related things that dont fit into #ubuntu's supportarea
19:20:05 <Tm_T> agree with AlanBell, needs some preparation that discussion
19:20:15 <IdleOne> AlanBell: indeed. I brought it up, you folks can shoot the idea around and make a decision. let us know at some point before December :)
19:20:15 <AlanBell> I like the idea of #ubuntu-discuss as a place for on-topic non support discussions
19:20:43 <IdleOne> isn't that what -ot is for?
19:20:45 <AlanBell> and somewhere that Ubuntu marketing materials from LoCos and Canonical can direct people to
19:20:46 <jussi> ubuntu in the news, improvements to ubuntu, etc etc
19:20:47 <Tm_T> I like the idea of #ubuntu-offtopic as aplace for all non-support discussion that is suitable to our community spirit
19:20:50 <IdleOne> on topic non support
19:21:01 <topyli> jussi: that's -ot IMO
19:21:03 <jussi> IdleOne: no, -ot is a break room type area, for just relaxing
19:21:16 <AlanBell> so why is it called "off topic"?
19:21:24 <IdleOne> jussi: but it can also be for cool ubuntu news and stuff
19:21:29 <topyli> jussi: i disagree :)
19:21:35 <Pici> I'd like to see some folks willing to staff -discuss that will actually be able to answer questions before we set it up
19:21:39 <jussi> topyli: topic says so :P
19:21:49 <Tm_T> AlanBell: good question, similar channels on other communities are called cafes etc
19:21:52 <jussi> Pici: hrm?
19:21:52 <topyli> AlanBell: historical reasons. it was created to move non-support away from #ubuntu back in 2005
19:22:01 <Pici> i.e. not all us ops are knee deep in Ubuntu to know enough to respond to everything .
19:22:18 <AlanBell> Tm_T: yes, a community cafe or something sounds about right
19:22:30 <topyli> forums have a community cafe
19:22:39 <topyli> so that would fit
19:22:41 <Tm_T> that's pretty much what our -ot is
19:22:42 <IdleOne> it sounds like another off topic channel
19:22:43 <Pici> Isn't that what community-team is for?
19:22:48 * topyli is defensive of -ot :)
19:23:05 <Tm_T> Pici: good point
19:23:07 <jussi> Pici: nah, community team is for jono to organise calls :P
19:23:11 <AlanBell> ok, so maybe community cafe is more what offtopic is
19:23:23 <Pici> No.. thats what he uses it for, but its also where the community teams coordinate things
19:23:52 <AlanBell> Canonical sent out a bunch of emails a while back relating to ubuntu phones or Ubuntu for Android asking people to "join the conversation in #ubuntu"
19:23:59 <topyli> my sauna is getting cold :(
19:24:08 <AlanBell> which I had to point out to them was not really what #ubuntu was all about
19:24:18 <jussi> AlanBell: exactly the type of discussion we want in -discuss.
19:24:36 <Tm_T> I wish -ot would be in shape for that kind of use
19:25:08 <Pici> A lot of people use -ot as a place to relax, they don't want to have to deal with that sort of stuff in there.
19:25:09 <topyli> ubuntu phones an ubuntu for android have nothing to do with the community afaik, and nobody knows nothing about them...
19:25:13 <AlanBell> and no, I don't think #ubuntu-offtopic is an appropriate place to direct people to, partly because the name is weird for that kind of thing, and partly because the conversations are a bit random at times
19:25:38 <jussi> I really think that -ot isnt for that, its not somewhere we send people for that type of discussion. its not that it cant happen in -ot, but that its nice to have a dedicates area
19:25:39 <AlanBell> topyli: not entirely true, but anyhow, this is a general point about marketing Ubuntu
19:25:42 <Tm_T> topyli: ...so best option is no channel in that case
19:26:02 <Pici> So, instead of going around in circles.... do we want to trial this?
19:26:03 <topyli> well, canonical can set one up
19:26:04 <Pici> or?
19:26:17 <AlanBell> sabdfl's response was that perhaps they should direct people to askubuntu.com and not IRC at all
19:26:19 <topyli> Tm_T: iirc #ubuntuone is working fine
19:26:21 <jussi> Pici: I would like to trial it
19:26:28 <AlanBell> I would like to trial it
19:26:46 <jussi> AlanBell: you guys want to have a vote? ;)
19:26:49 <Pici> AlanBell: unfortunately, sabdfl has a bit of a history of not exactly getting what we do.
19:26:54 <Tm_T> topyli: yup, because there's canonical folks answering
19:27:00 <topyli> we can trial it, see if people will join when encouraged, and what becomes of it
19:27:08 <topyli> (-discuss i mean)
19:27:28 <Pici> Worst thing that happens is that its a bust and we end up forwarding it to somewhere else.
19:27:37 <topyli> yep
19:27:48 <AlanBell> ok, lets have a little vote on this
19:28:05 <Tm_T> true, but I'm bit worried of the idea that Canonical points people to us and we have to clean up the mess, to put it bluntly
19:28:08 <jussi> ops should also direct people who have that kind of discussion in #ubuntu to there as well
19:28:23 <AlanBell> #vote set up a #ubuntu-discuss channel for high quality on-topic non-support discussions of Ubuntu as a trial to be reviewed at a later date
19:28:23 <meetingology> Please vote on: set up a #ubuntu-discuss channel for high quality on-topic non-support discussions of Ubuntu as a trial to be reviewed at a later date
19:28:23 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
19:28:28 <DJones> What area's of the community would you staff it from? core ops, members, canonical employee's, community-team etc?
19:28:40 <topyli> +1
19:28:40 <meetingology> +1 received from topyli
19:28:42 <AlanBell> #voters AlanBell Pici topyli Tm_T
19:28:42 <meetingology> Current voters: AlanBell Pici Tm_T topyli
19:28:44 <jussi> DJones: all of the above ?:D
19:28:51 <AlanBell> +1
19:28:51 <meetingology> +1 received from AlanBell
19:28:51 <Pici> +1
19:28:51 <meetingology> +1 received from Pici
19:29:03 <DJones> jussi: Agreed, it would have to be a mixture
19:29:09 <Tm_T> +0
19:29:09 <meetingology> +0 received from Tm_T
19:29:13 <topyli> i suspect jussi would like to set it up :)
19:29:14 <AlanBell> #endvote
19:29:14 <meetingology> Voting ended on: set up a #ubuntu-discuss channel for high quality on-topic non-support discussions of Ubuntu as a trial to be reviewed at a later date
19:29:14 <meetingology> Votes for:3 Votes against:0 Abstentions:1
19:29:14 <meetingology> Motion carried
19:29:21 <Pici> I can think of a few folks that would at least be willing to idle there and answer questions
19:30:00 <IdleOne> I'm still not sure about the idea but I'll be idle in there and happy o help out
19:30:02 <AlanBell> great
19:30:03 <topyli> would be nice to lure some canonical staff there
19:30:07 <AlanBell> ok, any more stuff?
19:30:16 <AlanBell> five
19:30:18 <AlanBell> four
19:30:20 <AlanBell> three
19:30:21 <AlanBell> two
19:30:21 <Pici> Is someone willing to send out a mail to the list so that the rest of the folks not present today will know about it?
19:30:28 <Pici> or... will the meeting notes be enoughj
19:30:31 <AlanBell> yeah, I will do that
19:30:35 <AlanBell> one
19:30:36 <Pici> AlanBell: great, thaks.
19:30:38 <AlanBell> #endmeeting