16:02:27 <jamespage> #startmeeting Ubuntu Server Team Meeting
16:02:27 <meetingology> Meeting started Tue Apr  3 16:02:27 2012 UTC.  The chair is jamespage. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02:27 <meetingology> 
16:02:27 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02:35 <adam_g> o/
16:02:42 <jamespage> #topic Review ACTION points from previous meeting
16:03:09 <jamespage> SpamapS: invite aquette to next server team meeting to discuss servercloud-p-cloud-power-management
16:03:55 <smoser> o/
16:03:57 <jamespage> hmm - guess that either did not happen or aquette could not make it
16:04:28 <jamespage> moving on
16:04:30 <jamespage> #topic Precise Development
16:04:42 <jamespage> #topic Release Bugs - http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:04:52 <jamespage> OK  - lets do the list...
16:05:30 <jamespage> bug 960276
16:05:32 <ubottu> Launchpad bug 960276 in nova (Ubuntu) "a bad AMI can hang an entire compute node" [Critical,Fix committed] https://launchpad.net/bugs/960276
16:05:57 <jamespage> zul - has the new patch for console logging landed yet?
16:06:19 <zul> jamespage: landed in our packaging hasnt landed upstream yet
16:06:48 <jamespage> zul: ack
16:07:07 <jamespage> bug 883988
16:07:09 <ubottu> Launchpad bug 883988 in glance (Ubuntu Precise) "db migration failing when upgrading glance - trying to create existing tables" [High,Triaged] https://launchpad.net/bugs/883988
16:07:29 <adam_g> jamespage: fixed upstream finally, will trickle into ubuntu with our next glance upload
16:07:35 <adam_g> or Essex final
16:07:39 <jamespage> +1
16:07:40 <zul> or rc3
16:07:47 <jamespage> lol
16:07:55 <jamespage> bug 924739
16:07:58 <ubottu> Launchpad bug 924739 in squid3 (Ubuntu Precise) "after upgrade from oneiric to precise, previous squid config unused, cannot be used when relocated" [High,Triaged] https://launchpad.net/bugs/924739
16:08:14 <jamespage> adam_g, I said I would help out with that last week - my bad - catchup later
16:08:21 <jamespage> bug 928990
16:08:21 <adam_g> k
16:08:22 <ubottu> Launchpad bug 928990 in cloud-init (Ubuntu) "fsck / dirty filesystem on instance is death" [High,Triaged] https://launchpad.net/bugs/928990
16:08:23 <lynxman> o/
16:09:22 <jamespage> utlemming, found any time to look at that yet?
16:10:01 <utlemming> I started, but got distracted on other things. I hope to get that done this week.
16:10:21 <jamespage> utlemming, ack - I'm going to assign you the bug (had to think hard back to last week)
16:10:40 <jamespage> bug 930916
16:10:43 <ubottu> Launchpad bug 930916 in amavisd-new (Ubuntu) "amavis start-stop script fails to stop amavisd" [High,Confirmed] https://launchpad.net/bugs/930916
16:10:49 <jamespage> assigned to SpamapS
16:10:58 <jamespage> who is not here....
16:11:09 <jamespage> I'll poke him about that and some php5 stuff as well later
16:11:19 <jamespage> adam_g: bug 966115
16:11:20 <ubottu> Launchpad bug 966115 in nova (Ubuntu) "nova-api{,-os-compute,-ec2,-os-volume} relationship" [High,In progress] https://launchpad.net/bugs/966115
16:11:28 <adam_g> jamespage: on my TODO today
16:11:32 <jamespage> \o/
16:11:35 <jamespage> great
16:11:54 <jamespage> bug 880339 appears to be blocked on lack of information from the reported ATM
16:11:57 <ubottu> Launchpad bug 880339 in mysql-5.5 (Ubuntu Precise) "AppArmor profile needs update" [Medium,Incomplete] https://launchpad.net/bugs/880339
16:12:08 <jamespage> bug 907197
16:12:09 <ubottu> Launchpad bug 907197 in nova (Ubuntu) "ip address can't be injected into the instance when using lxc " [Medium,Incomplete] https://launchpad.net/bugs/907197
16:12:45 <jamespage> zul: still pending a response? have you seen this issue yourself?
16:12:59 <zul> no i havent, i think we should take it off our list
16:13:41 <jamespage> zul: as we don't have confirmation at this point I think that makes sense
16:13:57 <jamespage> bug 916065
16:13:59 <ubottu> Launchpad bug 916065 in php5 (Ubuntu Precise) "php5 sessionmanagement ignores values in custom ini files" [Medium,Triaged] https://launchpad.net/bugs/916065
16:14:10 <jamespage> I need to catch SpamapS about
16:14:17 <jamespage> bug 966069
16:14:18 <ubottu> Launchpad bug 966069 in horizon (Ubuntu) "/etc/apache2/conf.d/dashboard.conf contains wrong paths in the Ubuntu package" [Medium,Triaged] https://launchpad.net/bugs/966069
16:14:45 <jamespage> looks like that is pending upload?
16:15:25 <jamespage> yes it is...
16:15:27 <adam_g> jamespage: waiting for the horizon rc
16:15:50 <jamespage> bug 967430
16:15:51 <ubottu> Launchpad bug 967430 in cobbler (Ubuntu) "Switching to internal python tftp server fails due to file name change" [Medium,Triaged] https://launchpad.net/bugs/967430
16:16:22 * ttx is waiting for the horizon rc too
16:16:36 <ttx> damn californians
16:16:54 <ttx> adam_g: note that Glance RC3 will include your db fix
16:16:59 <adam_g> ttx: saw that one, thanks
16:17:10 <jamespage> marvellous
16:17:23 <ttx> should be out today or early tomorrow
16:17:29 <jamespage> roaksoax, are you going to have time to pickup bug 967430?
16:17:30 <ubottu> Launchpad bug 967430 in cobbler (Ubuntu) "Switching to internal python tftp server fails due to file name change" [Medium,Triaged] https://launchpad.net/bugs/967430
16:17:40 <roaksoax> jamespage: i sure hope so
16:17:47 <roaksoax> by the end of the week
16:18:10 <jamespage> great
16:18:24 <roaksoax> assigning it to myself
16:18:38 <jamespage> roaksoax, one step ahead of you...
16:18:45 <jamespage> bug 901881
16:18:47 <ubottu> Launchpad bug 901881 in glance (Ubuntu) "nova and glance should depend on python-keystone" [Low,In progress] https://launchpad.net/bugs/901881
16:19:09 <adam_g> jamespage: still waiting on the keystone MIR to create the direct Depends
16:19:38 <zul> jamespage: im hoping next week for that one
16:19:45 <jamespage> zul: ack
16:20:15 <jamespage> scans the rest of the list....
16:20:49 <jamespage> there are a few FTBFS that need dealing with - genshi is already on the report
16:21:18 <jamespage> but I also saw pacemaker and heartbeat in the latest rebuild test....
16:21:27 <jamespage> I'll get bugs raised and them added to the list...
16:21:47 <jamespage> #action jamespage to raise bugs for FTBFS for server related packages from latest rebuild test.
16:21:47 * meetingology jamespage to raise bugs for FTBFS for server related packages from latest rebuild test.
16:21:56 <adam_g> i fixed the cluster-glue build last night, that should resolve the pacemaker + heartbeat builds. is there a way to re-trigger those without a new upload to each, now that the dependency is fixed?
16:22:00 <roaksoax> uhmm I though I had fixed pacemaker's FTBFS
16:22:31 <jamespage> http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120328-precise.html
16:22:55 <jamespage> roaksoax, looks like there is a new one :-)
16:22:57 <roaksoax> adam_g: yes, with a no change upload. I'll take care of it
16:23:10 <adam_g> thanks
16:23:18 <jamespage> those two packages both have the same issue - glibc headers have changed structure...
16:23:42 <jamespage> memcached is also failing tests on i386 - I'm looking at that
16:23:43 <adam_g> the issue was in the cluster-glue library they build against, which is fixed now. they should both build okay
16:24:15 <jamespage> MIR's - zul: sounds like keystone should be complete in the next week or so?
16:24:23 <zul> hopefully
16:24:35 <zul> i think most of the issues have been resolved, horizon is next on the list i think
16:24:41 <roaksoax> adam_g: awesome!
16:24:59 <jamespage> roaksoax, how about the cobbler MIR?
16:26:06 <roaksoax> jamespage: looking at it now
16:26:32 <roaksoax> jamespage: jdstrand has it assigned so I guess he's conducting his review work on it, or he will soon
16:26:38 <jamespage> great
16:26:55 <roaksoax> MAAS is also queued
16:27:15 <jamespage> Final Freeze kicks in on the 12th of April which is only 9 days away
16:27:18 <jamespage> busy busy busy!
16:27:19 <roaksoax> s/queued/waiting for final review after commends/
16:27:37 <jamespage> next
16:27:38 <jamespage> #topic Blueprints - http://status.ubuntu.com/ubuntu-precise/ubuntu-server.html
16:28:04 <jamespage> I did have a quick scan through these before the meeting
16:28:32 <jamespage> I could not see anything I though needed specific dicussion but please can you all start to review any outstanding work items you have
16:28:42 <jamespage> and POSTPONE anything that won't make this release.
16:29:01 <jamespage> anything that needs to make this release but is in trouble - start shouting loud!
16:29:35 <jamespage> Anything else anyone wants to mention about precise development?
16:30:25 <jamespage> great
16:30:26 <jamespage> #topic Ubuntu Server Team Events
16:30:44 <jamespage> Openstack Developer Summit in two weeks time
16:31:00 <jamespage> a fair few people are attending summit and/or conference
16:31:11 <jamespage> any other events people want to mention?
16:32:18 <jamespage> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:32:23 <jamespage> hggdh - around?
16:32:25 <jamespage> all yours
16:33:55 <jamespage> or maybe not
16:34:01 <jamespage> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:34:10 <smb> Hi. I think I found another thing where libvirt does not exactly do the right things with xen. Affecting HVM guests. Luckily it is not fatal-
16:34:22 <smb> Need to dig a bit more there.
16:34:27 <smb> Beside that...
16:34:33 <smb> Daviey, iscsitarget?
16:34:39 <zul> iscsitarget?
16:34:59 <jamespage> smb: iscsitarget?
16:35:00 <smb> zul, A fix I backported to the package, but I cannot upload
16:35:21 <smb> bug 962332
16:35:24 <ubottu> Launchpad bug 882540 in iscsitarget (Ubuntu) "duplicate for #962332 kernel crash whenever it is accessed" [Medium,In progress] https://launchpad.net/bugs/882540
16:36:00 <Daviey> smb: So, sorry
16:36:10 <Daviey> smb: I will make sure it is uploaded *today* without fail.
16:36:31 <smb> Daviey, Thank you master. :)
16:36:39 <jamespage> smb: any other kernel related matters to raise
16:36:40 <jamespage> ?
16:36:53 <jamespage> or does anyone have anything they want to raise with smb?
16:36:54 <smb> I don't think so
16:37:25 <jamespage> OK
16:37:28 <jamespage> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:37:38 <rbasak> Nothing to report. Any questions for me?
16:37:49 <jamespage> ARM server all looking sweet for precise then?
16:38:11 <rbasak> It looks good
16:38:32 <jamespage> #topic Open Discussion
16:38:59 <jamespage> I have one item to raise
16:39:15 <jamespage> Ursinha has now fixed the Triage Report - http://reports.qa.ubuntu.com/reports/ubuntu-server/triage-report.html
16:39:26 <Ursinha> \o/
16:39:50 <jamespage> we have alot of 'New' bugs - bugs which have been assigned a priority but triaged no further than that.
16:39:55 <jamespage> about 260 of them
16:40:04 <jamespage> (thanks Ursinha)
16:40:29 <hallyn> tnachen: \o
16:40:58 <zul> jamespage: keeping you busy i see :)
16:41:00 <jamespage> it would be great if people can ensure that these get some focus of the next week or so - specifically anything that might be an issue in precise
16:41:09 <jamespage> I found at least three this morning
16:41:23 <hallyn> tnachen is looking at getting involved with ubuntu server, and managed to sit through this whole meeting.  just wanted to introduce him
16:41:36 <jamespage> hi tnachen: welcome!
16:41:45 <tnachen> hi all, I emailed to ubuntu-server about the mentor program I saw on the wiki
16:42:00 <tnachen> and hallyn gladly to volunteer to lead the newbie (me)
16:42:12 <tnachen> I'll be working with him to learn more about libvirt and hopefully contribute!
16:42:17 <jamespage> \o/
16:42:27 <hallyn> i second that exuberance
16:42:31 <rbasak> I'm waiting on bug 968753 to be sponsored - it looks like an issue with ssh on precise but on i386 only. I presume it'll be picked up in time.
16:42:33 <ubottu> Launchpad bug 968753 in openssh (Ubuntu) "ssh crashed with SIGSEGV" [Medium,Triaged] https://launchpad.net/bugs/968753
16:43:08 <rbasak> (it got reported over the weekend with a pile of dupes)
16:43:28 <jamespage> rbasak, poke someone if it does not get picked up before the weekend
16:43:37 <rbasak> jamespage: will do, thanks
16:43:43 <jamespage> anything else?
16:44:35 <jamespage> ......
16:44:37 <jamespage> .....
16:44:40 <jamespage> ....
16:44:42 <jamespage> ...
16:44:44 <jamespage> ..
16:44:45 <jamespage> .
16:44:49 <Daviey> o/
16:44:57 <Daviey> Comgrats jamespage :)
16:45:03 <Daviey> Congrats*
16:46:18 <jamespage> #topic Announce next meeting date and time
16:46:40 <jamespage> Tues 10th April 1600 UTC - back here again!
16:46:46 <jamespage> see you all then!
16:46:59 <jamespage> #endmeeting