16:01:13 <SpamapS> #startmeeting Ubuntu Server Team
16:01:13 <meetingology> Meeting started Tue Mar 27 16:01:13 2012 UTC.  The chair is SpamapS. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01:13 <meetingology> 
16:01:13 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01:41 <SpamapS> No actions from last week, so lets get right into precise dev
16:01:46 <SpamapS> #topic Precise Development
16:02:04 <zul> |o|
16:02:08 <smoser> o/
16:02:17 <hallyn> (btw, kvm disk io perf regrssion might ought to be added to agenda, not sure)
16:03:03 <SpamapS> BTW, it would be helpful to have the release bug tracker in the meeting agenda
16:03:06 * SpamapS does not know the link
16:03:10 <arosales> http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:03:47 <arosales> SpamapS: probably should add that link and the server team blueprint link
16:03:53 <Ursinha> I recall adding the link to the meeting page
16:04:02 <SpamapS> Ok well I added the report link to the meeting
16:04:17 <arosales> ubuntu server team blueprint link (for reference) http://status.ubuntu.com/ubuntu-precise/ubuntu-server.html
16:04:35 <arosales> although that will obviously change with different cycles.
16:04:51 <SpamapS> Ok, lots of bugs still to get through
16:05:06 <SpamapS> bug #959426
16:05:08 <ubottu> Launchpad bug 959426 in Glance "nova + glance services die if started before db is reachable" [High,In progress] https://launchpad.net/bugs/959426
16:05:15 <adam_g> SpamapS: in progress
16:05:21 <SpamapS> werd
16:05:24 <SpamapS> bug #960276
16:05:25 <ubottu> Launchpad bug 960276 in nova (Ubuntu) "a bad AMI can hang an entire compute node" [Critical,Confirmed] https://launchpad.net/bugs/960276
16:05:57 <adam_g> chucks workin a replacement to the console fifo patch we're carrying
16:06:07 <SpamapS> Ah, so thats something we broke?
16:06:09 <SpamapS> :)
16:06:42 <SpamapS> can somebody mark that bug In Progress/zulcss? kthx
16:06:49 <hallyn> is that related to the cosnole log growing indefinately?
16:06:53 <SpamapS> bug #883988
16:06:55 <ubottu> Launchpad bug 883988 in glance (Ubuntu Precise) "db migration failing when upgrading glance - trying to create existing tables" [High,Confirmed] https://launchpad.net/bugs/883988
16:07:18 <adam_g> SpamapS: i have a patch for that, just trying to get upstream to sign off on it before we apply it. should happen this week, ive sent it already
16:07:33 <adam_g> hallyn: yeah
16:07:39 <SpamapS> sweet
16:08:00 <SpamapS> adam_g: should be status Triaged then
16:08:32 <adam_g> SpamapS: yeah, ill update bot
16:08:34 <adam_g> *both
16:08:43 <SpamapS> and probably linked to upstream
16:09:03 <SpamapS> bug #924739
16:09:05 <ubottu> Launchpad bug 924739 in squid3 (Ubuntu Precise) "after upgrade from oneiric to precise, previous squid config unused, cannot be used when relocated" [High,Triaged] https://launchpad.net/bugs/924739
16:09:08 <SpamapS> heh, its all adam_g, All morning
16:09:19 <SpamapS> /afternoon/evening depending on timezone ;)
16:09:37 <adam_g> ive sadly made no progress on that since last time, theres so much going on. if anyone else wants to help with that transition bug, please step up! :)
16:10:11 <SpamapS> I suspect that will affect lucid to precise as well
16:10:54 <adam_g> yes, theres not much we can do to work around it but we can do our best to make it as obvious to users thats the transition has happened
16:10:57 <SpamapS> anybody else have some available bandwidth to take over bug #924739?
16:10:58 <ubottu> Launchpad bug 924739 in squid3 (Ubuntu Precise) "after upgrade from oneiric to precise, previous squid config unused, cannot be used when relocated" [High,Triaged] https://launchpad.net/bugs/924739
16:11:17 <SpamapS> bug #928990
16:11:19 <ubottu> Launchpad bug 928990 in cloud-init (Ubuntu) "fsck / dirty filesystem on instance is death" [High,Triaged] https://launchpad.net/bugs/928990
16:11:35 <jamespage> SpamapS, adam_g: I can spare a few cycles - lemme catchup with adam_g later
16:11:40 <SpamapS> smoser: is that just there for good measure?
16:11:58 <smoser> probably.
16:12:07 <smoser> i'd love it if someone wanted to take it
16:12:08 <smoser> :)
16:12:21 <smoser> but i dont have it on my list of things that i'm going to fix right now.
16:12:52 <SpamapS> bug #930916
16:12:54 <ubottu> Launchpad bug 930916 in amavisd-new (Ubuntu) "amavis start-stop script fails to stop amavisd" [High,Confirmed] https://launchpad.net/bugs/930916
16:13:06 <SpamapS> I haven't poked it since last time, but intend to.. soon.. I swear. ;)
16:13:13 <utlemming> smoser: I can't commit entirely to fixing it...but I can try. I have a lot on my plate, but I'm blocked today, so I'll take a stab
16:13:23 <SpamapS> bug #959262
16:13:24 <ubottu> Launchpad bug 959262 in python-novaclient (Ubuntu) "[Errno 13] Permission denied: '/var/www/.novaclient'" [High,Confirmed] https://launchpad.net/bugs/959262
16:13:46 <adam_g> SpamapS: that one is fixed upstream, but we need to get it on their radar so its backported to essex/milestone-proposed. shouold happen today
16:13:58 <adam_g> otherwise we can patch, but shouldnt need to. its trivial
16:14:15 <SpamapS> adam_g: is it definitely going to happen before release, or 0-day SRU?
16:14:58 <SpamapS> bug #880339
16:14:59 <ubottu> Launchpad bug 880339 in mysql-5.5 (Ubuntu Precise) "AppArmor profile needs update" [Medium,Incomplete] https://launchpad.net/bugs/880339
16:15:13 <adam_g> SpamapS: should happen well before
16:15:19 <SpamapS> That one is actually Fix Committed .. just need to get 5.5.22 in as well
16:15:19 <Daviey> we really don't need to be thinking about 0-day SRU's yet.
16:15:23 <SpamapS> adam_g: alright
16:15:34 <SpamapS> Daviey: lot of bugs here.. not much time. ;)
16:16:06 <SpamapS> bug #907197
16:16:08 <ubottu> Launchpad bug 907197 in nova (Ubuntu) "ip address can't be injected into the instance when using lxc " [Medium,Incomplete] https://launchpad.net/bugs/907197
16:17:07 <SpamapS> Bueller? Bueller?
16:17:22 <SpamapS> zul: ^^ ?
16:17:36 <zul> no response from user
16:17:37 <Daviey> SpamapS: if we have time to plan to do a 0-day SRU at this stage, we have time to get it in the release. :)
16:17:47 <SpamapS> bug #966069
16:17:48 <ubottu> Launchpad bug 966069 in horizon (Ubuntu) "/etc/apache2/conf.d/dashboard.conf contains wrong paths in the Ubuntu package" [Medium,New] https://launchpad.net/bugs/966069
16:18:01 <SpamapS> Daviey: I admire your optimism! :)
16:18:07 <Daviey> zul is already cracking that one out i think
16:18:08 <zul> SpamapS: fixed in bzr
16:18:12 <Daviey> \o/
16:18:49 <SpamapS> bug #901881
16:18:50 <ubottu> Launchpad bug 901881 in glance (Ubuntu) "nova and glance should depend on python-keystone" [Low,New] https://launchpad.net/bugs/901881
16:19:24 <SpamapS> zul: can you make sure the status is right on that bug?
16:19:44 <zul> yep
16:19:47 <SpamapS> bug #959426
16:19:49 <ubottu> Launchpad bug 959426 in Glance "nova + glance services die if started before db is reachable" [High,In progress] https://launchpad.net/bugs/959426
16:20:30 <adam_g> SpamapS: in progress just like the nova task
16:20:34 <adam_g> same fix, basically
16:21:17 <SpamapS> sweet
16:21:24 <SpamapS> on to blueprints
16:21:30 <SpamapS> http://status.ubuntu.com/ubuntu-precise/ubuntu-server.html
16:22:00 <arosales> so we are at week 24/28 Bet2 release on the 29th
16:22:18 <arosales> ~85% thorough the cycle if you count all the way up to release
16:23:07 <arosales> Overall progress is 77%, so we have a few blueprints we need to evaluate if we are going to be able to complete this cycle
16:23:26 <arosales> SpamapS: Would you like to iterate through the blueprints?
16:23:42 <SpamapS> arosales: I was just looking through them for those that seem behind
16:23:57 <SpamapS> servercloud-p-juju-charm-testing
16:24:11 <SpamapS> m_3 and I are working on getting that one back on track this week.
16:24:24 <SpamapS> servercloud-p-openstack-testing
16:25:14 <SpamapS> adam_g: only one TODO left, Collaborate on defining charm use workflow between OpenStack and Ubuntu: TODO ... seems like that doesn't make much sense to do before 12.04 releases
16:25:38 <SpamapS> servercloud-p-automated-boot-testing
16:26:04 <SpamapS> That one is mine, and I need to update the status. jamespage has saved me on this one, and we actually have a single reboot test now for LAMP :)
16:26:15 <adam_g> SpamapS: its something we'll likely be discussing at ODS in a couple of weeks, so left as a TODO till then. but right, its not release critical by any means
16:26:37 <SpamapS> adam_g: alright sounds good
16:26:41 <SpamapS> servercloud-p-cloud-power-management
16:27:49 <SpamapS> I'm going to invite aquette to come to next week's meeting so we can discuss this
16:27:59 <Daviey> SpamapS: that sounds great
16:28:08 <SpamapS> #action SpamapS invite aquette to next server team meeting to discuss servercloud-p-cloud-power-management
16:28:08 * meetingology SpamapS invite aquette to next server team meeting to discuss servercloud-p-cloud-power-management
16:28:57 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-arm-service-orchestration
16:28:57 <Daviey> SpamapS: EOF?
16:29:03 <SpamapS> couple more
16:29:33 <SpamapS> rbasak: that one looks mostly on track, just pinging you on it since its < 75%
16:29:42 <Daviey> rbasak: We can go through, [racb] Validate cobbler enlistment works: TODO .. later if you want?
16:30:00 <SpamapS> also [racb] Validate juju using orchestra: TODO should probably be maas. :)
16:30:11 <rbasak> I feel a bit blocked on the new orchestra stuff and ARM support
16:30:21 <Daviey> rbasak: Grab me after this?
16:30:22 <rbasak> It's not quite clear what needs to be done with regard to this.
16:30:27 <rbasak> Daviey: OK
16:30:27 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-ceph
16:31:01 <SpamapS> MIR still pending.. I think I'll postpone a few of the items in that one this week.
16:31:26 <hallyn> we may want to take more active role in that one next cycle
16:31:33 <Daviey> the MIR team are *too* loaded right now.
16:31:43 <SpamapS> Yes, I think the MIR team needs another member.
16:31:48 <Daviey> Adding anything other than pure essential stuff is a no-go
16:32:02 <SpamapS> Its likely we'll continue to add openstack components and other bits.
16:32:04 <Daviey> Ie, if it's not the on the cd, it's a hard push to consider a MIR now.
16:32:29 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-orchestra
16:32:37 <SpamapS> That one is mostly on track, but looks a little behind
16:33:23 <Daviey> now accurate
16:33:28 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-openstack
16:33:39 <SpamapS> Perhaps just lagging on WI updates?
16:33:59 <Daviey> zul: ^^
16:34:13 <zul> Daviey: yeah need to update it today
16:34:18 <zul> mostly on track though
16:34:29 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-kvm-document-suggested-changes
16:34:50 <hallyn> Just updated that.  What remains TODO, I intend TODO
16:34:58 <SpamapS> sweet
16:34:59 <Daviey> groovy
16:35:16 <SpamapS> just a couple more
16:35:31 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-juju-mir
16:35:47 <SpamapS> Been working with jdstrand on this directly all week.
16:36:04 <Daviey> seemed intensive
16:36:05 <SpamapS> We have some security concerns to address, but otherwise it is progressing.
16:36:38 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-openstack-charms
16:37:08 <Daviey> adam_g: ^
16:37:11 <SpamapS> Some of these I think can be pushed as updates to the charms post-release
16:37:14 <adam_g> SpamapS: those are all not release critical, and not sure which will get done before release
16:37:36 <SpamapS> adam_g: perhaps just POSTPONE them and if you end up doing them, go back and change them to DONE?
16:37:37 <adam_g> i think pots-UDS calm would be a better time to address those, short of the swift tasks.. those charms need updating for keystone auth
16:38:15 <adam_g> SpamapS: yeah, sounds good
16:38:56 <SpamapS> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-p-juju-roadmap
16:38:58 <SpamapS> Last one
16:39:07 <SpamapS> juju team is landing many of those this week
16:39:54 <Daviey> - Okay.. So.. Beta-2... -
16:40:02 <SpamapS> aye
16:40:05 <Daviey> I'll be doing another spin later on today.
16:40:16 <zul> how come?
16:40:17 <Daviey> Is there anything else which is a candidate for inclusion ?
16:40:28 <Daviey> zul: Some changes required on the cd.
16:40:33 <Daviey> :)
16:40:39 <adam_g> Daviey: there are some other openstack rc1's that trickled in after freeze
16:40:53 <adam_g> nova, especially
16:40:58 <Daviey> adam_g: I saw a less than important quantum upload
16:41:00 <Daviey> anything else?
16:41:09 <adam_g> Daviey: i think nova was the only in-main component
16:41:11 <adam_g> zul ?
16:41:11 <Daviey> Has that been uploaded?  Is it in the queue?
16:41:19 <adam_g> oh!
16:41:23 <adam_g> keystone, though not in main
16:41:24 <zul> it beens uploaded for a while now
16:41:36 <Daviey> ok
16:41:44 <Daviey> I also pruned some things from the cd..
16:41:54 <Daviey> (including puppet and zsh)
16:42:08 <Daviey> Anything else beta-2 critical ?
16:42:09 <SpamapS> not zsh!! ;)
16:42:19 <SpamapS> Daviey: I can get you a few MB in mysql-client
16:42:23 <Daviey> SpamapS: fear not, it's still in mai.
16:42:33 <Daviey> SpamapS: have bags of space right now :)
16:42:38 <Daviey> now ruby is off the cd :)
16:42:39 <SpamapS> ok good
16:42:59 <SpamapS> (about ruby being gone, not your space.. who cares about space? ;)
16:43:08 <Daviey> Okay, nothing else of importance.. lets skip beta-2 and go straight to release. :)
16:43:27 <SpamapS> https://bugs.launchpad.net/ubuntu/+source/vde2/+bug/776818
16:43:28 <ubottu> Launchpad bug 776818 in vde2 (Ubuntu) "[MIR] vde2" [Undecided,Confirmed]
16:43:29 <zul> space...the final frontier...these are the voyages of the..
16:43:59 <hallyn> basically i was wondering if anyone else wanted to asnwer jdstrand's question:  "does serverr team want this"
16:44:14 <hallyn> i think the answer is, users want it so yes,
16:44:15 <SpamapS> heh, at this point, "Not for P"
16:44:28 <hallyn> naturally :)
16:44:59 <hallyn> but if the answer is yes, better to answer that now so when they have time, mir team can consider
16:45:17 <hallyn> otoh,
16:45:25 <hallyn> vde2 is way behind debian's version, and noone has cared enough to mention it
16:45:54 <SpamapS> I know it sucks to keep pushing back but this is LATE
16:45:55 <Daviey> hallyn: I'd like a UDS session on making kvm rock harder.. this can be discussed there
16:45:59 <SpamapS> lets push this to Q and make sure it happens in Q
16:46:18 <hallyn> SpamapS: of course it's pushed to Q, but i don't think answering the q should be pushed to q
16:46:33 <hallyn> all right ifne
16:46:38 <SpamapS> Sounds good
16:46:40 <Daviey> hallyn: we can push it to discuss at UDS-Q. :)
16:46:45 <SpamapS> time to move on
16:46:51 <SpamapS> #topic Ubuntu Server Team Events
16:46:52 <hallyn> Daviey: (we did that last time :)
16:46:59 <Daviey> hallyn: *doh*
16:47:12 <hallyn> Daviey: (note that comment was written *at* uds-p)
16:47:35 <Daviey> Events, Openstack Design Summit
16:47:39 <hallyn> events... uds coming up :)
16:47:43 <SpamapS> jcastro and marcoceppi are presenting on juju at POSSCON http://www.posscon.org/
16:47:54 <Daviey> - Apr 16-18 in San Francisco
16:48:05 <Daviey> ^  ODS
16:48:23 <SpamapS> Also the conference is the 2 days after that :)
16:48:41 <arosales> m_3 @ DevOptsDays Austin April 2-3
16:48:49 <hallyn> url?
16:48:54 <SpamapS> m_3 and robbiew will be at DevOpsDays Austin next week http://devopsdays.org/
16:49:02 <hallyn> thx
16:49:05 <SpamapS> arosales: jynx
16:49:09 <arosales> :-)
16:49:14 <arosales> thanks for providing the URL
16:49:29 <SpamapS> ok, we have just 11 minutes left
16:49:35 <SpamapS> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:49:39 <SpamapS> hggdh: anything to report?
16:49:53 <SpamapS> I suspect once Daviey does his respin we should all try to crank out some ISO testing
16:50:09 <hggdh> nothing, except I had just finished the server tests when I heard of the respin...
16:50:12 <hggdh> ..
16:50:31 <hallyn> someone buy the man a cupcake :(
16:50:37 <SpamapS> hggdh: I just threw something across the room in your honor
16:50:38 <hggdh> SpamapS: actually, yes, help will be very appreciated ;-)
16:50:54 <hggdh> SpamapS: thank you. I hope it did not break anything
16:51:00 <Daviey> 4 more test cases will be added to the tracker later doay
16:51:02 <Daviey> today
16:51:05 <SpamapS> Seriously, people, give the iso a try..  http://iso.qa.ubuntu.com
16:51:13 <hggdh> Daviey: perfect
16:51:14 <hallyn> ping on ubuntu-server when respin complete?
16:51:21 <Daviey> hallyn: sure
16:51:23 <SpamapS> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:51:27 <smb> Hi
16:51:31 <smb> Meddled a bit more in libvirt and could find the reason why xen shutdown is not seen in some cases. Sent patches upstream (to be so far ignored) and asked hallyn for sponsorship into precise.
16:51:39 <Daviey> Hey smb.. How is our lovely kernel?
16:51:45 <smb> Apart from that not that much exiting. :)
16:52:07 <smb> ..
16:52:10 <Daviey> smb: i386 on heavy boxes?  Is that being worked on?
16:52:31 <smb> Yes, apw wanted to think about a few things
16:52:45 <tgardner> Daviey, you read Andy's analysis, right ?
16:52:47 <smb> He had a few ideas how to go forward there
16:52:48 <Daviey> smb: In time for kernel final freeze?
16:52:58 <Daviey> tgardner: Yes, it was very compressive
16:53:02 <Daviey> comprehensive
16:53:13 * smb believes the probablility is good
16:53:16 <tgardner> Daviey, I don't think there is anything we'll do before freeze
16:53:17 <SpamapS> much love to the kernel team.. I have no complaints... both my macs, and my hundreds of short lived EC2 instances have all worked perfectly. :)
16:53:32 <Daviey> tgardner: I tohught the outcome was a printk "System incompatible with current kernel" etc.
16:53:55 <tgardner> Daviey, I think we can do that
16:54:18 <hallyn> except I think there's possibility our kvm guest perf woes might need kernel love... need to dig further
16:54:18 <Daviey> tgardner: I am adding to our MIN system requirements a MAX system requirement for i386, for the release notes.
16:54:36 <Daviey> hallyn: You've been speaking to smoser about kvm perf?
16:54:37 <smb> hallyn, Keep me posted there
16:54:39 <hallyn> yes
16:54:45 <hallyn> both
16:54:46 <Daviey> groovy
16:54:50 <tgardner> Daviey, Andy knows the most about this, but he's not in right now.
16:54:54 <smoser> yeah, thats gonna be fun.
16:54:59 <Daviey> ok, thanks tgardner / smb
16:55:15 <SpamapS> Alright moving on
16:55:19 <SpamapS> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:55:25 <smoser> i just want to make sure that we do a reasonable job, and ideally pick off the low hanging fruit for this cycle, not next.
16:55:30 <rbasak> Nothing to report. Any questions for me?
16:55:42 <hallyn> rbasak: mind running an lxc testsuite on arm in next week or two?
16:55:51 <SpamapS> rbasak: I can has armserver?! kthxbai
16:55:52 <rbasak> hallyn: sure.
16:55:55 <hallyn> (i need to convert it to pyunit, but for now...)
16:55:55 <hallyn> thx
16:56:11 <hallyn> hopefully no weird apparmor related glitches there
16:56:27 <SpamapS> rbasak: thanks!
16:56:33 <SpamapS> #topic Open Discussion
16:57:09 <Daviey> Nothin' from me, expect - well done on getting this far chaps!
16:57:36 <hallyn> s/pect/cept/
16:57:53 <Daviey> ta
16:57:58 <arosales> +1
16:58:05 <SpamapS> indeed, 12.04 is going to be awesome. :)
16:58:24 <SpamapS> #topic Announce next meeting date and time
16:59:05 <SpamapS> Tue, April 3, 16:00 UTC, right here
16:59:21 <SpamapS> #endmeeting