16:02 <infinity> #startmeeting
16:02 <meetingology> Meeting started Tue Jul  8 16:02:55 2014 UTC.  The chair is infinity. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:02 <infinity> Sure.
16:03 <infinity> #meetingtopic Tech Board Meeting
16:03 <infinity> The docs lie, apparently.
16:03 <slangasek> '#topic' ?
16:04 <slangasek> but it may not work for changing the channel topic, I'm not sure
16:04 <infinity> #topic Tech Board Meeting
16:04 * infinity shrugs.
16:04 <slangasek> yeah, probably not wired up correctly for use on this channel
16:04 <slangasek> but we can all use our imagination :)
16:04 <infinity> We'll live.  We have almost nothing to discuss, AFAICT.
16:05 <michagogo> Looks like it's not on the ACL
16:05 <slangasek> I don't think that's true
16:05 <slangasek> there are two open questions on the list
16:05 <infinity> #topic Mailing List Review
16:05 <infinity> So, which one first?
16:05 <slangasek> juju was first chronologically
16:05 <pitti> are there? I only have the juju SRU policy
16:06 <slangasek> IIRC
16:06 <infinity> juju and xfce?
16:06 <slangasek> pitti: xfce MRE
16:06 <pitti> ah
16:07 <infinity> So, stgraber and I spent a fair bit of time with the juju team helping them draft their initial policy.
16:07 <slangasek> ah, xfce was actually first
16:07 <slangasek> but either way :)
16:07 * slangasek nods to infinity
16:07 <infinity> I'll admit that I didn't read what went to the list to see how it matched what we asked them for.
16:07 <mdeslaur> I was curious what the answer to pitti question was going to be
16:08 <pitti> ah, I also looked at some initial internal google doc before
16:08 <pitti> it was really verbose, but the gist of what I'm interested in (which combinations of existing installs they test, and how) was a bit terse
16:09 <infinity> Should we take some action items for more than two people to read their proposal and get back to them? :P
16:09 <infinity> I'm in favour of it, in spirit, I just want to make sure it's done sanely in practise.
16:09 <pitti> I read the mail response as well, and it did resolve two of my original concerns, just not expanding on how they test compatiblity with older versions
16:09 <mdeslaur> ok, I'll take a look and respond on the list
16:09 <pitti> right, me too
16:10 <infinity> #action mdeslaur and infinity to read more into the juju stuff and actually reply
16:10 * meetingology mdeslaur and infinity to read more into the juju stuff and actually reply
16:10 <pitti> I mean, it's universe and I suppose won't be supported for the full lifetime of trusty anyway, but it makes a nice example how SRUs can look like
16:10 <infinity> pitti: "supported" is meaningless when Canonical is encouraging people to use it.
16:11 <infinity> pitti: No one (not even our employer) gets to get away with "we tell people to use it, but don't play by the rules because it's 'just universe'"
16:11 <pitti> infinity: right, but I mean trusty's go toolchain might stop being able to build juju well before the 5 year life time is over
16:12 <pitti> anyway, different topic (and that one was discussed to death already)
16:12 <infinity> pitti: Staying with the trusty toolchain was one of the criteria for this.
16:12 <infinity> pitti: Until 16.04 is out, that is.
16:12 <pitti> so, of course this is mostly a question of "how", not "if"
16:12 <mdeslaur> especially software like this that is typically used in enterprise deployments, rather than some universe desktop mp3 tagger or something
16:12 <infinity> #topic xfce MRE
16:12 <kees> sorry I'm late. here now
16:12 <mdeslaur> hi kees
16:12 <pitti> hey kees
16:12 <infinity> kees: *wave*
16:12 <kees> \o
16:13 <mdeslaur> xfce package list looked reasonable
16:13 <mdeslaur> does anything else use the unity-gtk greeter?
16:13 <kees> agreed: xfce looked fine to me
16:13 <mdeslaur> sorry, lightdm-gtk-greeter
16:13 <pitti> xfce-core list, yes; I just wonder what's teh "exception" part there, i. e. what kind of bugs get fixed which don't already fall under the normal SRU policy
16:13 <infinity> I'm not just interested in upstream's practises here, but also who will be doing these MRE uploads, and how they'll be tested in Ubuntu, I think.
16:14 <pitti> Task: xubuntu-desktop, xubuntu-core, mythbuntu-frontend, mythbuntu-desktop, mythbuntu-backend-slave, mythbuntu-backend-master, lubuntu-core, ubuntustudio-desktop-minimal, ubuntustudio-desktop
16:14 * infinity was recently burned by the requestor's SONAME change without package name change, and is now wary. :P
16:14 <pitti> ^ lightdm-gtk-greeter
16:15 <pitti> yeah, Noskcaj isn't yet an ubuntu dev/uploader
16:15 <pitti> (but that means that there's another sanity check through the sponsor queue)
16:15 <mdeslaur> those all happen to use xubuntu as their desktop environment, right?
16:15 <slangasek> so that implies we probably shouldn't bless this for lightdm-gtk-greeter without checking with the other flavors
16:15 <infinity> mdeslaur: Not lubuntu.
16:15 <slangasek> mdeslaur: lubuntu is lxde, not xfce
16:16 <mdeslaur> ah, ok, so yeah, I wouldn't include lightdm-gtk-greeter without checking with them
16:16 <pitti> mdeslaur: lubuntu is LXDE, not sure about mythbuntu
16:16 <slangasek> mythbuntu inherits the desktop bits from one of them but I forget which one - I think xubuntu
16:16 <mdeslaur> XFCE, so yeah
16:18 <slangasek> the one thing that concerns me in all of this is the emphasis on manual testing
16:18 <infinity> So, are we generally okay with everything on that list except that?
16:18 <slangasek> manual testing + an upstream policy on not introducing features
16:18 <infinity> Not that I think that one matters, since its upstream isn't XFCE.
16:18 <slangasek> I don't think the "xfce-related" category should qualify
16:19 <pitti> I agree; core+other looks ok to me
16:19 <mdeslaur> yeah, I think we shouldn't allow anything in the xfce-related category either
16:19 <slangasek> since "related" in no way implies they're covered by the xfce upstream microrelease policy
16:19 <mdeslaur> there seems to be stuff that are used by other environments in there
16:19 <pitti> supposedly quite similar to the GNOME/KDE updates (which also have manual testing for the most part)
16:19 <slangasek> pitti: but a lot of build-time test suites, I think?
16:20 <pitti> slangasek: for the libs, not for the pixelish bits
16:20 <slangasek> fair point
16:20 <pitti> e. g. exo has tests, but not thunar
16:21 <pitti> I'm fine with a provisional MRE for the first two blocks (i. e. not the "related" ones), and we can see how it goes
16:21 <infinity> I'm happy enough with trusting upstream here, for the upstream-derived bits and NACKing the "related".
16:22 <mdeslaur> same with me
16:22 <slangasek> pitti: oh, I meant: don't KDE and GNOME upstream have build-time test suites
16:22 <pitti> and during that, the test case should cover the most important use cases of said package
16:22 <infinity> #vote Allow XFCE provisional MRE for all but the "Related" list:
16:22 <meetingology> Please vote on: Allow XFCE provisional MRE for all but the "Related" list:
16:22 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:22 <infinity> +1
16:22 <meetingology> +1 received from infinity
16:22 <slangasek> i.e., my question is is the XFCE upstream testing really on par with what we expect
16:22 <pitti> slangasek: they do, but again pretty much the same: libs have fairly good coverage, GUI apps not
16:22 <slangasek> ok
16:22 <slangasek> +1
16:22 <meetingology> +1 received from slangasek
16:22 <mdeslaur> +1
16:22 <meetingology> +1 received from mdeslaur
16:22 <pitti> +1
16:22 <meetingology> +1 received from pitti
16:23 <infinity> #endvote
16:23 <meetingology> Voting ended on: Allow XFCE provisional MRE for all but the "Related" list:
16:23 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:23 <meetingology> Motion carried
16:23 <infinity> THat's looks quorumish.
16:23 <infinity> pitti: Want to relay to the list?
16:23 <pitti> infinity: can do
16:23 <infinity> #action pitti to relay XFCE vote results to the list
16:23 * meetingology pitti to relay XFCE vote results to the list
16:23 <pitti> (and to wiki, implied)
16:24 <infinity> #topic Community bugs: (none)
16:24 <infinity> #topic Next chair
16:24 <kees> me, yes?
16:24 <infinity> stgraber, unless he disappears again, then kees?
16:24 <pitti> would be kees
16:24 <kees> stgraber is out next time too
16:24 <infinity> Oh, sneaky Stephane.
16:25 <infinity> kees it is.
16:25 <kees> whee
16:25 <infinity> #topic AOB
16:25 <infinity> Anything else?
16:26 <infinity> Going once.
16:26 <infinity> Twice.
16:26 <infinity> #endmeeting