17:17 <blackboxsw> #startmeeting Cloud-init bi-weekly status
17:17 <meetingology> Meeting started Tue Dec 10 17:17:14 2019 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:17 <meetingology> 
17:17 <meetingology> Available commands: action commands idea info link nick
17:18 <blackboxsw> Welcome folks to another cloud-init status meeting. Probably the last one of the year I presume due to upcoming Holidays in two weeks
17:18 <blackboxsw> #chair rharper
17:18 <meetingology> Current chairs: blackboxsw rharper
17:18 <blackboxsw> #chair Odd_Bloke
17:18 <meetingology> Current chairs: Odd_Bloke blackboxsw rharper
17:18 <rharper> o/
17:18 <blackboxsw> cloud-init upstream uses this meeting as a platform for community updates, feature/bug discussions, and an opportunity to get some extra input on current development.
17:19 <blackboxsw> Let's start the meeting with setting the next meeting time
17:19 <blackboxsw> day/time
17:20 <blackboxsw> I think most of upstream is out the last two weeks of December. Shall we try January 7th?
17:20 <blackboxsw> Anyone opposed can voice their discontent as I remember the keystrokes to set the topic of the channel ;)_
17:21 <blackboxsw> I also dropped 19.3 upstream release date from the channel topic as "that's soooo November"
17:22 <blackboxsw> topics for this round: Feel free to interject/suggest other topics at any time.  Our typical format is the following: Previous Actions, Recent Changes, In-progress Development, Community Charter, Upcoming Meetings, Office Hours (~30 mins).
17:22 <blackboxsw> #topic Previous Actions
17:22 <blackboxsw> #topic Previous Actions
17:23 <blackboxsw> and oops, forgot to publish meeting minutes from last session.
17:23 <blackboxsw> doing that now.
17:24 <meena> is it meeting time or did I miss it?
17:25 <Odd_Bloke> meena: It's happening as we speak.
17:27 <blackboxsw> ok sorry for the delay. just pushed published meeting minutes
17:27 <blackboxsw> #link https://cloud-init.github.io/status-2019-11-26.html#status-2019-11-26
17:27 <blackboxsw> ok so previous actions from last meeting:
17:28 <blackboxsw> no unresolved actions listed
17:28 <blackboxsw> #topic Recent Changes
17:29 <blackboxsw> found via git log --since 11.26.2019
17:29 <blackboxsw> - dhcp: Support RedHat dhcp rfc3442 lease format for option 121 (#76)
17:29 <blackboxsw> [Eric Lafontaine] (LP: #1850642)
17:29 <blackboxsw> - network_state: handle empty v1 config (#45) (LP: #1852496)
17:29 <blackboxsw> - Merge pull request #94 from gaughen/patch-1 [Joshua Powers]
17:29 <blackboxsw> - removed a couple of "the"s [gaughen]
17:29 <blackboxsw> - docs: fix line length and remove highlighting [Joshua Powers]
17:29 <blackboxsw> - docs: Add security.md to readthedocs [Joshua Powers]
17:29 <ubot5> Launchpad bug 1850642 in cloud-init "No support for classless-static-routes on centos 7" [Medium,Triaged] https://launchpad.net/bugs/1850642
17:29 <blackboxsw> - Multiple file fix for AuthorizedKeysFile config (#60) [Eduardo Otubo]
17:29 <blackboxsw> - Merge pull request #88 from OddBloke/travis [Joshua Powers]
17:29 <blackboxsw> - Revert "travis: only run CI on pull requests"
17:29 <blackboxsw> - doc: update links on README.md [Joshua Powers]
17:29 <ubot5> Launchpad bug 1852496 in cloud-init (Ubuntu) "nocloud network-config mishandles empty config" [Low,In progress] https://launchpad.net/bugs/1852496
17:29 <blackboxsw> - doc: Updates to wording of README.md [Joshua Powers]
17:29 <blackboxsw> - Add security.md [Joshua Powers]
17:29 <blackboxsw> - setup.py: Amazon Linux sets libexec to /usr/libexec (#52)
17:29 <blackboxsw> [Frederick Lefebvre]
17:29 <blackboxsw> - Fix linting failure in test_url_helper (#83) [Eric Lafontaine]
17:29 <blackboxsw> - url_helper: read_file_or_url should pass headers param into readurl
17:29 <blackboxsw> (#66) (LP: #1854084)
17:29 <blackboxsw> - dmidecode: log result *after* stripping n [Igor Galić]
17:29 <blackboxsw> - cloud_tests: add azure platform support to integration tests
17:29 <blackboxsw> [ahosmanmsft]
17:29 <ubot5> Launchpad bug 1854084 in cloud-init "Headers no longer passed through read_file_or_url" [Undecided,Fix committed] https://launchpad.net/bugs/1854084
17:31 <blackboxsw> thanks for all the FreeBSD work landing, utility improvements, caching and doc changes. + the dhcp lease format updates
17:31 <blackboxsw> #topic In-progress Development
17:32 <blackboxsw> Generally upstream is doing a fair job of getting reviews to the community for PRs, though lately we've been spending a few cycles on SRU validation for cloud-init 19.4.31 into Ubuntu Xenial, Bionic, Disco and Eoan.
17:32 <blackboxsw> expectation is that we should be able to clear this SRU validation today/tomorrow and get back onto the review queue in github for cloud-init
17:33 <blackboxsw> most major cloud-platforms have passed validation with no regressions, so risk is low with this release
17:34 <blackboxsw> oops cloud-init 19.3.41  not 19.4.31
17:35 <blackboxsw> there is plenty of work in flight by meena (FreeBSD improvements) and ahosmanMSFT (Azure instance-id work). that we hope to get reviewed and landed.
17:36 <blackboxsw> community notice: Reminder we are working toward a 19.4 upstream release by end of year. So if there are bits/features that you hope to make the cut. please get those branches in shape by next tuesday Decemeber 17th
17:36 <blackboxsw> #link https://lists.launchpad.net/cloud-init/msg00236.html
17:37 <blackboxsw> community notice: Also a reminder that cloud-inig 19.4 will be the last release that claims official support for py2.7
17:37 <blackboxsw> in January, tip of cloud-init will be allowed to drift from python2.7 support and tox -e py27 will no longer be exercised by upstream CI
17:38 <blackboxsw> Odd_Bloke: or rharper anyything else in-progress at the moment?
17:39 <blackboxsw> also, anyone interested in cloud-init development, please run tools/migrate-lp-user-to-github as mentioned in the hacking guide to make sure we can account for the CLA (contributor license agreement) for cloud-init
17:39 <blackboxsw> #link https://cloudinit.readthedocs.io/en/latest/topics/hacking.html
17:40 <blackboxsw> #topic Community Charter
17:40 <blackboxsw> reminder on 19.4 release covered above, and getting your github account authorized for cloud-init conributions....
17:41 <Odd_Bloke> Nothing from me!
17:41 <meena> goneri and i have been working on / testing his freebsd render
17:42 <blackboxsw> for folks with time to burn and bite-sized branches/fixes. we've got a lane on our trello board that gives a variety of fixes that the community can grab if they are looking for quick suggestions. "Community low-hanging fruit"
17:42 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
17:42 <blackboxsw> meena: Goneri yes and thanks for the continued efforts there. A lot of good is coming out for cloud-init upstream as a result.
17:42 <meena> Goneri removed a lot of code, but from what i gather, that code is still used elsewhere
17:43 <meena> could someone explain why our where our how
17:43 <blackboxsw> as always, any community member is encouraged to review other PRs from devs. All reviews and input welcome.
17:44 <blackboxsw> meena: I'm not sure I follow, are you referring to a specific branch?
17:44 <blackboxsw> or just where stale snapshots or cloud-init code lives on certain distros?
17:45 <blackboxsw> #topic Office Hours (next ~30 mins)
17:45 <blackboxsw> might as well kick the topic and open office hours for general cloud-init discussions, questions, bug/feature work etc.
17:46 <blackboxsw> some upstream devs will have eyes/time available for discussion around anything cloud-init. This time will also be spent grooming the active review queue @ https://git.io/JeVed
17:46 <blackboxsw> #link https://git.io/JeVed
17:48 <meena> blackboxsw: https://github.com/canonical/cloud-init/pull/61#pullrequestreview-329139891
17:48 <blackboxsw> checking
17:52 <blackboxsw> meena: so Distro._bring_up_interface() is called by Distro._bring_up_interfaces() base class via Distro.apply_network
17:59 <blackboxsw> which is called from Init.apply_network_config which gets run during "cloud-init init"  when network is brought up
18:06 <blackboxsw> I think https://github.com/canonical/cloud-init/pull/42 looks ready to merge. rharper has an outstanding "changes requested" but I believe those have been fixed. rharper I'll defer to you on this one
18:08 <blackboxsw> and policy question on reviews: if we get one upstream core-dev +1 can we proceed to land the branch as long as the "changes requested" from other upstream core seem to be resolved?
18:09 <blackboxsw> I'd vote that most recent core-dev on the PR that +1's can squash merge if they see that any prior core-dev's concerns seem to be addressed
18:12 <blackboxsw> I think I'll add an action for next meeting to make sure we iron out review/merge policy so PRs don't sit stale
18:13 <blackboxsw> #action rharper confirm no concerns on https://github.com/canonical/cloud-init/pull/42 and that PR can land.
18:13 * meetingology rharper confirm no concerns on https://github.com/canonical/cloud-init/pull/42 and that PR can land.
18:14 <blackboxsw> #action upstream core-devs to decide about whether a PR can land if any upstream dev still has 'requested changes'
18:14 * meetingology upstream core-devs to decide about whether a PR can land if any upstream dev still has 'requested changes'
18:16 <blackboxsw> ok I *think* that about wraps the meeting. Merry Christmas, Happy Hanukkah, Happy New Year and all that good stuff. See you all online.
18:16 <blackboxsw> #endmeeting