16:26 <blackboxsw> #startmeeting Cloud-init bi-weekly status
16:26 <meetingology> Meeting started Mon Sep  9 16:26:10 2019 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:26 <meetingology> 
16:26 <meetingology> Available commands: action commands idea info link nick
16:27 <blackboxsw> Hey folks, welcome to the ~biweekly cloud-init status meeting.
16:28 <blackboxsw> #chair rharper Odd_Bloke
16:28 <meetingology> Current chairs: Odd_Bloke blackboxsw rharper
16:28 <Odd_Bloke> o/
16:28 <blackboxsw> cloud-init upstream uses this meeting as a platform for community updates, feature/bug discussions, and an opportunity to get some extra input on current development.
16:30 <blackboxsw> Feel free to interject at any time. Our typical format is the following:  Previous Actions, Recent Changes, In-progress Development, Office Hours (~30 mins)
16:30 <blackboxsw> Last meeting's minutes live here:
16:30 <blackboxsw> #link https://cloud-init.github.io/status-2019-08-19.html#status-2019-08-19
16:30 <blackboxsw> #topic Previous actions
16:31 <blackboxsw> no actions from last meeting so we'll plow right through to Recent Changes
16:31 <blackboxsw> #topic Recent Changes
16:32 <blackboxsw> The following branches have landed in tip since last meeting: via    git log --since 2019-08-19
16:32 <blackboxsw> - doc: document doc, create makefile and tox target [Joshua Powers]
16:32 <blackboxsw> - .gitignore: ignore files produced by package builds [Daniel Watkins]
16:32 <blackboxsw> - docs: fix whitespace, spelling, and line length [Joshua Powers]
16:32 <blackboxsw> - docs: remove unnecessary file in doc directory [Joshua Powers]
16:32 <blackboxsw> - Oracle: Render secondary vnic IP and MTU values only [Ryan Harper]
16:32 <blackboxsw> - exoscale: fix sysconfig cloud_config_modules overrides
16:32 <blackboxsw> [Chad Smith] (LP: #1841454)
16:32 <ubot5> Launchpad bug 1841454 in cloud-init "Exoscale datasource overwrites *all* cloud_config_modules" [Undecided,Fix committed] https://launchpad.net/bugs/1841454
16:32 <blackboxsw> - net/cmdline: refactor to allow multiple initramfs network config sources
16:32 <blackboxsw> [Daniel Watkins]
16:32 <blackboxsw> - ubuntu-drivers: call db_x_loadtemplatefile to accept NVIDIA EULA
16:32 <blackboxsw> [Chad Smith] (LP: #1840080)
16:32 <ubot5> Launchpad bug 1840080 in cloud-init (Ubuntu) "cloud-init cc_ubuntu_drivers does not set up /etc/default/linux-modules-nvidia" [High,Fix released] https://launchpad.net/bugs/1840080
16:32 <blackboxsw> - Add missing #cloud-config comment on first example in documentation.
16:32 <blackboxsw> [Florian Müller]
16:32 <blackboxsw> - ubuntu-drivers: emit latelink=true debconf to accept nvidia eula
16:32 <blackboxsw> [Chad Smith] (LP: #1840080)
16:32 <blackboxsw> - DataSourceOracle: prefer DS network config over initramfs
16:32 <blackboxsw> [Daniel Watkins]
16:32 <blackboxsw> - format.rst: add text/jinja2 to list of content types (+ cleanups)
16:32 <blackboxsw> [Daniel Watkins]
16:32 <blackboxsw> - Add GitHub pull request template to point people at hacking doc
16:32 <blackboxsw> [Daniel Watkins]
16:34 <blackboxsw> Additionally: we have also cut a stable-18.4 branch from the 18.4 tag as our last supported python2.6 branch. There will be an email sent out to the mailing list about the intent of this branch.  It requires a couple of minor fixes to make sure py2.6 support is functional, but this will be reference branch for any distribution that does not have access to py.27 or later.  No additional feature development is
16:34 <blackboxsw> planned on stable-18.4
16:37 <blackboxsw> a reminder again that python2.6 support was 'dropped' in cloud-init upstream as of the 18.4 release, so expectations for py2.6 support stopped  in 18.4 and there is a deprecation plan for py 2.7 as well
16:37 <blackboxsw> #link https://lists.launchpad.net/cloud-init/msg00170.html
16:37 <blackboxsw> Again, see the mailinglist for details and updates
16:37 <blackboxsw> #link https://lists.launchpad.net/cloud-init/
16:38 <blackboxsw> #topic In-progress Development
16:38 <blackboxsw> Last week or so the team has been working on SRU validation for cloud-init 19.2.24 into Xenial, Bionic and Disco.
16:39 <blackboxsw> We have passed all SRU validation tests and our expected pubish date for 19.2.24 is tomorrow for those Ubuntu series
16:40 <blackboxsw> good work on validation folks
16:41 <blackboxsw> and thanks for extra cloud-init community verification from exoscale, azure and VMware for validation efforts
16:42 <blackboxsw> There is additional Oracle, FreeBSD and Azure work in flight at the moment as well as some boot speed improvements and analysis from rharper
16:43 <blackboxsw> The following link represents any carded work upstream is  tracking. The Doing lane is content or features we expect to land shortly
16:43 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:47 <blackboxsw> Now is probably a good time to also mention that our entire ubuntu server team also reflects our weekly accomplishements over in the ubuntu-server discourse. If there are deeper discussions or questions on various topics or features please join us there as well
16:47 <blackboxsw> #link https://discourse.ubuntu.com/c/server
16:48 <blackboxsw> I think that about wraps it for in-progress development
16:48 <blackboxsw> #topic Office Hours (next ~30 mins)
16:48 <blackboxsw> upstream cloud-init devs will have eyes on this channel for any discussions, questions, bugs or feature work the greater community would like to discuss.
16:49 <blackboxsw> During this time, we'll also groom our activereview queue to make sure we try to get review comments out to devs who have active branches.
16:49 <blackboxsw> Again, thanks for tuning in
16:57 <blackboxsw> Ok just addressed review comments on https://code.launchpad.net/~chad.smith/cloud-init/+git/cloud-init/+merge/372432 .   I'm reviewing https://code.launchpad.net/~goneri/cloud-init/+git/cloud-init/+merge/368507
16:59 * blackboxsw also sets the next meeting topic so we don't forget.
17:01 <blackboxsw> Odd_Bloke: rharper powersj, I *think* we decided to shift from Mondays to Tuesdays for status meetings to avoid collisions with holidays, vacation work travel etc. Are we doing that for next status meeting, or maybe waiting to discuss that more broadly?
17:02 <Odd_Bloke> Tuesday in two weeks is likely to be a travel day for anyone heading to the cloud-init summit.
17:02 <Odd_Bloke> But Monday is likely to be a swap day for Canonical folks because we're all travelling next week too.
17:03 <blackboxsw> hrm right, maybe we wait then and discuss at the summit
17:03 <Odd_Bloke> So I would perhaps suggest skipping the next meeting, and then we can resume on Tuesdays two weeks after the summit?
17:03 <blackboxsw> discuss scheduling changes that is
17:03 <blackboxsw> sure, let's push/postpone until summit +2 weeks
17:05 <blackboxsw> #action blackboxsw send email to the list notifying of status meeting day change.
17:05 * meetingology blackboxsw send email to the list notifying of status meeting day change.
17:10 <rharper> +1 Odd_Bloke
17:11 <blackboxsw> Also note that the version of cloud-init that has undergone SRU verification is also published to our copr el-testing repo. We only update that repo during upstream cloud-init releases XX.YY and any Ubuntu SRUs so it is much more stable than our daily copr repo.
17:11 <blackboxsw> #link https://copr.fedorainfracloud.org/coprs/g/cloud-init/el-testing/
17:33 <blackboxsw> I think that about wraps our cloud-init status meeting for today. I'm wrapping up my review here and will post it to the set_passwords branch.
17:33 <blackboxsw> #endmeeting