16:15 <blackboxsw> #startmeeting Cloud-init bi-weekly status
16:15 <meetingology> Meeting started Mon Oct 15 16:15:41 2018 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:15 <meetingology> 
16:15 <meetingology> Available commands: action commands idea info link nick
16:17 <blackboxsw> hi guys and gals. Today marks a belated cloud-init status meeting we use to provide a forum where folks from the cloud-init community can keep up to date on latest cloud-init developments and tap a shoulder if bugs or features need discussion/attention.
16:17 <blackboxsw> Next meeting will be two weeks from now on October 29th. at 16:00 UTC (as in the topic of this channel)
16:18 <blackboxsw> Today's meeting will go through the typical topics: Previous Actions, Recent Changes, In-progress development and Office hours
16:18 <blackboxsw> #topic Previous Actions
16:19 <blackboxsw> No unresolved actions from last meeting on Sept 25th.
16:19 <blackboxsw> For those interested our previous meeting minutes are at the following:
16:19 <blackboxsw> #link https://cloud-init.github.io/
16:19 <blackboxsw> #topic Recent Changes
16:20 <blackboxsw> There has been a lot of work put into cloud-init over the last couple of weeks due to the timing of the Ubuntu Cosmic (18.10) series final freeze and release schedule
16:21 <blackboxsw> We managed to squeeze in a couple of features into 18.4 as well as improved some of Ubuntu's automated testing for StableReleaseUpdates (SRUs).
16:22 <blackboxsw> Beyond the 18.4 public upstream release (which is in Ubuntu Cosmic). We have the following commits that have landed since the last status meeting.
16:22 <blackboxsw> - tests: allow skipping an entire cloud_test without running.
16:22 <blackboxsw> - tests: disable lxd tests on cosmic
16:22 <blackboxsw> - cii-tests: use unittest2.SkipTest in ntp_chrony due to new deps
16:22 <blackboxsw> - lxd: adjust to snap installed lxd.
16:22 <blackboxsw> - docs: surface experimental doc in instance-data.json
16:22 <blackboxsw> - tests: fix ec2 integration tests. process meta_data instead of meta-data
16:22 <blackboxsw> - Add support for Infiniband network interfaces (IPoIB). [Mark Goddard]
16:22 <blackboxsw> - cli: add cloud-init query subcommand to query instance metadata
16:22 <blackboxsw> - tools/tox-venv: update for new features.
16:22 <blackboxsw> - pylint: ignore warning assignment-from-no-return for _write_network
16:22 <blackboxsw> - stages: Fix bug causing datasource to have incorrect sys_cfg.
16:22 <blackboxsw> ([LP: #1787459](https://bugs.launchpad.net/bugs/1787459))
16:22 <blackboxsw> - Remove dead-code _write_network distro implementations.
16:22 <blackboxsw> - net_util: ensure static configs have netmask in translate_network result
16:22 <blackboxsw> [Thomas Berger] ([LP: #1792454](https://bugs.launchpad.net/bugs/1792454))
16:22 <ubot5> Ubuntu bug 1787459 in cloud-init (Ubuntu) "datasource.sys_cfg gets different values in local stage and after." [Medium,Fix released]
16:22 <blackboxsw> - Fall back to root:root on syslog permissions if other options fail.
16:22 <blackboxsw> [Robert Schweikert]
16:22 <ubot5> Ubuntu bug 1792454 in cloud-init "Network configuration broken for some distributions with OpenNebula, EC2, Azure" [High,Fix released]
16:22 <blackboxsw> - tests: Add mock for util.get_hostname. [Robert Schweikert] ([LP: #1792799](https://bugs.launchpad.net/bugs/1792799))
16:22 <blackboxsw> - ds-identify: doc string cleanup.
16:22 <ubot5> Ubuntu bug 1792799 in cloud-init "Host environment bleeds into test for mirror access testing" [Undecided,Fix released]
16:22 <blackboxsw> - OpenStack: Support setting mac address on bond.
16:22 <blackboxsw> - bash_completion/cloud-init: fix shell syntax error.
16:22 <blackboxsw> - EphemeralIPv4Network: Be more explicit when adding default route.
16:22 <blackboxsw> ([LP: #1792415](https://bugs.launchpad.net/bugs/1792415))
16:22 <blackboxsw> - OpenStack: support reading of newer versions of metdata.
16:22 <blackboxsw> - OpenStack: fix bug causing 'latest' version to be used from network.
16:22 <ubot5> Ubuntu bug 1792415 in cloud-init (Ubuntu) "WARNINGs and failures in log on OVH public cloud" [Medium,Fix released]
16:22 <blackboxsw> ([LP: #1792157](https://bugs.launchpad.net/bugs/1792157))
16:22 <ubot5> Ubuntu bug 1792157 in cloud-init (Ubuntu) "cloud-init uses openstack latest version due to decoding bug" [Medium,Fix released]
16:23 <blackboxsw> - Correct spelling in an error message (udevadm). [Katie McLaughlin]
16:23 <blackboxsw> - tests: meta_data key changed to meta-data in ec2 instance-data.json
16:23 <blackboxsw> ([LP: #1797231](https://bugs.launchpad.net/bugs/1797231))
16:23 <blackboxsw> - tests: fix kvm integration test to assert flexible config-disk path
16:23 <blackboxsw> ([LP: #1797199](https://bugs.launchpad.net/bugs/1797199))
16:23 <blackboxsw> - tools: Add cloud-id command line utility
16:23 <blackboxsw> - instance-data: Add standard keys platform and subplatform. Refactor ec2.
16:23 <blackboxsw> - net: ignore nics that have "zero" mac address. ([LP: #1796917](https://bugs.launchpad.net/bugs/1796917))
16:23 <blackboxsw> - tests: fix apt_configure_primary to be more flexible
16:23 <ubot5> Ubuntu bug 1797231 in cloud-init "ec2 integration test failure on changed instance-data.json" [High,Fix committed]
16:23 <blackboxsw> - Ubuntu: update sources.list to comment out deb-src entries. ([LP: #74747](https://bugs.launchpad.net/bugs/74747))
16:23 <blackboxsw> - release 18.4 ([LP: #1795741](https://bugs.launchpad.net/bugs/1795741))
16:23 <ubot5> Ubuntu bug 1797199 in cloud-init "kvm integration test failures due to invalid config-disk path" [High,Fix committed]
16:23 <ubot5> Ubuntu bug 1796917 in cloud-images "cloud-init fails to run on latest cosmic minimal image" [High,Fix released]
16:23 <ubot5> Ubuntu bug 74747 in cloud-init (Ubuntu Bionic) "Default sources.list file has source packages enabled by default" [Medium,Confirmed]
16:23 <ubot5> Ubuntu bug 1795741 in cloud-init (Ubuntu) "Release 18.4" [Medium,Fix released]
16:26 <blackboxsw> If you get a chance, it's worth noting that #cloud-config files can now be presented as a jinja template to the instance by adding a ## template: jinja as the first line above the #cloud-config in your user-data. Any metadata that cloud-init consumes (like cloud-given hostnames, ip addresses, region names etc) can be sourced and rendered in your cloud-config files now.
16:27 <blackboxsw> #link https://cloudinit.readthedocs.io/en/latest/topics/instancedata.html#using-instance-data
16:27 <blackboxsw> ^ for more information on instance data and templating
16:28 <blackboxsw> #topic In-Progress Development
16:28 <blackboxsw> #link trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:29 <blackboxsw> Our trello board tracks our current work. The most notable effort is cloud-init network hotplug handling for datasources which is  currently being driven by rharper
16:30 <blackboxsw> What he is adding is the ability for for a datasource to be configured react to network hotplug events and apply cloud-init determined network configuration on device add/remove
16:31 <blackboxsw> This feature will be opt-in and configurable by the end-user to allow cloud-init to own network for any device added or removed after the initial boot. This feature will debut in OpenStack clouds and will shortly be adopted by other cloud/datasource types.
16:33 <blackboxsw> Also, smoser and I will be heading to OpenSource Summit Europe next week in Edinburgh, UK.  https://events.linuxfoundation.org/events/open-source-summit-europe-2018/
16:34 <blackboxsw> If you are in town come say hi :)
16:35 <blackboxsw> Without further ado, I think that about wraps our status for today
16:35 <blackboxsw> #topic Office hours (next ~30 mins)
16:37 <blackboxsw> Almost forgot; as part of the SRU process for for cloud-init to release into Xenial and Bionic, we'll be doing some additional manual and automated testing of cloud-init version 18.4 before publishing to those LTS series. I expect that'll take up a bit of our time this week and next as there is a lot to verify for that release.
16:38 <blackboxsw> For the next 30 mins, a few of us will have eyes on the channel  for anyone with a desire to talk cloud-init bugs, features or reviews. Thanks again for the contributions and making cloud-init better!
16:40 <paulmey> Hi blackboxsw
16:41 <blackboxsw> Hi paulmey, how're things
16:41 <blackboxsw> ?
16:41 <paulmey> Good! How about yourself?
16:41 <paulmey> My buddy Jason has a bug open that could use some attention: https://bugs.launchpad.net/cloud-init/+bug/1794399
16:41 <ubot5> Ubuntu bug 1794399 in cloud-init "cloud-init dhcp_discovery() crashes on preprovisioned RHEL 7.6 VM in Azure" [Undecided,New]
16:41 <paulmey> this is a stopgap fix until we have a pure-python dhcp client
16:42 <blackboxsw> it's been a push for the Cosmic release for us, racing to get things sorted, but I think we are on the other side of any fires now :)
16:42 <blackboxsw> ahh checking that bug
16:42 <paulmey> :-) good to hear that
16:42 <paulmey> it's basically just some more robustness around the handling of dhclient execution
16:44 <paulmey> it reproed very reliably on RHEL with reprovisioning (changing network etc., maybe slower/faster dhcp response?), but pretty unreproducible outside of that...
16:44 <blackboxsw> paulmey: jason made reference to a patch, but I don't see it linked to the bug.... I'm checking the review queue now
16:44 <paulmey> we saw cloud-init killing or trying to kill the initial process (which has already finished after the util exec)
16:45 <blackboxsw> was that bug just a request for us to make cloud-init more resilient in light of forking, or a request to accept a patch
16:45 <paulmey> let me link the patch... once I find it :-)
16:45 <paulmey> give me a minute
16:46 * blackboxsw documents the link for the meeting bot
16:46 <blackboxsw> #link https://bugs.launchpad.net/cloud-init/+bug/1794399
16:46 <ubot5> Ubuntu bug 1794399 in cloud-init "cloud-init dhcp_discovery() crashes on preprovisioned RHEL 7.6 VM in Azure" [Undecided,New]
16:46 * blackboxsw Sort and review azure RHEL branch related to ephemeral dhcp handling of dhclient https://bugs.launchpad.net/cloud-init/+bug/1794399
16:47 <blackboxsw> #action Sort and review azure RHEL branch related to ephemeral dhcp handling of dhclient https://bugs.launchpad.net/cloud-init/+bug/1794399
16:47 * meetingology Sort and review azure RHEL branch related to ephemeral dhcp handling of dhclient https://bugs.launchpad.net/cloud-init/+bug/1794399
16:48 <blackboxsw> yeah, I wonder if now that 18.4 is cut and released if we want to start banging the drum to get our scapy-based dhclient solution landed in cloud-init proper so we don't have to patchup the ephemeral dhcp work in cloud-init.
16:50 <blackboxsw> while you look paulmey, I'll make sure we talk at our standups about what we can do with cloud-init's own dhcp-discovery so we don't have to handle different distro implementations of dhclient. The sandboxed dhclient solution we have felt dirty in the first place.
16:51 <paulmey> yar... I can't find a reference to it in my mails... I'll need to circle back with Jason. I prototyped the patch and he write some unit tests. I know it's somewhere, just not exactly where...
16:51 <blackboxsw> our only concern I thought with using scapy was adding the additional package dependency, (which we wouldn't be able to get released back into Ubuntu Xenial Bionic or Cosmic). But, we can resolve to come of with an approach for the nearterm
16:52 <blackboxsw> paulmey: sounds good. :) care if I add a virtual action  item for you too to the meeting minutes
16:52 <paulmey> Sure, no problem
16:52 <blackboxsw> at least it'll guarantee we make progress before next meeting
16:52 <blackboxsw> #action paulmey to dig up reference to proposed patch for https://bugs.launchpad.net/cloud-init/+bug/1794399
16:52 * meetingology paulmey to dig up reference to proposed patch for https://bugs.launchpad.net/cloud-init/+bug/1794399
16:52 <ubot5> Ubuntu bug 1794399 in cloud-init "cloud-init dhcp_discovery() crashes on preprovisioned RHEL 7.6 VM in Azure" [Undecided,New]
16:52 <blackboxsw> thanks
16:53 <blackboxsw> paulmey: are there other azure related discussions/features that are collecting dust with us that you know of?
16:54 <paulmey> not yet collecting dust, but I know that Sushant Sharma is going to be coming with some networking-related updates for pre-provisioning like we discussed at the summit
16:54 <paulmey> he's testing those on real systems right now
16:54 <blackboxsw> I know hyperv reporting feature is functional in cloud-init now. and that folks are instrumenting changes in images to support that.
16:55 <blackboxsw> ahh right. good to hear
16:55 <paulmey> we're also talking to SUSE this week to see what the next steps are to get cloud-init functional on Azure
16:55 <blackboxsw> ohh neat!
16:56 <paulmey> I know we still have some work items, but we're prototyping some stuff to get ahead of some testing work
16:56 <paulmey> funny thing is that I'm hardly doing any of this work. :-)
16:56 <paulmey> good to see more and more people at MS doing work on cloud-init
16:57 <blackboxsw> heh, juggling a lot I'm sure. yeah it is nice to see more devs involved
16:58 <smoser> paulmey: thats great to hear wrt suse
16:58 <paulmey> ok, cool. I'll follow up with Jason and circle back. If anything else comes to fruition before the 29th, I'll send people here to evangalize
16:59 <blackboxsw> perfect. Thanks again paulmey
16:59 <smoser> and /me agrees it'd be good to have a dhclient in cloud-init for what we need it for. scapy or other.
16:59 <blackboxsw> think I'll wrap up this meeting for today
16:59 <paulmey> (although it's always nice to talk to you guys... feels good being able to say was on IRC this week... :-P)
16:59 <paulmey> sgtm
16:59 <blackboxsw> heh, take care
16:59 <paulmey> ttyl
17:00 <blackboxsw> #endmeeting