16:09 <blackboxsw> #startmeeting Cloud-init bi-weekly status meeting
16:09 <meetingology> Meeting started Mon Aug 20 16:09:08 2018 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:09 <meetingology> 
16:09 <meetingology> Available commands: action commands idea info link nick
16:09 <blackboxsw> For those around, let's kickoff another cloud-init status meeting.  Feel free to interrupt as we go through the agenda for today.
16:10 <blackboxsw> agenda: Previous Actions, Recent Changes, In-progress development and office hours (~30 minutes)
16:13 <blackboxsw> #topic Previous Actions
16:13 <blackboxsw> nothing to speak of here as far as I recall.
16:13 <blackboxsw> #topic Recent Changes
16:14 <blackboxsw> We have recently landed the following content in tip of cloud-init over the last 2 weeks
16:14 <blackboxsw> - Add datasource Oracle Compute Infrastructure (OCI).
16:14 <blackboxsw> - azure: allow azure to generate network configuration from IMDS per boot.
16:14 <blackboxsw> - Scaleway: Add network configuration to the DataSource [Louis Bouchard]
16:14 <blackboxsw> - docs: Fix example cloud-init analyze command to match output.
16:14 <blackboxsw> [Wesley Gao]
16:14 <blackboxsw> - netplan: Correctly render macaddress on a bonds and bridges when
16:14 <blackboxsw> provided. (LP: #1784699)
16:14 <blackboxsw> - tools: Add 'net-convert' subcommand command to 'cloud-init devel'.
16:14 <blackboxsw> - redhat: remove ssh keys on new instance. (LP: #1781094)
16:14 <ubot5> Launchpad bug 1784699 in cloud-init "cloud-init not setting mac address for bond or bridge in bionic" [Medium,Fix committed] https://launchpad.net/bugs/1784699
16:15 <blackboxsw> - Use typeset or local in profile.d scripts. (LP: #1784713)
16:15 <blackboxsw> - OpenNebula: Fix null gateway6 [Akihiko Ota] (LP: #1768547)
16:15 <ubot5> Launchpad bug 1781094 in cloud-init "cloud.cfg.tmpl should not include "ssh_deletekeys: 0"" [Medium,Fix committed] https://launchpad.net/bugs/1781094
16:15 <ubot5> Launchpad bug 1784713 in cloud-init (Ubuntu) "cloud-init profile.d files use bash-specific builtin "local"" [Low,Confirmed] https://launchpad.net/bugs/1784713
16:15 <ubot5> Launchpad bug 1768547 in cloud-init (Ubuntu) "OpenNebula DataSource adds null gateway6 to netplan config" [Medium,Confirmed] https://launchpad.net/bugs/1768547
16:15 <blackboxsw> most notable is the new datasource for Oracle and Azure datasource now emitting network configuration per boot.
16:21 <blackboxsw> new Ubuntu cosmic images should contain 18.3-24-gf6249277-0ubuntu1 with the lastest patches
16:21 <blackboxsw> #topic In-progress Development
16:23 <blackboxsw> The team in general is perparing for the cloud-init summit conference which will be the second half of this week with cloud and distro vendors so we'll probably be landing a couple more branches in preparation for talks/demos there.
16:23 <blackboxsw> *preparing* rather
16:24 <blackboxsw> Our trello board is a good representation of any existing work we are "Doing"
16:24 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:26 <blackboxsw> recently powersj has also moved our jenkins server around to a new network so there has been a good bit of work getting all things jenkins back up and running behind the new proxies/firewalls etc.
16:26 <blackboxsw> thanks for the heavy lift powersj
16:27 <blackboxsw> I think that wraps up all things cloud-init....
16:27 <blackboxsw> #topic Office Hource (next ~30 mins)
16:28 <blackboxsw> We'll have eyes on this channel for any quips, complaints, bug, feature or branch discussions for the next half hour
16:28 <blackboxsw> Otherwise, we'll be excited to see a few of you again in this year's cloud-init summit.\
16:28 <paulmey> Hi all, I'd like to request a review for this MP: https://code.launchpad.net/~andyliuliming/cloud-init/+git/cloud-init/+merge/351742 (attached to LP: #1722959)
16:28 <ubot5> Launchpad bug 1722959 in cloud-init "Implement Key-Value Pair Telemetry for Azure" [Undecided,In progress] https://launchpad.net/bugs/1722959
16:29 <paulmey> Hoping we can get this merged sometime soon. :-)
16:29 <blackboxsw> Hi paulmey thanks for the ping on this.
16:29 <blackboxsw> #link https://code.launchpad.net/~andyliuliming/cloud-init/+git/cloud-init/+merge/351742
16:30 <blackboxsw> #action rharper/blackboxsw close out on this review before cloud-init summit https://code.launchpad.net/~andyliuliming/cloud-init/+git/cloud-init/+merge/351742
16:30 * meetingology rharper/blackboxsw close out on this review before cloud-init summit https://code.launchpad.net/~andyliuliming/cloud-init/+git/cloud-init/+merge/351742
16:30 <blackboxsw> that has gotten dusty, thank you
16:31 <blackboxsw> I'll start a review in earnest now
16:31 <paulmey> Thanks. The dust is mostly mine... Andy has been working on this, but he's in a different time zone, so I'm still pushing it...
16:31 <paulmey> 😉
16:32 <blackboxsw> paulmey: I'll try spinning up an azure vm to test this out
16:34 <paulmey> let me know if you need anything
17:04 <blackboxsw> ok thanks folks for tuning in. See you next time
17:04 <blackboxsw> #endmeeting