16:05 <blackboxsw> #startmeeting Cloud-init bi-weekly status meeting
16:05 <meetingology> Meeting started Mon Jul  2 16:05:44 2018 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:05 <meetingology> 
16:05 <meetingology> Available commands: action commands idea info link nick
16:06 <blackboxsw> hi folks, just kicking off another cloud-init status meeting to communicate the recent events in cloud-init land.
16:06 <blackboxsw> welcome to all, feel free to interrupt as we go through the agenda. As always cloud-init status minutes will live at the following url
16:07 <blackboxsw> #link https://cloud-init.github.io/
16:07 <blackboxsw> The meeting agenda is as follows:
16:08 <blackboxsw> agenda: Previous Actions, Recent Changes, In-progress develepment and office hours (~30 minutes)
16:09 <blackboxsw> #topic Previous Actions
16:09 <blackboxsw> Last meeting we have a couple of actions to look over:
16:10 <blackboxsw> #ACTION blackboxsw carryover network hotplug vs network maintenance on reboot-only
16:10 <blackboxsw> #ACTION blackboxsw carryover network hotplug vs network maintenance on reboot-only [DONE]
16:11 <blackboxsw> we held multiple meetings, including discussion with mgerdts on a SmartOS solution for handling regenerating network configuration per-boot when a user selects this behavior
16:12 <blackboxsw> We have just landed a supporting branch in cloud-init tip to enable datasources to define what events (BOOT vs BOOT_NEW_INSTANCE) they will react to when generating network config.
16:12 <blackboxsw> #link https://code.launchpad.net/~chad.smith/cloud-init/+git/cloud-init/+merge/348000
16:13 <blackboxsw> that should give a foundation for other datasources to write/change network config across boots, instead of allowing network config to remain static based on cloud-init's initial network configuration
16:13 <blackboxsw> the 2nd action ..
16:14 <blackboxsw> #ACTION haper/blackboxsw review https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/333904 [CARRYOVER]
16:14 * meetingology haper/blackboxsw review https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/333904 [CARRYOVER]
16:14 <blackboxsw> I'd like to carry this one over. We got a bit bogged down in SRU, CentOs stuff last week and we shold be able to get some eyes on this branch
16:14 <blackboxsw> I think that's it for actions.
16:15 <blackboxsw> #topic Recent Changes
16:16 <blackboxsw> Below is a list of changes landed in cloud-init tip or package publishing that has occured for the project:
16:16 <blackboxsw> * our 18.3 release was cut from tip if you caught the email on that mailing list
16:16 <blackboxsw> Congrats all for a great effort at improving quality and adding more datasource/cloud support
16:17 <blackboxsw> #link https://lists.launchpad.net/cloud-init/msg00164.html
16:17 <blackboxsw> ^ in case you didn't get the message
16:18 <blackboxsw> * we also publish 18.3 release into Ubuntu Cosmic and started a stable release update (SRU) to publish 18.3 in to xenial, artful, bionic
16:18 <blackboxsw> published*
16:19 <blackboxsw> expectations are that xenial, artful and bionic will have 18.3 after this week of testing
16:20 <blackboxsw> the remaining changes landed in tip are:
16:20 <blackboxsw> - update_metadata: a datasource can support network re-config every boot
16:20 <blackboxsw> [Chad Smith]
16:20 <blackboxsw> - tests: drop salt-minion integration test (LP: #1778737)
16:20 <blackboxsw> - Retry on failed import of gpg receive keys.
16:20 <blackboxsw> - tools: Fix run-container when neither source or binary package requested.
16:20 <blackboxsw> - docs: Fix a small spelling error. [Oz N Tiram]
16:20 <blackboxsw> - tox: use simplestreams from git repository rather than bzr.
16:20 <ubot5> Launchpad bug 1778737 in cloud-init "salt-minion test needs fixing" [Undecided,Fix committed] https://launchpad.net/bugs/1778737
16:20 <blackboxsw> - release 18.3 [Chad Smith] (LP: #1777743)
16:20 <blackboxsw> - docs: represent sudo:false in docs for user_groups config module
16:20 <blackboxsw> [Chad Smith]
16:20 <blackboxsw> - Explicitly prevent `sudo` access for user module
16:20 <ubot5> Launchpad bug 1777743 in cloud-init "Release 18.3" [Undecided,Fix released] https://launchpad.net/bugs/1777743
16:20 <blackboxsw> [Jacob Bednarz] (LP: #1771468)
16:20 <ubot5> Launchpad bug 1771468 in cloud-init "Allow a way to explicitly disable sudo for a user" [Undecided,Fix released] https://launchpad.net/bugs/1771468
16:21 <blackboxsw> next topic
16:21 <blackboxsw> #topic In-progress Development
16:22 <blackboxsw> Our ongoing development is always listed publicly at the following trello board
16:22 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:23 <blackboxsw> We are going to be focused on SRU validation for Ubuntu this week which should take up the majority of the week.
16:23 <blackboxsw> At the end of this SRU process we will also rebuild centos binaries in our copr repo
16:23 <blackboxsw> #link https://copr.fedorainfracloud.org/coprs/g/cloud-init/el-testing/
16:24 <blackboxsw> so that folks in other envs will have access to latest bits if their distro/cloud doesn't have that update
16:24 <blackboxsw> Also, specfic to mgerdts  and danMS_ there is a branch in progress for Azure support to regenerate network-config for all interfaces on each boot.
16:25 <blackboxsw> #link https://code.launchpad.net/~chad.smith/cloud-init/+git/cloud-init/+merge/348704
16:25 <blackboxsw> mgerdts: might like it only as another example of a datasource managing network config across boots
16:26 <mgerdts> Thanks.  Will look at that soon.
16:26 <blackboxsw> no prob, sorry for all the pings :)
16:26 <danMS_> will take a look too and spk to paulmey
16:27 <blackboxsw> also smoser is working on implementing an OCIC datasource (Oracle Cloud Infrastructure Classic)
16:31 <blackboxsw> think that wraps it up for this week.
16:31 <blackboxsw> #topic Office Hours (next ~30 mins)
16:31 <blackboxsw> there should be a couple of eyes on this channel for discusssions, questions, bug requests etc that might need a bit more attention.
16:33 <blackboxsw> again, thanks for tuning in and helping make cloud-init better!
16:33 <blackboxsw> meeting minutes will ultimately show at
16:33 <blackboxsw> #link https://cloud-init.github.io/
17:02 <blackboxsw> #endmeeting